
From lars@netapp.com  Tue Apr 10 02:39:50 2012
Return-Path: <lars@netapp.com>
X-Original-To: cfrg@ietfa.amsl.com
Delivered-To: cfrg@ietfa.amsl.com
Received: from localhost (localhost [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id 9FDF121F8800 for <cfrg@ietfa.amsl.com>; Tue, 10 Apr 2012 02:39:50 -0700 (PDT)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -11.578
X-Spam-Level: 
X-Spam-Status: No, score=-11.578 tagged_above=-999 required=5 tests=[AWL=0.910, BAYES_00=-2.599, GB_I_INVITATION=-2, RCVD_IN_DNSWL_HI=-8, SARE_NETPROD=0.111]
Received: from mail.ietf.org ([12.22.58.30]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id yVkJnb3uzEj5 for <cfrg@ietfa.amsl.com>; Tue, 10 Apr 2012 02:39:50 -0700 (PDT)
Received: from mx2.netapp.com (mx2.netapp.com [216.240.18.37]) by ietfa.amsl.com (Postfix) with ESMTP id D7C0321F87FF for <cfrg@irtf.org>; Tue, 10 Apr 2012 02:39:49 -0700 (PDT)
X-IronPort-AV: E=Sophos;i="4.75,398,1330934400";  d="p7s'?scan'208";a="639668577"
Received: from smtp1.corp.netapp.com ([10.57.156.124]) by mx2-out.netapp.com with ESMTP; 10 Apr 2012 02:39:49 -0700
Received: from vmwexceht02-prd.hq.netapp.com (vmwexceht02-prd.hq.netapp.com [10.106.76.240]) by smtp1.corp.netapp.com (8.13.1/8.13.1/NTAP-1.6) with ESMTP id q3A9dnBW001803 for <cfrg@irtf.org>; Tue, 10 Apr 2012 02:39:49 -0700 (PDT)
Received: from SACEXCMBX01-PRD.hq.netapp.com ([169.254.2.117]) by vmwexceht02-prd.hq.netapp.com ([10.106.76.240]) with mapi id 14.02.0247.003; Tue, 10 Apr 2012 02:39:49 -0700
From: "Eggert, Lars" <lars@netapp.com>
To: "cfrg@irtf.org" <cfrg@irtf.org>
Thread-Topic: Call for Nominations: Applied Networking Research Prize 2012
Thread-Index: AQHNFv3fucav8Pzsb02Rim9aWZTTDQ==
Date: Tue, 10 Apr 2012 09:39:48 +0000
Message-ID: <90B3F35D-B4F5-4AEF-B0D3-F692A62786B7@netapp.com>
Accept-Language: en-US
Content-Language: en-US
X-MS-Has-Attach: yes
X-MS-TNEF-Correlator: 
x-originating-ip: [10.106.53.51]
Content-Type: multipart/signed; boundary="Apple-Mail=_A5460245-F158-46E2-B3DA-FF53AF3FDD6B"; protocol="application/pkcs7-signature"; micalg=sha1
MIME-Version: 1.0
Subject: [Cfrg] Call for Nominations: Applied Networking Research Prize 2012
X-BeenThere: cfrg@irtf.org
X-Mailman-Version: 2.1.12
Precedence: list
Reply-To: "anrp@irtf.org" <anrp@irtf.org>
List-Id: Crypto Forum Research Group <cfrg.irtf.org>
List-Unsubscribe: <http://www.irtf.org/mailman/options/cfrg>, <mailto:cfrg-request@irtf.org?subject=unsubscribe>
List-Archive: <http://www.irtf.org/mail-archive/web/cfrg>
List-Post: <mailto:cfrg@irtf.org>
List-Help: <mailto:cfrg-request@irtf.org?subject=help>
List-Subscribe: <http://www.irtf.org/mailman/listinfo/cfrg>, <mailto:cfrg-request@irtf.org?subject=subscribe>
X-List-Received-Date: Tue, 10 Apr 2012 09:39:50 -0000

--Apple-Mail=_A5460245-F158-46E2-B3DA-FF53AF3FDD6B
Content-Transfer-Encoding: quoted-printable
Content-Type: text/plain;
	charset=windows-1252


                       CALL FOR NOMINATIONS:
        =20
            APPLIED NETWORKING RESEARCH PRIZE (ANRP) 2012
              =20
                       http://irtf.org/anrp

***    Submit nominations for the 2012 award period of the        ***
***   Applied Networking Research Prize until May 13, 2012!       ***


The Applied Networking Research Prize (ANRP) is awarded for recent
results in applied networking research that are relevant for
transitioning into shipping Internet products and related
standardization efforts. Researchers with relevant, recently
published results are encouraged to apply for this prize, which will
offer them the opportunity to present and discuss their work with
the engineers, network operators, policy makers and scientists that
participate in the Internet Engineering Task Force (IETF) and its
research arm, the Internet Research Task Force (IRTF).

The goal of the Applied Networking Research Prize is to recognize
the best new ideas in networking, and bring them to the IETF and
IRTF especially in cases where they would not otherwise see much
exposure or discussion.

The Applied Networking Research Prize (ANRP) consists of:

  * cash prize of $500 (USD)
 =20
  * travel grant to attend a week-long IETF meeting
    (airfare, hotel, registration, stipend)
   =20
  * invited talk at the IRTF Open Meeting
 =20
  * recognition at the IETF plenary
 =20
  * invitation to related social activities
 =20
  * potential for additional travel grants to future IETF
    meetings, based on community feedback


HOW TO NOMINATE

Only a single person can be nominated for the award. The basis of
the nomination is a peer-reviewed, recently-published, original
journal, conference or workshop paper they authored. The nominee
must be one of the main authors of the nominated paper. Both self
nominations (nominating one=92s own paper) and third-party nominations
(nominating someone else=92s paper) are encouraged.

The nominated paper should provide a scientific foundation for
possible future IETF engineering work or IRTF research and
experimentation, analyze the behavior of Internet protocols in
operational deployments or realistic testbeds, make an important
contribution to the understanding of Internet scalability,
performance, reliability, security or capability, or otherwise be of
relevance to ongoing or future IETF or IRTF activities.

Applicants must briefly describe how the nominated paper relates to
these goals, and are encouraged to describe how a presentation of
these research results would foster their transition into new IETF
engineering or IRTF experimentation, or otherwise seed new
activities that will have an impact on the real-world Internet.

The goal of the Applied Networking Research Prize (ANRP) is to
foster the transitioning of research results into real-world
benefits for the Internet. Therefore, applicants must indicate that
they (or the nominee, in case of third-party nominations) are
available to attend at least one of the year=92s IETF meetings in
person and in its entirety.

Nominations must include:

  * the name and email address of the nominee

  * a bibliographic reference to the published nominated paper

  * a PDF copy of the nominated paper

  * a statement that describes how the nominated paper fulfills the
    goals of the award

  * a statement about which of the year=92s IETF meetings the nominee
    would be available to attend in person and in its entirety

  * a brief biography or CV of the nominee

  * optionally, any other supporting information (link to nominee=92s
    web site, etc.)

Nominations are submitted via the submission site at
http://irtf.org/anrp/2012/. In exceptional cases, nominations may
also be submitted by email to anrp@irtf.org.


SELECTION PROCESS

A small selection committee comprised of individuals knowledgeable
about the IRTF, IETF and the broader networking research community
will evaluate the submissions against these selection criteria.


IMPORTANT DATES

Applications close:  May 13, 2012 (hard)
Notifications:       June 1, 2012


SPONSORS

The Applied Networking Research Prize (ANRP) is supported by the
Internet Society (ISOC), as part of its Internet Research Award
Programme, in coordination with the Internet Research Task Force
(IRTF).


HELP PUBLICIZE THE ANRP

If you would like to help publicize the ANRP within your
organization, you are welcome to print and use the flyer at
http://irtf.org/anrp-2012-flyer.pdf


--Apple-Mail=_A5460245-F158-46E2-B3DA-FF53AF3FDD6B
Content-Disposition: attachment; filename="smime.p7s"
Content-Type: application/pkcs7-signature; name="smime.p7s"
Content-Transfer-Encoding: base64
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--Apple-Mail=_A5460245-F158-46E2-B3DA-FF53AF3FDD6B--

From housley@vigilsec.com  Thu Apr 12 09:07:59 2012
Return-Path: <housley@vigilsec.com>
X-Original-To: cfrg@ietfa.amsl.com
Delivered-To: cfrg@ietfa.amsl.com
Received: from localhost (localhost [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id 41AAC21F8661 for <cfrg@ietfa.amsl.com>; Thu, 12 Apr 2012 09:07:59 -0700 (PDT)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -102.529
X-Spam-Level: 
X-Spam-Status: No, score=-102.529 tagged_above=-999 required=5 tests=[AWL=0.070, BAYES_00=-2.599, USER_IN_WHITELIST=-100]
Received: from mail.ietf.org ([12.22.58.30]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id TrK+cN7008pe for <cfrg@ietfa.amsl.com>; Thu, 12 Apr 2012 09:07:58 -0700 (PDT)
Received: from odin.smetech.net (mail.smetech.net [208.254.26.82]) by ietfa.amsl.com (Postfix) with ESMTP id 8C62021F853F for <cfrg@irtf.org>; Thu, 12 Apr 2012 09:07:58 -0700 (PDT)
Received: from localhost (unknown [208.254.26.81]) by odin.smetech.net (Postfix) with ESMTP id 6975A9A4728 for <cfrg@irtf.org>; Thu, 12 Apr 2012 12:08:21 -0400 (EDT)
X-Virus-Scanned: amavisd-new at smetech.net
Received: from odin.smetech.net ([208.254.26.82]) by localhost (ronin.smetech.net [208.254.26.81]) (amavisd-new, port 10024) with ESMTP id SzUQ1fadXLty for <cfrg@irtf.org>; Thu, 12 Apr 2012 12:07:41 -0400 (EDT)
Received: from [192.168.2.101] (pool-96-255-13-167.washdc.fios.verizon.net [96.255.13.167]) (using TLSv1 with cipher AES128-SHA (128/128 bits)) (No client certificate requested) by odin.smetech.net (Postfix) with ESMTP id 942709A4727 for <cfrg@irtf.org>; Thu, 12 Apr 2012 12:08:18 -0400 (EDT)
Content-Type: text/plain; charset=us-ascii
Mime-Version: 1.0 (Apple Message framework v1084)
From: Russ Housley <housley@vigilsec.com>
In-Reply-To: <D7A0423E5E193F40BE6E94126930C4930B96D9FDAB@MBCLUSTER.xchange.nist.gov>
Date: Thu, 12 Apr 2012 12:07:54 -0400
Content-Transfer-Encoding: quoted-printable
Message-Id: <13A25203-FC96-4AFD-99B6-A1AE06EE280A@vigilsec.com>
References: <D7A0423E5E193F40BE6E94126930C4930B96D9FDAB@MBCLUSTER.xchange.nist.gov>
To: IRTF CFRG <cfrg@irtf.org>
X-Mailer: Apple Mail (2.1084)
Subject: [Cfrg] Fwd: NIST Request for Comments on Proposed Changes to FIPS 186-3: The Digital Signature Standard
X-BeenThere: cfrg@irtf.org
X-Mailman-Version: 2.1.12
Precedence: list
List-Id: Crypto Forum Research Group <cfrg.irtf.org>
List-Unsubscribe: <http://www.irtf.org/mailman/options/cfrg>, <mailto:cfrg-request@irtf.org?subject=unsubscribe>
List-Archive: <http://www.irtf.org/mail-archive/web/cfrg>
List-Post: <mailto:cfrg@irtf.org>
List-Help: <mailto:cfrg-request@irtf.org?subject=help>
List-Subscribe: <http://www.irtf.org/mailman/listinfo/cfrg>, <mailto:cfrg-request@irtf.org?subject=subscribe>
X-List-Received-Date: Thu, 12 Apr 2012 16:07:59 -0000

FYI

-------- Original Message --------
Subject: NIST Request for Comments on Proposed Changes to FIPS 186-3: =
The Digital Signature Standard
Date: Thu, 12 Apr 2012 11:21:48 -0400
From: Caswell, Sara J. <sara.caswell@nist.gov>
To: stephen.farrell@cs.tcd.ie <stephen.farrell@cs.tcd.ie>

**************** PLEASE DO NOT REPLY TO THIS EMAIL ****************

NIST requests comments on proposed changes to Federal Information =
Processing Standard 186-3, the Digital Signature Standard. The Federal =
Register Notice requests that electronic comments be sent by May 25, =
2012 to: =
fips_186-3_change_notice@nist.gov<mailto:fips_186-3_change_notice@nist.gov=
?Subject=3D186-3%20Change%20Notice>, with 186-3 Change Notice in the =
subject line.

The Federal Register =
Notice<http://csrc.nist.gov/fedreg/2012/frn_vol77_no69_tues-april-10-2012.=
pdf> for this proposed change notice for FIPS 186-3 can be accessed by =
clicking the link "Federal Register Notice".
The first link below is the Proposed Change Notice that are proposed for =
FIPS 186-3. The second link below is the current approved FIPS 186-3.

=
change-notice_fips-186-3.pdf<http://csrc.nist.gov/publications/drafts/fips=
186-3/change-notice_fips-186-3.pdf> (152 KB)
=
fips_186-3.pdf<http://csrc.nist.gov/publications/drafts/fips186-3/fips_186=
-3.pdf>

**************** PLEASE DO NOT REPLY TO THIS EMAIL ****************


From mcgrew@cisco.com  Tue Apr 24 08:37:52 2012
Return-Path: <mcgrew@cisco.com>
X-Original-To: cfrg@ietfa.amsl.com
Delivered-To: cfrg@ietfa.amsl.com
Received: from localhost (localhost [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id C4DEA21F8826 for <cfrg@ietfa.amsl.com>; Tue, 24 Apr 2012 08:37:52 -0700 (PDT)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -110.599
X-Spam-Level: 
X-Spam-Status: No, score=-110.599 tagged_above=-999 required=5 tests=[BAYES_00=-2.599, RCVD_IN_DNSWL_HI=-8, USER_IN_WHITELIST=-100]
Received: from mail.ietf.org ([12.22.58.30]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id q6YvjROzJN4F for <cfrg@ietfa.amsl.com>; Tue, 24 Apr 2012 08:37:52 -0700 (PDT)
Received: from mtv-iport-2.cisco.com (mtv-iport-2.cisco.com [173.36.130.13]) by ietfa.amsl.com (Postfix) with ESMTP id 3038B21F881B for <cfrg@irtf.org>; Tue, 24 Apr 2012 08:37:52 -0700 (PDT)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/simple; d=cisco.com; i=mcgrew@cisco.com; l=240; q=dns/txt; s=iport; t=1335281872; x=1336491472; h=from:content-transfer-encoding:subject:date:message-id: to:mime-version; bh=H+n2wO/Mx+6XpfoebYWfP0QFbkkBZLqOH3SKv+XbFpM=; b=lCmVAefLi4rskTZdvtMMXR1JcyKMibexVl7xm1XAkmyMxqBWNHRi9CEr x+PJ/+Rpl1nWuqYOIFmI5VpFtbJFrUM6rjg4VV9SPteMGZCWV1pFYNZZz L1r+weF2KPtk/Amc9nk8eA6ik+sbCIOumZZ+qFey6HcZfxDcuNgE+Sjcz k=;
X-IronPort-Anti-Spam-Filtered: true
X-IronPort-Anti-Spam-Result: AvwEAJjHlk+rRDoG/2dsb2JhbABEsXiBB4IiASeCModsDJkPgSigRwSOLIJCYwSVeo5VgWmDBQ
X-IronPort-AV: E=Sophos;i="4.75,473,1330905600"; d="scan'208";a="41953600"
Received: from mtv-core-1.cisco.com ([171.68.58.6]) by mtv-iport-2.cisco.com with ESMTP; 24 Apr 2012 15:37:51 +0000
Received: from stealth-10-32-254-214.cisco.com (stealth-10-32-254-214.cisco.com [10.32.254.214]) by mtv-core-1.cisco.com (8.14.3/8.14.3) with ESMTP id q3OFbpjc002337 for <cfrg@irtf.org>; Tue, 24 Apr 2012 15:37:51 GMT
From: David McGrew <mcgrew@cisco.com>
Content-Type: text/plain; charset=us-ascii
Content-Transfer-Encoding: quoted-printable
Date: Tue, 24 Apr 2012 11:37:51 -0400
Message-Id: <F89A2476-16C7-4726-A297-5038DD508E25@cisco.com>
To: cfrg@irtf.org
Mime-Version: 1.0 (Apple Message framework v1257)
X-Mailer: Apple Mail (2.1257)
Subject: [Cfrg] minutes from meeting at IETF83 posted
X-BeenThere: cfrg@irtf.org
X-Mailman-Version: 2.1.12
Precedence: list
List-Id: Crypto Forum Research Group <cfrg.irtf.org>
List-Unsubscribe: <http://www.irtf.org/mailman/options/cfrg>, <mailto:cfrg-request@irtf.org?subject=unsubscribe>
List-Archive: <http://www.irtf.org/mail-archive/web/cfrg>
List-Post: <mailto:cfrg@irtf.org>
List-Help: <mailto:cfrg-request@irtf.org?subject=help>
List-Subscribe: <http://www.irtf.org/mailman/listinfo/cfrg>, <mailto:cfrg-request@irtf.org?subject=subscribe>
X-List-Received-Date: Tue, 24 Apr 2012 15:37:52 -0000

Hi,=20

the minutes have been posted at =
<https://datatracker.ietf.org/meeting/83/materials.html> (search for =
"CFRG").   Thanks to Sean Turner for taking notes during the meeting.    =
  The presentations are also online.

David




From thomas.r.henderson@boeing.com  Tue Apr 24 17:03:18 2012
Return-Path: <thomas.r.henderson@boeing.com>
X-Original-To: cfrg@ietfa.amsl.com
Delivered-To: cfrg@ietfa.amsl.com
Received: from localhost (localhost [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id 0AD2421F8570 for <cfrg@ietfa.amsl.com>; Tue, 24 Apr 2012 17:03:18 -0700 (PDT)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -108.599
X-Spam-Level: 
X-Spam-Status: No, score=-108.599 tagged_above=-999 required=5 tests=[AWL=2.000, BAYES_00=-2.599, RCVD_IN_DNSWL_HI=-8, USER_IN_WHITELIST=-100]
Received: from mail.ietf.org ([12.22.58.30]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id y5UfGHIiN7fa for <cfrg@ietfa.amsl.com>; Tue, 24 Apr 2012 17:03:17 -0700 (PDT)
Received: from stl-smtpout-01.boeing.com (stl-smtpout-01.boeing.com [130.76.96.56]) by ietfa.amsl.com (Postfix) with ESMTP id 03B7C21F8557 for <cfrg@irtf.org>; Tue, 24 Apr 2012 17:03:16 -0700 (PDT)
Received: from stl-av-01.boeing.com (stl-av-01.boeing.com [192.76.190.6]) by stl-smtpout-01.ns.cs.boeing.com (8.14.4/8.14.4/8.14.4/SMTPOUT) with ESMTP id q3P04kwa024487 (version=TLSv1/SSLv3 cipher=DHE-RSA-AES256-SHA bits=256 verify=FAIL); Tue, 24 Apr 2012 19:04:51 -0500 (CDT)
Received: from stl-av-01.boeing.com (localhost [127.0.0.1]) by stl-av-01.boeing.com (8.14.4/8.14.4/DOWNSTREAM_RELAY) with ESMTP id q3P03Snp017274; Tue, 24 Apr 2012 19:03:28 -0500 (CDT)
Received: from XCH-NWHT-02.nw.nos.boeing.com (xch-nwht-02.nw.nos.boeing.com [130.247.70.248]) by stl-av-01.boeing.com (8.14.4/8.14.4/UPSTREAM_RELAY) with ESMTP id q3P03SZv017258 (version=TLSv1/SSLv3 cipher=RC4-MD5 bits=128 verify=OK); Tue, 24 Apr 2012 19:03:28 -0500 (CDT)
Received: from XCH-NW-16V.nw.nos.boeing.com ([130.247.25.240]) by XCH-NWHT-02.nw.nos.boeing.com ([130.247.70.248]) with mapi; Tue, 24 Apr 2012 17:02:52 -0700
From: "Henderson, Thomas R" <thomas.r.henderson@boeing.com>
To: "'cfrg@irtf.org'" <cfrg@irtf.org>
Date: Tue, 24 Apr 2012 17:02:52 -0700
Thread-Topic: advice about best current practices for HIP
Thread-Index: Ac0idsJYLzFbb+aKQea5f90FHsHniQ==
Message-ID: <758141CC3D829043A8C3164DD3D593EA1BD24C86F7@XCH-NW-16V.nw.nos.boeing.com>
Accept-Language: en-US
Content-Language: en-US
X-MS-Has-Attach: 
X-MS-TNEF-Correlator: 
acceptlanguage: en-US
Content-Type: text/plain; charset="us-ascii"
Content-Transfer-Encoding: quoted-printable
MIME-Version: 1.0
Cc: 'Robert Moskowitz' <rgm@htt-consult.com>
Subject: [Cfrg] advice about best current practices for HIP
X-BeenThere: cfrg@irtf.org
X-Mailman-Version: 2.1.12
Precedence: list
List-Id: Crypto Forum Research Group <cfrg.irtf.org>
List-Unsubscribe: <http://www.irtf.org/mailman/options/cfrg>, <mailto:cfrg-request@irtf.org?subject=unsubscribe>
List-Archive: <http://www.irtf.org/mail-archive/web/cfrg>
List-Post: <mailto:cfrg@irtf.org>
List-Help: <mailto:cfrg-request@irtf.org?subject=help>
List-Subscribe: <http://www.irtf.org/mailman/listinfo/cfrg>, <mailto:cfrg-request@irtf.org?subject=subscribe>
X-List-Received-Date: Wed, 25 Apr 2012 00:03:18 -0000

Hello, I'm one of the authors working on revising HIP [*], and I would like=
 advice on how to respond to an IESG comment on RFC5201.

The IESG comment in the experimental specification for HIP reads as follows=
:

   HIP defines the usage of RSA in signing and encrypting data.  Current
   recommendations propose usage of, for example, RSA OAEP/PSS for these
   operations in new protocols.  Changing the algorithms to more current
   best practice should be considered.

This comment was made over four years ago, and I'm not an expert on cryptog=
raphy, so I thought I'd check with the CFRG for advice on how to respond no=
w.

1) signature padding

Presently, the HIP draft specifies these algorithms for keys (section 5.2.9=
 of the draft):

        DSA              3 [RFC2536] (RECOMMENDED)
        RSA              5 [RFC3110] (REQUIRED)
        ECDSA            7 [RFC4754] (RECOMMENDED)
        ECDSA_LOW        9 [SECG]    (RECOMMENDED)

However, the specification of how to compute the signature is somewhat vagu=
e:

   3.  Compute the signature using the private key corresponding to the
       Host Identifier (public key).

I believe that, in practice, whatever default padding was provided by OpenS=
SL RSA_sign() has been used (I believe it to be PKCS#1 v1.5).  I'm wonderin=
g whether the way to address this comment is to mandate that, when signatur=
es are computed, and RSA is the key type, the RSAASA-PSS [RFC3447] method o=
f padding is required, and to replace the reference to RFC3110 above with R=
FC3447.

The above discussion is limited to RSA.  Do we need signature specification=
s for all of these key types, or is it well implied for the other key types=
 how to perform the signatures?

2) encryption padding

HIP uses a block cipher to generate ENCRYPTED parameters, using encryption =
keys generated by the Diffie Hellman exchange.  In practice, the Host Ident=
ity (a public key) may be encrypted for privacy in the I2 message.

These ciphers are specified for HIP (section 5.2.8 of the draft):=20

        AES-128-CBC        2     ([RFC3602])
        3DES-CBC           3     ([RFC2451])
        AES-256-CBC        4     ([RFC3602])

The draft specifies also to use whatever padding is specified by the encryp=
tion algorithm, citing PKCS5 for AES, and not mentioning 3DES-CBC padding (=
in practice, our implementation also pads this according to PKCS5).

I understand that RSAES-OAEP is a padding technique for key transport in pa=
rticular.  However, HIP does not specify RSA for encryption, and does not u=
se 'key transport' mode but rather 'data encryption' mode.  Does RSAES-OAEP=
 apply in this case?  Should HIP be considering another best practice algor=
ithm for doing this?

In closing, an important consideration for our implementations is availabil=
ity in OpenSSL, so required algorithms should be supported there.

Thanks,
Tom

[*] http://tools.ietf.org/html/draft-ietf-hip-rfc5201-bis-08
