From owner-ipfc@standards.gadzoox.com  Thu Feb  1 22:24:13 2001
Received: from standards.gadzoox.com (standards.gadzoox.com [216.52.31.24])
	by ietf.org (8.9.1a/8.9.1a) with SMTP id WAA18593
	for <ipfc-archive@odin.ietf.org>; Thu, 1 Feb 2001 22:24:12 -0500 (EST)
Received: (from majordom@localhost)
	by standards.gadzoox.com (8.8.7/8.8.7) id RAA14387
	for ipfc-list; Thu, 1 Feb 2001 17:36:50 -0800
X-Authentication-Warning: standards.gadzoox.com: majordom set sender to owner-ipfc@standards.gadzoox.com using -f
Received: from lightsand.com ([208.50.99.84])
	by standards.gadzoox.com (8.8.7/8.8.7) with SMTP id RAA14384
	for <ipfc@standards.gadzoox.com>; Thu, 1 Feb 2001 17:36:25 -0800
Received: from muralipc (dhcp094.lightsand.com [192.168.1.94])
	by lightsand.com (8.9.3+Sun/8.9.1) with SMTP id SAA26103;
	Thu, 1 Feb 2001 18:43:04 -0800 (PST)
From: "Murali Rajagopal" <muralir@lightsand.com>
To: "Mark A. Carlson" <mark.carlson@sun.com>
Cc: <gavin@gadzoox.com>, <lhu3@yahoo.com>, <nordmark@jurassic.Eng.Sun.COM>,
        <narten@raleigh.ibm.com>, <ipfc@standards.gadzoox.com>,
        "Erik Nordmark" <Erik.Nordmark@eng.sun.com>
Subject: RE: draft-ietf-ipfc-mib-framework-03.txt (Fwd)
Date: Thu, 1 Feb 2001 18:44:26 -0800
Message-ID: <MABBKAENHGDNNGLLHCPKIEKKCCAA.muralir@lightsand.com>
MIME-Version: 1.0
Content-Type: text/plain;
	charset="iso-8859-1"
Content-Transfer-Encoding: 7bit
X-Priority: 3 (Normal)
X-MSMail-Priority: Normal
X-Mailer: Microsoft Outlook IMO, Build 9.0.2416 (9.0.2911.0)
In-Reply-To: <Roam.SIMC.2.0.6.976665574.14385.nordmark@jurassic>
Importance: Normal
X-MimeOLE: Produced By Microsoft MimeOLE V5.00.2919.6600
Sender: owner-ipfc@standards.gadzoox.com
Precedence: bulk
Content-Transfer-Encoding: 7bit

Mark:

Please provide your plan of action regarding this.

-Murali

-----Original Message-----
From: owner-ipfc@standards.gadzoox.com
[mailto:owner-ipfc@standards.gadzoox.com]On Behalf Of Erik Nordmark
Sent: Tuesday, December 12, 2000 4:00 PM
To: muralir@lightsand.com
Cc: Mark A. Carlson; gavin@gadzoox.com; lhu3@yahoo.com;
nordmark@jurassic.Eng.Sun.COM; narten@raleigh.ibm.com;
ipfc@standards.gadzoox.com
Subject: RE: draft-ietf-ipfc-mib-framework-03.txt (Fwd)


The framework document was discussed in the IESG.

The overarching comment was that for the document to serve the WG
it should be more exact and specific when it comes to the set
of requirements that the WG are imposing on the fibre channel mibs.

See the detailed comments.

  Erik


- Section 3. text like:
     The Fibre Channel MIBs may consist of an arbitrary collection 
     of groups,and may contain objects of type: READ-ONLY,
      READ-WRITE, or WRITE-ONLY.

The WRITE-ONLY was a SMIv1 concept which no longer exists.

      The following principles should be observed in developing MIBs.
  
This then goes on to list a set of motherhood and apple pie items
that are common to all MIBs... so not ipfc specific.
Then follow a few ipfc specific items.
I can live with it, but the motherhood and apple pie might be omited.
The one statement for that is that they should be SMIv2 compliant.

- section 4.
  4.1 General
  These MIBs should provide for proxy SNMP management. 
  In other words, at a relatively high level of the MIB, table(s)
  should exist that allowmultiple entities to be referenced.
  The indexing of the table shouldallow multiple entities to be
  referenced through a single SNMP agent,at a single IP
  address.In general, an agent will proxy for a group of 
  devices from a singlevendor. 
  The method which an NMS uses to determine a set of 
  addressableagents is beyond the scope of this document.

This was needed for SNMPv1 and SNMPv2c. With SNMPv3
and the new SNMP Architecture (RFC2571), this is best
handled by using contextNames. If you do that, then there
are no more special considerations for proxy w.r.t. the MIB.
That then all becomes an SNMP agent configuration issue,
for which we have the SNMP PROXY MIB (RFC2573).
That then at the same time specifies a std for an NMS
to learn about the various contexts (logical MIBs if you like).

Another possibility is that maybe they want to use the
entity MIB (RFC2737) for this purpose too. Did they
evaluate that one?

I guess what I would like to see here is that maybe they
evaluate some of these alternatives and then justyify why
they choose a particular approach.

In addition, RFC 2837 doesn't have any proxy indexing (which is good)
so the framework document doesn't seem to capture what is currently done
in the ipfc MIBs.

- Section 4.2 Security

I don't think that the MIB needs to have anything
specific to allow for only read access. That is an implementation
issue. For an SNMP agent with only SNMPv1, it would be
something like specifying only community names with READ
access. In any event, it is not something that needs/should be
specified in a MIB itself (or maybe they mean that just english
text in the security section of such a mib should explain it...
that is fine... but not clear from what they write here.
Also... I am not sure that we would encourage read-only
access via SNMP and write access via HTTP??? If you
do that, I would rather encourage to use SNMPv3.

Section 5.1

Not sure I am happy with the terms "Proxy Management Domain"
and "Proxy Master". We do not have such terms in SNMP, and
also our use of the term "proxy" is not inline with what they 
describe (See RFC2571 and RFC2573). Their wording seems
to be more the description of a master agent and subagent,
somthing that we do know about as in RFC2741

Other nits:
- the reference [1] is not referenced anywhere and seems
  not needed to me.

- reference [2] should be to RFC2578 instead of 1902 which they
  already have as [7]

- but worse, references [2] through [7] are not referenced anywhere.
  So they just seem gratuitous references.

- I see no security section for this document itself. Sect 4.2 talks
  about what nbeeds to be done in MIBs in the ipfc environment
  I believe.

- no standard copy-right section.


---





From owner-ipfc@standards.gadzoox.com  Fri Feb  2 09:25:28 2001
Received: from standards.gadzoox.com (standards.gadzoox.com [216.52.31.24])
	by ietf.org (8.9.1a/8.9.1a) with SMTP id JAA09972
	for <ipfc-archive@odin.ietf.org>; Fri, 2 Feb 2001 09:25:27 -0500 (EST)
Received: (from majordom@localhost)
	by standards.gadzoox.com (8.8.7/8.8.7) id EAA14840
	for ipfc-list; Fri, 2 Feb 2001 04:47:29 -0800
X-Authentication-Warning: standards.gadzoox.com: majordom set sender to owner-ipfc@standards.gadzoox.com using -f
Received: from s3.smtp.oleane.net (s3.smtp.oleane.net [195.25.12.10])
	by standards.gadzoox.com (8.8.7/8.8.7) with SMTP id EAA14837
	for <ipfc@standards.gadzoox.com>; Fri, 2 Feb 2001 04:47:23 -0800
Received: from smtp2.cluster.oleane.net (smtp2.cluster.oleane.net [195.25.12.17])
	by s3.smtp.oleane.net (Postfix) with ESMTP id D013221239
	for <ipfc@standards.gadzoox.com>; Fri,  2 Feb 2001 14:56:56 +0100 (CET)
Received: from oleane (dyn-1-2-204.Vin.dialup.oleane.fr [194.2.4.204]) by smtp2.cluster.oleane.net with SMTP id f12DgtO69255 for <ipfc@standards.gadzoox.com>; Fri, 2 Feb 2001 14:42:55 +0100 (CET)
Message-ID: <004901c08d1e$29c3b180$8001a8c0@oleane.com>
From: "Peter Lewis" <peter.lewis@upperside.fr>
To: <ipfc@standards.gadzoox.com>
Subject: Beyond Sonet/SDH Conference
Date: Fri, 2 Feb 2001 14:43:44 +0100
MIME-Version: 1.0
Content-Type: multipart/alternative;
	boundary="----=_NextPart_000_0046_01C08D26.8B2C8C00"
X-Priority: 3
X-MSMail-Priority: Normal
X-Mailer: Microsoft Outlook Express 5.00.2314.1300
X-MIMEOLE: Produced By Microsoft MimeOLE V5.00.2314.1300
Sender: owner-ipfc@standards.gadzoox.com
Precedence: bulk

This is a multi-part message in MIME format.

------=_NextPart_000_0046_01C08D26.8B2C8C00
Content-Type: text/plain;
	charset="Windows-1252"
Content-Transfer-Encoding: quoted-printable

Everything on Gigabit Ethernet and 10 Gigabit Ethernet promises in the =
MAN & WAN.
Digital Wrapper, Resilient Packet Ring, Spatial Reuse Protocol, PONs, =
ASON technical descriptions :
Beyond Sonet/SDH Conference, Paris, 10-13 April.
Close to the Gigabit Ethernet Exhibition , 11-12 April
=20
http://www.upperside.fr/babeyondsdh.htm

------=_NextPart_000_0046_01C08D26.8B2C8C00
Content-Type: text/html;
	charset="Windows-1252"
Content-Transfer-Encoding: quoted-printable

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
<HTML><HEAD>
<META content=3D"text/html; charset=3Dwindows-1252" =
http-equiv=3DContent-Type>
<META content=3D"MSHTML 5.00.2314.1000" name=3DGENERATOR>
<STYLE></STYLE>
</HEAD>
<BODY bgColor=3D#ffffff>
<DIV><FONT face=3DArial size=3D2>
<DIV><FONT color=3D#000000 size=3D2>Everything on Gigabit Ethernet and =
10 Gigabit=20
Ethernet promises in the MAN &amp; WAN.</FONT></DIV>
<DIV><FONT color=3D#000000 size=3D2></FONT><FONT size=3D2>Digital =
Wrapper, Resilient=20
Packet Ring, Spatial Reuse Protocol, PONs, ASON technical descriptions=20
:</FONT></DIV>
<DIV><FONT color=3D#000000 size=3D2><STRONG>Beyond Sonet/SDH =
Conference</STRONG>,=20
Paris, 10-13 April.</FONT></DIV>
<DIV><FONT color=3D#000000 size=3D2>Close to the <STRONG>Gigabit =
Ethernet Exhibition=20
</STRONG>, 11-12 April</FONT></DIV>
<DIV><FONT color=3D#000000 size=3D2></FONT>&nbsp;</DIV>
<DIV><FONT color=3D#000000 size=3D2><A=20
href=3D"http://www.upperside.fr/babeyondsdh.htm">http://www.upperside.fr/=
babeyondsdh.htm</A></FONT></DIV></FONT></DIV></BODY></HTML>

------=_NextPart_000_0046_01C08D26.8B2C8C00--



From owner-ipfc@standards.gadzoox.com  Mon Feb 12 16:40:19 2001
Received: from standards.gadzoox.com (standards.gadzoox.com [216.52.31.24])
	by ietf.org (8.9.1a/8.9.1a) with SMTP id QAA22121
	for <ipfc-archive@odin.ietf.org>; Mon, 12 Feb 2001 16:40:18 -0500 (EST)
Received: (from majordom@localhost)
	by standards.gadzoox.com (8.8.7/8.8.7) id LAA20543
	for ipfc-list; Mon, 12 Feb 2001 11:49:45 -0800
X-Authentication-Warning: standards.gadzoox.com: majordom set sender to owner-ipfc@standards.gadzoox.com using -f
Received: from lightsand.com ([208.50.99.84])
	by standards.gadzoox.com (8.8.7/8.8.7) with SMTP id LAA20540
	for <ipfc@standards.gadzoox.com>; Mon, 12 Feb 2001 11:49:40 -0800
Received: from muralipc ([192.168.2.52])
	by lightsand.com (8.9.3+Sun/8.9.1) with SMTP id MAA23272
	for <ipfc@standards.gadzoox.com>; Mon, 12 Feb 2001 12:58:46 -0800 (PST)
From: "Murali Rajagopal" <muralir@lightsand.com>
To: <ipfc@standards.gadzoox.com>
Subject: FW: IP over Fibre throughput numbers
Date: Mon, 12 Feb 2001 13:00:12 -0800
Message-ID: <MABBKAENHGDNNGLLHCPKCENPCCAA.muralir@lightsand.com>
MIME-Version: 1.0
Content-Type: multipart/alternative;
	boundary="----=_NextPart_000_0002_01C094F3.BC285EE0"
X-Priority: 3 (Normal)
X-MSMail-Priority: Normal
X-Mailer: Microsoft Outlook IMO, Build 9.0.2416 (9.0.2911.0)
Importance: Normal
X-MimeOLE: Produced By Microsoft MimeOLE V5.00.2919.6600
Sender: owner-ipfc@standards.gadzoox.com
Precedence: bulk

This is a multi-part message in MIME format.

------=_NextPart_000_0002_01C094F3.BC285EE0
Content-Type: text/plain;
	charset="iso-8859-1"
Content-Transfer-Encoding: 7bit

Please respond to the IPFC reflector if you have any comments.

-----Original Message-----
From: Dennis Solari [mailto:dys70@amdahl.com]
Sent: Wednesday, January 17, 2001 10:37 AM
To: muralir@lightsand.com
Subject: Fw: IP over Fibre throughput numbers


Just curious if you received this email from me?

Dennis (Amdahl Corp)
678-319-4226

----- Original Message -----
From: Dennis Solari
To: muralir@lightsand.com
Sent: Tuesday, January 16, 2001 9:41 PM
Subject: IP over Fibre throughput numbers


Murali,
I am currently testing the speed I can get with IP over fibre channel using:
* two Sun Ultra 5's (360Mhz)
* both are have Emulex LP8000 SCSI/IP combo fibre channel PCI cards
* connected through a Brocade silkworm 2400 switch.

I can only drive IP over fibre to as high as ~200 Mbs. using iperf
(variation of ttcp utility)

What are some numbers you have seen doing bandwith testing while tweaking
the Unix TCP/IP stack?
Do you know were I can get other performance numbers of people doing the
same type performance tests?

Thanks in Advance,
Dennis

------=_NextPart_000_0002_01C094F3.BC285EE0
Content-Type: text/html;
	charset="iso-8859-1"
Content-Transfer-Encoding: quoted-printable

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
<HTML><HEAD>
<META content=3D"text/html; charset=3Diso-8859-1" =
http-equiv=3DContent-Type>
<META content=3D"MSHTML 5.00.2919.6307" name=3DGENERATOR>
<STYLE></STYLE>
</HEAD>
<BODY bgColor=3D#ffffff>
<DIV><FONT color=3D#0000ff face=3DArial size=3D2><SPAN =
class=3D540305920-12022001>Please=20
respond to the IPFC reflector if you have any =
comments.</SPAN></FONT></DIV>
<DIV><FONT color=3D#0000ff face=3DArial size=3D2><SPAN=20
class=3D540305920-12022001></SPAN></FONT>&nbsp;</DIV>
<DIV align=3Dleft class=3DOutlookMessageHeader dir=3Dltr><FONT =
face=3DTahoma=20
size=3D2>-----Original Message-----<BR><B>From:</B> Dennis Solari=20
[mailto:dys70@amdahl.com]<BR><B>Sent:</B> Wednesday, January 17, 2001 =
10:37=20
AM<BR><B>To:</B> muralir@lightsand.com<BR><B>Subject:</B> Fw: IP over =
Fibre=20
throughput numbers<BR><BR></FONT></DIV>
<DIV><FONT size=3D2>Just curious if you received this email from =
me?</FONT></DIV>
<DIV>&nbsp;</DIV>
<DIV><FONT size=3D2>Dennis (Amdahl Corp)</FONT></DIV>
<DIV><FONT size=3D2>678-319-4226</FONT></DIV>
<DIV>&nbsp;</DIV>
<DIV style=3D"FONT: 10pt arial">----- Original Message -----=20
<DIV style=3D"BACKGROUND: #e4e4e4; font-color: black"><B>From:</B> <A=20
href=3D"mailto:dys70@amdahl.com" title=3Ddys70@amdahl.com>Dennis =
Solari</A> </DIV>
<DIV><B>To:</B> <A href=3D"mailto:muralir@lightsand.com"=20
title=3Dmuralir@lightsand.com>muralir@lightsand.com</A> </DIV>
<DIV><B>Sent:</B> Tuesday, January 16, 2001 9:41 PM</DIV>
<DIV><B>Subject:</B> IP over Fibre throughput numbers</DIV></DIV>
<DIV><BR></DIV>
<DIV><FONT size=3D2>Murali,</FONT></DIV>
<DIV><FONT size=3D2>I am currently testing the speed I can get with IP =
over fibre=20
channel using:</FONT></DIV>
<DIV><FONT size=3D2>*&nbsp;two Sun&nbsp;Ultra 5's (360Mhz)</FONT></DIV>
<DIV><FONT size=3D2>* both are&nbsp;have Emulex LP8000&nbsp;SCSI/IP =
combo fibre=20
channel PCI cards</FONT></DIV>
<DIV><FONT size=3D2>* connected through a Brocade silkworm 2400=20
switch.</FONT></DIV>
<DIV>&nbsp;</DIV>
<DIV><FONT size=3D2>I can&nbsp;only drive IP over fibre to&nbsp;as high =
as ~200=20
Mbs. using iperf (variation of ttcp utility)</FONT></DIV>
<DIV>&nbsp;</DIV>
<DIV><FONT size=3D2>What are some numbers you have seen doing bandwith =
testing=20
while tweaking the Unix&nbsp;TCP/IP stack?</FONT></DIV>
<DIV><FONT size=3D2>Do you know were I can get other performance numbers =
of people=20
doing the same type performance tests?</FONT></DIV>
<DIV>&nbsp;</DIV>
<DIV><FONT size=3D2>Thanks in Advance,</FONT></DIV>
<DIV><FONT size=3D2>Dennis</FONT>&nbsp;</DIV></BODY></HTML>

------=_NextPart_000_0002_01C094F3.BC285EE0--



From owner-ipfc@standards.gadzoox.com  Mon Feb 12 16:55:23 2001
Received: from standards.gadzoox.com (standards.gadzoox.com [216.52.31.24])
	by ietf.org (8.9.1a/8.9.1a) with SMTP id QAA22417
	for <ipfc-archive@odin.ietf.org>; Mon, 12 Feb 2001 16:55:22 -0500 (EST)
Received: (from majordom@localhost)
	by standards.gadzoox.com (8.8.7/8.8.7) id MAA20561
	for ipfc-list; Mon, 12 Feb 2001 12:20:57 -0800
X-Authentication-Warning: standards.gadzoox.com: majordom set sender to owner-ipfc@standards.gadzoox.com using -f
Received: from lightsand.com ([208.50.99.84])
	by standards.gadzoox.com (8.8.7/8.8.7) with SMTP id MAA20558
	for <ipfc@standards.gadzoox.com>; Mon, 12 Feb 2001 12:20:52 -0800
Received: from muralipc ([192.168.2.52])
	by lightsand.com (8.9.3+Sun/8.9.1) with SMTP id NAA24706;
	Mon, 12 Feb 2001 13:29:21 -0800 (PST)
From: "Murali Rajagopal" <muralir@lightsand.com>
To: "Infante, Jon" <Jon.Infante@emulex.com>
Cc: "Weber, William L" <William.Weber@unisys.com>,
        "IPFC Mailing List \(E-mail\)" <ipfc@standards.gadzoox.com>
Subject: RE: Question about WW_NN and RFC 2625
Date: Mon, 12 Feb 2001 13:30:47 -0800
Message-ID: <MABBKAENHGDNNGLLHCPKEEOBCCAA.muralir@lightsand.com>
MIME-Version: 1.0
Content-Type: text/plain;
	charset="iso-8859-1"
Content-Transfer-Encoding: 7bit
X-Priority: 3 (Normal)
X-MSMail-Priority: Normal
X-Mailer: Microsoft Outlook IMO, Build 9.0.2416 (9.0.2911.0)
Importance: Normal
X-MimeOLE: Produced By Microsoft MimeOLE V5.00.2919.6600
In-Reply-To: <3A5E4F86.21BE36B2@emulex.com>
Sender: owner-ipfc@standards.gadzoox.com
Precedence: bulk
Content-Transfer-Encoding: 7bit

Jon:

I have to agree that the document does not spell it out.

I also agree that there no reason not to allow other NAA types for WW_NN.

But when you consider FARP, there is an implication that the WW_PN and WW_NN
use the same NAA Type. (Nobody said anything about a different NAA type
during FARP discussions!)

Hope this clarifes what I said.

-Murali
-----Original Message-----
From: owner-ipfc@standards.gadzoox.com
[mailto:owner-ipfc@standards.gadzoox.com]On Behalf Of Infante, Jon
Sent: Thursday, January 11, 2001 4:28 PM
To: Murali Rajagopal
Cc: Weber, William L; IPFC Mailing List (E-mail)
Subject: Re: Question about WW_NN and RFC 2625


Murali,

I disagree. The Fibre Channel Network header ONLY contains the
WWPN. That is the main reason the NAA for the WWPN must
be 1 (mapping MAC addresses to WWPNs).

Correct me if I'm wrong. however, I don't see any  technical reason
for the WWNN NAA to be 1 nor did I infer that was the intent of
the many discussions the group had on this topic???

Jon


Murali Rajagopal wrote:

> The intent was NAA=1 for both.
> If it did not get reflected, then it was an oversight.
>
> -Murali
>
> -----Original Message-----
> From: owner-ipfc@standards.gadzoox.com
> [mailto:owner-ipfc@standards.gadzoox.com]On Behalf Of Infante, Jon
> Sent: Thursday, January 11, 2001 8:13 AM
> To: Weber, William L
> Cc: IPFC Mailing List (E-mail)
> Subject: Re: Question about WW_NN and RFC 2625
>
> Bill,
>
> My understanding is that only the World Wide Port Name requires NAA = 1.
> It is not a requirement for the World Wide Node Name to have NAA = 1;
>
> Jon Infante
> Emulex
>
> "Weber, William L" wrote:
>
> > I have a question concerning RFC 2625, IP and ARP over Fibre Channel,
and
> > Network_Address_Authority (NAA) of World Wide Names (WWN).  I thought
this
> > would be the proper forum to present the question.
> > The question is:
> >    Can the Node WWN (WW_NN) use NAA=5 for IEEE registered format and
still
> > be
> >    compliant/compatible with RFC 2625?
> >
> > I understand that the RFC 2625 requires the Port WWN (WW_PN) to use NAA
=
> 1
> > for IEEE 48-bit addresses.  RFC 2625 does not explicitly state the NAA
for
> > the WW_NN, however the examples in Appendix E (i.e. E.4.2) show the
WW_NN
> > with NAA=1.
> >
> > Thanks,
> > // Bill Weber               Phone: +1-610-648-7022
> > // Unisys Corporation       Fax:   +1-610-648-4010
> > // 2476 Swedesford Rd.      mailto:William.Weber@unisys.com
> > // Malvern, PA 19355-9700





From owner-ipfc@standards.gadzoox.com  Mon Feb 12 18:27:00 2001
Received: from standards.gadzoox.com (standards.gadzoox.com [216.52.31.24])
	by ietf.org (8.9.1a/8.9.1a) with SMTP id SAA23744
	for <ipfc-archive@odin.ietf.org>; Mon, 12 Feb 2001 18:26:58 -0500 (EST)
Received: (from majordom@localhost)
	by standards.gadzoox.com (8.8.7/8.8.7) id NAA20707
	for ipfc-list; Mon, 12 Feb 2001 13:48:03 -0800
X-Authentication-Warning: standards.gadzoox.com: majordom set sender to owner-ipfc@standards.gadzoox.com using -f
Received: from emulex.emulex.com (emulex.emulex.com [138.239.112.1])
	by standards.gadzoox.com (8.8.7/8.8.7) with SMTP id NAA20704
	for <ipfc@standards.gadzoox.com>; Mon, 12 Feb 2001 13:47:58 -0800
Received: from emulex.com (jinfantepc.emulex.com [138.239.96.81])
	by emulex.emulex.com (8.9.1a/8.9.1) with ESMTP id OAA02650;
	Mon, 12 Feb 2001 14:52:29 -0800 (PST)
Message-ID: <3A886A0D.3890B5DC@emulex.com>
Date: Mon, 12 Feb 2001 14:56:13 -0800
From: "Infante, Jon" <Jon.Infante@emulex.com>
Organization: Emulex Corporation
X-Mailer: Mozilla 4.74 [en] (Win98; U)
X-Accept-Language: en
MIME-Version: 1.0
To: Murali Rajagopal <muralir@lightsand.com>
CC: "Weber, William L" <William.Weber@unisys.com>,
        "IPFC Mailing List (E-mail)" <ipfc@standards.gadzoox.com>
Subject: Re: Question about WW_NN and RFC 2625
References: <MABBKAENHGDNNGLLHCPKEEOBCCAA.muralir@lightsand.com>
Content-Type: text/plain; charset=us-ascii
Content-Transfer-Encoding: 7bit
Content-Transfer-Encoding: 7bit
Sender: owner-ipfc@standards.gadzoox.com
Precedence: bulk
Content-Transfer-Encoding: 7bit

Murali,

I agree that the document does not spell it out and that there no reason not to
allow other NAA types for WWNN.

With regards to FARP, I thought special consideration was given to make FARP a
generic ELS command and not specifically tie it to our IP Profile. Thus the WWPN
and WWNN in the FARP payload specifies the full 8 byte WWN and not just the last
6 bytes as in a IEEE address.

Considering you can specify  the full 8 byte WWNN, the full 8 byte WWPN and the
Match Address Code Points specify match on just the WWNN, just the WWPN, or
both, I don't feel there is any implication that the WWPN and WWNN use the same
NAA Type. In fact, I don't think the FARP chapter mentions NAA at all.

Jon


Murali Rajagopal wrote:

> Jon:
>
> I have to agree that the document does not spell it out.
>
> I also agree that there no reason not to allow other NAA types for WW_NN.
>
> But when you consider FARP, there is an implication that the WW_PN and WW_NN
> use the same NAA Type. (Nobody said anything about a different NAA type
> during FARP discussions!)
>
> Hope this clarifes what I said.
>
> -Murali
> -----Original Message-----
> From: owner-ipfc@standards.gadzoox.com
> [mailto:owner-ipfc@standards.gadzoox.com]On Behalf Of Infante, Jon
> Sent: Thursday, January 11, 2001 4:28 PM
> To: Murali Rajagopal
> Cc: Weber, William L; IPFC Mailing List (E-mail)
> Subject: Re: Question about WW_NN and RFC 2625
>
> Murali,
>
> I disagree. The Fibre Channel Network header ONLY contains the
> WWPN. That is the main reason the NAA for the WWPN must
> be 1 (mapping MAC addresses to WWPNs).
>
> Correct me if I'm wrong. however, I don't see any  technical reason
> for the WWNN NAA to be 1 nor did I infer that was the intent of
> the many discussions the group had on this topic???
>
> Jon
>
> Murali Rajagopal wrote:
>
> > The intent was NAA=1 for both.
> > If it did not get reflected, then it was an oversight.
> >
> > -Murali
> >
> > -----Original Message-----
> > From: owner-ipfc@standards.gadzoox.com
> > [mailto:owner-ipfc@standards.gadzoox.com]On Behalf Of Infante, Jon
> > Sent: Thursday, January 11, 2001 8:13 AM
> > To: Weber, William L
> > Cc: IPFC Mailing List (E-mail)
> > Subject: Re: Question about WW_NN and RFC 2625
> >
> > Bill,
> >
> > My understanding is that only the World Wide Port Name requires NAA = 1.
> > It is not a requirement for the World Wide Node Name to have NAA = 1;
> >
> > Jon Infante
> > Emulex
> >
> > "Weber, William L" wrote:
> >
> > > I have a question concerning RFC 2625, IP and ARP over Fibre Channel,
> and
> > > Network_Address_Authority (NAA) of World Wide Names (WWN).  I thought
> this
> > > would be the proper forum to present the question.
> > > The question is:
> > >    Can the Node WWN (WW_NN) use NAA=5 for IEEE registered format and
> still
> > > be
> > >    compliant/compatible with RFC 2625?
> > >
> > > I understand that the RFC 2625 requires the Port WWN (WW_PN) to use NAA
> =
> > 1
> > > for IEEE 48-bit addresses.  RFC 2625 does not explicitly state the NAA
> for
> > > the WW_NN, however the examples in Appendix E (i.e. E.4.2) show the
> WW_NN
> > > with NAA=1.
> > >
> > > Thanks,
> > > // Bill Weber               Phone: +1-610-648-7022
> > > // Unisys Corporation       Fax:   +1-610-648-4010
> > > // 2476 Swedesford Rd.      mailto:William.Weber@unisys.com
> > > // Malvern, PA 19355-9700



From owner-ipfc@standards.gadzoox.com  Mon Feb 12 19:07:20 2001
Received: from standards.gadzoox.com (standards.gadzoox.com [216.52.31.24])
	by ietf.org (8.9.1a/8.9.1a) with SMTP id TAA24183
	for <ipfc-archive@odin.ietf.org>; Mon, 12 Feb 2001 19:07:19 -0500 (EST)
Received: (from majordom@localhost)
	by standards.gadzoox.com (8.8.7/8.8.7) id OAA20787
	for ipfc-list; Mon, 12 Feb 2001 14:32:42 -0800
X-Authentication-Warning: standards.gadzoox.com: majordom set sender to owner-ipfc@standards.gadzoox.com using -f
Received: from lightsand.com ([208.50.99.84])
	by standards.gadzoox.com (8.8.7/8.8.7) with SMTP id OAA20784
	for <ipfc@standards.gadzoox.com>; Mon, 12 Feb 2001 14:32:38 -0800
Received: from muralipc ([192.168.2.52])
	by lightsand.com (8.9.3+Sun/8.9.1) with SMTP id PAA29109;
	Mon, 12 Feb 2001 15:41:11 -0800 (PST)
From: "Murali Rajagopal" <muralir@lightsand.com>
To: "Infante, Jon" <Jon.Infante@emulex.com>
Cc: "Weber, William L" <William.Weber@unisys.com>,
        "IPFC Mailing List \(E-mail\)" <ipfc@standards.gadzoox.com>
Subject: RE: Question about WW_NN and RFC 2625
Date: Mon, 12 Feb 2001 15:42:36 -0800
Message-ID: <MABBKAENHGDNNGLLHCPKOEOGCCAA.muralir@lightsand.com>
MIME-Version: 1.0
Content-Type: text/plain;
	charset="iso-8859-1"
Content-Transfer-Encoding: 7bit
X-Priority: 3 (Normal)
X-MSMail-Priority: Normal
X-Mailer: Microsoft Outlook IMO, Build 9.0.2416 (9.0.2911.0)
Importance: Normal
X-MimeOLE: Produced By Microsoft MimeOLE V5.00.2919.6600
In-Reply-To: <3A886A0D.3890B5DC@emulex.com>
Sender: owner-ipfc@standards.gadzoox.com
Precedence: bulk
Content-Transfer-Encoding: 7bit

Jon:

I fully agree with your statements. They are technically accurate.

A guess it helps to assert that a different NAA type for the WW_NN
should be allowed. This should put to rest any subjective interpretations
such as mine and others (we would not be having a email discussion on this
at this time).

Regards,

Murali

-----Original Message-----
From: owner-ipfc@standards.gadzoox.com
[mailto:owner-ipfc@standards.gadzoox.com]On Behalf Of Infante, Jon
Sent: Monday, February 12, 2001 2:56 PM
To: Murali Rajagopal
Cc: Weber, William L; IPFC Mailing List (E-mail)
Subject: Re: Question about WW_NN and RFC 2625


Murali,

I agree that the document does not spell it out and that there no reason not
to
allow other NAA types for WWNN.

With regards to FARP, I thought special consideration was given to make FARP
a
generic ELS command and not specifically tie it to our IP Profile. Thus the
WWPN
and WWNN in the FARP payload specifies the full 8 byte WWN and not just the
last
6 bytes as in a IEEE address.

Considering you can specify  the full 8 byte WWNN, the full 8 byte WWPN and
the
Match Address Code Points specify match on just the WWNN, just the WWPN, or
both, I don't feel there is any implication that the WWPN and WWNN use the
same
NAA Type. In fact, I don't think the FARP chapter mentions NAA at all.

Jon


Murali Rajagopal wrote:

> Jon:
>
> I have to agree that the document does not spell it out.
>
> I also agree that there no reason not to allow other NAA types for WW_NN.
>
> But when you consider FARP, there is an implication that the WW_PN and
WW_NN
> use the same NAA Type. (Nobody said anything about a different NAA type
> during FARP discussions!)
>
> Hope this clarifes what I said.
>
> -Murali
> -----Original Message-----
> From: owner-ipfc@standards.gadzoox.com
> [mailto:owner-ipfc@standards.gadzoox.com]On Behalf Of Infante, Jon
> Sent: Thursday, January 11, 2001 4:28 PM
> To: Murali Rajagopal
> Cc: Weber, William L; IPFC Mailing List (E-mail)
> Subject: Re: Question about WW_NN and RFC 2625
>
> Murali,
>
> I disagree. The Fibre Channel Network header ONLY contains the
> WWPN. That is the main reason the NAA for the WWPN must
> be 1 (mapping MAC addresses to WWPNs).
>
> Correct me if I'm wrong. however, I don't see any  technical reason
> for the WWNN NAA to be 1 nor did I infer that was the intent of
> the many discussions the group had on this topic???
>
> Jon
>
> Murali Rajagopal wrote:
>
> > The intent was NAA=1 for both.
> > If it did not get reflected, then it was an oversight.
> >
> > -Murali
> >
> > -----Original Message-----
> > From: owner-ipfc@standards.gadzoox.com
> > [mailto:owner-ipfc@standards.gadzoox.com]On Behalf Of Infante, Jon
> > Sent: Thursday, January 11, 2001 8:13 AM
> > To: Weber, William L
> > Cc: IPFC Mailing List (E-mail)
> > Subject: Re: Question about WW_NN and RFC 2625
> >
> > Bill,
> >
> > My understanding is that only the World Wide Port Name requires NAA = 1.
> > It is not a requirement for the World Wide Node Name to have NAA = 1;
> >
> > Jon Infante
> > Emulex
> >
> > "Weber, William L" wrote:
> >
> > > I have a question concerning RFC 2625, IP and ARP over Fibre Channel,
> and
> > > Network_Address_Authority (NAA) of World Wide Names (WWN).  I thought
> this
> > > would be the proper forum to present the question.
> > > The question is:
> > >    Can the Node WWN (WW_NN) use NAA=5 for IEEE registered format and
> still
> > > be
> > >    compliant/compatible with RFC 2625?
> > >
> > > I understand that the RFC 2625 requires the Port WWN (WW_PN) to use
NAA
> =
> > 1
> > > for IEEE 48-bit addresses.  RFC 2625 does not explicitly state the NAA
> for
> > > the WW_NN, however the examples in Appendix E (i.e. E.4.2) show the
> WW_NN
> > > with NAA=1.
> > >
> > > Thanks,
> > > // Bill Weber               Phone: +1-610-648-7022
> > > // Unisys Corporation       Fax:   +1-610-648-4010
> > > // 2476 Swedesford Rd.      mailto:William.Weber@unisys.com
> > > // Malvern, PA 19355-9700




From owner-ipfc@standards.gadzoox.com  Tue Feb 13 17:47:15 2001
Received: from standards.gadzoox.com (standards.gadzoox.com [216.52.31.24])
	by ietf.org (8.9.1a/8.9.1a) with SMTP id RAA01990
	for <ipfc-archive@odin.ietf.org>; Tue, 13 Feb 2001 17:47:14 -0500 (EST)
Received: (from majordom@localhost)
	by standards.gadzoox.com (8.8.7/8.8.7) id NAA21586
	for ipfc-list; Tue, 13 Feb 2001 13:05:03 -0800
X-Authentication-Warning: standards.gadzoox.com: majordom set sender to owner-ipfc@standards.gadzoox.com using -f
Received: from ludwig.troikanetworks.com (ludwig.troikanetworks.com [12.31.172.3])
	by standards.gadzoox.com (8.8.7/8.8.7) with SMTP id NAB21583
	for <ipfc@standards.gadzoox.com>; Tue, 13 Feb 2001 13:04:58 -0800
Received: by host03.troikanetworks.com with Internet Mail Service (5.5.2653.19)
	id <D48QVG01>; Tue, 13 Feb 2001 14:15:16 -0800
Message-ID: <C7CA595F9B9FD311A40D009027DC4A85D57FA7@host03.troikanetworks.com>
From: Bill Moshier <billm@TroikaNetworks.com>
To: ipfc@standards.gadzoox.com
Subject: RE: IP over Fibre throughput numbers
Date: Tue, 13 Feb 2001 14:15:15 -0800
MIME-Version: 1.0
X-Mailer: Internet Mail Service (5.5.2653.19)
Content-Type: multipart/alternative;
	boundary="----_=_NextPart_001_01C0960A.70D46160"
Sender: owner-ipfc@standards.gadzoox.com
Precedence: bulk

This message is in MIME format. Since your mail reader does not understand
this format, some or all of this message may not be legible.

------_=_NextPart_001_01C0960A.70D46160
Content-Type: text/plain;
	charset="iso-8859-1"

Dennis - I've been able to get more than 850Mbs (more than 85 MBytes/sec),
on 
Windows 2k using Troika fibre-channel cards and Brocade switches, using 
iometer to measure the throughput. You might check to see if you can use
large 
packets (size greater than one fibre-channel frame).  My numbers were with
16Kbyte
ip packets.  
 
Bill Moshier

-----Original Message-----
From: Murali Rajagopal [mailto:muralir@lightsand.com]
Sent: Monday, February 12, 2001 1:00 PM
To: ipfc@standards.gadzoox.com
Subject: FW: IP over Fibre throughput numbers


Please respond to the IPFC reflector if you have any comments.
 
-----Original Message-----
From: Dennis Solari [mailto:dys70@amdahl.com]
Sent: Wednesday, January 17, 2001 10:37 AM
To: muralir@lightsand.com
Subject: Fw: IP over Fibre throughput numbers


Just curious if you received this email from me?
 
Dennis (Amdahl Corp)
678-319-4226
 
----- Original Message ----- 
From: Dennis Solari <mailto:dys70@amdahl.com>  
To: muralir@lightsand.com <mailto:muralir@lightsand.com>  
Sent: Tuesday, January 16, 2001 9:41 PM
Subject: IP over Fibre throughput numbers

Murali,
I am currently testing the speed I can get with IP over fibre channel using:
* two Sun Ultra 5's (360Mhz)
* both are have Emulex LP8000 SCSI/IP combo fibre channel PCI cards
* connected through a Brocade silkworm 2400 switch.
 
I can only drive IP over fibre to as high as ~200 Mbs. using iperf
(variation of ttcp utility)
 
What are some numbers you have seen doing bandwith testing while tweaking
the Unix TCP/IP stack?
Do you know were I can get other performance numbers of people doing the
same type performance tests?
 
Thanks in Advance,
Dennis 


------_=_NextPart_001_01C0960A.70D46160
Content-Type: text/html;
	charset="iso-8859-1"

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
<HTML><HEAD>
<META HTTP-EQUIV="Content-Type" CONTENT="text/html; charset=iso-8859-1">


<META content="MSHTML 5.00.3018.900" name=GENERATOR>
<STYLE></STYLE>
</HEAD>
<BODY bgColor=#ffffff>
<DIV><FONT color=#0000ff face=Arial size=2><SPAN class=870250622-13022001>Dennis 
- I've been able to get more than 850Mbs (more than 85 MBytes/sec), on 
</SPAN></FONT></DIV>
<DIV><FONT color=#0000ff face=Arial size=2><SPAN 
class=870250622-13022001>Windows 2k using </SPAN></FONT><FONT color=#0000ff 
face=Arial size=2><SPAN class=870250622-13022001>Troika fibre-channel cards and 
Brocade switches, using </SPAN></FONT></DIV>
<DIV><FONT color=#0000ff face=Arial size=2><SPAN 
class=870250622-13022001>iometer to measure </SPAN></FONT><FONT color=#0000ff 
face=Arial size=2><SPAN class=870250622-13022001>the throughput. 
</SPAN></FONT><FONT color=#0000ff face=Arial size=2><SPAN 
class=870250622-13022001>You might check to see if you can use large 
</SPAN></FONT></DIV>
<DIV><FONT color=#0000ff face=Arial size=2><SPAN 
class=870250622-13022001>packets </SPAN></FONT><FONT color=#0000ff face=Arial 
size=2><SPAN class=870250622-13022001>(size greater than one fibre-channel 
frame).&nbsp; My numbers were with 16Kbyte</SPAN></FONT></DIV>
<DIV><FONT color=#0000ff face=Arial size=2><SPAN class=870250622-13022001>ip 
packets.&nbsp; </SPAN></FONT></DIV>
<DIV><FONT color=#0000ff face=Arial size=2><SPAN 
class=870250622-13022001></SPAN></FONT>&nbsp;</DIV>
<DIV><FONT color=#0000ff face=Arial size=2><SPAN class=870250622-13022001>Bill 
Moshier</SPAN></FONT></DIV>
<BLOCKQUOTE style="MARGIN-RIGHT: 0px">
  <DIV align=left class=OutlookMessageHeader dir=ltr><FONT face=Tahoma 
  size=2>-----Original Message-----<BR><B>From:</B> Murali Rajagopal 
  [mailto:muralir@lightsand.com]<BR><B>Sent:</B> Monday, February 12, 2001 1:00 
  PM<BR><B>To:</B> ipfc@standards.gadzoox.com<BR><B>Subject:</B> FW: IP over 
  Fibre throughput numbers<BR><BR></DIV></FONT>
  <DIV><FONT color=#0000ff face=Arial size=2><SPAN 
  class=540305920-12022001>Please respond to the IPFC reflector if you have any 
  comments.</SPAN></FONT></DIV>
  <DIV><FONT color=#0000ff face=Arial size=2><SPAN 
  class=540305920-12022001></SPAN></FONT>&nbsp;</DIV>
  <DIV align=left class=OutlookMessageHeader dir=ltr><FONT face=Tahoma 
  size=2>-----Original Message-----<BR><B>From:</B> Dennis Solari 
  [mailto:dys70@amdahl.com]<BR><B>Sent:</B> Wednesday, January 17, 2001 10:37 
  AM<BR><B>To:</B> muralir@lightsand.com<BR><B>Subject:</B> Fw: IP over Fibre 
  throughput numbers<BR><BR></FONT></DIV>
  <DIV><FONT size=2>Just curious if you received this email from 
me?</FONT></DIV>
  <DIV>&nbsp;</DIV>
  <DIV><FONT size=2>Dennis (Amdahl Corp)</FONT></DIV>
  <DIV><FONT size=2>678-319-4226</FONT></DIV>
  <DIV>&nbsp;</DIV>
  <DIV style="FONT: 10pt arial">----- Original Message ----- 
  <DIV style="BACKGROUND: #e4e4e4; font-color: black"><B>From:</B> <A 
  href="mailto:dys70@amdahl.com" title=dys70@amdahl.com>Dennis Solari</A> </DIV>
  <DIV><B>To:</B> <A href="mailto:muralir@lightsand.com" 
  title=muralir@lightsand.com>muralir@lightsand.com</A> </DIV>
  <DIV><B>Sent:</B> Tuesday, January 16, 2001 9:41 PM</DIV>
  <DIV><B>Subject:</B> IP over Fibre throughput numbers</DIV></DIV>
  <DIV><BR></DIV>
  <DIV><FONT size=2>Murali,</FONT></DIV>
  <DIV><FONT size=2>I am currently testing the speed I can get with IP over 
  fibre channel using:</FONT></DIV>
  <DIV><FONT size=2>*&nbsp;two Sun&nbsp;Ultra 5's (360Mhz)</FONT></DIV>
  <DIV><FONT size=2>* both are&nbsp;have Emulex LP8000&nbsp;SCSI/IP combo fibre 
  channel PCI cards</FONT></DIV>
  <DIV><FONT size=2>* connected through a Brocade silkworm 2400 
  switch.</FONT></DIV>
  <DIV>&nbsp;</DIV>
  <DIV><FONT size=2>I can&nbsp;only drive IP over fibre to&nbsp;as high as ~200 
  Mbs. using iperf (variation of ttcp utility)</FONT></DIV>
  <DIV>&nbsp;</DIV>
  <DIV><FONT size=2>What are some numbers you have seen doing bandwith testing 
  while tweaking the Unix&nbsp;TCP/IP stack?</FONT></DIV>
  <DIV><FONT size=2>Do you know were I can get other performance numbers of 
  people doing the same type performance tests?</FONT></DIV>
  <DIV>&nbsp;</DIV>
  <DIV><FONT size=2>Thanks in Advance,</FONT></DIV>
  <DIV><FONT size=2>Dennis</FONT>&nbsp;</DIV></BLOCKQUOTE></BODY></HTML>

------_=_NextPart_001_01C0960A.70D46160--


