From owner-rap@ops.ietf.org  Thu Sep 12 03:33:04 2002
Received: from psg.com (smmsp@psg.com [147.28.0.62])
	by ietf.org (8.9.1a/8.9.1a) with ESMTP id DAA15305
	for <rap-archive@lists.ietf.org>; Thu, 12 Sep 2002 03:33:03 -0400 (EDT)
Received: from lserv by psg.com with local (Exim 3.36 #1)
	id 17pOSN-000IOY-00
	for rap-data@psg.com; Thu, 12 Sep 2002 00:32:07 -0700
Received: from gc-na5.alcatel.fr ([64.208.49.5] helo=smail2.alcatel.fr)
	by psg.com with esmtp (Exim 3.36 #1)
	id 17pOSJ-000ION-00
	for rap@ops.ietf.org; Thu, 12 Sep 2002 00:32:04 -0700
Received: from medine.ms.alcatel.fr (medine.ms.alcatel.fr [193.105.117.1])
	by smail2.alcatel.fr (ALCANET/NETFR) with ESMTP id g8C7TfCv015014;
	Thu, 12 Sep 2002 09:29:41 +0200
Received: from ms.ms.alcatel.fr (ms.ms.alcatel.fr [188.9.12.93])
	by medine.ms.alcatel.fr (8.8.8/8.8.8/aar-1.2) with ESMTP id JAA10967;
	Thu, 12 Sep 2002 09:29:35 +0200 (MET DST)
Received: from athos.dinsunnet (athos [188.9.12.98])
	by ms.ms.alcatel.fr (8.8.7/8.8.7/aar-1.0) with ESMTP id JAA25100;
	Thu, 12 Sep 2002 09:30:52 +0200 (MET DST)
Received: from alcatel.fr by athos.dinsunnet (8.9.1b+Sun/SMI-SVR4)
	id JAA22881; Thu, 12 Sep 2002 09:33:23 +0200 (MET DST)
Message-ID: <3D8042E2.80400@alcatel.fr>
Date: Thu, 12 Sep 2002 09:31:46 +0200
From: Yacine El Mghazli <yacine.el_mghazli@alcatel.fr>
Organization: Alcate R&I
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; fr-FR; rv:0.9.4) Gecko/20011019 Netscape6/6.2
X-Accept-Language: fr-fr
MIME-Version: 1.0
To: "Wijnen, Bert (Bert)" <bwijnen@lucent.com>
CC: Lemponen Jussi <juzi@cs.tut.fi>, diffserv@ietf.org,
        "rap@ops.ietf.org" <rap@ops.ietf.org>
Subject: Re: [Diffserv] parameters section missing from the Diffserv PIB
References: <A451D5E6F15FD211BABC0008C7FAD7BC0EE45591@nl0006exch003u.nl.lucent.com>
Content-Type: text/plain; charset=us-ascii; format=flowed
Content-Transfer-Encoding: 7bit
X-Virus-Scanned: by amavisd-milter (http://amavis.org/)
X-Spam-Status: No, hits=0.0 required=5.0
	tests=none
	version=2.31
Sender: owner-rap@ops.ietf.org
Precedence: bulk
Content-Transfer-Encoding: 7bit

I was wondering about this point:

how are the OIDs identified in the MIB senseful within the PIB ?

my understanding is that the PIB is an AUTONOMOUS named data 
structure... in this context, what is the meaning of an OID referencing 
nothing in the PIB itself ?

thank you for your explanations,
yacine



Wijnen, Bert (Bert) wrote:

> I think they are the parameters that have been sepcified and identified 
> in the diffserv MIB (RFC3289)
> 
> Thanks,
> Bert 
> 
> 
>>-----Original Message-----
>>From: Lemponen Jussi [mailto:juzi@cs.tut.fi]
>>Sent: woensdag 11 september 2002 23:02
>>To: diffserv@ietf.org
>>Subject: [Diffserv] parameters section missing from the Diffserv PIB
>>
>>
>>
>>
>>Reading through draft-ietf-diffserv-pib-09.txt, I noticed that
>>the parameters section in the PIB itself is missing. The descriptions
>>for attributes dsTBParamType and dsIfSchedulerCapsServiceDisc do still
>>imply that some parameter definitions should be there.
>>
>>
>>Jussi Lemponen
>>Tampere University of Technology
>>Institute of Communications Engineering
>>_______________________________________________
>>diffserv mailing list
>>diffserv@ietf.org
>>https://www1.ietf.org/mailman/listinfo/diffserv
>>Archive: 
>>http://www.ietf.org/mail-archive/working-groups/diffserv/curre
>>
> nt/maillist.html
> _______________________________________________
> diffserv mailing list
> diffserv@ietf.org
> https://www1.ietf.org/mailman/listinfo/diffserv
> Archive: http://www.ietf.org/mail-archive/working-groups/diffserv/current/maillist.html
> 
> 
> 





From owner-rap@ops.ietf.org  Thu Sep 12 14:09:00 2002
Received: from psg.com (smmsp@psg.com [147.28.0.62])
	by ietf.org (8.9.1a/8.9.1a) with ESMTP id OAA01688
	for <rap-archive@lists.ietf.org>; Thu, 12 Sep 2002 14:08:59 -0400 (EDT)
Received: from lserv by psg.com with local (Exim 3.36 #1)
	id 17pYOR-0004Vo-00
	for rap-data@psg.com; Thu, 12 Sep 2002 11:08:43 -0700
Received: from [192.11.223.161] (helo=auemail1.firewall.lucent.com)
	by psg.com with esmtp (Exim 3.36 #1)
	id 17pYOE-0004SS-00
	for rap@ops.ietf.org; Thu, 12 Sep 2002 11:08:30 -0700
Received: from nl0006exch001h.wins.lucent.com (h135-85-76-62.lucent.com [135.85.76.62])
	by auemail1.firewall.lucent.com (Switch-2.2.2/Switch-2.2.0) with ESMTP id g8CI8Qp01760
	for <rap@ops.ietf.org>; Thu, 12 Sep 2002 14:08:26 -0400 (EDT)
Received: by nl0006exch001h.nl.lucent.com with Internet Mail Service (5.5.2653.19)
	id <SLBWPYBJ>; Thu, 12 Sep 2002 20:08:25 +0200
Message-ID: <A451D5E6F15FD211BABC0008C7FAD7BC0E2C44CF@nl0006exch003u.nl.lucent.com>
From: "Wijnen, Bert (Bert)" <bwijnen@lucent.com>
To: "'Yacine El Mghazli'" <yacine.el_mghazli@alcatel.fr>,
        "Wijnen, Bert (Bert)" <bwijnen@lucent.com>
Cc: Lemponen Jussi <juzi@cs.tut.fi>, diffserv@ietf.org, rap@ops.ietf.org
Subject: RE: [Diffserv] parameters section missing from the Diffserv PIB
Date: Thu, 12 Sep 2002 20:07:25 +0200
MIME-Version: 1.0
X-Mailer: Internet Mail Service (5.5.2653.19)
Content-Type: text/plain
X-Spam-Status: No, hits=1.1 required=5.0
	tests=DOUBLE_CAPSWORD
	version=2.31
X-Spam-Level: *
Sender: owner-rap@ops.ietf.org
Precedence: bulk

The DIFFSERV MIB specifies some OIDs that identify
specific algorithms. These algorithms are the same
no matter if they are used by a MIB or by a PIB.
So using one OID to identify the same thing instead of
two OIDs identifying the same thing, seems the right
thing to do to me, don't you think so too?

Actually your Diffserv MIB and/or PIB authors/editors 
should be answering these questions...

Thanks,
Bert 

> -----Original Message-----
> From: Yacine El Mghazli [mailto:yacine.el_mghazli@alcatel.fr]
> Sent: donderdag 12 september 2002 9:32
> To: Wijnen, Bert (Bert)
> Cc: Lemponen Jussi; diffserv@ietf.org; rap@ops.ietf.org
> Subject: Re: [Diffserv] parameters section missing from the 
> Diffserv PIB
> 
> 
> I was wondering about this point:
> 
> how are the OIDs identified in the MIB senseful within the PIB ?
> 
> my understanding is that the PIB is an AUTONOMOUS named data 
> structure... in this context, what is the meaning of an OID 
> referencing 
> nothing in the PIB itself ?
> 
> thank you for your explanations,
> yacine
> 
> 
> 
> Wijnen, Bert (Bert) wrote:
> 
> > I think they are the parameters that have been sepcified 
> and identified 
> > in the diffserv MIB (RFC3289)
> > 
> > Thanks,
> > Bert 
> > 
> > 
> >>-----Original Message-----
> >>From: Lemponen Jussi [mailto:juzi@cs.tut.fi]
> >>Sent: woensdag 11 september 2002 23:02
> >>To: diffserv@ietf.org
> >>Subject: [Diffserv] parameters section missing from the Diffserv PIB
> >>
> >>
> >>
> >>
> >>Reading through draft-ietf-diffserv-pib-09.txt, I noticed that
> >>the parameters section in the PIB itself is missing. The 
> descriptions
> >>for attributes dsTBParamType and 
> dsIfSchedulerCapsServiceDisc do still
> >>imply that some parameter definitions should be there.
> >>
> >>
> >>Jussi Lemponen
> >>Tampere University of Technology
> >>Institute of Communications Engineering
> >>_______________________________________________
> >>diffserv mailing list
> >>diffserv@ietf.org
> >>https://www1.ietf.org/mailman/listinfo/diffserv
> >>Archive: 
> >>http://www.ietf.org/mail-archive/working-groups/diffserv/curre
> >>
> > nt/maillist.html
> > _______________________________________________
> > diffserv mailing list
> > diffserv@ietf.org
> > https://www1.ietf.org/mailman/listinfo/diffserv
> > Archive: 
http://www.ietf.org/mail-archive/working-groups/diffserv/current/maillist.html
> 
> 
> 


_______________________________________________
diffserv mailing list
diffserv@ietf.org
https://www1.ietf.org/mailman/listinfo/diffserv
Archive: http://www.ietf.org/mail-archive/working-groups/diffserv/current/maillist.html



From owner-rap@ops.ietf.org  Thu Sep 12 14:43:22 2002
Received: from psg.com (smmsp@psg.com [147.28.0.62])
	by ietf.org (8.9.1a/8.9.1a) with ESMTP id OAA02937
	for <rap-archive@lists.ietf.org>; Thu, 12 Sep 2002 14:43:22 -0400 (EDT)
Received: from lserv by psg.com with local (Exim 3.36 #1)
	id 17pYvM-0006s1-00
	for rap-data@psg.com; Thu, 12 Sep 2002 11:42:44 -0700
Received: from zcars04e.nortelnetworks.com ([47.129.242.56] helo=zcars04e.ca.nortel.com)
	by psg.com with esmtp (Exim 3.36 #1)
	id 17pYvI-0006rn-00
	for rap@ops.ietf.org; Thu, 12 Sep 2002 11:42:40 -0700
Received: from zbl6c012.us.nortel.com (zbl6c012.us.nortel.com [132.245.205.62])
	by zcars04e.ca.nortel.com (Switch-2.2.0/Switch-2.2.0) with ESMTP id g8CIfJt04099;
	Thu, 12 Sep 2002 14:41:19 -0400 (EDT)
Received: from zbl6c002.us.nortel.com (zbl6c002.corpeast.baynetworks.com [132.245.205.52]) by zbl6c012.us.nortel.com with SMTP (Microsoft Exchange Internet Mail Service Version 5.5.2653.13)
	id RPMDN7WQ; Thu, 12 Sep 2002 14:41:22 -0400
Received: from tweedy.NortelNetworks.com (tweedy.engeast.baynetworks.com [192.32.135.157]) by zbl6c002.us.nortel.com with SMTP (Microsoft Exchange Internet Mail Service Version 5.5.2653.13)
	id NSA9NWZV; Thu, 12 Sep 2002 14:41:20 -0400
Message-Id: <5.0.0.25.0.20020912142746.0254f470@zbl6c002.corpeast.baynetworks.com>
X-Sender: khchan@zbl6c002.corpeast.baynetworks.com
X-Mailer: QUALCOMM Windows Eudora Version 5.0
Date: Thu, 12 Sep 2002 14:39:10 -0400
To: Yacine El Mghazli <yacine.el_mghazli@alcatel.fr>
From: Kwok Ho Chan <khchan@NortelNetworks.com>
Subject: Re: [Diffserv] parameters section missing from the Diffserv PIB
Cc: "Wijnen, Bert (Bert)" <bwijnen@lucent.com>,
        Lemponen Jussi <juzi@cs.tut.fi>, diffserv@ietf.org,
        "rap@ops.ietf.org" <rap@ops.ietf.org>
In-Reply-To: <3D8042E2.80400@alcatel.fr>
References: <A451D5E6F15FD211BABC0008C7FAD7BC0EE45591@nl0006exch003u.nl.lucent.com>
Mime-Version: 1.0
Content-Type: text/plain; charset="us-ascii"; format=flowed
X-Spam-Status: No, hits=-2.3 required=5.0
	tests=IN_REP_TO,DOUBLE_CAPSWORD
	version=2.31
Sender: owner-rap@ops.ietf.org
Precedence: bulk

Yacine, Jussi:
The Diffserv PIB already IMPORT Dscp and IfDirection from different modules of
the Diffserv MIB.  So I did not think there is any issue to also reused the 
definitions
for dsTBParamType and dsIfSchedulerCapsServiceDisc from the Diffserv MIB as
advised during IESG review.

The Diffserv PIB's references to the Diffserv MIB are clearly specified as:

    dsIfSchedulerCapsServiceDisc OBJECT-TYPE
        SYNTAX      AutonomousType
        STATUS      current
        DESCRIPTION
          "The scheduling discipline for which the set of capabilities
          specified in this object apply. Object identifiers for several
          general purpose and well-known scheduling disciplines are
          shared with and defined in the Diffserv MIB.

          These include diffServSchedulerPriority,
          diffServSchedulerWRR, diffServSchedulerWFQ."

and

    dsTBParamType OBJECT-TYPE
        SYNTAX       AutonomousType
        STATUS       current
        DESCRIPTION
          "The Metering algorithm associated with the
          Token-Bucket parameters.  zeroDotZero indicates this
          is unknown.
          Standard values for generic algorithms are as follows:
          diffServTBParamSimpleTokenBucket, diffServTBParamAvgRate,
          diffServTBParamSrTCMBlind, diffServTBParamSrTCMAware,
          diffServTBParamTrTCMBlind, diffServTBParamTrTCMAware,
          diffServTBParamTswTCM

          These are specified in the Diffserv MIB."

respectively.

I believe the above text is clear.
Please advise if improvement can be made.
Thanks!
-- Kwok --


At 09:31 AM 9/12/02 +0200, Yacine El Mghazli wrote:
>I was wondering about this point:
>
>how are the OIDs identified in the MIB senseful within the PIB ?
>
>my understanding is that the PIB is an AUTONOMOUS named data structure... 
>in this context, what is the meaning of an OID referencing nothing in the 
>PIB itself ?
>
>thank you for your explanations,
>yacine
>
>
>
>Wijnen, Bert (Bert) wrote:
>
>>I think they are the parameters that have been sepcified and identified 
>>in the diffserv MIB (RFC3289)
>>Thanks,
>>Bert
>>
>>>-----Original Message-----
>>>From: Lemponen Jussi [mailto:juzi@cs.tut.fi]
>>>Sent: woensdag 11 september 2002 23:02
>>>To: diffserv@ietf.org
>>>Subject: [Diffserv] parameters section missing from the Diffserv PIB
>>>
>>>
>>>
>>>
>>>Reading through draft-ietf-diffserv-pib-09.txt, I noticed that
>>>the parameters section in the PIB itself is missing. The descriptions
>>>for attributes dsTBParamType and dsIfSchedulerCapsServiceDisc do still
>>>imply that some parameter definitions should be there.
>>>
>>>
>>>Jussi Lemponen
>>>Tampere University of Technology
>>>Institute of Communications Engineering
>>>_______________________________________________
>>>diffserv mailing list
>>>diffserv@ietf.org
>>>https://www1.ietf.org/mailman/listinfo/diffserv
>>>Archive: http://www.ietf.org/mail-archive/working-groups/diffserv/curre
>>nt/maillist.html
>>_______________________________________________
>>diffserv mailing list
>>diffserv@ietf.org
>>https://www1.ietf.org/mailman/listinfo/diffserv
>>Archive: 
>>http://www.ietf.org/mail-archive/working-groups/diffserv/current/maillist.html
>>
>
>




From owner-rap@ops.ietf.org  Fri Sep 13 02:22:43 2002
Received: from psg.com (smmsp@psg.com [147.28.0.62])
	by ietf.org (8.9.1a/8.9.1a) with ESMTP id CAA26208
	for <rap-archive@lists.ietf.org>; Fri, 13 Sep 2002 02:22:43 -0400 (EDT)
Received: from lserv by psg.com with local (Exim 3.36 #1)
	id 17pjpe-00062R-00
	for rap-data@psg.com; Thu, 12 Sep 2002 23:21:34 -0700
Received: from wiprom2mx1.wipro.com ([203.197.164.41])
	by psg.com with esmtp (Exim 3.36 #1)
	id 17pjpa-00062G-00
	for rap@ops.ietf.org; Thu, 12 Sep 2002 23:21:30 -0700
Received: from m2vwall5.wipro.com (m2vwall5.wipro.com [10.115.50.5])
	by wiprom2mx1.wipro.com (8.11.3/8.11.3) with SMTP id g8D6LOi29528
	for <rap@ops.ietf.org>; Fri, 13 Sep 2002 11:51:26 +0530 (IST)
Received: from m2vwall5.wipro.com ([10.115.50.5]) by
          ace.mail.wipro.com (Netscape Messaging Server 4.15) with SMTP id
          H2D5NJ00.F4X for <rap@ops.ietf.org>; Fri, 13 Sep 2002 11:51:19 +0530 
Received: from blr-ec-bh1.wipro.com ([10.200.50.91]) by
          mailstore.mail.wipro.com (Netscape Messaging Server 4.15) with
          ESMTP id H2D5NI00.KRQ for <rap@ops.ietf.org>; Fri, 13 Sep 2002
          11:51:18 +0530 
Received: from hyd-mdp-msg.wipro.com ([10.150.50.99]) by blr-ec-bh1.wipro.com with Microsoft SMTPSVC(5.0.2195.4905);
	 Fri, 13 Sep 2002 11:51:18 +0530
Received: from wipro.com ([192.168.143.56]) by hyd-mdp-msg.wipro.com with Microsoft SMTPSVC(5.0.2195.4905);
	 Fri, 13 Sep 2002 11:51:17 +0530
Message-ID: <3D8183DD.970C0758@wipro.com>
Date: Fri, 13 Sep 2002 11:51:17 +0530
From: Krishna Prasad Akkineni <krishna.akkineni@wipro.com>
Reply-To: krishna.akkineni@wipro.com
Organization: Wipro Technologies
X-Mailer: Mozilla 4.79 [en] (Windows NT 5.0; U)
X-Accept-Language: en
MIME-Version: 1.0
To: rap@ops.ietf.org, Kamal Kishore Mantri <kamal.kishore@wipro.com>,
        Naganna VVS Vydyula <naganna.vydyula@wipro.com>
Subject: decision object maximum length ?
Content-Type: multipart/mixed;
	boundary="----=_NextPartTM-000-40726f6b-bfbb-11d6-ba7c-006067005148"
X-OriginalArrivalTime: 13 Sep 2002 06:21:17.0750 (UTC) FILETIME=[C4EE5D60:01C25AED]
X-Spam-Status: No, hits=-0.1 required=5.0
	tests=SUBJ_ENDS_IN_Q_MARK
	version=2.31
Sender: owner-rap@ops.ietf.org
Precedence: bulk


------=_NextPartTM-000-40726f6b-bfbb-11d6-ba7c-006067005148
Content-Type: multipart/alternative;
	 boundary="------------E01C018294936A69EFC566AF"

--------------E01C018294936A69EFC566AF
Content-Type: text/plain; charset=us-ascii
Content-Transfer-Encoding: 7bit

Hi,
   This is a query related to the COPS Decision object (named decision
data)
maximum length. As per RFC2748, the maximum object length is 2^16
(65536) bytes.
If number of policies are more then decision object length will go
beyond
65536 bytes. I can add more decision objects to avoid this problem, but
I require
to replicate the context object once again. How RFC2748 addresses this
problem?

Thanks
Krishna


--------------E01C018294936A69EFC566AF
Content-Type: text/html; charset=us-ascii
Content-Transfer-Encoding: 7bit

<!doctype html public "-//w3c//dtd html 4.0 transitional//en">
<html>
<tt>Hi,</tt>
<br><tt>&nbsp;&nbsp; This is a query related to the COPS Decision object
(named decision data)</tt>
<br><tt>maximum length. As per RFC2748, the maximum object length is 2^16
(65536) bytes.</tt>
<br><tt>If number of policies are more then decision object length will
go beyond</tt>
<br><tt>65536 bytes. I can add more decision objects to avoid this problem,
but I require</tt>
<br><tt>to replicate the context object once again. How RFC2748 addresses
this</tt>
<br><tt>problem?</tt><tt></tt>
<p><tt>Thanks</tt>
<br><tt>Krishna</tt>
<br><tt></tt>&nbsp;</html>

--------------E01C018294936A69EFC566AF--


------=_NextPartTM-000-40726f6b-bfbb-11d6-ba7c-006067005148--




From owner-rap@ops.ietf.org  Fri Sep 13 03:53:44 2002
Received: from psg.com (smmsp@psg.com [147.28.0.62])
	by ietf.org (8.9.1a/8.9.1a) with ESMTP id DAA27853
	for <rap-archive@lists.ietf.org>; Fri, 13 Sep 2002 03:53:44 -0400 (EDT)
Received: from lserv by psg.com with local (Exim 3.36 #1)
	id 17plHu-0009Xf-00
	for rap-data@psg.com; Fri, 13 Sep 2002 00:54:50 -0700
Received: from ceg-na5.alcatel.fr ([213.223.66.5] helo=smail2.alcatel.fr)
	by psg.com with esmtp (Exim 3.36 #1)
	id 17plHn-0009XK-00
	for rap@ops.ietf.org; Fri, 13 Sep 2002 00:54:43 -0700
Received: from medine.ms.alcatel.fr (medine.ms.alcatel.fr [193.105.117.1])
	by smail2.alcatel.fr (ALCANET/NETFR) with ESMTP id g8D7qBCv002904;
	Fri, 13 Sep 2002 09:52:11 +0200
Received: from ms.ms.alcatel.fr (ms.ms.alcatel.fr [188.9.12.93])
	by medine.ms.alcatel.fr (8.8.8/8.8.8/aar-1.2) with ESMTP id JAA14121;
	Fri, 13 Sep 2002 09:52:11 +0200 (MET DST)
Received: from athos.dinsunnet (athos [188.9.12.98])
	by ms.ms.alcatel.fr (8.8.7/8.8.7/aar-1.0) with ESMTP id JAA14776;
	Fri, 13 Sep 2002 09:53:20 +0200 (MET DST)
Received: from alcatel.fr by athos.dinsunnet (8.9.1b+Sun/SMI-SVR4)
	id JAA26388; Fri, 13 Sep 2002 09:55:59 +0200 (MET DST)
Message-ID: <3D8199AF.6080004@alcatel.fr>
Date: Fri, 13 Sep 2002 09:54:23 +0200
From: Yacine El Mghazli <yacine.el_mghazli@alcatel.fr>
Organization: Alcate R&I
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; fr-FR; rv:0.9.4) Gecko/20011019 Netscape6/6.2
X-Accept-Language: fr-fr
MIME-Version: 1.0
To: Kwok Ho Chan <khchan@NortelNetworks.com>
CC: "Wijnen, Bert (Bert)" <bwijnen@lucent.com>,
        Lemponen Jussi <juzi@cs.tut.fi>, diffserv@ietf.org,
        "rap@ops.ietf.org" <rap@ops.ietf.org>
Subject: Re: [Diffserv] parameters section missing from the Diffserv PIB
References: <A451D5E6F15FD211BABC0008C7FAD7BC0EE45591@nl0006exch003u.nl.lucent.com> <5.0.0.25.0.20020912142746.0254f470@zbl6c002.corpeast.baynetworks.com>
Content-Type: text/plain; charset=us-ascii; format=flowed
Content-Transfer-Encoding: 7bit
X-Virus-Scanned: by amavisd-milter (http://amavis.org/)
X-Spam-Status: No, hits=1.1 required=5.0
	tests=DOUBLE_CAPSWORD
	version=2.31
X-Spam-Level: *
Sender: owner-rap@ops.ietf.org
Precedence: bulk
Content-Transfer-Encoding: 7bit

Kwok Ho Chan wrote:

> Yacine, Jussi:
> The Diffserv PIB already IMPORT Dscp and IfDirection from different 
> modules of
> the Diffserv MIB.  So I did not think there is any issue to also reused 
> the definitions



ok for reuse but here we're talking about OIDs...
my question is: what is the signification of MIB-specific OIDs within a 
PIB ?

in the previous versions of the PIB draft, these were identified by 
PRIDS, they pointed towards a PRC within the same PIB... how does it 
work now ?

thanks,
yacine


> for dsTBParamType and dsIfSchedulerCapsServiceDisc from the Diffserv MIB as
> advised during IESG review.
> 
> The Diffserv PIB's references to the Diffserv MIB are clearly specified as:
> 
>    dsIfSchedulerCapsServiceDisc OBJECT-TYPE
>        SYNTAX      AutonomousType
>        STATUS      current
>        DESCRIPTION
>          "The scheduling discipline for which the set of capabilities
>          specified in this object apply. Object identifiers for several
>          general purpose and well-known scheduling disciplines are
>          shared with and defined in the Diffserv MIB.
> 
>          These include diffServSchedulerPriority,
>          diffServSchedulerWRR, diffServSchedulerWFQ."
> 
> and
> 
>    dsTBParamType OBJECT-TYPE
>        SYNTAX       AutonomousType
>        STATUS       current
>        DESCRIPTION
>          "The Metering algorithm associated with the
>          Token-Bucket parameters.  zeroDotZero indicates this
>          is unknown.
>          Standard values for generic algorithms are as follows:
>          diffServTBParamSimpleTokenBucket, diffServTBParamAvgRate,
>          diffServTBParamSrTCMBlind, diffServTBParamSrTCMAware,
>          diffServTBParamTrTCMBlind, diffServTBParamTrTCMAware,
>          diffServTBParamTswTCM
> 
>          These are specified in the Diffserv MIB."
> 
> respectively.
> 
> I believe the above text is clear.
> Please advise if improvement can be made.
> Thanks!
> -- Kwok --
> 
> 
> At 09:31 AM 9/12/02 +0200, Yacine El Mghazli wrote:
> 
>> I was wondering about this point:
>>
>> how are the OIDs identified in the MIB senseful within the PIB ?
>>
>> my understanding is that the PIB is an AUTONOMOUS named data 
>> structure... in this context, what is the meaning of an OID 
>> referencing nothing in the PIB itself ?
>>
>> thank you for your explanations,
>> yacine
>>
>>
>>
>> Wijnen, Bert (Bert) wrote:
>>
>>> I think they are the parameters that have been sepcified and 
>>> identified in the diffserv MIB (RFC3289)
>>> Thanks,
>>> Bert
>>>
>>>> -----Original Message-----
>>>> From: Lemponen Jussi [mailto:juzi@cs.tut.fi]
>>>> Sent: woensdag 11 september 2002 23:02
>>>> To: diffserv@ietf.org
>>>> Subject: [Diffserv] parameters section missing from the Diffserv PIB
>>>>
>>>>
>>>>
>>>>
>>>> Reading through draft-ietf-diffserv-pib-09.txt, I noticed that
>>>> the parameters section in the PIB itself is missing. The descriptions
>>>> for attributes dsTBParamType and dsIfSchedulerCapsServiceDisc do still
>>>> imply that some parameter definitions should be there.
>>>>
>>>>
>>>> Jussi Lemponen
>>>> Tampere University of Technology
>>>> Institute of Communications Engineering
>>>> _______________________________________________
>>>> diffserv mailing list
>>>> diffserv@ietf.org
>>>> https://www1.ietf.org/mailman/listinfo/diffserv
>>>> Archive: http://www.ietf.org/mail-archive/working-groups/diffserv/curre
>>>
>>> nt/maillist.html
>>> _______________________________________________
>>> diffserv mailing list
>>> diffserv@ietf.org
>>> https://www1.ietf.org/mailman/listinfo/diffserv
>>> Archive: 
>>> http://www.ietf.org/mail-archive/working-groups/diffserv/current/maillist.html 
>>>
>>>
>>
>>
> 
> 





From owner-rap@ops.ietf.org  Fri Sep 13 12:43:39 2002
Received: from psg.com (smmsp@psg.com [147.28.0.62])
	by ietf.org (8.9.1a/8.9.1a) with ESMTP id MAA11749
	for <rap-archive@lists.ietf.org>; Fri, 13 Sep 2002 12:43:38 -0400 (EDT)
Received: from lserv by psg.com with local (Exim 3.36 #1)
	id 17ptWu-00006z-00
	for rap-data@psg.com; Fri, 13 Sep 2002 09:42:52 -0700
Received: from petasus.ch.intel.com ([143.182.124.5])
	by psg.com with esmtp (Exim 3.36 #1)
	id 17ptWj-00006i-00
	for rap@ops.ietf.org; Fri, 13 Sep 2002 09:42:41 -0700
Received: from fmsmsxv040-1.fm.intel.com (fmsmsxvs040.fm.intel.com [132.233.42.124])
	by petasus.ch.intel.com (8.11.6/8.11.6/d: solo.mc,v 1.43 2002/08/30 20:06:11 dmccart Exp $) with SMTP id g8DGiUd11005
	for <rap@ops.ietf.org>; Fri, 13 Sep 2002 16:44:30 GMT
Received: from fmsmsx28.fm.intel.com ([132.233.42.28])
 by fmsmsxv040-1.fm.intel.com (NAVGW 2.5.2.11) with SMTP id M2002091309432010480
 ; Fri, 13 Sep 2002 09:43:20 -0700
Received: by fmsmsx28.fm.intel.com with Internet Mail Service (5.5.2653.19)
	id <SR6Q1LMM>; Fri, 13 Sep 2002 09:42:39 -0700
Message-ID: <EDC461A30AC4D511ADE10002A5072CAD02A4B6F1@orsmsx119.jf.intel.com>
From: "Durham, David" <david.durham@intel.com>
To: "'krishna.akkineni@wipro.com'" <krishna.akkineni@wipro.com>,
        rap@ops.ietf.org
Subject: RE: decision object maximum length ?
Date: Fri, 13 Sep 2002 09:42:36 -0700
MIME-Version: 1.0
X-Mailer: Internet Mail Service (5.5.2653.19)
Content-Type: multipart/alternative;
	boundary="----_=_NextPart_001_01C25B44.90AC9B50"
X-Spam-Status: No, hits=-1.1 required=5.0
	tests=SUBJ_ENDS_IN_Q_MARK,MIME_NULL_BLOCK
	version=2.31
Sender: owner-rap@ops.ietf.org
Precedence: bulk

This message is in MIME format. Since your mail reader does not understand
this format, some or all of this message may not be legible.

------_=_NextPart_001_01C25B44.90AC9B50
Content-Type: text/plain;
	charset="iso-8859-1"

Yes, the context and decision flags objects will be replicated for each
decision object. I do not see where the problem lies however, as the total
length of these replicated objects is only 16bytes for every 65536bytes of
decision object data.
 
-Dave

-----Original Message-----
From: Krishna Prasad Akkineni [mailto:krishna.akkineni@wipro.com]
Sent: Thursday, September 12, 2002 11:21 PM
To: rap@ops.ietf.org; Kamal Kishore Mantri; Naganna VVS Vydyula
Subject: decision object maximum length ?


Hi, 
   This is a query related to the COPS Decision object (named decision data)

maximum length. As per RFC2748, the maximum object length is 2^16 (65536)
bytes. 
If number of policies are more then decision object length will go beyond 
65536 bytes. I can add more decision objects to avoid this problem, but I
require 
to replicate the context object once again. How RFC2748 addresses this 
problem? 

Thanks 
Krishna 
  


------_=_NextPart_001_01C25B44.90AC9B50
Content-Type: text/html;
	charset="iso-8859-1"

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
<HTML><HEAD>
<META HTTP-EQUIV="Content-Type" CONTENT="text/html; charset=iso-8859-1">


<META content="MSHTML 5.50.4916.2300" name=GENERATOR></HEAD>
<BODY>
<DIV><FONT face=Arial color=#0000ff size=2><SPAN class=340543516-13092002>Yes, 
the context and decision flags objects&nbsp;will be replicated for each decision 
object. I do not see where the problem lies however, as the total length of 
these replicated objects is only 16bytes for every 65536bytes of decision object 
data.</SPAN></FONT></DIV>
<DIV><FONT face=Arial color=#0000ff size=2><SPAN 
class=340543516-13092002></SPAN></FONT>&nbsp;</DIV>
<DIV><FONT face=Arial color=#0000ff size=2><SPAN 
class=340543516-13092002>-Dave</SPAN></FONT></DIV>
<BLOCKQUOTE dir=ltr 
style="PADDING-LEFT: 5px; MARGIN-LEFT: 5px; BORDER-LEFT: #0000ff 2px solid; MARGIN-RIGHT: 0px">
  <DIV class=OutlookMessageHeader dir=ltr align=left><FONT face=Tahoma 
  size=2>-----Original Message-----<BR><B>From:</B> Krishna Prasad Akkineni 
  [mailto:krishna.akkineni@wipro.com]<BR><B>Sent:</B> Thursday, September 12, 
  2002 11:21 PM<BR><B>To:</B> rap@ops.ietf.org; Kamal Kishore Mantri; Naganna 
  VVS Vydyula<BR><B>Subject:</B> decision object maximum length 
  ?<BR><BR></FONT></DIV><TT>Hi,</TT> <BR><TT>&nbsp;&nbsp; This is a query 
  related to the COPS Decision object (named decision data)</TT> <BR><TT>maximum 
  length. As per RFC2748, the maximum object length is 2^16 (65536) bytes.</TT> 
  <BR><TT>If number of policies are more then decision object length will go 
  beyond</TT> <BR><TT>65536 bytes. I can add more decision objects to avoid this 
  problem, but I require</TT> <BR><TT>to replicate the context object once 
  again. How RFC2748 addresses this</TT> <BR><TT>problem?</TT><TT></TT> 
  <P><TT>Thanks</TT> <BR><TT>Krishna</TT> <BR><TT></TT>&nbsp; 
</P></BLOCKQUOTE></BODY></HTML>

------_=_NextPart_001_01C25B44.90AC9B50--



From owner-rap@ops.ietf.org  Fri Sep 13 13:18:40 2002
Received: from psg.com (smmsp@psg.com [147.28.0.62])
	by ietf.org (8.9.1a/8.9.1a) with ESMTP id NAA12708
	for <rap-archive@lists.ietf.org>; Fri, 13 Sep 2002 13:18:38 -0400 (EDT)
Received: from lserv by psg.com with local (Exim 3.36 #1)
	id 17pu5u-0001JA-00
	for rap-data@psg.com; Fri, 13 Sep 2002 10:19:02 -0700
Received: from hoemail1.lucent.com ([192.11.226.161] helo=hoemail1.firewall.lucent.com)
	by psg.com with esmtp (Exim 3.36 #1)
	id 17pu5q-0001Ha-00
	for rap@ops.ietf.org; Fri, 13 Sep 2002 10:18:58 -0700
Received: from nl0006exch001h.wins.lucent.com (h135-85-76-62.lucent.com [135.85.76.62])
	by hoemail1.firewall.lucent.com (Switch-2.2.2/Switch-2.2.0) with ESMTP id g8DHIo718986
	for <rap@ops.ietf.org>; Fri, 13 Sep 2002 13:18:50 -0400 (EDT)
Received: by nl0006exch001h.nl.lucent.com with Internet Mail Service (5.5.2653.19)
	id <SLBWQ9GN>; Fri, 13 Sep 2002 19:18:46 +0200
Message-ID: <A451D5E6F15FD211BABC0008C7FAD7BC0EE45A7A@nl0006exch003u.nl.lucent.com>
From: "Wijnen, Bert (Bert)" <bwijnen@lucent.com>
To: Yacine El Mghazli <yacine.el_mghazli@alcatel.fr>,
        Kwok Ho Chan
	 <khchan@NortelNetworks.com>
Cc: "Wijnen, Bert (Bert)" <bwijnen@lucent.com>,
        Lemponen Jussi
	 <juzi@cs.tut.fi>, diffserv@ietf.org, rap@ops.ietf.org
Subject: RE: [Diffserv] parameters section missing from the Diffserv PIB
Date: Fri, 13 Sep 2002 19:18:41 +0200
MIME-Version: 1.0
X-Mailer: Internet Mail Service (5.5.2653.19)
Content-Type: text/plain
X-Spam-Status: No, hits=1.1 required=5.0
	tests=DOUBLE_CAPSWORD
	version=2.31
X-Spam-Level: *
Sender: owner-rap@ops.ietf.org
Precedence: bulk

> Kwok Ho Chan wrote:
> 
> > Yacine, Jussi:
> > The Diffserv PIB already IMPORT Dscp and IfDirection from different 
> > modules of
> > the Diffserv MIB.  So I did not think there is any issue to 
> > also reused the definitions
> 
> 
> 
> ok for reuse but here we're talking about OIDs...
> my question is: what is the signification of MIB-specific 
> OIDs within a PIB ?
> 
I suspect that you have NOT yet gone to the diffserv MIB to take
a look as to what those OIDs are representing. Once you do that,
I think it should be pretty clear.

Bert
> In the previous versions of the PIB draft, these were identified by 
> PRIDS, they pointed towards a PRC within the same PIB... how does it 
> work now ?
> 
No, this is incorrect. In earlier versions, they were OBJECT IDENTIFIERS
which basically DUPLICATED what was already in the MIB. And because of
that duplication I (in my role of PIB/MIB reviewer) recommended that the
OIDs from the MIB should be re-used.

Bert
> thanks,
> yacine
> 
> 
> > for dsTBParamType and dsIfSchedulerCapsServiceDisc from the 
> Diffserv MIB as
> > advised during IESG review.
> > 
> > The Diffserv PIB's references to the Diffserv MIB are 
> clearly specified as:
> > 
> >    dsIfSchedulerCapsServiceDisc OBJECT-TYPE
> >        SYNTAX      AutonomousType
> >        STATUS      current
> >        DESCRIPTION
> >          "The scheduling discipline for which the set of 
> capabilities
> >          specified in this object apply. Object identifiers 
> for several
> >          general purpose and well-known scheduling disciplines are
> >          shared with and defined in the Diffserv MIB.
> > 
> >          These include diffServSchedulerPriority,
> >          diffServSchedulerWRR, diffServSchedulerWFQ."
> > 
> > and
> > 
> >    dsTBParamType OBJECT-TYPE
> >        SYNTAX       AutonomousType
> >        STATUS       current
> >        DESCRIPTION
> >          "The Metering algorithm associated with the
> >          Token-Bucket parameters.  zeroDotZero indicates this
> >          is unknown.
> >          Standard values for generic algorithms are as follows:
> >          diffServTBParamSimpleTokenBucket, diffServTBParamAvgRate,
> >          diffServTBParamSrTCMBlind, diffServTBParamSrTCMAware,
> >          diffServTBParamTrTCMBlind, diffServTBParamTrTCMAware,
> >          diffServTBParamTswTCM
> > 
> >          These are specified in the Diffserv MIB."
> > 
> > respectively.
> > 
> > I believe the above text is clear.
> > Please advise if improvement can be made.
> > Thanks!
> > -- Kwok --
> > 
> > 
> > At 09:31 AM 9/12/02 +0200, Yacine El Mghazli wrote:
> > 
> >> I was wondering about this point:
> >>
> >> how are the OIDs identified in the MIB senseful within the PIB ?
> >>
> >> my understanding is that the PIB is an AUTONOMOUS named data 
> >> structure... in this context, what is the meaning of an OID 
> >> referencing nothing in the PIB itself ?
> >>
> >> thank you for your explanations,
> >> yacine
> >>
> >>
> >>
> >> Wijnen, Bert (Bert) wrote:
> >>
> >>> I think they are the parameters that have been sepcified and 
> >>> identified in the diffserv MIB (RFC3289)
> >>> Thanks,
> >>> Bert
> >>>
> >>>> -----Original Message-----
> >>>> From: Lemponen Jussi [mailto:juzi@cs.tut.fi]
> >>>> Sent: woensdag 11 september 2002 23:02
> >>>> To: diffserv@ietf.org
> >>>> Subject: [Diffserv] parameters section missing from the 
> Diffserv PIB
> >>>>
> >>>>
> >>>>
> >>>>
> >>>> Reading through draft-ietf-diffserv-pib-09.txt, I noticed that
> >>>> the parameters section in the PIB itself is missing. The 
> descriptions
> >>>> for attributes dsTBParamType and 
> dsIfSchedulerCapsServiceDisc do still
> >>>> imply that some parameter definitions should be there.
> >>>>
> >>>>
> >>>> Jussi Lemponen
> >>>> Tampere University of Technology
> >>>> Institute of Communications Engineering
> >>>> _______________________________________________
> >>>> diffserv mailing list
> >>>> diffserv@ietf.org
> >>>> https://www1.ietf.org/mailman/listinfo/diffserv
> >>>> Archive: 
http://www.ietf.org/mail-archive/working-groups/diffserv/curre
>>>
>>> nt/maillist.html
>>> _______________________________________________
>>> diffserv mailing list
>>> diffserv@ietf.org
>>> https://www1.ietf.org/mailman/listinfo/diffserv
>>> Archive: 
>>> http://www.ietf.org/mail-archive/working-groups/diffserv/current/maillist.html 
>>>
>>>
>>
>>
> 
> 




From owner-rap@ops.ietf.org  Fri Sep 13 13:21:39 2002
Received: from psg.com (smmsp@psg.com [147.28.0.62])
	by ietf.org (8.9.1a/8.9.1a) with ESMTP id NAA12797
	for <rap-archive@lists.ietf.org>; Fri, 13 Sep 2002 13:21:38 -0400 (EDT)
Received: from lserv by psg.com with local (Exim 3.36 #1)
	id 17pu9v-0001SG-00
	for rap-data@psg.com; Fri, 13 Sep 2002 10:23:11 -0700
Received: from zcars04f.nortelnetworks.com ([47.129.242.57] helo=zcars04f.ca.nortel.com)
	by psg.com with esmtp (Exim 3.36 #1)
	id 17pu9s-0001S1-00
	for rap@ops.ietf.org; Fri, 13 Sep 2002 10:23:08 -0700
Received: from zbl6c012.us.nortel.com (zbl6c012.us.nortel.com [132.245.205.62])
	by zcars04f.ca.nortel.com (Switch-2.2.0/Switch-2.2.0) with ESMTP id g8DHLkr13708;
	Fri, 13 Sep 2002 13:21:46 -0400 (EDT)
Received: from zbl6c002.us.nortel.com (zbl6c002.corpeast.baynetworks.com [132.245.205.52]) by zbl6c012.us.nortel.com with SMTP (Microsoft Exchange Internet Mail Service Version 5.5.2653.13)
	id RPMD3K70; Fri, 13 Sep 2002 13:21:47 -0400
Received: from tweedy.NortelNetworks.com (TWEEDY [192.32.135.157]) by zbl6c002.us.nortel.com with SMTP (Microsoft Exchange Internet Mail Service Version 5.5.2653.13)
	id NSA9N8CR; Fri, 13 Sep 2002 13:20:58 -0400
Message-Id: <5.0.0.25.0.20020913100731.02463530@zbl6c002.corpeast.baynetworks.com>
X-Sender: khchan@zbl6c002.corpeast.baynetworks.com
X-Mailer: QUALCOMM Windows Eudora Version 5.0
Date: Fri, 13 Sep 2002 13:18:46 -0400
To: Yacine El Mghazli <yacine.el_mghazli@alcatel.fr>
From: Kwok Ho Chan <khchan@NortelNetworks.com>
Subject: Re: [Diffserv] parameters section missing from the Diffserv PIB
Cc: "Kwok-Ho Chan" <khchan@NortelNetworks.com>,
        "Wijnen, Bert (Bert)" <bwijnen@lucent.com>,
        Lemponen Jussi <juzi@cs.tut.fi>, diffserv@ietf.org,
        "rap@ops.ietf.org" <rap@ops.ietf.org>
In-Reply-To: <3D8199AF.6080004@alcatel.fr>
References: <A451D5E6F15FD211BABC0008C7FAD7BC0EE45591@nl0006exch003u.nl.lucent.com>
 <5.0.0.25.0.20020912142746.0254f470@zbl6c002.corpeast.baynetworks.com>
Mime-Version: 1.0
Content-Type: text/plain; charset="us-ascii"; format=flowed
X-Spam-Status: No, hits=-2.3 required=5.0
	tests=IN_REP_TO,DOUBLE_CAPSWORD
	version=2.31
Sender: owner-rap@ops.ietf.org
Precedence: bulk

Yacine:
Please see response embedded below.
Thanks!
-- Kwok --

At 09:54 AM 9/13/02 +0200, Yacine El Mghazli wrote:
>Kwok Ho Chan wrote:
>
>>Yacine, Jussi:
>>The Diffserv PIB already IMPORT Dscp and IfDirection from different 
>>modules of
>>the Diffserv MIB.  So I did not think there is any issue to also reused 
>>the definitions
>
>
>
>ok for reuse but here we're talking about OIDs...
>my question is: what is the signification of MIB-specific OIDs within a PIB ?

These "OBJECT-IDENTITY" are just constant values used to represent a 
standardized
parameter (more like a global #define in C).  They are just as if 
the  "OBJECT-IDENTITY"
is defined in a PIB.  We are thinking of new PIBs reusing technology 
dependent definitions
in either existing PIBs or MIBs, whenever possible.
Hope this answered your concerns.


>in the previous versions of the PIB draft, these were identified by PRIDS, 
>they pointed towards a PRC within the same PIB... how does it work now ?

In DSPIB-06, IfSchedulerCapsServiceDisc and TBParamType were of type
"OBJECT IDENTIFIER", referencing objects of type "OBJECT-IDENTITY",
for example qosTBParamSimpleTokenBucket and qosSchedulerPriority.

Now they are of type "AutonomousType" which are TCs with syntax of
"OBJECT IDENTIFIER", as defined in RFC 2579 (SNMPv2-TC).
Referencing objects of type "OBJECT-IDENTITY", for example 
diffServTBParamSimpleTokenBucket and diffServSchedulerPriority.

Hence there is no change from the compiler point of view, and no change
from a usage point of view.  This is not related to PRIDS.


>thanks,
>yacine
>
>
>>for dsTBParamType and dsIfSchedulerCapsServiceDisc from the Diffserv MIB as
>>advised during IESG review.
>>The Diffserv PIB's references to the Diffserv MIB are clearly specified as:
>>    dsIfSchedulerCapsServiceDisc OBJECT-TYPE
>>        SYNTAX      AutonomousType
>>        STATUS      current
>>        DESCRIPTION
>>          "The scheduling discipline for which the set of capabilities
>>          specified in this object apply. Object identifiers for several
>>          general purpose and well-known scheduling disciplines are
>>          shared with and defined in the Diffserv MIB.
>>          These include diffServSchedulerPriority,
>>          diffServSchedulerWRR, diffServSchedulerWFQ."
>>and
>>    dsTBParamType OBJECT-TYPE
>>        SYNTAX       AutonomousType
>>        STATUS       current
>>        DESCRIPTION
>>          "The Metering algorithm associated with the
>>          Token-Bucket parameters.  zeroDotZero indicates this
>>          is unknown.
>>          Standard values for generic algorithms are as follows:
>>          diffServTBParamSimpleTokenBucket, diffServTBParamAvgRate,
>>          diffServTBParamSrTCMBlind, diffServTBParamSrTCMAware,
>>          diffServTBParamTrTCMBlind, diffServTBParamTrTCMAware,
>>          diffServTBParamTswTCM
>>          These are specified in the Diffserv MIB."
>>respectively.
>>I believe the above text is clear.
>>Please advise if improvement can be made.
>>Thanks!
>>-- Kwok --
>>
>>At 09:31 AM 9/12/02 +0200, Yacine El Mghazli wrote:
>>
>>>I was wondering about this point:
>>>
>>>how are the OIDs identified in the MIB senseful within the PIB ?
>>>
>>>my understanding is that the PIB is an AUTONOMOUS named data 
>>>structure... in this context, what is the meaning of an OID referencing 
>>>nothing in the PIB itself ?
>>>
>>>thank you for your explanations,
>>>yacine
>>>
>>>
>>>
>>>Wijnen, Bert (Bert) wrote:
>>>
>>>>I think they are the parameters that have been sepcified and identified 
>>>>in the diffserv MIB (RFC3289)
>>>>Thanks,
>>>>Bert
>>>>
>>>>>-----Original Message-----
>>>>>From: Lemponen Jussi [mailto:juzi@cs.tut.fi]
>>>>>Sent: woensdag 11 september 2002 23:02
>>>>>To: diffserv@ietf.org
>>>>>Subject: [Diffserv] parameters section missing from the Diffserv PIB
>>>>>
>>>>>
>>>>>
>>>>>
>>>>>Reading through draft-ietf-diffserv-pib-09.txt, I noticed that
>>>>>the parameters section in the PIB itself is missing. The descriptions
>>>>>for attributes dsTBParamType and dsIfSchedulerCapsServiceDisc do still
>>>>>imply that some parameter definitions should be there.
>>>>>
>>>>>
>>>>>Jussi Lemponen
>>>>>Tampere University of Technology
>>>>>Institute of Communications Engineering
>>>>>_______________________________________________
>>>>>diffserv mailing list
>>>>>diffserv@ietf.org
>>>>>https://www1.ietf.org/mailman/listinfo/diffserv
>>>>>Archive: http://www.ietf.org/mail-archive/working-groups/diffserv/curre
>>>>
>>>>nt/maillist.html
>>>>_______________________________________________
>>>>diffserv mailing list
>>>>diffserv@ietf.org
>>>>https://www1.ietf.org/mailman/listinfo/diffserv
>>>>Archive: 
>>>>http://www.ietf.org/mail-archive/working-groups/diffserv/current/maillist.html
>>>
>




From owner-rap@ops.ietf.org  Mon Sep 16 08:33:15 2002
Received: from psg.com (smmsp@psg.com [147.28.0.62])
	by ietf.org (8.9.1a/8.9.1a) with ESMTP id IAA02232
	for <rap-archive@lists.ietf.org>; Mon, 16 Sep 2002 08:33:15 -0400 (EDT)
Received: from lserv by psg.com with local (Exim 3.36 #1)
	id 17qv2J-0008Bp-00
	for rap-data@psg.com; Mon, 16 Sep 2002 05:31:31 -0700
Received: from colt-na6.alcatel.fr ([62.23.212.6] helo=smail3.alcatel.fr)
	by psg.com with esmtp (Exim 3.36 #1)
	id 17qv2E-0008BZ-00
	for rap@ops.ietf.org; Mon, 16 Sep 2002 05:31:26 -0700
Received: from frmail30.netfr.alcatel.fr (frmail30.netfr.alcatel.fr [155.132.182.163])
	by smail3.alcatel.fr (ALCANET/NETFR) with ESMTP id g8GCP8iB010209;
	Mon, 16 Sep 2002 14:25:08 +0200
Received: from alcatel.fr ([139.54.208.223])
          by frmail30.netfr.alcatel.fr (Lotus Domino Release 5.0.9a)
          with ESMTP id 2002091614300497:4676 ;
          Mon, 16 Sep 2002 14:30:04 +0200 
Message-ID: <3D85CDCF.6FA54246@alcatel.fr>
Date: Mon, 16 Sep 2002 14:25:51 +0200
From: Yacine.El_Mghazli@alcatel.fr
Organization: Alcatel
X-Mailer: Mozilla 4.7 [fr] (WinNT; I)
X-Accept-Language: fr
MIME-Version: 1.0
To: "Wijnen, Bert (Bert)" <bwijnen@lucent.com>
Cc: Kwok Ho Chan <khchan@NortelNetworks.com>, Lemponen Jussi <juzi@cs.tut.fi>,
        diffserv@ietf.org, rap@ops.ietf.org
Subject: Re: [Diffserv] parameters section missing from the Diffserv PIB
References: <A451D5E6F15FD211BABC0008C7FAD7BC0EE45A7A@nl0006exch003u.nl.lucent.com>
X-MIMETrack: Itemize by SMTP Server on FRMAIL30/FR/ALCATEL(Release 5.0.9a |January 7, 2002) at
 09/16/2002 14:30:05,
	Serialize by Router on FRMAIL30/FR/ALCATEL(Release 5.0.9a |January 7, 2002) at
 09/16/2002 14:30:08
Content-Type: text/plain; charset=iso-8859-1
X-Virus-Scanned: by amavisd-milter (http://amavis.org/)
X-Spam-Status: No, hits=1.6 required=5.0
	tests=NO_REAL_NAME,DOUBLE_CAPSWORD
	version=2.31
X-Spam-Level: *
Sender: owner-rap@ops.ietf.org
Precedence: bulk
Content-Transfer-Encoding: 8bit
X-MIME-Autoconverted: from quoted-printable to 8bit by ietf.org id IAA02232

please see bellow

"Wijnen, Bert (Bert)" a écrit :
> 
> > Kwok Ho Chan wrote:
> >
> > > Yacine, Jussi:
> > > The Diffserv PIB already IMPORT Dscp and IfDirection from different
> > > modules of
> > > the Diffserv MIB.  So I did not think there is any issue to
> > > also reused the definitions
> >
> >
> >
> > ok for reuse but here we're talking about OIDs...
> > my question is: what is the signification of MIB-specific
> > OIDs within a PIB ?
> >
> I suspect that you have NOT yet gone to the diffserv MIB to take
> a look as to what those OIDs are representing. Once you do that,
> I think it should be pretty clear.
> 

I suspect that you suspect easily... let me know if I cant ask questions
about things I dont understand (be sure I looked for answers before
asking on the list).

** example:
diffServTBParamSimpleTokenBucket OID = mib-2.97.3.1
this OID has a meaning in the MIB tree, but it has not in the PIB tree. 
it seems that it's just a pointer towards the MIB and I was wondering
about the conssistency with the PIB namespace.

thank you Kwok for your explanations
yacine


> Bert
> > In the previous versions of the PIB draft, these were identified by
> > PRIDS, they pointed towards a PRC within the same PIB... how does it
> > work now ?
> >
> No, this is incorrect. In earlier versions, they were OBJECT IDENTIFIERS
> which basically DUPLICATED what was already in the MIB. And because of
> that duplication I (in my role of PIB/MIB reviewer) recommended that the
> OIDs from the MIB should be re-used.
> 
> Bert
> > thanks,
> > yacine
> >
> >
> > > for dsTBParamType and dsIfSchedulerCapsServiceDisc from the
> > Diffserv MIB as
> > > advised during IESG review.
> > >
> > > The Diffserv PIB's references to the Diffserv MIB are
> > clearly specified as:
> > >
> > >    dsIfSchedulerCapsServiceDisc OBJECT-TYPE
> > >        SYNTAX      AutonomousType
> > >        STATUS      current
> > >        DESCRIPTION
> > >          "The scheduling discipline for which the set of
> > capabilities
> > >          specified in this object apply. Object identifiers
> > for several
> > >          general purpose and well-known scheduling disciplines are
> > >          shared with and defined in the Diffserv MIB.
> > >
> > >          These include diffServSchedulerPriority,
> > >          diffServSchedulerWRR, diffServSchedulerWFQ."
> > >
> > > and
> > >
> > >    dsTBParamType OBJECT-TYPE
> > >        SYNTAX       AutonomousType
> > >        STATUS       current
> > >        DESCRIPTION
> > >          "The Metering algorithm associated with the
> > >          Token-Bucket parameters.  zeroDotZero indicates this
> > >          is unknown.
> > >          Standard values for generic algorithms are as follows:
> > >          diffServTBParamSimpleTokenBucket, diffServTBParamAvgRate,
> > >          diffServTBParamSrTCMBlind, diffServTBParamSrTCMAware,
> > >          diffServTBParamTrTCMBlind, diffServTBParamTrTCMAware,
> > >          diffServTBParamTswTCM
> > >
> > >          These are specified in the Diffserv MIB."
> > >
> > > respectively.
> > >
> > > I believe the above text is clear.
> > > Please advise if improvement can be made.
> > > Thanks!
> > > -- Kwok --
> > >
> > >
> > > At 09:31 AM 9/12/02 +0200, Yacine El Mghazli wrote:
> > >
> > >> I was wondering about this point:
> > >>
> > >> how are the OIDs identified in the MIB senseful within the PIB ?
> > >>
> > >> my understanding is that the PIB is an AUTONOMOUS named data
> > >> structure... in this context, what is the meaning of an OID
> > >> referencing nothing in the PIB itself ?
> > >>
> > >> thank you for your explanations,
> > >> yacine
> > >>
> > >>
> > >>
> > >> Wijnen, Bert (Bert) wrote:
> > >>
> > >>> I think they are the parameters that have been sepcified and
> > >>> identified in the diffserv MIB (RFC3289)
> > >>> Thanks,
> > >>> Bert
> > >>>
> > >>>> -----Original Message-----
> > >>>> From: Lemponen Jussi [mailto:juzi@cs.tut.fi]
> > >>>> Sent: woensdag 11 september 2002 23:02
> > >>>> To: diffserv@ietf.org
> > >>>> Subject: [Diffserv] parameters section missing from the
> > Diffserv PIB
> > >>>>
> > >>>>
> > >>>>
> > >>>>
> > >>>> Reading through draft-ietf-diffserv-pib-09.txt, I noticed that
> > >>>> the parameters section in the PIB itself is missing. The
> > descriptions
> > >>>> for attributes dsTBParamType and
> > dsIfSchedulerCapsServiceDisc do still
> > >>>> imply that some parameter definitions should be there.
> > >>>>
> > >>>>
> > >>>> Jussi Lemponen
> > >>>> Tampere University of Technology
> > >>>> Institute of Communications Engineering
> > >>>> _______________________________________________
> > >>>> diffserv mailing list
> > >>>> diffserv@ietf.org
> > >>>> https://www1.ietf.org/mailman/listinfo/diffserv
> > >>>> Archive:
> http://www.ietf.org/mail-archive/working-groups/diffserv/curre
> >>>
> >>> nt/maillist.html
> >>> _______________________________________________
> >>> diffserv mailing list
> >>> diffserv@ietf.org
> >>> https://www1.ietf.org/mailman/listinfo/diffserv
> >>> Archive:
> >>> http://www.ietf.org/mail-archive/working-groups/diffserv/current/maillist.html
> >>>
> >>>
> >>
> >>
> >
> >



From owner-rap@ops.ietf.org  Mon Sep 16 20:07:25 2002
Received: from psg.com (smmsp@psg.com [147.28.0.62])
	by ietf.org (8.9.1a/8.9.1a) with ESMTP id UAA20327
	for <rap-archive@lists.ietf.org>; Mon, 16 Sep 2002 20:07:24 -0400 (EDT)
Received: from lserv by psg.com with local (Exim 3.36 #1)
	id 17r5tU-000Fhv-00
	for rap-data@psg.com; Mon, 16 Sep 2002 17:07:08 -0700
Received: from hoemail2.lucent.com ([192.11.226.163] helo=hoemail2.firewall.lucent.com)
	by psg.com with esmtp (Exim 3.36 #1)
	id 17r5tQ-000FhX-00
	for rap@ops.ietf.org; Mon, 16 Sep 2002 17:07:04 -0700
Received: from nl0006exch001h.wins.lucent.com (h135-85-76-62.lucent.com [135.85.76.62])
	by hoemail2.firewall.lucent.com (Switch-2.2.2/Switch-2.2.0) with ESMTP id g8H070o17213
	for <rap@ops.ietf.org>; Mon, 16 Sep 2002 20:07:00 -0400 (EDT)
Received: by nl0006exch001h.nl.lucent.com with Internet Mail Service (5.5.2653.19)
	id <SLBWSZM5>; Tue, 17 Sep 2002 02:06:59 +0200
Message-ID: <A451D5E6F15FD211BABC0008C7FAD7BC0EF24DC3@nl0006exch003u.nl.lucent.com>
From: "Wijnen, Bert (Bert)" <bwijnen@lucent.com>
To: Yacine.El_Mghazli@alcatel.fr
Cc: Kwok Ho Chan <khchan@NortelNetworks.com>,
        Lemponen Jussi
	 <juzi@cs.tut.fi>, diffserv@ietf.org, rap@ops.ietf.org
Subject: RE: [Diffserv] parameters section missing from the Diffserv PIB
Date: Tue, 17 Sep 2002 02:06:58 +0200
MIME-Version: 1.0
X-Mailer: Internet Mail Service (5.5.2653.19)
Content-Type: text/plain;
	charset="iso-8859-1"
X-Spam-Status: No, hits=1.1 required=5.0
	tests=DOUBLE_CAPSWORD
	version=2.31
X-Spam-Level: *
Sender: owner-rap@ops.ietf.org
Precedence: bulk

> > > ok for reuse but here we're talking about OIDs...
> > > my question is: what is the signification of MIB-specific
> > > OIDs within a PIB ?
> > >
> > I suspect that you have NOT yet gone to the diffserv MIB to take
> > a look as to what those OIDs are representing. Once you do that,
> > I think it should be pretty clear.
> > 
> 
> I suspect that you suspect easily... let me know if I cant ask questions
> about things I dont understand (be sure I looked for answers before
> asking on the list).
> 
You can ask question. No problem with that... but on the following:

> ** example:
> diffServTBParamSimpleTokenBucket OID = mib-2.97.3.1
> this OID has a meaning in the MIB tree, but it has not in the PIB tree. 
> it seems that it's just a pointer towards the MIB and I was wondering
> about the conssistency with the PIB namespace.
> 
It seems quite obvious to me (and I think Kwok also tried to explain),
the descrition says:

  diffServTBParamSimpleTokenBucket OBJECT-IDENTITY
    STATUS       current
    DESCRIPTION
       "Two Parameter Token Bucket Meter as described in the Informal
       Differentiated Services Model section 5.2.3."
    ::= { diffServTBMeters 1 }

So, this is an OBJECT-IDENTITY. See RFC2578, sect 6 for an explantion
of what it is used for.

In this case, it identifies (by OID) a specific type of Token Bucket Meter.
Such a meter can be used in a MIB, but it can also be used in a PIB.
And when you want to indicate that you are using this type of meter,
then you can indicate so by using the above OID in the appropriate object
(attribute), no matter if that object is defined in a MIB or in a PIB.
Typically the OID is the value that is assigned to a object with
a SYNTAX of AutonomousType (as is the case in both the MIB and the PIB).

Hope this helps more.

Bert
> thank you Kwok for your explanations
> yacine
> 
> 
> > Bert
> > > In the previous versions of the PIB draft, these were 
> identified by
> > > PRIDS, they pointed towards a PRC within the same PIB... 
> how does it
> > > work now ?
> > >
> > No, this is incorrect. In earlier versions, they were 
> OBJECT IDENTIFIERS
> > which basically DUPLICATED what was already in the MIB. And 
> because of
> > that duplication I (in my role of PIB/MIB reviewer) 
> recommended that the
> > OIDs from the MIB should be re-used.
> > 
> > Bert
> > > thanks,
> > > yacine
> > >
> > >
> > > > for dsTBParamType and dsIfSchedulerCapsServiceDisc from the
> > > Diffserv MIB as
> > > > advised during IESG review.
> > > >
> > > > The Diffserv PIB's references to the Diffserv MIB are
> > > clearly specified as:
> > > >
> > > >    dsIfSchedulerCapsServiceDisc OBJECT-TYPE
> > > >        SYNTAX      AutonomousType
> > > >        STATUS      current
> > > >        DESCRIPTION
> > > >          "The scheduling discipline for which the set of
> > > capabilities
> > > >          specified in this object apply. Object identifiers
> > > for several
> > > >          general purpose and well-known scheduling 
> disciplines are
> > > >          shared with and defined in the Diffserv MIB.
> > > >
> > > >          These include diffServSchedulerPriority,
> > > >          diffServSchedulerWRR, diffServSchedulerWFQ."
> > > >
> > > > and
> > > >
> > > >    dsTBParamType OBJECT-TYPE
> > > >        SYNTAX       AutonomousType
> > > >        STATUS       current
> > > >        DESCRIPTION
> > > >          "The Metering algorithm associated with the
> > > >          Token-Bucket parameters.  zeroDotZero indicates this
> > > >          is unknown.
> > > >          Standard values for generic algorithms are as follows:
> > > >          diffServTBParamSimpleTokenBucket, 
> diffServTBParamAvgRate,
> > > >          diffServTBParamSrTCMBlind, diffServTBParamSrTCMAware,
> > > >          diffServTBParamTrTCMBlind, diffServTBParamTrTCMAware,
> > > >          diffServTBParamTswTCM
> > > >
> > > >          These are specified in the Diffserv MIB."
> > > >
> > > > respectively.
> > > >
> > > > I believe the above text is clear.
> > > > Please advise if improvement can be made.
> > > > Thanks!
> > > > -- Kwok --
> > > >
> > > >
> > > > At 09:31 AM 9/12/02 +0200, Yacine El Mghazli wrote:
> > > >
> > > >> I was wondering about this point:
> > > >>
> > > >> how are the OIDs identified in the MIB senseful within 
> the PIB ?
> > > >>
> > > >> my understanding is that the PIB is an AUTONOMOUS named data
> > > >> structure... in this context, what is the meaning of an OID
> > > >> referencing nothing in the PIB itself ?
> > > >>
> > > >> thank you for your explanations,
> > > >> yacine
> > > >>
> > > >>
> > > >>
> > > >> Wijnen, Bert (Bert) wrote:
> > > >>
> > > >>> I think they are the parameters that have been sepcified and
> > > >>> identified in the diffserv MIB (RFC3289)
> > > >>> Thanks,
> > > >>> Bert
> > > >>>
> > > >>>> -----Original Message-----
> > > >>>> From: Lemponen Jussi [mailto:juzi@cs.tut.fi]
> > > >>>> Sent: woensdag 11 september 2002 23:02
> > > >>>> To: diffserv@ietf.org
> > > >>>> Subject: [Diffserv] parameters section missing from the
> > > Diffserv PIB
> > > >>>>
> > > >>>>
> > > >>>>
> > > >>>>
> > > >>>> Reading through draft-ietf-diffserv-pib-09.txt, I 
> noticed that
> > > >>>> the parameters section in the PIB itself is missing. The
> > > descriptions
> > > >>>> for attributes dsTBParamType and
> > > dsIfSchedulerCapsServiceDisc do still
> > > >>>> imply that some parameter definitions should be there.
> > > >>>>
> > > >>>>
> > > >>>> Jussi Lemponen
> > > >>>> Tampere University of Technology
> > > >>>> Institute of Communications Engineering
> > > >>>> _______________________________________________
> > > >>>> diffserv mailing list
> > > >>>> diffserv@ietf.org
> > > >>>> https://www1.ietf.org/mailman/listinfo/diffserv
> > > >>>> Archive:
> > http://www.ietf.org/mail-archive/working-groups/diffserv/curre
> > >>>
> > >>> nt/maillist.html
> > >>> _______________________________________________
> > >>> diffserv mailing list
> > >>> diffserv@ietf.org
> > >>> https://www1.ietf.org/mailman/listinfo/diffserv
> > >>> Archive:
> > >>> 
http://www.ietf.org/mail-archive/working-groups/diffserv/current/maillist.html
> >>>
> >>>
> >>
> >>
> >
> >



