
From sm@elandsys.com  Thu Apr 21 23:51:07 2011
Return-Path: <sm@elandsys.com>
X-Original-To: yam@ietfc.amsl.com
Delivered-To: yam@ietfc.amsl.com
Received: from localhost (localhost [127.0.0.1]) by ietfc.amsl.com (Postfix) with ESMTP id 16F81E0810 for <yam@ietfc.amsl.com>; Thu, 21 Apr 2011 23:51:07 -0700 (PDT)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -102.599
X-Spam-Level: 
X-Spam-Status: No, score=-102.599 tagged_above=-999 required=5 tests=[BAYES_00=-2.599, USER_IN_WHITELIST=-100]
Received: from mail.ietf.org ([208.66.40.236]) by localhost (ietfc.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id 7slCxNi4D+OB for <yam@ietfc.amsl.com>; Thu, 21 Apr 2011 23:51:04 -0700 (PDT)
Received: from mail.elandsys.com (mail.elandsys.com [208.69.177.125]) by ietfc.amsl.com (Postfix) with ESMTP id B00ECE0800 for <yam@ietf.org>; Thu, 21 Apr 2011 23:51:03 -0700 (PDT)
Received: from subman.elandsys.com ([41.136.235.101]) (authenticated bits=0) by mail.elandsys.com (8.13.8/8.13.8) with ESMTP id p3M6osFt030486 for <yam@ietf.org>; Thu, 21 Apr 2011 23:51:00 -0700
DKIM-Signature: v=1; a=rsa-sha1; c=simple/simple; d=elandsys.com; s=mail; t=1303455061; bh=b254WHT3GaZn1peNDaYYbhVcE+8=; h=Message-Id:Date:To:From:Subject:Mime-Version:Content-Type; b=j2qbNr96SGvOy9ZpPZo61CbG/d3yHmQA7pPy7C98ktYhPyFTvl96UZ7KITokBQXI5 XWEfXjuihLjkXlle0BrMHqDtskkHdtJVjNHSAk/Qn5rrcbqcaklgqPtl7IwDXj64rw Jj7TmCUVuTHwsek8mQdCUMN2vXjJ5O7z5UZiQotI=
Message-Id: <6.2.5.6.2.20110421223638.049e18d0@elandnews.com>
X-Mailer: QUALCOMM Windows Eudora Version 6.2.5.6
Date: Thu, 21 Apr 2011 23:49:34 -0700
To: yam@ietf.org
From: S Moonesamy <sm+ietf@elandsys.com>
Mime-Version: 1.0
Content-Type: text/plain; charset="us-ascii"; format=flowed
Subject: [yam] Status of draft-ietf-yam-4409bis-submit
X-BeenThere: yam@ietf.org
X-Mailman-Version: 2.1.12
Precedence: list
List-Id: Yet Another Mail working group discussion list <yam.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/options/yam>, <mailto:yam-request@ietf.org?subject=unsubscribe>
List-Archive: <http://www.ietf.org/mail-archive/web/yam>
List-Post: <mailto:yam@ietf.org>
List-Help: <mailto:yam-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/yam>, <mailto:yam-request@ietf.org?subject=subscribe>
X-List-Received-Date: Fri, 22 Apr 2011 06:51:07 -0000

Dear YAM WG,

draft-ietf-yam-4409bis-submit-pre-evaluation-00, submitted in July 
2010, contains a preliminary evaluation of RFC 4409 (Message 
Submission for Mail).  The I-D discusses changes and non-changes that 
the YAM WG proposes to make in a revision.

Given that RFC 4409 is a document that this working group has been 
working on and there has been a preliminary evaluation, I'll ask John 
Klensin and Randall Gellens to work on 
draft-ietf-yam-4409bis-submit.  Some of the references may have to be 
updated as STD 71 has been published.

John Klensin emailed the YAM WG Chairs about adding some text which 
discusses about encoding conversions.  The change is related to the 
work currently being done in the EAI WG. I suggest that John Klensin 
sends the proposed text to the YAM mailing list.  The YAM WG can then 
decide on whether the proposed text should be incorporated in a 
revision of RFC 4409.

If there is any objection to the above, please send it to the YAM mailing list.

Regards,
S. Moonesamy
YAM WG co-chair


From julian.reschke@gmx.de  Sat Apr 30 07:24:15 2011
Return-Path: <julian.reschke@gmx.de>
X-Original-To: yam@ietfa.amsl.com
Delivered-To: yam@ietfa.amsl.com
Received: from localhost (localhost [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id 34AF7E0664 for <yam@ietfa.amsl.com>; Sat, 30 Apr 2011 07:24:15 -0700 (PDT)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -105.092
X-Spam-Level: 
X-Spam-Status: No, score=-105.092 tagged_above=-999 required=5 tests=[AWL=-2.493, BAYES_00=-2.599, USER_IN_WHITELIST=-100]
Received: from mail.ietf.org ([64.170.98.30]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id uE4PjVkfHDJY for <yam@ietfa.amsl.com>; Sat, 30 Apr 2011 07:24:14 -0700 (PDT)
Received: from mailout-de.gmx.net (mailout-de.gmx.net [213.165.64.23]) by ietfa.amsl.com (Postfix) with SMTP id 01B73E062A for <yam@ietf.org>; Sat, 30 Apr 2011 07:24:10 -0700 (PDT)
Received: (qmail invoked by alias); 30 Apr 2011 14:24:08 -0000
Received: from p508FBEF0.dip.t-dialin.net (EHLO [192.168.178.33]) [80.143.190.240] by mail.gmx.net (mp025) with SMTP; 30 Apr 2011 16:24:08 +0200
X-Authenticated: #1915285
X-Provags-ID: V01U2FsdGVkX1+jjrpKB3+jMtDaztWLVntzzdhDINJ5FznfK26hbo LdZhSNkQRg8efl
Message-ID: <4DBC1B7F.7020101@gmx.de>
Date: Sat, 30 Apr 2011 16:23:59 +0200
From: Julian Reschke <julian.reschke@gmx.de>
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.17) Gecko/20110414 Lightning/1.0b2 Thunderbird/3.1.10
MIME-Version: 1.0
To: yam@ietf.org
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: 7bit
X-Y-GMX-Trusted: 0
Subject: [yam] Thoughts on text/* encoding defaults
X-BeenThere: yam@ietf.org
X-Mailman-Version: 2.1.12
Precedence: list
List-Id: Yet Another Mail working group discussion list <yam.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/options/yam>, <mailto:yam-request@ietf.org?subject=unsubscribe>
List-Archive: <http://www.ietf.org/mail-archive/web/yam>
List-Post: <mailto:yam@ietf.org>
List-Help: <mailto:yam-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/yam>, <mailto:yam-request@ietf.org?subject=subscribe>
X-List-Received-Date: Sat, 30 Apr 2011 14:24:15 -0000

Hi there.

In Prague, we had a few hallway conversations with respect to the 
default encoding of text/* media types.

Below are my notes (references to the relevant spec sections, 
information about a recent change in HTTPbis, and a rough proposal about 
how to proceed).

I'm posting this here because Alexey thought the audience might fit...

Best regards, Julian

-- snip --


1) RFC 2046 says that the default is US-ASCII

"Note that the character set used, if anything other than US- ASCII, 
must always be explicitly specified in the Content-Type field." -- 
<http://greenbytes.de/tech/webdav/rfc2046.html#rfc.section.4.1.2.p.18>

2) RFC 2616 says it's ISO-8859-1

"The "charset" parameter is used with some media types to define the 
character set (Section 3.4) of the data. When no explicit charset 
parameter is provided by the sender, media subtypes of the "text" type 
are defined to have a default charset value of "ISO-8859-1" when 
received via HTTP. Data in character sets other than "ISO-8859-1" or its 
subsets MUST be labeled with an appropriate charset value. See Section 
3.4.1 for compatibility problems." -- 
<http://greenbytes.de/tech/webdav/rfc2616.html#rfc.section.3.7.1.p.4>

3) For text/xml, RFC 3023 says it's US-ASCII, no matter what 2616 says :-)

"Conformant with [RFC2046], if a text/xml entity is received with the 
charset parameter omitted, MIME processors and XML processors MUST use 
the default charset value of "us-ascii"[ASCII].  In cases where the XML 
MIME entity is transmitted via HTTP, the default charset value is still 
"us-ascii".  (Note: There is an inconsistency between this specification 
and HTTP/1.1, which uses ISO-8859-1[ISO8859] as the default for a 
historical reason.  Since XML is a new format, a new default should be 
chosen for better I18N.  US-ASCII was chosen, since it is the 
intersection of UTF-8 and ISO-8859-1 and since it is already used by 
MIME.)" -- <http://tools.ietf.org/html/rfc3023#section-3.1>

The problem

Recipients do not implement this; they take the absence of encoding 
information as indicator to inspect the payload; this is at least true 
for text/xml and text/html (see 
<http://www.w3.org/TR/REC-xml/#sec-guessing> and 
<http://www.w3.org/TR/2011/WD-html5-20110405/parsing.html#determining-the-character-encoding>)

Current development: HTTPbis, P3 has dropped drop the default and 
delegate to the relevant media type definitions (see 
<http://trac.tools.ietf.org/wg/httpbis/trac/ticket/20>, 
<http://greenbytes.de/tech/webdav/draft-ietf-httpbis-p3-payload-14.html>).

Left to do:

a) Revise RFC 2046; allow text/* types that carry encoding information 
inline to do the expected thing (overriding the US-ASCII default); warn 
against doing so in new registrations (recommend to only support UTF-8, 
and require to always explicitly include the charset parameter, such as 
text/vcard is going to do it?)

b) Revise RFC 3023 to delegate text/xml charset defaults to revision of 
2046?

Best regards, Julian


