Subject: [92hackathon] Tasks and roles at Hackaton

From: Szilveszter Nadas <[email-masked]>
Date: Fri, 6 Mar 2015 10:12:36 +0000

Hi,

I plan to participate in SPUD. However I might not be able to do actual coding due to the need of company approval for that.

Does it still make sense to participate if that happens to be the case? I.e. can I do testing/documentation only without actually writing code and is that a valuable contribution?

Is the list of champions available somewhere?

Cheers,
Sz.

From: 92hackathon [mailto:[email-masked]] On Behalf Of Reinaldo Penno (repenno)
Sent: Friday, March 06, 2015 0:43
To: [email-masked]
Subject: [92hackathon] To Those planning on attending the SFC Hackaton

Hi,

If you are planning on attending the SFC hackaton can you reply (in pvt if you prefer) about what would you like to work on or contribute?

It could be:

- Coding
- Testing against the data plane or ODL interop
- Standards/Documentation as related to items above

Based on this I will try to put together some well-defined work items.

Thanks,

Reinaldo

---

From: "Pal Martinsen (palmarti)" <[email-masked]>
Date: Mon, 9 Mar 2015 09:46:14 +0000

On 06 Mar 2015, at 11:12, Szilveszter Nadas <[email-masked]<mailto:[email-masked]>> wrote:

Hi,

I suspect so. Their might be various other things to do that is not just writing code.

Playing with Linux and netfilter to intercept SPUD packets.
A iptables rule like:
-A PREROUTING -p udp —match u32 --u32 "0>>22&0x3C@8=0xd80000d8" -j NFQUEUE --queue-num 0
 Seems to be able to catch SPUD packet in at least one direction. But I am having problems getting it to do so on the return path as well.

Related to that it would be interesting to do some load test on the raspberry PI to see how well it can cope with SPUD.

In addition to that we should probably have some generic design discussions regarding how to build an open src library that is portable, extensible and easy to use.

.-.
Pål-Erik

Cheers,
Sz.

From: 92hackathon [mailto:[email-masked]] On Behalf Of Reinaldo Penno (repenno)
Sent: Friday, March 06, 2015 0:43
To: [email-masked]<mailto:[email-masked]>
Subject: [92hackathon] To Those planning on attending the SFC Hackaton

Hi,

It could be:

- Coding

Thanks,

Reinaldo
_______________________________________________
92hackathon mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/92hackathon