Subject: Re: [92hackathon] SPUDlib available

From: "Charles Eckel (eckelcu)" <[email-masked]>
Date: Fri, 20 Mar 2015 23:53:28 +0000

Actually, I meant SPUDlib at https://github.com/iptube/SPUDlib
But check out SPUDshark as well :)

On 3/20/15, 6:51 PM, "Charles Eckel (eckelcu)" <[email-masked]> wrote:

>For those of you planning to work on SPUD related stuff at the Hackathon,
>check out: https://github.com/iptube/SPUDshark
>
>There is a list of issues included in the project in case you want to
>start looking now for good things to work on this weekend. You will hear
>more about it tomorrow morning. See you then!
>
>Cheers,
>Charles
>
>_______________________________________________
>92hackathon mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/92hackathon

---

From: "Visweswaran, Gowri" <[email-masked]>
Date: Sat, 21 Mar 2015 00:36:56 +0000

Thanks Charles, 

Which platforms does this code build on? I am not able to build it on my
Mac Yosemite or on a Centos 6X machine.

Gowri

---

From: "Pal Martinsen (palmarti)" <[email-masked]>
Date: Sat, 21 Mar 2015 02:05:28 +0000

> On 20 Mar 2015, at 19:36, Visweswaran, Gowri <[email-masked]> wrote:
> 
> Thanks Charles, 
> 

What did ./configure tell you?

You need to have auto-tools installed to build the ./configure script

Works on my Darwin kernel 14.0.1 and Ubuntu box.
On OS-X i works well with gcc, clang and cc( Apple clang)
Ubuntu works with gcc and clang

Making sure this compile an all platforms is important to us. Can we sit down tomorrow and see if we can figure out what the problem is?

.-.
Pål-Erik

---

From: "Visweswaran, Gowri" <[email-masked]>
Date: Sat, 21 Mar 2015 02:17:13 +0000

Hello,

I would be happy to sit down tomorrow and figure this out, meantime, here
is what I am seeing on both my machinesŠ

On the Mac OS X Yosemite 10.10.2:

bash-3.2$ ./bootstrap.sh
Can't exec "libtoolize": No such file or directory at
/usr/local/share/autoconf/Autom4te/FileUtils.pm line 345, <GEN2> line 5.
autoreconf: failed to run libtoolize: No such file or directory
autoreconf: libtoolize is needed because this package uses Libtool

On my Centos 6.6 machine:

./configure: line 12756: syntax error near unexpected token `CHECK,'
./configure: line 12756: `  PKG_CHECK_MODULES(CHECK, check >= 0.9.8)'

I commented out that line to see if I could proceed and did build the
libraries and samples.

I did try to run the spud echo sample but could not see my UDP request
echo¹ed back. 

Tests did fail to build though:

Head of output:
[gmadkat@gmadkat SPUDlib]$ make check
Making check in src
make[1]: Entering directory `/home/gmadkat/spud/SPUDlib/src'
make[1]: Nothing to be done for `check'.
make[1]: Leaving directory `/home/gmadkat/spud/SPUDlib/src'
Making check in samplecode
make[1]: Entering directory `/home/gmadkat/spud/SPUDlib/samplecode'
make[1]: Nothing to be done for `check'.
make[1]: Leaving directory `/home/gmadkat/spud/SPUDlib/samplecode'
Making check in .
make[1]: Entering directory `/home/gmadkat/spud/SPUDlib'
make[1]: Leaving directory `/home/gmadkat/spud/SPUDlib'
Making check in test
make[1]: Entering directory `/home/gmadkat/spud/SPUDlib/test'
make  check_spudlib
make[2]: Entering directory `/home/gmadkat/spud/SPUDlib/test'
/bin/sh ../libtool  --tag=CC   --mode=link gcc -std=gnu99  -g -O2 -g   -o
check_spudlib ls_str_test.o ls_sockaddr_test.o ls_error_test.o
ls_mem_test.o ls_log_test.o ls_htable_test.o ls_eventing_test.o
spud_test.o tube_test.o cbor_test.o test_utils.o testmain.o
../src/libspud.la -lm -lpthread
libtool: link: gcc -std=gnu99 -g -O2 -g -o .libs/check_spudlib
ls_str_test.o ls_sockaddr_test.o ls_error_test.o ls_mem_test.o
ls_log_test.o ls_htable_test.o ls_eventing_test.o spud_test.o tube_test.o
cbor_test.o test_utils.o testmain.o  ../src/.libs/libspud.so -lm -lpthread
tube_test.o: In function `tube_manager_loop_test':
/home/gmadkat/spud/SPUDlib/test/tube_test.c:272: warning: `sys_errlist' is
deprecated; use `strerror' or `strerror_r' instead
ls_str_test.o: In function `ls_str_suite':
/home/gmadkat/spud/SPUDlib/test/ls_str_test.c:196: undefined reference to
`suite_create'
/home/gmadkat/spud/SPUDlib/test/ls_str_test.c:200: undefined reference to
`tcase_create'
/home/gmadkat/spud/SPUDlib/test/ls_str_test.c:201: undefined reference to
`_tcase_add_test'
/home/gmadkat/spud/SPUDlib/test/ls_str_test.c:202: undefined reference to
`_tcase_add_test'
/home/gmadkat/spud/SPUDlib/test/ls_str_test.c:203: undefined reference to
`_tcase_add_test'
/home/gmadkat/spud/SPUDlib/test/ls_str_test.c:204: undefined reference to
`_tcase_add_test'
/home/gmadkat/spud/SPUDlib/test/ls_str_test.c:205: undefined reference to
`_tcase_add_test'

On 3/20/15, 10:05 PM, "Pal Martinsen (palmarti)" <[email-masked]>
wrote:

>Making sure this compile an all platforms is important to us. Can we sit
>down tomorrow and see if we can figure out what the problem is?
>
>.-.
>Pål-Erik
>
>> 
>> Gowri
>>

---

From: "Pal Martinsen (palmarti)" <[email-masked]>
Date: Sat, 21 Mar 2015 03:26:12 +0000

> On 20 Mar 2015, at 21:17, Visweswaran, Gowri <[email-masked]> wrote:
> 
> Hello,
> 
Cool.

> autoreconf: libtoolize is needed because this package uses Libtool

sudo port install libtool should fix that. (Assuming you have macports installed)

> ./configure: line 12756: `  PKG_CHECK_MODULES(CHECK, check >= 0.9.8)’
> 
Weird.

Did you run a plain ./configure or with —enable-check?

If you want to do development running the unit-tests are essential. Install check.
CentOS is RPM based right?
(http://rpmfind.net/linux/rpm2html/search.php?query=check(x86-32))

> I did try to run the spud echo sample but could not see my UDP request
Running them on the same box is not always successful. Need to look into that as well.

> Tests did fail to build though:
No wonder since you commented it out in the configure.ac… :-)

.-.
Pål-Erik

---

From: "Joe Hildebrand (jhildebr)" <[email-masked]>
Date: Sat, 21 Mar 2015 04:26:02 +0000

>sudo port install libtool should fix that. (Assuming you have macports installed)

I use homebrew: http://brew.sh/

I think you may need:

    brew install autoconf libtool check

We'll see tomorrow if anything else is required, and put it in the README.

>Did you run a plain ./configure or with —enable-check?

I think you need to install pkg-config, and make sure your autoconf is up to date.

-- 
Joe Hildebrand