Subject: Re: Comments on draft-calhoun-diameter-18.txt

From: Pat Calhoun <[email-masked]>
Date: Wed, 17 Jan 2001 09:51:15 -0800

Thanks for the catch. I will make sure that this is corrected in the draft-ietf-aaa
version.

Thanks,

PatC
>Hi
>
>Found a type in section 8.2. The Command Codes that are specified within
>this specification should be 257, 259, 274-276
>Compare section 8.2 with 2.1
>
>/Fredrik
>
>8.2  Command Code Values
>
>   As defined in section 2.1, the Command Code field has an associated
>   value maintained by IANA. Values 0-255 are reserved for backward
>   RADIUS compatibility, and values 256, 259, 174, 275 and 276 are
>   defined in this specification. The remaining values are available for
>   assignment via Designated Expert [12].
>
>
>2.1
>...
>   Command-Code
>      The Command-Code field is four octets, and is used in order to
>      communicate the command associated with the message. The 32-bit
>      address space is managed by IANA (see section 8.2). The following
>      Command Codes are currently defined in the DIAMETER base protocol:
>
>         Command-Name             Abbrev.    Code       Reference
>         --------------------------------------------------------
>         Device-Reboot-Ind         DRI       257           2.5
>         Message-Reject-Ind        MRI       259           5.1
>         Session-Termination-Ind   STI       274           3.5.1
>         Session-Termination-      STR       275           3.5.2
>            Request
>         Session-Termination-      STA       276           3.5.3
>            Answer
>
>
>
>----------------------------------------------------------------------------
>-------
>Fredrik Johansson                    W: +46 (0)8 725 5916
>Interactive People Unplugged     M: +46 (0)70 786 5035
>mailto:[email-masked]
>http://www.ipunplugged.com
>
>

---

From: Tony Johansson <[email-masked]>
Date: Wed, 17 Jan 2001 12:00:43 -0800

Hi Pat,

I think this one starts to look really good, just a couple of comments.

section 2.4 State Machine, page 16:

I think the typo is made on the second  row from the top (this has been sent earlier on
the list by some one else): New State should be Wait-DRI not Open.

State     Event                          Action    New State
-----     -----                          ------    ---------
...

Initial   Receive transport level        Send DRI  Open
          connection request from a
          DIAMETER peer.

Should be:
<<<<<<
State     Event                          Action    New State
-----     -----                          ------    ---------
...

Initial   Receive transport level        Send DRI  Wait-DRI
          connection request from a
          DIAMETER peer.

Section 6.7 Loop Detection, page 30:

It is clear that you should reply with an Answer on Request and a Reply on a Query with
the Result-Code AVP set to DIAMETER_LOOP_DETECTED, but what about an Indication? To me
the most logical thing would be to send back an MRI. Is that the right assumption...

BR,

/Tony

---

From: Pat Calhoun <[email-masked]>
Date: Fri, 19 Jan 2001 13:52:53 -0800 (PST)

> I think the typo is made on the second  row from the top (this has been sent
> earlier on the list by some one else): New State should be Wait-DRI not Open.
>  >>>>>

hmmm.... I could have sworn that I fixed this problem, but apparently not :(

> It is clear that you should reply with an Answer on Request and a Reply on a
> Query with the Result-Code AVP set to DIAMETER_LOOP_DETECTED, but what about
> an Indication? To me the most logical thing would be to send back an MRI. Is
> that the right assumption...

Correct. Section 5.1 states that the MRI is to be sent when:

2. An error is found in a message for which there is no appropriate
response.

PatC