Subject: RE: Self Describing record formats for multiple (non-network-acce ss) usage types ...

From: Abhi Deshmukh <[email-masked]>
Date: Wed, 17 Jan 2001 09:27:46 -0500

As we know, SNMP is commonly used at the network element level for a variety
of purposes including configuration and usage information (RMON2). There are
a class of apps like Streaming servers, Web Servers, Caching Servers,
Proxies, load balancers, and other service-specific apps that use log files,
etc to store their usage related information. These apps do not have SNMP
support. How do we plan on accomodating these usage records in the AAA
framework ?

- Abhi

> -----Original Message-----
> From: David Harrington [mailto:[email-masked]]
> Sent: Tuesday, January 16, 2001 5:11 PM
> To: Abhi Deshmukh
> Cc: [email-masked]'
> Subject: Re: Self Describing record formats for multiple
> (non-network-access) usage types ...
> 
> 
> What types of usage did you have in mind?
> SNMP is the standard that is typically used to monitor 
> network activity.
> 
> dbh
> 
> Abhi Deshmukh wrote:
> > 
> > Hello:
> > 
> > I have been looking at the AAA related documents for record 
> formats and I
> > have an idea to share about the formats.
> > 
> > Is there a thought in the AAA WG of having self describing 
> records in the
> > overall AAA framework ?. This would allow other known 
> unknown and not
> > invented usage records to be accomodated in the AAA 
> framework. This way, if
> > the transport issues are resolved, new usage types would 
> not present a
> > challenge to the record format. Also having a AAA framework 
> that accomodates
> > other usage types (other than end user network access) 
> would be beneficial.
> > 
> > I have some ideas on this thought process. If this thought 
> is-being or
> > has-been dicussed, then perhaps I missed it. Is there any 
> place that I
> > should be looking ? Any useful pointers ?
> > 
> > Thanks for your time.
> > 
> > - Abhi Deshmukh
> > 
> > PS: I also looked at an Internet Draft
> > 
> (http://ietf.org/internet-drafts/draft-ietf-aaa-issues-04.txt)
 but did not
> this issue listed explicitly.

-- 
---
David Harrington            Network Management Standards Architect
[email-masked]           Office of the CTO
+1 603 337 2614 - voice     Enterasys Networks
+1 603 332 1524 - fax       Rochester NH, USA

---

From: Abhi Deshmukh <[email-masked]>
Date: Wed, 17 Jan 2001 15:14:10 -0500

I haven't had an answer from this mailing list to the following question.
Does that mean a "NO" ??? Your feedback is very important.
- Abhi

-----Original Message-----
From: Abhi Deshmukh [mailto:[email-masked]]
Sent: Wednesday, January 17, 2001 9:28 AM
To: [email-masked]'
Cc: [email-masked]'
Subject: RE: Self Describing record formats for multiple
(non-network-acce ss) usage types ...

- Abhi

 but did not

---

From: "Nelson, David" <[email-masked]>
Date: Wed, 17 Jan 2001 15:29:34 -0500

Abhi Deshmukh writes...

> There are a class of apps like Streaming servers, Web Servers, Caching 
> Servers, Proxies, load balancers, and other service-specific apps that 
> use log files, etc to store their usage related information. These apps
> do not have SNMP support. How do we plan on accommodating these usage 
> records in the AAA framework ?

The AAA Working Group Charter states, in part:
(see http://www.ietf.org/html.charters/aaa-charter.html)

The Authentication, Authorization and Accounting Working Group focused on
the development of requirements for Authentication, Authorization and
Accounting as applied to network access. Requirements were gathered from
NASREQ, MOBILE IP, and ROAMOPS Working Groups as well as TIA 45.6.

How do the applications you mention fit into this scope of work?  I ask
this not in a cynical fashion, but simply to clarify the nature of the
applications you mention and their relation to our work.  We are working on
AAA to meet specific requirements (NASREQ, MOBILE IP, and ROAMOPS), not a 
generalized, all-purpose AAA service.

Regards,

Dave

David B. Nelson, Software Architect
Enterasys Networks, Inc.
50 Minuteman Road
Andover, MA 01801-1008
Phone: (978) 684-1330  FAX: (978) 684-1368
E-mail: [email-masked]

---

From: "Nelson, David" <[email-masked]>
Date: Wed, 17 Jan 2001 15:53:10 -0500

Abhi Deshmukh writes...

> One way to accommodate known and unknown record formats is to have the
> payload records describe themselves. This way the transport can
accommodate
> *any* usage record.

> I however understand the AAA framework is not meant to be all purpose. I
was
> trying to see if there was a thought process along the lines of extending
> the AAA transport to accommodate "other" usage types.

Certainly the DIAMETER protocol, currently under development in the AAA WG,
is extensible, and could very likely be adapted for the use you envision,
by specifying the needed extensions to the DIAMETER base document, possibly
leveraging the proposed DIAMETER Accounting extensions.

Whether standardizing such extensions would be fodder for the AAA WG is 
another question, of course.

Regards,

Dave

---

From: "Martin Julien (ECE)" <[email-masked]>
Date: Thu, 18 Jan 2001 13:49:44 +0100

Abhi,

Maybe the discussion on this ML "Choice of Data Model SMI vs XML vs. UML)" could give you a better idea of what is being discussed about an AAA dictionnary at the moment. I am not sure exactly where that discussion is going (SMIng???), but I'd like to see it going towards what you want as well, which I think is defining new attributes (AVPs) in a flexible way at run-time and being able to output them for accounting purposes, for example, as is to an accounting server. Since the logging format and the accounting format is no longer ADIF, I'm not sure what to expect besides the dumping of AVPs at the moment. Refer to ML "DISCUSSION REQUESTED: ADIF, Batching, M bit" for the following comment:

> However, I think that specifying a recommended XML or SMI format for the
> accounting file that is written on the server MAY be a desirable goal.

Hope it helps,
Martin

-----Original Message-----
From: Erik Guttman [mailto:[email-masked]]
Sent: Thursday, January 18, 2001 10:04 AM
To: Abhi Deshmukh
Cc: [email-masked]'; [email-masked]
Subject: RE: Self Describing record formats for multiple

Abhi,

You wrote:
> In particular the attributes of usage records in this case would be
> different than RADIUS, Mobile IP, etc. If the AAA transport can 
> accomodate different record formats, then the AAA framework will be 
> very attractive for *adoption* for billing systems for various services.

DIAMETER data, represented by AVPs, is grouped in commands.  Both
the commands and the AVPs are accompanied by centrally assigned
identifiers for all standardized extensions to the protocol.  Two
compliant implementations of the protocol will be able to recognize
known commands and data, as well as unknown, non-implemented
formats, as such.  Vendor extensions allow for non-standard messages
to be sent.  

In order to make progress with AAA standardization, the working
group narrowed its focus.  This does not mean that DIAMETER extensions 
couldn't be written for other purposes than network access.  

It is up to you to figure out what your requirements are and to assess 
whether DIAMETER, SNMP or whatever best fulfill them.

> One way to accomodate known and unknown record formats is to have the
> payload records describe themself. This way the transport can accomodate
> *any* usage record.

Self describing data records alone do not achieve much.  Labeling a 
record format as having fields with particular data types does not 
allow the record to be *interpreted.*  Correct interpretation requires 
common rules (a protocol) to be implemented by communicating parties
so they know *what to do* with the data when they get it.

Erik

._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._._.
E r i k   G u t t m a n         SHORT msgs: [email-masked]
Sr Staff Engineer, Sun Microsystems       Email: [email-masked]
Eichhoelzelstr. 7, 74915 Waibstadt Germany    Phone: +49 172 865 5497