Subject: DIAMETER Base Protocol (Alpha 1) / 2.5.1 Vendor-Name AVP

From: "Bob Kopacz" <[email-masked]>
Date: Thu, 11 Jan 2001 17:15:57 -0500

Hi Pat,

The DRI contains a Vendor-Name AVP, which the draft says
is so that a Diameter peer might "know which vendor
specific attributes may be sent to the peer".

Since it is the 32-bit vendor number that appears in the
AVP header and in the Diameter header, should the DRI
instead include a Vendor-ID AVP which contains the
vendor's enterprise code?  It seems a vendor ID value
would be more directly useful for the above-mentioned
purpose.

Or if the Vendor-Name AVP is the way to go, should there
be a list of vendor name strings so that they can be
mapped to known vendors, and an indication if this string
is case-sensitive, etc.?

The "DIAMETER Base Protocol (Alpha 1)" document says:

> 2.5.1  Vendor-Name AVP
> 
> The Vendor-Name AVP (AVP Code 266) is of type
> OctetString and is used to inform a DIAMETER peer of the
> Vendor Name of the DIAMETER device. This MAY be used in
> order to know which vendor specific attributes may be
> sent to the peer. It is also envisioned that the
> combination of the Vendor-Name and the Firmware-Revision
> (section 2.5.2) AVPs MAY provide very useful debugging
> information.

---

From: Pat Calhoun <[email-masked]>
Date: Thu, 11 Jan 2001 14:17:55 -0800 (PST)

I have no idea why a name was chosen over the IANA managed value. I agree that
using the value that one would find in the Vendor-Id field seems much more
reasonable. I think that the name was added for debugging purpose so users
(that have no idea what IANA, much less enterprise numbers) can figure out
what's at the other end.

What do other prefer? Just the ID, or both?

Thanks for the great catch!

PatC

---

From: David Harrington <[email-masked]>
Date: Mon, 22 Jan 2001 13:12:59 -0500

Hi,

I prefer the use of the enterprise ID. 
It is concise and factual. It should be satisfactual.
Applications can provide the translation to English for those that need
it.

dbh

-- 
---
David Harrington            Network Management Standards Architect
[email-masked]           Office of the CTO
+1 603 337 2614 - voice     Enterasys Networks
+1 603 332 1524 - fax       Rochester NH, USA