Subject: [AAA-WG]: Re: DIAMETER Base Protocol (Alpha 1) - Comments Section 3.0

From: "Martin Julien (ECE)" <[email-masked]>
Date: Mon, 22 Jan 2001 17:46:24 +0100

Pat,

See comments inline.

Martin

> From: Pat Calhoun [mailto:[email-masked]]
> Sent: Monday, January 22, 2001 4:39 PM
>
> > > > Section 3.5.2
> > > > -------------
> > > > What the Resource-Owner-NAI AVP used for in the STR? Is it 
> > > for routing? I
> > > > guess not, since the User-Name AVP is present. Can it be 
> > > used in the server
> > > > for any particular reason I don't see, since I think the 
> > > active session
> > > > should be aware of what's going on within itself, right?
> > > 
> > > If the home server wishes for the NAS to reliquish 
> resources, then the
> > > User-name AVP doesn't really help since it would cause the 
> > > packet to get
> > > routed to the home server (loop). So something is needed for 
> > > the message to
> > > get routed to the NAS, and I envisioned was that the AVP 
> > > would be used for
> > > routing purposes (and eventually get to the NAS).
> > 
> > Then, are you telling me that the message routing can be 
> done using other
> > AVPs than the Routing-Realm AVP and the User-Name AVP? 
> Also, is it really
> > needed in the STR, which is sent from the access device to 
> the Home AAA?
> 
> In the STR no, only in the STI. Can anyone think of a better 
> mechanism? I
> really don't know of a better way to do this.

Shouldn't we use the Routing-Realm AVP in order to reach the access device? Then, would you obsolete the Resource-Owner-NAI AVP, or do you see any further need for it? 

My understanding was that the Routing-Realm AVP was the destination of the message, as it is routed through the network, and the Host-Name AVP the originator of the message, which should never change during the message transit to its final destination. However, what could cause problems is the fact that some proxies might modify the Routing-Realm AVP in transit, right?

---

From: Pat Calhoun <[email-masked]>
Date: Mon, 22 Jan 2001 09:10:46 -0800 (PST)

> Shouldn't we use the Routing-Realm AVP in order to reach the access device?
> Then, would you obsolete the Resource-Owner-NAI AVP, or do you see any
> further need for it? 
> 
> My understanding was that the Routing-Realm AVP was the destination of the
> message, as it is routed through the network, and the Host-Name AVP the
> originator of the message, which should never change during the message
> transit to its final destination. However, what could cause problems is the
> fact that some proxies might modify the Routing-Realm AVP in transit, right?

I didn't think that Routing-Realm would pin point a particular NAS, but rather
the domain that it happens to be in. Isn't this your understanding as well?

PatC