Subject: Comment on DIAMETER Base Protocol / Port 1812

From: "Bob Kopacz" <[email-masked]>
Date: Thu, 18 Jan 2001 16:48:59 -0500

Hi Pat,

The Diameter base drafts say: 

   "The base DIAMETER protocol is run over SCTP [26] port 1812."

I'm not sure 1812 is a given; the draft might better say 

   "The base DIAMETER protocol is run over SCTP [26] port [TBD]."

Discussion:
-----------
IANA's "well known port numbers" currently assign port 1812 
to RADIUS/UDP and RADIUS/TCP.  Specifically, IANA's entry
for port 1812 is:

> Port Assignments:
>
> Keyword         Decimal    Description    Refrences
> -------         -------    -----------    ---------                  
> [...]
> radius          1812/tcp    RADIUS        Carl Rigney <cdr@...>
> radius          1812/udp    RADIUS        Carl Rigney <cdr@...>

When I look over IANA's other assigned ports, it seems their 
consistent notion is that the port is associated with exactly 
one application.  So assigning 1812 to both Radius and Diameter 
would result in the unusual:

> Port Assignments:
>
> Keyword         Decimal    Description    Refrences
> -------         -------    -----------    ---------                  
> [...]
> radius          1812/tcp    RADIUS        Carl Rigney <cdr@...>
> radius          1812/udp    RADIUS        Carl Rigney <cdr@...>
> diameter        1812/tcp    DIAMETER      Pat Calhoun <...>
> diameter        1812/sctp   DIAMETER      Pat Calhoun <...>
> #                           

So I'm guessing that Diameter would end up with a brand new port
number (and that PCC will be eliminated).

--------------------------------------------------------------
Bob Kopacz                mailto:[email-masked]
Interlink Networks, Inc.  http://www.interlinknetworks.com
[Tel] 734-821-1230

---

From: Pat Calhoun <[email-masked]>
Date: Thu, 18 Jan 2001 15:13:57 -0800

>   "The base DIAMETER protocol is run over SCTP [26] port [TBD]."

Until I do get a port number, you are correct. However, a port number needs
to be specified at the moment for interoperability.

>would result in the unusual:

I am not sure this is correct, but I must admit that having port 1812 for
TCP reserved for RADIUS is very odd. I seriously doubt that IANA would
allow such waste to occur. Perhaps this is an error, and I will look into
this.

>number (and that PCC will be eliminated).

Yes, the PCC will be eliminated (in fact, I thought I had in -18).

PatC