Subject: [AAA-WG]: Few comments on draft-ietf-aaa-diameter-mobileip-02.txt

From: "Martin Julien (ECE)" <[email-masked]>
Date: Wed, 11 Apr 2001 18:24:56 +0200

Hi,

Section 1.3, page 7: At the end of the first paragraph, it should be mentionned that the AAAF is responsible for allocating a HA.

page 8: "If a Home Agent was specified, and it belongs to a different domain than the Foreign Agent in the MIP-Previous-FA-FQDN AVP, the AAAH MUST verify whether it will permit this type of the service to the Mobile Node."

I still do not understand that.
It is the text, which suggests that the AAAH MUST verify whether or
not it will allow a HA to be kept in a Foreign Network different
than the actual FA, only if the MIP-Previous-FA-FQDN AVP and 
MIP-Home-Agent-Address AVP are in different domains. Since both
entities will most probably be from the same domain (in the case where
the FA and HA are in the foreign domain, which is recommended for route
optimization), then no check should be performed, according to your text, right? 
I guess that it is not what you really wanted to express, but rather when an AAAH
receives a MIP-Previous-FA-FQDN AVP, the AAAH deduces that the MN
has moved to a new domain, and then must check if a 
MIP-Home-Agent-Address AVP was present in that same network, in which case
it must take a decision whether or not to allow the HA to be used.

Page 9: "...the optional KDC session keys to the AAAF in foreign network 1."

I think that line does not fit in the text.

Page 9: "If the old Foreign Network does not permit the use of its Home Agent
   when the Mobile Node moves to a new foreign network, the Mobile Node
   MAY allocate a new Home Agent in its current network, as described
   above."

First, I guess it should say "...the AAAH or the AAAF MAY allocate..."

Second, what does it imply exactly? If the MN changes HA, then it means that it will also change Home address??? Does it make any sense to support that?

Section 2.1: To the list of information extracted from the Registration messages, maybe we should also add the MN-HA Key Request and the MN-FA Key Request?

It should also be mentionned that of the Home Agent Address is 0.0.0.0 or 255.255.255.255, then the corresponding AVP must not be present.

In the message, the Session-ID should be in < >. I guess the Destination-FQDN should be {}. The Integrity-Check AVP should be removed from all the messages in the document.

Section 2.2: "A successful AMA message MUST include the MIP-Home-Agent-Address AVP."

The MIP-Home-Mobile-Node-Address AVP and MIP-Reg-Reply AVP as well.

Section 2.3: "If the Home Agent is to be assigned in a foreign network, the HAR is issued by AAAF."

I guess it should be "...the HAR is issued by the AAAH and forwared by the AAAF."

That's it for now.
Martin

---

From: Patrice Calhoun <[email-masked]>
Date: Thu, 26 Apr 2001 12:56:09 -0700 (PDT)

> Hi,
> 
> Section 1.3, page 7: At the end of the first paragraph, it should be
> mentionned that the AAAF is responsible for allocating a HA.

ok.

> 
> page 8: "If a Home Agent was specified, and it belongs to a different domain
> than the Foreign Agent in the MIP-Previous-FA-FQDN AVP, the AAAH MUST verify
> whether it will permit this type of the service to the Mobile Node."
> 
> optimization), then no check should be performed, according to your text,
> right?  I guess that it is not what you really wanted to express, but rather
> when an AAAH receives a MIP-Previous-FA-FQDN AVP, the AAAH deduces that the
> MN has moved to a new domain, and then must check if a 

ok, the new text reads:

"... If a AAAH deduces that the Mobile Node has moved to a new domain, it must 
check whether the Mobile can still use the previously assigned Home Agent."

> I think that line does not fit in the text.

Right, it now reads:

"If the Mobile Node is allowed to keep the Home Agent the AAAH then sends
a HAR, which contains the Mobile IP Registration Request message data
encapsulated in the MIP-Reg-Request AVP and the MIP-Home-Agent-Address AVP
with Home Agent address, as well as any optional KDC session keys,
to the AAAF in foreign network 1."

> Second, what does it imply exactly? If the MN changes HA, then it means that
> it will also change Home address??? Does it make any sense to support that?

Yup, this is broken. An error must be sent back to the mobile, and it would
have to re-register, and request a new home agent.

Here is the new proposed text:

"If the old Foreign Network does not permit the use of its Home Agent
when the Mobile Node moves to a new foreign network, the AAAH or AAAF
MUST return an AMA with the Result-Code AVP set to
DIAMETER_ERROR_HA_NOT_AVAILABLE. Upon receipt of this error, the Foreign
Agent MUST issue a Mobile IP Registration Reply to the Mobile Node with
an appropriate error. The Mobile Node MAY attempt to request that a new
Home Agent and Address be allocated. When the AAAH transmits such an
error, it MUST issue a Diameter Session-Termination-Indication message
to the AAAF overseeing the Home Agent to enable it to release any resources."

> 
> Section 2.1: To the list of information extracted from the Registration
> messages, maybe we should also add the MN-HA Key Request and the MN-FA Key
> Request?

correct.

> 
> It should also be mentionned that of the Home Agent Address is 0.0.0.0 or
> 255.255.255.255, then the corresponding AVP must not be present.

done.

> 
> In the message, the Session-ID should be in < >. 
yes.

> I guess the
> Destination-FQDN should be {}. 
no, but it should be [], as it is optional.

> The Integrity-Check AVP should be removed
> from all the messages in the document.
right.

> The MIP-Home-Mobile-Node-Address AVP and MIP-Reg-Reply AVP as well.

Correct.

> I guess it should be "...the HAR is issued by the AAAH and forwared by the

check.

Thanks for the input!

PatC