Subject: RE: [AAA-WG]: Base Session State Machine

From: Patrice Calhoun <[email-masked]>
Date: Tue, 3 Apr 2001 08:25:05 -0700 (PDT)

> will you clarify that in the session state machine.
> 
> current version:
> Discon    STR Received                   Discon.    Closed
>                                          user/device
> 
> Suggestion:
> Discon    STR Received                   Discon.    Closed
>                                          user/device
>                                          Send STA

Actually, the correct state is the following (Disc. user/device was a cut and
paste error):

Discon    STR Received                   Send STA   Closed

PatC

---

From: "Fredrik Johansson" <[email-masked]>
Date: Tue, 3 Apr 2001 17:08:06 +0200

>
>> 1. I guess that this state applies to Session-Timeout Expires on
>FA as well.
>>
>>       Open      Session-Timeout Expires on     send STR   Discon
>>                 NAS
>> Suggestion:
>> 	Open	    Session-Timeout Expires on	send STR	Discon
>> 		    access device
>
>I guess my NAS biases are now coming out :)
>
>I have changed NAS to Access Device.

Great :-)

>
>> 2. Is there a possible raise condition if the Session-Timeout in
>the NAS/FA
>> and the Session-Timeout in the home AAA server expires at the
>same time? The
>> AAA server will send a STI and go to disconnected when it
>receives the STR
>> from the NAS/FA it will disconnect and go to closed but it will
>never send a
>> STA, thus the NAS/FA will never receive a STA and will never go
>to closed.
>> Or is the STR only sent in response to a STI?
>
>If an STI is received, and STR MUST be sent. Therefore, the race condition
>here doesn't exist since the STR will be received. Furthermore, an STR MUST
>generate an STA, so again, no problem.
>

current version:

Suggestion:

/Fredrik

>> /Fredrik