Subject: RE: [AAA-WG]: New API Draft -- Initial impression

From: Cain Brian-BCAIN1 <[email-masked]>
Date: Tue, 17 Apr 2001 17:54:24 -0500

Initial impression from a quick skim through the new draft.

> -----Original Message-----
> From: James Kempf [mailto:[email-masked]]
> Subject: [AAA-WG]: New API Draft
> 
> ...
> 
> One thing that came up while I was doing the Java API is that Java
> has no way to represent Unsigned64 or Float128. What I've done is 
> define classes that identify these types as having been sent
> on the wire, but simply pass through to Long and Double, respectively.
> This means that it will not be possible to get an unsigned long
> and that any floats over 64 bits will be flagged as errors, even
> though they were sent as Float128. An alternative definition would
> use BigInt and Decimal, which don't work like the normal numerical
> types but do allow arbitrary precision numbers.

BigInteger and BigDecimal, for sure.  Worst case I can see that would result
is some additional overhead, and as a software developer, I count on Moore's
Law to crank out several more clock cycles by the time there's a finished
product.

~~~~~~~~
From AAACommandDescriptor:
>4.3.4.3 Fields
>
>   The following fields indicate the kind of command, and correspond to
>   flag settings described in Section 3.0 of [1]:
>
-      static public byte INDICATION = 0
+      public static final byte INDICATION = 0
-      static public byte REQUEST    = 1
+      public static final byte REQUEST    = 0x04
-      static public byte ANSWER     = 2
+      public static final byte ANSWER     = 0x01
-      static public byte QUERY      = 3
+      public static final byte QUERY      = 0x06
-      static public byte REPLY      = 4
+      public static final byte REPLY      = 0x03

Changed to directly correspond to Section 3.0.  I'm not opposed to using an
enumeration, but if it stays I think there should be a slight adjustment to
the wording of "correspond to flag settings...", because this enumeration
really only corresponds to the names of the flags, not their values.  I
can't see which method in AAACommandDescriptor would use these, though.  How
about this addition to 4.3.4.4?

>4.3.4.4 Instance Methods
>
>      public String getName()
>
>   Return the command's name.
+
+     public byte getCommandType()
+
+   Returns the command's type (one of INDICATION, REQUEST, ANSWER, QUERY,
REPLY defined above).
+

From AVPDescriptor (4.3.3.5):
-      public boolean isEndToEndEncrypted()
+      public boolean isEndToEndEncryptable()
-   Return true if this AVP is encrypted end-to-end.
+   Returns true if this AVP is encrypted end-to-end.

---

From: James Kempf <[email-masked]>
Date: Tue, 17 Apr 2001 16:20:22 -0700 (PDT)

OK, thanx Brian. I will fold your comments into the next draft.

		jak
		
>From: Cain Brian-BCAIN1 <[email-masked]>
>To: "'James Kempf'" <[email-masked]>, [email-masked]
>Subject: RE: [AAA-WG]: New API Draft -- Initial impression
>Date: Tue, 17 Apr 2001 17:54:24 -0500
>