Subject: RE: [AAA-WG]: Comments on draft-ietf-aaa-diameter-mobileip-02.txt

From: Patrice Calhoun <[email-masked]>
Date: Thu, 26 Apr 2001 13:31:13 -0700 (PDT)

> Patrice Calhoun wrote:
> 
> > > > The AMA message is missing AVPs Destination-Realm AVP and
> Destination-FQDN
> > > > AVP.  These have to be atleast optional in the AMA message.
> > > > If Destination-Realm AVP is not present in the AMA, how would the
> message be
> > > > routed back to the AAAF from AAAH.
> 
> > You use the Route-Record and not on the Destination-Realm AVP to route the
> AMA
> > back from the AAAH to the AAAF. So why should the Destination-Realm AVP be
> present
> > in the AMA?!
> I am not sure what happens to Route-Record AVP, if the AMR travels through
> multiple proxy servers.  I think having Destination-Realm AVP and
> Destination-FQDN are cleanest way to do it.

The base protocol is pretty clear in that responses and answers are proxied
using the Route-Record AVP, not the Destination-Realm AVP.

PatC

---

From: "Rambabu Tummala" <[email-masked]>
Date: Thu, 26 Apr 2001 14:28:27 -0500

Tony and Pat,

Comments below.

Rambabu Tummala
Nortel Networks
ESN 444-8970
External (972)684-8970

-----Original Message-----
From: Tony Johansson [mailto:[email-masked]]
Sent: Thursday, April 26, 2001 12:51 PM
To: Patrice Calhoun
Cc: Tummala, Rambabu [RICH1:IP35:EXCH]; [email-masked]
Subject: Re: [AAA-WG]: Comments on
draft-ietf-aaa-diameter-mobileip-02.txt

Hi Pat and Rambabu,

Please see comments embedded...

BR,

/Tony

Destination-FQDN
message be

AMA
present
>
> > > If Destination-FQDN AVP is present, the message can easily delivered
to the
> > > originating FA by AAAF.
> > > AAAH has the information from the AMR message it received.

> I agree.

>
> >
> > The same comments apply to HAA also.
>
> You are correct. Furthermore, the Destination-FQDN MUST also be optional
in
> the HAR, since the HAR may be directed at a particular Home Agent.

Good point.  I agree with you.

> I don't understand. Why do we need Destination-FQDN in the HAR message?

If the home agent is allocated in the visiting network, you are trying to
send HAR to a particular HA.