Subject: RE: [AAA-WG]: AAA WG Interim meeting dates

From: Patrice Calhoun <[email-masked]>
Date: Mon, 2 Apr 2001 10:53:24 -0700 (PDT)

I can make those dates, but I question whether the meeting is simply too far
off. We need to get these documents through WG last call as soon as possible.
I expect to have -02 by the end of the week. At that point, features are
frozen, but I am not sure that I will have received the updated state machine.

So if I do have the new state machine, I would propose a WG last call. A
future meeting could still be held, but only as a document reading party, and
changes would be limited to bug fixing, and grammar.

Having said that, I believe that having the interim meeting in a month an a
half is simply too far off :(

PatC
> As Bert Wijnen has recently noted, NANOG 22 and 
> OPS-NM Interim will be in Scottsdale Arizona, USA, 
> in the Doubltree Paradise Valley, as follows:
> 
>   May 20-22   NANOG 22, ends around 3pm on 22nd
> 
>   May 22-23  OPS-NM Interim, starts on 22nd 4pm 
>                     So we plan to meet 4-6pm, 8-10pm on 22nd
>                     9-1pm 23rd possibly 2-4pm 23rd too.
> 
> 
> It has been suggested that we might consider having the
> AAA Interim meeting at the same location, scheduled
> on May 18-19, 2001. 
> 
> How would this work?
>

---

From: Jonathan Trostle <[email-masked]>
Date: Mon, 02 Apr 2001 09:56:20 -0700

Probably can't make that date.

Jonathan

---

From: "Bernard Aboba" <[email-masked]>
Date: Mon, 2 Apr 2001 10:33:27 -0700

How would this work?

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 3 Apr 2001 03:53:24 -0700

Didn't get the original of this...

> >AAA Interim meeting at the same location, scheduled

I can't make the 18th and Outlook tells me the 18th is a Saturday :-(

---

From: Patrice Calhoun <[email-masked]>
Date: Tue, 3 Apr 2001 06:32:11 -0700 (PDT)

> I can't make the 18th and Outlook tells me the 18th is a Saturday :-(

No, it's a Friday, but the 19th *is* a Saturday. Perhaps trying to squeeze in
that week isn't really worth it. Could we please go back to the original dates
(and place)?

PatC

---

From: Jonathan Trostle <[email-masked]>
Date: Tue, 03 Apr 2001 13:00:18 -0700

Can't go to Scottsdale AZ on May 18th.

Jonathan

---

From: "Bernard Aboba" <[email-masked]>
Date: Wed, 4 Apr 2001 09:13:56 -0700

Unfortunately, the original dates (Monday, April 30 and Tuesday,
May 1, 2001) are no longer within the 30 day window.

May 5-11 is Networld+Interop. So unless people are up for meeting in Las
Vegas the weekend of May 12-13 the earliest we could do it would be the
week of May 14.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf
Of Patrice Calhoun
Sent: Tuesday, April 03, 2001 6:32 AM
To: [email-masked]
Cc: Jonathan Trostle; Bernard Aboba; Aaa-Wg@Merit. Edu
Subject: RE: [AAA-WG]: AAA WG Interim meeting dates

> I can't make the 18th and Outlook tells me the 18th is a Saturday :-(

No, it's a Friday, but the 19th *is* a Saturday. Perhaps trying to squeeze
in
that week isn't really worth it. Could we please go back to the original
dates
(and place)?

PatC

---

From: Patrice Calhoun <[email-masked]>
Date: Wed, 4 Apr 2001 09:15:27 -0700 (PDT)

Weekend meetings are out for me (sorry, but I travel too much, and weekends I
want to be home). The very fact that we lingered for so long is quite
upsetting. People claimed they could do May 3rd, and that was WELL within the
window when people sent those e-mails. Week of May 14th will work for me too,
but let's get this thing setup so we don't have to move it out further.

PatC

---

From: Randy Bush <[email-masked]>
Date: Wed, 04 Apr 2001 10:55:02 -0700

> At this point, I would propose May 14-15, San Francisco Bay Area.

monday i am flying back from ghana.  sorry.

randy

---

From: "Bernard Aboba" <[email-masked]>
Date: Wed, 4 Apr 2001 10:46:49 -0700

>but let's get this thing setup so we don't have to move it out further.

There were quite a few people who could not make the earlier date (including
our AD), so it wasn't just a matter of letting it slip.

At this point, I would propose May 14-15, San Francisco Bay Area. This is
a Monday & Tuesday (avoids weekends).

What do people think?

---

From: Patrice Calhoun <[email-masked]>
Date: Wed, 4 Apr 2001 12:22:40 -0700 (PDT)

That works for me.

PatC

---

From: Randy Bush <[email-masked]>
Date: Wed, 04 Apr 2001 12:48:39 -0700

> ok, here is a question. Do we need the AD for the first day of a document
> reading party??

no

---

From: Tony Johansson <[email-masked]>
Date: Wed, 04 Apr 2001 14:01:56 -0700

That works for me.

/Tony

---

From: Randy Bush <[email-masked]>
Date: Wed, 04 Apr 2001 14:54:34 -0700

> ok, here is a question. Do we need the AD for the first day of a document

but i think the aaa wg needs to do a LOT more than review docs to get this
out the door.

---

From: John Schnizlein <[email-masked]>
Date: Wed, 04 Apr 2001 18:49:49 -0400

Maybe the number of issues is not as important as their toughness.
I found the security reaction in Minneapolis clear and tough:
proxies and security don't mix. Since forwarding AAA has been one
of the spectacular successes in functionality for RADIUS, this seems
to be a big issue. We worried about details of hop-by-hop versus
end-to-end, but it seems we have not cracked the nut that Steve
Bellovin laid on the table when persuaded to speak.

John

At 06:08 PM 4/4/2001, Patrice Calhoun wrote:
>If that's the case, then I would appreciate a list of issues. So far, there
>don't seem to be many (modulo the two of three on the list at the moment).
>
>PatC

---

From: Michael Chen <[email-masked]>
Date: Wed, 04 Apr 2001 13:50:22 -0700

In Base Protocol session 12.1 Figure 2
Why do we need Destination-Realm AVP in the REPLY message?
The REPLY message Must follow the Route-Records to route the Reply message,
isn't it?
In 12.4.7
"When present, the Destination-Realm AVP is used to perform message routing
decisions"
So how does AAA  route the message if we have BOTH Route-Record and
Destination-Ream AVPs?

-Michael

---

From: Patrice Calhoun <[email-masked]>
Date: Wed, 4 Apr 2001 15:59:58 -0700 (PDT)

umm.... are we meeting to redesign how AAA currently works in networks, hence
how a new protocol could be designed? Or do we have to live with what people
run in their networks?

What is needed is to get the specs out. I am not sure that meeting for two
days would convince Steve B. that proxies are good, nor could we convince
ourselves that the world will change tomorrow and proxies will go away.

PatC
> >> > ok, here is a question. Do we need the AD for the first day of a
> document >> > reading party??
> >> 
> >> out the door. >

---

From: Patrice Calhoun <[email-masked]>
Date: Wed, 4 Apr 2001 16:41:33 -0700 (PDT)

> So how does AAA  route the message if we have BOTH Route-Record and

You are absolutely correct. The Destination-Realm AVP MUST NOT be present in
*-Reply or *-Answer messages. I will update the -02 candidate.

Thanks for the catch (and I still owe you a response to your other question),

PatC

---

From: Patrice Calhoun <[email-masked]>
Date: Wed, 4 Apr 2001 15:08:39 -0700 (PDT)

PatC

---

From: Patrice Calhoun <[email-masked]>
Date: Wed, 4 Apr 2001 12:23:48 -0700 (PDT)

PatC

---

From: Randy Bush <[email-masked]>
Date: Wed, 04 Apr 2001 22:03:37 -0700

> ourselves that the world will change tomorrow and proxies will go away.

two days?  who says two days.  we're locking you in a room with nothing
but pizza and jolt until you come up with a solution that has reasonable
security and, if you insist, proxies.

kidding about jolt and pizza, would not do that to even a jim flemming.
but not kidding about security and proxies.

randy

---

From: "Glen Zorn" <[email-masked]>
Date: Wed, 4 Apr 2001 23:04:53 -0700

Bernard Aboba [mailto:[email-masked]] writes:

> >Weekend meetings are out for me (sorry, but I travel too much,
> and weekends
> I

Those dates are out for me.

---

From: "Glen Zorn" <[email-masked]>
Date: Thu, 5 Apr 2001 00:11:45 -0700

> Vegas the weekend of May 12-13 the earliest we could do it would be the

How many people go to N+I (out of the group that would participate in the
interim meeting)?  Of course, I don't think I can make May 5-11 anyway...

---

From: "Fredrik Johansson" <[email-masked]>
Date: Thu, 5 Apr 2001 09:32:50 +0200

14-15 works for me

/Fredrik

>Of Tony Johansson
>Sent: den 4 april 2001 23:02
>To: Bernard Aboba
>Cc: Aaa-Wg@Merit. Edu
>Subject: Re: [AAA-WG]: AAA WG Interim meeting dates
>
>
>That works for me.
>
>/Tony
>
>Bernard Aboba wrote:
>
>> >upsetting. People claimed they could do May 3rd, and that was
>WELL within
>> the

---

From: Jonathan Trostle <[email-masked]>
Date: Thu, 05 Apr 2001 17:29:58 -0700

I can probably make this date (or at least part of the meeting on these dates).

Jonathan

---

From: Michael Chen <[email-masked]>
Date: Tue, 10 Apr 2001 15:39:47 -0700

In base protocol 12.4.1
  "A Diameter server that proxies a message or type Request, Query or
   Indication MUST append a Route-Record AVP, which includes its
   identity.  Diameter Servers that receive messages MUST validate the
   last Route-Record AVP in the message and ensure that the host
   identified in the AVP is the same as the sender of the message."

My suggestin to add text, something like this:
The FIRST creater(AAA3 in my example) of an Indication Message MUST remove all
the Route-Rrecord AVPs before return to the sender of the request to avoid LOOP
DETECTION.
If it's correct, the Indication might not send the same route back as the request
message.
Well, if it's very obvious, just ignore this email.

Here is an example

 AAA1(a.com) AAA2(b.com)  AAA3(c.com)   AAA4(d.com)
----------  -----------  -----------   ------------

     ----------->
     route-record=aaa1.a.com

                 ------------->
                 route-record=aaa1.a.com
                 route-record=aaa2.b.com

                               -----link broken---

                 <-------------
                 route-record=aaa3.c.com
     <-------------
     route-record=aaa3.c.com
     route-record=aaa2.b.com

---

From: Michael Chen <[email-masked]>
Date: Tue, 10 Apr 2001 17:55:10 -0700

In base protocol section 5.0

"When a Diameter entity receives a Diameter message of type Request,
   Query or Indication that includes a Destination-FQDN AVP, and the
   host specified in the AVP can be contacted directly, the message MUST

   be forwarded to the host in question. ..........."

As I know, there is NO Destination-FQDN AVP in the "Request" or "Query"
Message.
So I don't understand what you are trying to say. Am I missing something
here?