Subject: [AAA-WG]: IANA considerations

From: Jari Arkko <[email-masked]>
Date: Wed, 18 Apr 2001 13:38:50 +0300

I just read the IANA considerations section of the
base protocol. It seems OK, but there is one part
that worries me: currently, we allow new extension
IDs for only services that are _Standards Track RFCs_.
Given that the extension number space is 32 bits
wide, and that various new services might pop up
that require specific new functionality in the
form of an extension, why are we requiring this
much? Wouldn't allocation through Designated
Expert be sufficient? Or do we expect all new services
stay solely within the business of adding new AVPs?

Also, I'm not sure I understand the purpose of
the Diameter shall not be extended - statement
in 17.3. Surely we can imagine situations that
even Diameter base protocol will be extended.
Hopefully not soon, but we have even reserved
mechanisms for this in the form of version numbers
in the header etc.

Jari

---

From: Patrice Calhoun <[email-masked]>
Date: Thu, 26 Apr 2001 10:32:35 -0700 (PDT)

> stay solely within the business of adding new AVPs?

You are correct, and it has been changed to Designated Expert.

> mechanisms for this in the form of version numbers

The text was intended to state that if someone wants to create an extension,
the only limitation is that it must not break (or require modificaitons) to
the base protocol).

This was intended to limit the applicability of Diameter. Otherwise, it could
be used as a floor wax and desert topping :)

PatC