Subject: [AAA-WG]: Christian's comments

From: Patrice Calhoun <[email-masked]>
Date: Fri, 6 Apr 2001 14:37:30 -0700 (PDT)

Sorry for the latency.

Comments below

> I have a somewhat fundamental issue with the Diameter. Why is the IETF
> trying to invent yet another marshalling protocol, instead of using
> existing technologies such as XML or ASN.1? Radius made some sense,
> because it was very well scoped and very limited in complexity. The
> Diameter specification is much more ambitious than Radius; it attempts
> to define a fully capable marshalling protocol, using the RFC process
> and the IANA as a substitute for an interface definition language. If I
> am developing a specific application protocol, why should I base it on
> Diameter rather than ASN.1 or XML?

I understand that you were probably not following the WG's mailing list when
the protocol evaluation was under way, but there were plenty of binary vs.
ascii protocol wars at that time, and Diameter came out as the preferred
protocol.

I see now reason to re-open that can of worms.

> 
> The answer to that specific issue will probably be given by the market.
> If the application developers are not convinced by Diameter, they will
> probably simply use something else. 

correct.

> In any case, there are quite a few
> detailed problems in the specification.
> 
> 1) Mandatory use of SLP or SLPv2 for "Diameter service discovery"
> 
> This creates a dependency on SLP for very little benefit, and possibly
> some harmful consequences. Diameter is primarily meant to be used for
> AAA applications; these applications require some tight control; in
> practice, that control requires some form of explicit parametrization of
> the device. The DNS SRV mechanism already provides a layer of
> indirection between the name of the server and its actual
> implementation; there is no need for an additional mechanism. In any
> case, the decision to use a local discovery mechanism rather than a
> configuration mechanism belongs in the application documents, not in the
> base spec.

Note that SLP is only recommended as one of the server discovery approaches,
and only for intra-domain cases. If the WG feels that the use of SLP as a
service location protocol is innapropriate for AAA, we can make the necessary
changes.

> 
> 2) AVP header format
> 
> As specified, it seems impossible to encode an attribute in less than 96
> bits. This is way less efficient than Radius. This seems particularly
> ill-suited to mobile applications, in which bandwidth is at a premium.

only over the air, and Diameter *never* gets sent over the air. BTW, one of
the reasons for NOT using a text-based approach was for bloat :)

> Having a 64 header per attribute means that in most practical
> applications there will not be any advantage to using the binary format
> of Diameter compared to more modern technologies such as XML; there will
> also be no particular advantage compared to classic technologies such as
> ASN.1/BER. If that is the case, why bother with Diameter at all?

Again, see the archives. RADIUS compatibility (or interoperability) was also
ranked very high as a pritority, so we decided to maintain the RADIUS
philosophy.

> 
> Why do we believe that we need 32 bits to encode attribute types? It is
> certainly possible to encode the combination of length, flags and
> attribute type in a single 32 bit word, at least in the common case of
> attribute length lower than 255. 
Been there, done that in RADIUS, and 255 is way too restrictive. 

Again, I'd like to hear why the backbone is so contrained that the header
sizes will cause problems.

> A format like the following would
> feature the same amount of information in half the space, still allowing
> for more attribute types than the IANA can possibly handle; if the
> length is larger than 254, the AVP length is set to 255 and an optional
> length field is added. Four bits are reserved for type indication,
> discussed later.
> 
>        0                   1                   2                   3
>        0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
>       +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
>       |           AVP Code            |P|V|M|r|t t t t|  AVP Length   |
>       +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
>       |                 Extended length (optional)                    |
>       +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
>       |                        Vendor-ID (opt)                        |
>       +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
>       |    Data ...
>       +-+-+-+-+-+-+-+-+

I don't particularly like the fact that I need to look for an 8-bit length, to
find out that I have a 32-bit length. If the WG decides this is a valuable
approach, I will listen.

> 3) AVP Data Formats
> 
> In the spec, the data format is determined by the value of the AVP code.
> This has an operational consequence: it becomes impossible to write a
> monitoring utility or a logging utility without having a complete
> dictionary. I suggest sticking a 4 bit "data type" field as a complement
> to the AVP code
> 
>       1 - OctetString
>       2 - Address
>       3 - Integer32
>       4 - Integer64
>       5 - Unsigned32
>       6 - Unsigned64
>       7 - Float32
>       8 - Float64
>       9 - Float128
>      10 - Grouped

I don't have a particular problem with this proposal. What does the rest of
the WG think?

> By the way, it would probably be very practical to defined a "boolean"
> type, of code zero, to encode a basic protocol flag.

The SMIng folks didn't seem to think that boolean is a valuable type, so I
will let them speak for this one.

> 
> 4) Grouped attributes
> 
> In the case of the "grouped" attribute, we have a real problem of type
> definition. Shall we require that all AVP codes in the group are present
> in the dictionary, or can they be simply defined in the context of the
> group? The latter does provide for much more flexibility, and is in line
> with the practice of ASN.1 or XML.
> 
> Both ASN.1 and XML Schema Language provide way to define the structure
> of grouping: order list, unordered set, array of elements. How do we do
> this in Diameter?
> 
> Adding two categories for "XML text" and "ASN.1 BER" would actually make
> a lot of sense.

see archives.

> 
> 5) Device-Reboot-Ind (DRI) Command
> 
> Having a mandatory Vendor-ID in the command creates a barrier to entry
> for implementors: it requires that they first register with the IANA.
> This should be optional. There is no reason to mandate the presence of a
> vendor-id if no vendor extensions are used, a case which we hope should
> be quite common.

This was a concern at the bake-off, and we had proposed to make a change that
would not require IANA registration. However, members of the WG opposed that
idea as the process to get the vendor id is apparently painless.

> 
> 6)  Extension-Id AVP in DRI command
> 
> The presence of an extension-id AVP is symptomatic of an unsolved
> dilemma in the Diameter sprecification. Is Diameter a protocol framework
> or a service specification? If it is a protocol framework, then the
> extension is in fact the service; which server to use and which port
> number to connect to will be determined by this service; negotiating the
> extension at this point does not make any sense.

I believe that you are proposing the use of multiple ports (one per service)
instead of performing capabilities exchange via the Extension-Id. If this is
the case, I would argue that ports are much more limited than extension-id,
but again I will listen to the WG.

> 
> 7) Host-IP-Address AVP in DRI command
> 
> What does that do in the presence of a NAT?

Historically this was useful for RADIUS servers, so we kept it. However, we
can do away with this AVP if you believe that it isn't necessary. For those
interested, this is used to know the IP address of the NAS. This is NOT used
to send, or validate received packets. It this required when a home domain
contacts an operator about a NAS that may be mis-behaving (or for accounting
purposes).

> 
> 8) and many more issues, but we will need more time...

Looking forward to them.

PatC

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

> Sorry for the latency.

Ditto.

> ascii protocol wars at that time, and Diameter came out as the preferred

In actual point of fact, virtually all of Christian's comments (with the
possible exception of his characterization of Diameter as "yet another
marshalling protocol", possibly because it is _such_ a gross
oversimplification) have been discussed at length and resolved over the last
4 years.

> I see now reason to re-open that can of worms.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>

---

From: "Glen Zorn" <[email-masked]>
Date: Tue, 10 Apr 2001 15:58:53 -0700

Ditto.

Nor any of the others.

<text deleted>