Subject: [AAA-WG]: [#issue 55] Accounting clarifications

From: "Yolanda Garcia-Serrano (ECE)" <[email-masked]>
Date: Fri, 1 Jun 2001 12:00:28 +0200

Hi, Pat
Here I send you an official new issue from something already brought up
in the Mailing-list.

Thanks
	/Yolanda García

-----Original Message-----
From: Jari Arkko [mailto:[email-masked]] 
Sent: Monday, May 28, 2001 9:43 AM
To: Yolanda Garcia-Serrano (ECE)
Cc: [email-masked]'; [email-masked]'
Subject: Re: [AAA-WG]: Accounting clarifications

Replying to an old e-mail on accounting issues, hope this helps:

Yolanda Garcia-Serrano (ECE) wrote:

> 12.5. Accounting-Records
>  What can be exactly an accounted service? Is it an extension (Mobile IP, NASREQ), or is it indicated
> by Service-Type AVP in NASREQ, but in Mobile IP which is the service/s? Could be the text more specific,
> giving some examples?

This was already discussed earlier on the list. In general the service 
could be anything, and the included
AVPs must specify what service was provided. What AVPs are used for this 
specification is
service-specific.

> 14.1 Accounting-Record-Type
> Are EVENT_RECORDs (one-time events) and START-STOP records mutually exclusive for the same
> Session-Id, i.e. if received an event record for sessionId=x.abc.com:8888:1234567890 is/is not possible
> to receive a Start/interim/stop one for same sessionId=x.abc.com:8888:1234567890 ?

I think we should have just one submitted event or start-stop for one 
session-id. There
is definately sometimes a need to correlate several records related to 
the same true
user session. However, at a diameter level this is often not possible. 
Rather, such
coordination should be left up to the postprocessing systems. For 
instance, one box
could be delivering NASREQ data, including the user's IP address while 
another
box might be providing some additional service. Both records would 
contain IP
addresses which would help the postprocessing systems in correlating the 
records
even if they came from two different boxes.

And as you indicate below, there is a need to clarify this text in the 
draft. I propose
that we add a statement to the explanation of the session id AVP that 
prohibits
the submission of several sessions with the same session id, and says 
that the type of
the session must be one of event or start-interim-stop for a particular 
session id.

> 
> Is the type or record (EVENT vs START/INTERIM/STOP) tight to the particular kind of service, so that
> when some services are used, it is reported accounted info of kind EVENT, and when some other services
> are used, it is reported accounted info in the style Start/Interim/Stop ?

This should be dictated by the text appearing in a particular extension 
document.

> 
> Is it possible to send (Diameter client)/receive (Accounting server) several EVENT_RECORD for the same
> Session-Id?
> 
> Same question but for measurable length services: is it possible to send/receive several START-STOP
> sequences for the same Session-Id?

For both, see above.

> 
> For the answer of all these questions, could be added the corresponding clarifying text on the I-D?
> It would be quite helpful.

I agree.

Jari

---

From: Pat Calhoun <[email-masked]>
Date: Fri, 1 Jun 2001 07:07:36 -0700

> Here I send you an official new issue from something already brought up

May I ask that you actually submit the issue in the format that we've been
using, as opposed to having me sift through this e-mail and guess what the
issue should be?

Thanks,

PatC