Subject: [AAA-WG]: MIP-MN-HA-Preferred-SPI in AA-Mobile-Node-Request ?

From: Thomas Panagiotis-PTHOMAS1 <[email-masked]>
Date: Thu, 21 Jun 2001 16:01:24 -0500

Hi Pat,

Shouldn't the AA-Mobile-Node-Request in
draft-ietf-aaa-diameter-mobileip-06.txt
also include a MIP-MN-HA-Preferred-SPI AVP, to be sent to AAAH when the
MN-HA
Key Request From AAA subtype is present in the Registration Request?

"2.1 AA-Mobile-Node-Request
...
    <AA-Mobile-Node-Request> ::= < Diameter Header: 260, REQ, PXY >
                                 < Session-ID >
                                 { Auth-Application-Id }
                                 { User-Name }
                                 { Destination-Realm }
                                 { Origin-Host }
                                 { Origin-Realm }
                                 { MIP-Reg-Request }
                                 { MIP-MN-AAA-Auth }
                                 [ MIP-Mobile-Node-Address ]
                                 [ MIP-Home-Agent-Address ]
                                 [ MIP-Feature-Vector ]
                                 [ Authorization-Lifetime ]
                                 [ MIP-FA-MN-Preferred-SPI ]
                                 [ MIP-FA-HA-Preferred-SPI ]
                                 [ MIP-Previous-FA-Host ]
                                 [ MIP-Previous-FA-Addr ]
                                 [ MIP-FA-Challenge ]
                                 [ Destination-Host ]
                                 [ Origin-State-Id ]
                               * [ AVP ]
                               * [ Proxy-Info ]
                               * [ Route-Record ]                  
..."

-Panos

---

From: Pat Calhoun <[email-masked]>
Date: Fri, 22 Jun 2001 14:16:54 -0700

> Key Request From AAA subtype is present in the Registration Request?
yes, it should, and will in the next revision.

PatC