Subject: Re: [AAA-WG]: Comments on draft-ietf-aaa-transport-03.txt

From: Jonathan Wood <[email-masked]>
Date: Mon, 4 Jun 2001 16:47:45 -0700 (PDT)

> > 
> > Should read "The AAA client SHOULD wait for the transport layer
> > to report connection" success, but MAY chose to bound this wait
> > time by the watchdog interval, Tw."
> > 
> > The intent is to let the transport layer decide when a connection
> > attempt has failed (TCP and SCTP both retransmit and back off
> > connection attempts). However, in some cases, the RTO can
> > grow quite large, which means it may take minutes for the
> > transport to decide that a connection attempt has failed. The
> > second half of the sentence, "but MAY chose ..." gives the
> > AAA layer a way out of this, by limiting the wait time to
> > something more reasonable.
> > 
> > Let me know if you still think it needs fixing.
> s/bound/bind/

Hmm my Websters agrees with 'bound'. How about
s/bound/limit
and be done with it?

---

From: Steve Rich <[email-masked]>
Date: Mon, 4 Jun 2001 21:53:25 -0400

Perhaps, changing to 'limit' can avoid confusion/controversy.

Certainly, though, 'bound' is correct in this context, as 'bounding'
something is very different than 'binding' something...

$0.02,
sjr

---

From: Pat Calhoun <[email-masked]>
Date: Mon, 4 Jun 2001 20:07:39 -0700

> Hmm my Websters agrees with 'bound'. How about
Deal!

PatC

---

From: David Spence <[email-masked]>
Date: Wed, 27 Jun 2001 21:48:19 -0600

> > Hmm my Websters agrees with 'bound'. How about

Argh!  "...bound this wait time by the watchdog interval..." was just fine. 
Now the draft reads  "...limit this wait time by the watchdog interval..". 
I think you bound by, but you limit to.  So the text should read: "...limit
this wait time to the watchdog interval..."

Meanwhile, the real problem with that sentence remains uncorrected:

   s/chose/choose

Sheesh!

-- 
David Spence                            email: [email-masked]
Interlink Networks, Inc.                phone: (734) 821-1203
775 Technology Drive, Suite 200         fax:   (734) 821-1235
Ann Arbor, MI 48108           
U.S.A.

---

From: Bernard Aboba <[email-masked]>
Date: Thu, 28 Jun 2001 22:42:55 -0700 (PDT)

File an issue on this and include the recommended text. 

Anyone else with an issue to file on transport-04, please get them in
ASAP, so I can make the changes by the deadline.