Subject: RE: [AAA-WG]: [issue] Server Identification

From: Cain Brian-BCAIN1 <[email-masked]>
Date: Fri, 1 Jun 2001 15:05:47 -0500

> -----Original Message-----
> From: Pat Calhoun [mailto:[email-masked]]
> On Thu, May 31, 2001 at 04:03:26PM -0400, Mark Eklund wrote:
> > Pat, 
> > 
> > On Thu, 31 May 2001, Pat Calhoun wrote:
> > 
> > > On Wed, May 30, 2001 at 04:38:10PM -0400, Mark Eklund wrote:
> > > > Pat,
> > > > 
> > > > If you had
> > > > 
> > > > If you have a proxy that speaks both radius and diameter and is
> > > > connected to a radius NAS and a Diameter server, could it set
> > > > the NAS identifier as below before proxying to the Diameter
> > > > server?
> > > > 
> > > > radius://nas.legacy.xyz:1813;transport=udp
> > > 
> > > Seems like a good idea for a protocol gateway to do. I guess
> > > that would belong somewhere in the NASREQ spec. I suppose I should
> > > open a separate issue on that one.
> > 
> > Sounds good.  It would also involve the base.  A change
> > something like this would be needed.
> > 
...
>       port               = ":" port

This is the only part I would draw into question, because it looks slightly
unclear.  I know what the intent was, but it looks as if this is a recursive
rule, and it will end up being one or more colons.  

Perhaps I'm nitpicking, but maybe this would be better:

        port               = ":" 1*DIGIT
                           ; A colon followed by the port number
                           ; If absent, the default Diameter port (TBD) is
assumed.
...
> Comments?

Looks good!

---

From: Pat Calhoun <[email-masked]>
Date: Fri, 1 Jun 2001 13:02:56 -0700

>                            ; If absent, the default Diameter port (TBD) is

Perhaps a nit, but I believe you are correct. I will make the change.

PatC