Subject: Re: [AAA-WG]: [issue] Server Identification

From: Pat Calhoun <[email-masked]>
Date: Fri, 1 Jun 2001 12:43:39 -0700

On Thu, May 31, 2001 at 04:03:26PM -0400, Mark Eklund wrote:
> Pat, 
> 
> On Thu, 31 May 2001, Pat Calhoun wrote:
> 
> > On Wed, May 30, 2001 at 04:38:10PM -0400, Mark Eklund wrote:
> > > Pat,
> > > 
> > > If you had
> > > 
> > > If you have a proxy that speaks both radius and diameter and is
> > > connected to a radius NAS and a Diameter server, could it set
> > > the NAS identifier as below before proxying to the Diameter
> > > server?
> > > 
> > > radius://nas.legacy.xyz:1813;transport=udp
> > 
> > Seems like a good idea for a protocol gateway to do. I guess
> > that would belong somewhere in the NASREQ spec. I suppose I should
> > open a separate issue on that one.
> 
> Sounds good.  It would also involve the base.  A change
> something like this would be needed.
> 

Actually, what I've come up with is the following:

2.7  Diameter Identity Encoding

   Several Diameter AVPs are used to include a node's identity, such as
   the Destination-Host, Origin-Host, Route-Record, etc. The contents of
   such AVPs follow the Uniform Resource Identifiers (URI) syntax [47]
   rules specified below:

      Diameter-Identity  = [protocol] fqdn [ port ]
                           [ transport ]

      protocol-name      = ( "diameter" | "radius" | "tacacs+" )

      protocol           = protocol-name "://"
      ; If absent, the default is "diameter://"

      fqdn               = Fully Qualified Host Name

      port               = ":" port
      ; If absent, the default Diameter port (TBD) is assumed.

      transport          = ";transport=" ( "tcp" | "sctp" | "udp")
      ; If absent, the default SCTP [26] protocol is assumed.
      ; UDP is ONLY used when the protocol is set to RADIUS

   The following are examples of valid Diameter host identities:

      host.abc.com:6666;transport=tcp
      diameter://host.abc.com
      diameter://host.abc.com:6666
      diameter://host.abc.com;transport=tcp
      diameter://host.abc.com:6666;transport=tcp
      radius://host.abc.com:1813;transport=udp

Comments?

PatC

---

From: Mark Eklund <[email-masked]>
Date: Fri, 1 Jun 2001 15:59:38 -0400 (EDT)

Pat, 

This looks good.  At first I was concerned about the possibility
that someone comes up with some other protocol, but I'm not too
worded about that.  If they want to use something other than
(tacacs+, diameter, or radius), they can.  They will be in
violation of the RFC, but only the most pedantic will care.  If
a new version of the RFC comes out, they will probably push to
get it added.  No need to document a procedure for everything.

-mark