Subject: [AAA-WG]: [Issue] ABNF editorial changes

From: Jacques Caron <[email-masked]>
Date: Wed, 06 Jun 2001 23:37:52 +0200

Submitter name: Jacques Caron
Submitter email address: [email-masked]
Date first submitted: 06-Jun-2001
Reference: http://www.merit.edu/mail.archives/aaa-wg/msg01150.html
Document: Base
Comment type: E
Priority: 2
Section: 3.2 Command code ABNF specification
Rationale/Explanation of issue:
- "fixed" isn't defined. It seems to mean that it is required, but at a
specific position or in a specific order, but that's really unclear.
- the defaults for min & max in qual are not defined if only one of them is
present (i.e. no qual = 1*1, but what about *n or n*? I guess the latter
means n*infinity, but does *n mean 1*n or 0*n)?
- it says that it describes AVPs which MUST NOT be present, but that's not
part of the ABNF (it's implicit).

Requested change:

[add following text under definition of fixed]
			; defines AVPs the position and order of which is fixed,
			; either at the start or at the AVP list

[add following text under definition of min and associated comments]
			; default is 0

[add following text under definition of max and associated comments]
			; default is infinity

for resolution of the MUST NOT issue, either:
- replace MUST, MAY or MUST NOT by MUST or MAY in first paragraph
- add a specific notation:
forbidden		= "%" avp-spec "%"
- or add text under qual:
			; 0*0 means the AVP is not allowed in this command

_________________________________________________________
Do You Yahoo!?
Get your free @yahoo.com address at http://mail.yahoo.com

---

From: Pat Calhoun <[email-masked]>
Date: Thu, 7 Jun 2001 07:11:25 -0700

> Submitter name: Jacques Caron
[...]

Thanks for the submission. The web page has been updated, and I consider this one
closed since I've already addressed the necessary text which will appear in the
next revision of the draft.

Thanks for your help!

PatC