Subject: [AAA-WG]: Re: AVP code address space

From: Pat Calhoun <[email-masked]>
Date: Mon, 4 Jun 2001 10:00:20 -0700

On Mon, Jun 04, 2001 at 07:04:20PM +0200, Yolanda Garcia-Serrano (ECE) wrote:
> 
> So here comes the doubt, and is regarding *uniquely* under AVP Code paragraph: could the same AVP code (lets say 501) exist with different meaning for vendor Id=123456 and vendor Id=987654? In other words, the unique key that identifies an AVP is vendorId + AVP Code or just
> AVP Code?

You are correct. The Vendor-Id is used to identify the AVP Code namespace. The absence of 
the Vendor Id implies that it is zero (0), which is the IETF standards namespace. There
is more explanation in the IANA considerations section 15.1.1:

"the AVP Code namespace is used to identify attributes. When the Vendor ID
value is set to zero (0), IANA will maintain a registry of assigned AVP
codes, and in some cases also their values. AVP Codes 0-254 are
managed separately as RADIUS Attribute Types [46], while the remaining
namespace is available for assignment via Specification Required [12].

Vendor-Specific AVP Codes, where the Vendor-Id field in the AVP header
is set to a non-zero value, is for Private Use."

PatC

---

From: "Yolanda Garcia-Serrano (ECE)" <[email-masked]>
Date: Mon, 4 Jun 2001 19:04:20 +0200

Hi, Pat and others:

I have a question on how the address to define AVP codes works for different vendor
ids. The I-D says:

--------------------------------------------------------------------------------------------------------------
4.1 
  AVP Code
      The AVP Code identifies the attribute uniquely.
	...
  The 'V' bit, ...... When set the AVP Code belongs to the specific vendor code address
      space.

4.2  
   Vendor-Id
     Any vendor wishing to implement a Diameter extension MUST use their own Vendor-ID 
      along with their privately managed AVP address space, guaranteeing that
      they will not collide with any other vendor's extensions, nor with
      future IETF extensions.
--------------------------------------------------------------------------------------------------------------

Thanks in advance for your answer
BR
	/Yolanda Garcia