Subject: [AAA-WG]: [Issue] Server-initiated re-auth

From: Pat Calhoun <[email-masked]>
Date: Fri, 1 Jun 2001 12:04:45 -0700

Server-initiated re-auth
Submitter name: Pat Calhoun 
Submitter email address: [email-masked] 
Date first submitted: June 01, 2001
Reference: 
Document: All 
Comment type: C 
Priority: 1 
Section: 
Rationale/Explanation of issue: 

In the process of fixing Issue #32, the Indication messages have been removed from
the NASREQ extension. However, the specification also makes use of the indication
messages to allow a server to send an unsolicited request for re-auth.

Is this feature required? If so, is it specific to NASREQ, or could it be generalized
and defined in the base protocol specification?

Three options:
1. Delete the feature
2. Create a new message set in the nasreq specification that is sent by
   a server to request that a user be re-auth.
3. Create a new message set in the base protocol that is sent by
   a server to request that a user be re-auth.

Comments?

PatC

---

From: "Fredrik Johansson" <[email-masked]>
Date: Tue, 5 Jun 2001 11:31:41 +0200

Hi Pat,

I believe that the message sequence that you suggest is good (re-auth
req/re-auth answer followed by the actual re-auth). The message should be
added to the NASREQ extension since there is no way for a access device to
request a mobile node to re-auth in MIP. Or should it be a request to the FA
to go via AAA the next time the MN register instead of sending the MIP Reg
Req directly to the HA?

/Fredrik

>-----Original Message-----
>From: [email-masked] [mailto:[email-masked]]On Behalf
>Of Pat Calhoun
>Sent: den 1 juni 2001 21:05
>To: [email-masked]
>Subject: [AAA-WG]: [Issue] Server-initiated re-auth
>
>
>Server-initiated re-auth

---

From: Pat Calhoun <[email-masked]>
Date: Tue, 5 Jun 2001 06:23:00 -0700

> to go via AAA the next time the MN register instead of sending the MIP Reg

Right, but there MAY be future Diameter applications that require re-auth
support. So, I am sort-of wondering whether it belongs in the base (similar
to STR).

PatC