Subject: [AAA-WG]: Clarification on ABNF Command specification

From: Cain Brian-BCAIN1 <[email-masked]>
Date: Tue, 24 Jul 2001 17:18:58 -0500

from -07, Section 3.2:
      fixed            = [qual] "<" avp-spec ">"
                         ; Defines the fixed position of an AVP

      required         = [qual] "{" avp-spec "}"
                         ; The AVP MUST be present

      optional         = [qual] "[" avp-name "]"
                         ; The avp-name in the 'optional' rule cannot
                         ; evaluate to any AVP Name which is included
                         ; in a fixed or required rule.

Fixed AVPs are implicitly required, correct?  And from this, it appears that
it may be legal for AVPs to appear in both the fixed and required sections.
Is there a logical reason for any AVP to appear in both?

-Brian

---

From: Pat Calhoun <[email-masked]>
Date: Tue, 24 Jul 2001 16:58:13 -0700

> Is there a logical reason for any AVP to appear in both?

A fixed AVP is required, but has a specific location in the packet. A
required AVP must also be present, but may appear anywhere in the packet.

PatC