Subject: RE: [AAA-WG]: draft-koehler-aaa-diameter-base-protocol-mib-00.txt

From: "Marta Morant-Artazkotz (ECE)" <[email-masked]>
Date: Fri, 6 Jul 2001 12:42:09 +0200

Hi,
I need some clarification regarding some of the objects defined in the diameterPerPeerStatsTable:
- diameterPeerStatsAccSessState:
	this object is described as "state of accounting services"
	its possible values are (almost all) the states defined in the authorization session state machine
	does it have any sense define the session state per peer? one session per peer?
	IMHO, sessions are related to home servers, not any server, and there are several per each one...
- diameterPeerStatsFailAccRequestes:
	this object is described as "failed accounting requests in and out per peer"
	again, does it have any senses define this per peer?
	IMHO, accounting requests are proccessed by home servers, not any server, any peer..
- diameterPeerStatsState:
	this object is described as "state of peer that Diameter server is communicating with"
	its possible values are (almost all) the states defined in the peer state machine in the base draft -05
	IMHO, its possible values should be the states defined in the peer state machine in the base draft -06
- diameterPeerStatsEndToEndErrorrs:
	this object is described as "end to end error count"
	IMHO, end to end errors are proccessed by home servers, not any server, any peer..
- diameterPeerStatsTransientFailure, diameterPeerStatsPermanentFailure, diameterPeerStatsInfoEvent, diameterPeerStatsRedirectEvent
	IMHO, this objects should be alligned with the classes of errors defined in the draft -06
- diameterPeerStatsSessTerminSent
	what is the difference between this object and the diameterPeerStatsSTROut?
Thank you in advance.
Regards,
Marta

-----Original Message-----
From: Mark Eklund [mailto:[email-masked]]
Sent: Monday, July 02, 2001 7:24 PM
To: [email-masked]
Subject: [AAA-WG]: draft-koehler-aaa-diameter-base-protocol-mib-00.txt

All,

Jay Koehler has created a mib for the Diameter base protocol and
submitted it to IETF.  It is available at

http://www.ietf.org/internet-drafts/draft-koehler-aaa-diameter-base-protocol-mib-00.txt

If it is O.K. with the list, please use [email-masked] to
discuss any issues with this draft.

-mark

---

From: Mark Eklund <[email-masked]>
Date: Mon, 9 Jul 2001 18:02:05 -0400 (EDT)

Marta,

Thanks for your input.  Please see responses inline.

On Fri, 6 Jul 2001, Marta Morant-Artazkotz (ECE) wrote:

> 	this object is described as "state of accounting services" its
>       possible values are (almost all) the states defined in the
>       authorization session state machine does it have any sense define
>       the session state per peer? one session per peer?  IMHO, sessions
>       are related to home servers, not any server, and there are several
>       per each one...

Agreed.  This will be removed.

> 	this object is described as "failed accounting requests in and
>       out per peer" again, does it have any senses define this per peer?

Consider a proxy in the middle of the chain.  If it attempts to
proxy an accounting request and fails, that failure would be counted
here.  From this you could determine if one of the peers is acting
flakey when it comes to responding to accounting requests.

> 	this object is described as "state of peer that Diameter
>       server is communicating with" its possible values are (almost all)
>       the states defined in the peer state machine in the base draft -05

Agreed.  This will be updated.

> 	this object is described as "end to end error count" IMHO, end
>       to end errors are proccessed by home servers, not any server, any
>       peer..

Agreed. This object will be removed.

> - diameterPeerStatsTransientFailure, diameterPeerStatsPermanentFailure,
>   diameterPeerStatsInfoEvent, diameterPeerStatsRedirectEvent

I believe that the MRA mechanism is changing once again.  If it is
O.K. with you, we will wait until draft -07 to update this.

> 	what is the difference between this object and the

Agreed. This object will be removed.

Again, thanks for your input.  I welcome any more you have.

-mark