Subject: RE: [AAA-WG]: Clarification on ABNF Command specification

From: Cain Brian-BCAIN1 <[email-masked]>
Date: Wed, 25 Jul 2001 12:10:49 -0500

> -----Original Message-----
> From: Erik Guttman [mailto:[email-masked]]
...
> Right, though the required AVPs come before the optional ones 
> according
> to the grammar.

Okay, what about an AVP that shows up in required with, e.g. 0 as minimum occurrences, and 5 as its maximum.  Now, this AVP can show up any place in the required section, but must all of its occurrences be contiguous, or can they be scattered throughout the required AVPs?

Command format:

     < A >
 0*5 { B }
     { Q }

An Actual instance of the given Command: 

A
B
B
B
Q
B

This would be valid, or invalid, given the format above?

I think the text "The AVP MUST be present" is slightly ambiguous.  Perhaps "All occurrences of the AVP MUST be present in one contiguous block" or "The occurrences of this AVP MUST show up anywhere within the required section, potentially non-contiguously", depending on the answer.  Okay, that doesn't quite flow that well, but someone could come up with an equivalent, I imagine.

-Brian

---

From: Pat Calhoun <[email-masked]>
Date: Wed, 25 Jul 2001 12:12:41 -0700

> This would be valid, or invalid, given the format above?

valid, given the above. The following, however, would be invalid
Q
A
B
B

> I think the text "The AVP MUST be present" is slightly ambiguous.  Perhaps "All occurrences of the AVP MUST be present in one contiguous block" or "The occurrences of this AVP MUST show up anywhere…

They don't have to be present in a contiguous block, and nowhere have we
stated this. The only AVPs that have strict ordering are the ones with
< >. All other AVPs may be present anywhere in a message.

PatC

---

From: Erik Guttman <[email-masked]>
Date: Thu, 26 Jul 2001 11:06:52 +0200 (MET DST)

> > I think the text "The AVP MUST be present" is slightly ambiguous.  
> > Perhaps "All occurrences of the AVP MUST be present in one contiguous 
> > block" or "The occurrences of this AVP MUST show up anywhere within 
> > the required section, potentially non-contiguously", depending on the 
> > answer.  Okay, that doesn't quite flow that well, but someone could 
> > come up with an equivalent, I imagine.
> 
> They don't have to be present in a contiguous block, and nowhere 
> have we stated this. The only AVPs that have strict ordering are 
> the ones with < >.  All other AVPs may be present anywhere in a 
> message.

Brian,

The intent is to allow radius-like flexibility while adding three
constraints - 
1: AVPs can be fixed at the beginning and end (order and number)
2: AVPs can be required in the middle (number not order) 
3: AVPs can be stuck in optionally (no order or number restrictions 
as long as it doesn't conflict with numbering restrictions in the 
'required' section).  

If this is ambiguous in the current text I will open an issue with 
suggested new text.

Erik