Subject: [AAA-WG]: Another editorial change :(

From: David Frascone <[email-masked]>
Date: Fri, 27 Jul 2001 12:10:47 -0500

in Section 4.6 of the base protocol, the table ambiguously uses base and
derived types.

Submitter name: Dave Frascone
Submitter email address: [email-masked]
Date first submitted: July 27th, 2001
Reference: N/A
Document: base
Comment type: E
Priority: 1
Section: 
Rationale/Explanation of issue: 

In section 4.6 of the base protocol draft, there is a table of all base
protocol AVPs.  Most AVPs are only mentioned with their Base types (with
the exception of a few IPAddress's).  But, further on when the AVPs are
described in detail, they mention their derived types. (i.e. section 5.3.7
Product-Id is called a UTF8String)

Requested change: 

Update table in section 4.6 to contain derived types, when applicable.

---

From: David Frascone <[email-masked]>
Date: Sun, 29 Jul 2001 22:43:36 -0500

Sorry there is no number yet.  I'm not sure how to get one.  But, here
is a list of the table changes, and one other question (perhaps it should
be a different issue?)

Section 4.6: AVP table

Accounting-Record-Number should be Unsigned32
Acct-Application-Id      should be Unsigned32
Alternate-Peer           should be DiameterIdentity
Auth-Application-Id      should be Unsigned32
Destination-Host         should be DiameterIdentity
Destination-Realm        should be UTF8String
Error-Message            should be UTF8String
Error-Reporting-Host     should be DiameterIdentity
Origin-Host              should be DiameterIdentity
Origin-Realm             should be UTF8String
Product-Name             should be UTF8String
Proxy-Host               should be DiameterIdentity
Redirect-Host            should be DiameterIdentity
Route-Record             should be DiameterIdentity
Session-Id               should be UTF8String
Source-Route             should be DiameterIdentity

Also, since it seems like things are in alphabetical order, 
Session-Binding should come before Session-Id

And finally, should Vendor-Id be considered Enumerated?  In the ethereal
packet dissector, I've switched it to enumerated, so it can attempt to
look up the vendor-id in it's VERY limited table.  

-Dave

---

From: Pat Calhoun <[email-masked]>
Date: Mon, 30 Jul 2001 06:49:31 -0700

I assign the numbers when I integrate the issue into the web page. I
am a little behind, but will catch up by the end of the day. If you
could, though, file an official issue (format and [issue] in the subject),
that would make it easier for me.

Thanks,

PatC