Subject: Re: [AAA-WG]: [Issue] Error messages: decimal or hex?

From: Jari Arkko <[email-masked]>
Date: Wed, 02 Jan 2002 10:36:11 +0200

>Is an Informational error message 1000 - 1999 in DECIMAL?
>Or is it 10000000 - 1FFFFFFF in HEX? 

Perhaps the hex variant is better, at least it saves a few
ifs when testing for the error, and looks more logical.
I propose however, that we do not consume the whole
error code space today, and hence I would like to have
hex-thousand ranges instead.

I suggest the following new table for 7.1:

      - 0x1000..0x1FFFF (Informational)
      - 0x2000..0x2FFFF (Success)
      - 0x3000..0x3FFFF (Protocol Errors)
      - 0x4000..0x4FFFF (Transient Failures)
      - 0x5000..0x5FFFF (Permanent Failure)

---

From: Jari Arkko <[email-masked]>
Date: Wed, 02 Jan 2002 11:49:39 +0200

Uh... a small correction:

      - 0x1000..0x1FFF (Informational)
      - 0x2000..0x2FFF (Success)
      - 0x3000..0x3FFF (Protocol Errors)
      - 0x4000..0x4FFF (Transient Failures)
      - 0x5000..0x5FFF (Permanent Failure)