Subject: RE: [AAA-WG]: One basic question

From: "Ghadiyaram Venkata (EXT-TataConsultancy/Helsinki)" <[email-masked]>
Date: Wed, 16 Jan 2002 16:51:03 +0200

Hi,

That was my point. 

"Why have a AVP Dictionary at all?"
Why should the base protocol assume that there is going to be a
Dictionary.

There are two aspects to this.

    1. Parsing the Diameter message.
    2. Handling/Serving the Diameter message.

If an implementation has to access the AVP dictionary for each AVP that
is present in the message in order to parse it and validate it, are we
not losing on efficiency. During handling the message the dictionary MAY
be required. If it is required the imlementation searches for the
descriptors of the AVPs which it is interested in the message rather
than ALL the AVPs.

"What could you do with a type that
you couldn't do with the AVP code?"

So I could parse the message without accessing the dictionary. It is not
just the question of debugging information but a lot more than that.

Regards,
Kishore

-----Original Message-----
From: ext David Frascone [mailto:[email-masked]]
Sent: 16. January 2002 16:26
To: Li Chunan (Nokia-RD/Beijing)
Cc: Ghadiyaram Venkata (EXT-TataConsultancy/Helsinki); [email-masked]
Subject: Re: [AAA-WG]: One basic question

But, then why have a dictionary at all.  What could you do with a type
that
you couldn't do with the AVP code?

I mean, let's say you get an unknown AVP, where the data type tells you
it's an OctetString.  Now what do you have that you didn't have before?

I suppose you could have better debugging information i.e.: "Received
unknown AVP 0x29485 Value:"qwerty"  But, I don't see that it adds any 
additional functionality to the protocol itself.

So, I'm against this change.

-Dave

On Wednesday, 16 Jan 2002, Li Chunan (Nokia-RD/Beijing) wrote:
> Hi
> 
> That's a good question. If the AVP data type is known in advance, it
> will be helpful to save and access the AVP data in real Diameter
> implementation.
> 
> 
> B.R.
> 
> Li ChunAn
> ----------------------------------------------------
> Advanced Internet Technologies Group
> Communication Systems Laboratory
> Nokia Research Center
> No.11, Hepingli Dongjie, Beijing, 100013
> Email: [email-masked]
> MP: +86 13601028331
> 
> 
> -----Original Message-----
> From: ext Ghadiyaram Venkata (EXT-TataConsultancy/Helsinki) 
> Sent: Wednesday, January 16, 2002 4:31 PM
> To: [email-masked]
> Subject: [AAA-WG]: One basic question
> 
> 
> Hi,
> 
> I have one question out of curiosity. 
> 
> What if the AVP header also contains the data type information? 
> 
>        0                   1                   2                   3
>        0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
>
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
>       |                           AVP Code
|
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
>       |V M P D r r r r|                  AVP Length
|
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
>       |                        Vendor-ID (opt)
|
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
>       |                        DataType code
|
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
>       |    Data ...
>                 +-+-+-+-+-+-+-+-+
> 
> DataType code - The code representing the data type. 
> D flag - Tells wheher the data type is vendor specific or not.
> 
> I feel that this reduces a lot of overhead on the implementations. Any
> comments...
> 
> Is this already considered previously. If yes, why is it rejected. 
> 
> Thanks and regards,
> Kishore
>

---

From: David Frascone <[email-masked]>
Date: Wed, 16 Jan 2002 09:05:53 -0600

> just the question of debugging information but a lot more than that.

I disagree.  You will know the format of the data's syntax, but not what it
means.  (Basic Syntatic-vs-Symmantic problem)

So, Let's say you do get an OctetString.  What is it?  Username?  Password?
Credit Card number?

Since you can't know what the data *is*, you have to have a dictionary 
anyway.  So, since symmantic defination has to happen somewhere, there is
no need for the overhead of the syntactic definition in the AVP.

As far as parsing goes, you already know the length of the data, which is
all you need to parse it.  Why would you need to know it's type,for anything
other than display purposes?

-Dave