Subject: RE: [AAA-WG]: Issue about which AVPs to encrypt and which not

From: <[email-masked]>
Date: Mon, 25 Feb 2002 13:48:49 +0200

Jari,

A side effect of your change will also increase the dependency of the
base spec on CMS, which is something we are trying to eliminate.  Unless
someone speaks up, I am planning on marking this issue as a reject.

John

> -----Original Message-----
> From: ext Jari Arkko [mailto:[email-masked]]
> Sent: 10 February, 2002 21:31
> To: Pat R. Calhoun; [email-masked]
> Subject: Re: [AAA-WG]: Issue about which AVPs to encrypt and which not
> 
> 
> RE: [AAA-WG]: Issue about which AVPs to encrypt and which 
> not>The WG decided to eliminate the Expected AVPs because of the 
> >possibility for conflicting information between the tables in the 
> >specifications, and what one sends in its Expected list of secured 
> >AVPs. 
> >I see no reason to go back to the more complex scheme. 
> 
> Agreed. I think the confusion arises from some parts of the old
> scheme still being visible in the text. My proposed fix tries to
> write everything in a manner where the data is fixed and not
> sent in the Expected lists.
> 
> Jari
> 
> 
> 
>

---

From: Jari Arkko <[email-masked]>
Date: Mon, 25 Feb 2002 15:56:15 +0200

> someone speaks up, I am planning on marking this issue as a reject.

Well, we obviously have to do something as the current
text has some remnants of the old scheme left. The WG
did decide a long time ago that we don't need operators
to specify individual AVP encryption policy, we can
do it in the RFC. So I think we should stick with that,
and fix the problems in the specs accordingly (which
I tried to do, but I'm sure the proposals could be
improved).

Jari