Subject: [AAA-WG]: ISSUE: User-Name AVP should not be a MUST in accounting records

From: Sebastian Zander <[email-masked]>
Date: Mon, 11 Feb 2002 08:29:37 +0100

Submitter name: Sebastian Zander
Submitter email address: [email-masked]
Date first submitted: February 11th, 2002
Reference: http://www.merit.edu/mail.archives/aaa-wg/msg02998.html
Document: base-08
Comment type: T
Priority: 1
Section: 9.5, 10.2 
Rationale/Explanation of issue: 

Section 9.5 of base-08 reads: 
"In all accounting records the Session-Id and User-Name AVPs MUST be present."

The Diameter client may not know the user's identity. Therefore there can not be a
MUST for including it. Furthermore there is some inconsistency in the draft since the 
User-Name AVP is already marked optional in section 9.7.1 and 9.7.2 but mandatory
in section 10.2.

Requested change: 

Section 9.5 should be changed to:
"In all accounting records the Session-Id AVP MUST be present. The User-Name AVP 
MUST be present if it is available to the Diameter client."

The table in section 10.2 should be changed so that User-Name is optional.

-- Sebastian

---

From: "Kevin Purser" <[email-masked]>
Date: Mon, 11 Feb 2002 14:06:48 -0800

Submitter name: Kevin Purser
Submitter email address: [email-masked]
Date first submitted: February 11th, 2002
Reference: none
Document: base-08alpha02
Comment type: Editorial
Priority: 1
Section: 5.6 "Peer State Machine"
Rationale/Explanation of issue:

There are a couple of references in this section to "the state machine
described in [52]".  However, in the latest version of the transport draft,
such a state machine is not present.

Requested change:

Remove these references in the text.

---

From: "Kevin Purser" <[email-masked]>
Date: Thu, 14 Feb 2002 12:58:22 -0800

Submitter name: Kevin Purser
Submitter email address: [email-masked]
Date first submitted: February 14th, 2002
Reference: none
Document: base-08alpha02
Comment type: Technical
Priority: 1
Sections: 2.9.3, 6.12
Rationale/Explanation of issue:

Diameter redirect agents currently provide realm to server address
resolution.  Within a single administrative domain, it could be useful to
allow redirect agents to have the option of providing user to server address
resolution.

Requested change:

* change the first paragraph of section 2.9.3 to read:

Redirect agents provide Realm to Server address resolution and MAY also
provide User to Server address resolution.  These redirect agents would make
use of the Diameter routing table or optionally, a user table to determine
where a given request should be forwarded. When a request is received by a
redirect agent, a special answer is created, which includes the identity of
the Diameter server(s) the originator of the request should contact
directly.

* add the following enumerated value in section 6.12:

      ALL_USER                   6
         All messages for the user requested MAY be sent to the
         host specified in the Redirect-Host AVP.