Subject: [AAA-WG]: User-Name AVP must be present in all accounting records?

From: Sebastian Zander <[email-masked]>
Date: Fri, 08 Feb 2002 15:05:10 +0100

Hi,

Section 9.5 of base-08 reads: 
"In all accounting records the Session-Id and User-Name AVPs MUST be present."

I don't understand why there is a must for the User-Name since the Diameter node
sending the accounting request may not know it. Still the target can use the various
session-ID AVPs to correlate the records. There also seems to be some inconsistency
in the draft and between base-08 and nasreq-08:

In section 9.7.1 & 9.7.2 (ACR, ACA definition) User-Name AVP is marked as optional 
while in section 10.2 it is again specified as MUST.

nasreq-08 reads: 
"Unless the access device interprets the EAP-Response/Identity packet
returned by the authenticating peer, it will not have access to the
user's identity. Therefore, the Diameter Server SHOULD return the
user's identity by inserting it in the User-Name attribute of
subsequent Diameter-EAP-Answer packets. Without the user's identity,
the Session-Id AVP MAY be used for accounting and billing, however
operationally this MAY be very difficult to manage."

This make sense to me but my interpretation of this is that the User-Name AVP SHOULD
be present in accounting messages which contradicts to the MUST in the base draft.

Could someone please clarify on this issue?

-- Sebastian

---

From: "Jari Arkko" <[email-masked]>
Date: Fri, 8 Feb 2002 21:26:49 +0200

> while in section 10.2 it is again specified as MUST.

You are correct. This is not right. I suggest chaning 9.5 so that it reads.
"User-Name AVP MUST be present if it is available to the Diameter client."
Then change the tables accordingly.

Can you file an issue?

> be present in accounting messages which contradicts to the MUST in the base draft.

I would suggest that the nasreq-08 be kept as is -- using the server to
dig out the User-Name so that it eventually becomes available to the
client, and be inserted in the (at the very least) the Stop record for the
session.

Jari