Subject: Re: [AAA-WG]: Issue about User-Name AVP and accounting

From: Bernard Aboba <[email-masked]>
Date: Sun, 10 Feb 2002 08:05:39 -0800

Question: Why would the NAS not know the User-Name? Are we talking about call-check functionality, or is there another reason?

---------- Original message ----------
Date: Sun, 10 Feb 2002 18:02:54 +0200
From: Jari Arkko <[email-masked]>
Reply-To: Jari Arkko <[email-masked]>
To: [email-masked]
Subject: [AAA-WG]: Issue about User-Name AVP and accounting

Submitter name: Jari Arkko (Sebastian Zander)
Submitter email address: [email-masked]
Date first submitted: Feb 10, 2002
Reference: http://www.merit.edu/mail.archives/aaa-wg/msg03001.html
Document: base, nasreq
Comment type: E
Priority: 2
Section: 9.5, 9.7.1, 9.7.2, nasreq 10.2
Rationale/Explanation of issue:

Section 9.5 of base-08 reads:  "In all accounting records the
Session-Id and User-Name AVPs MUST be present.". However, the Diameter node
sending the accounting request may not know it. Still the target can use the various
session-ID AVPs to correlate the records. There also seems to be some inconsistency
in the draft and between base-08 and nasreq-08: In section 9.7.1 & 9.7.2
(ACR, ACA definition) User-Name AVP is marked as optional  while in
section 10.2 it is again specified as MUST.

Proposed change:

I suggest modifying 9.5 so that it reads. "User-Name AVP MUST be present if
it is available to the Diameter client."

Then change the tables in 10.2 as follows:

    User-Name                     | 0+   | 0+   |

---

From: Jari Arkko <[email-masked]>
Date: Sun, 10 Feb 2002 18:50:48 +0200

> Question: Why would the NAS not know the User-Name? Are we talking about call-check functionality, or is there another reason?

This could be a NAS call which isn't authenticated at all by the
NAS and L2TP tunneled to another device, and only have a phone
number.

Or this could be a Diameter node that is
acting only for accounting purposes. Possibly, User-Name
might not be available at an early stage of EAP authentication (since
the server is to return the User-Name) -- but I'm not sure we are
sending any accounting messages at that stage yet.

Jari