Subject: RE: [AAA-WG]: Issue 271: comments needed

From: <[email-masked]>
Date: Wed, 27 Feb 2002 14:01:04 +0200

Hi,

Well what I wonder here is if this
 
9.8.x. Accounting-Realtime-Required AVP

is supposed to be sent to the client in the very first ACA from accounting server but the server doesn't response at all? Or how this will work, I might be lost...

The new Accounting-Record-Types 5-8 might work more flexible in this case but maybe Jari can give us some comments.

br,
JPK     

-----Original Message-----
From: Loughney John (NRC/Helsinki) 
Sent: 27. February 2002 13:34
To: Koskinen Juha-Pekka (NET/Tampere); [email-masked]'
Cc: [email-masked]'
Subject: RE: [AAA-WG]: Issue 271: comments needed

Hi Juha,

> As Jari has stated: 
> "..in some cases we would like to stop services if we can't 
> provide real-time accounting, while in some other cases we would like
> to continue."
> 
> That was also in my mind when I suggested issue 272. There is 
> cases where the accounting records could simply be stored by 
> the client if the accounting server doesn't response even to 
> intial ACR but in some cases the services must be stopped if 
> ACA is not received. That was the reason I proposed new 
> Accounting-Record-Type values 5-8. When these values (5-8) is 
> sent in ACR, the service must be stopped if ACA is not received. 

Do you think that Jari's comments are enough for both issues (271 & 272)?
Or do you have other text?

John

---

From: Jari Arkko <[email-masked]>
Date: Wed, 27 Feb 2002 17:18:19 +0200

Ah, now I see that 272 is also discussed under this thread. Sorry
for the confusion. Anyway, to answer Juha-Pekka first: The new
AVP design was actually that it would be sent from the auth server
to the NAS. Additionally, we could allow also it come from the acct
server in the responses. In any case, if you are not using
authentication and didn't get any response from the acct server,
then there's theoretically no way to figure out what to do with
the service, unless local configuration knows. So, it would seem
to me that providing both auth server and acct server responses
with this new AVP where needed would satisfy all needs.

However, my proposal for realtime-required avp was actually
a bit different than what I understood issue 272 to want to have.
Basically, there are two things:

  - Whether you want to give service if you can't send in acct data
  - Priority order between queued records at an accounting server or
    proxy

The realtime-required AVP deals with the first issue. The new AVP
I was talking about in issue 272 deals with the second issue. If you
think we're fine with just the first service then we could just agree
on 271 and reject 272. If not, we need to do something also for
272. I believe 271 needs to be done in any case, because the current
spec is inconsistent.

Jari