Subject: [AAA-WG]: [issue] Ambiguities in AVP Flag rules tables

From: David Spence <[email-masked]>
Date: Fri, 22 Feb 2002 16:48:26 -0500

Subject: [issue] Ambiguities in AVP Flag rules tables

Submitter name: David Spence
Submitter email address: [email-masked]
Date first submitted: 2/22/2
Reference: 
Document: base, cms-sec
Comment type: T
Priority: 1
Section: base sec. 4.6, cms-sec sec. 6.0
Rationale/Explanation of issue:

   Several AVPs listed in the table in sec. 4.6 of the base draft do not
   include all three flags in the AVP Flag rules columns.  This leads to
   ambiguities.  For example, how should I set the 'M' flag in the
   Error-Message AVP?  'M' is not listed in the MAY column so I guess I
   can't set it, but then 'M' is not listed in the MUST NOT column so
   perhaps I can set it.

   In the AVP Flag rules table in sec. 6.0 of the cms-sec draft, in the
   DSA-TTL row, the 'P' flag is listed twice.  It appears in both the
   MAY and MUST NOT columns.

Requested change:

   The following rows in the table in sec. 4.6 of the base draft need to
   be fixed:

      Error-Message
      Error-Reporting-Host
      Product-Name
      Redirect-Host

   The following row in the table in sec 6.0 of the cms-sec draft needs
   to be fixed:

      DSA-TTL

---

From: Stephen Farrell <[email-masked]>
Date: Tue, 26 Feb 2002 17:09:06 +0000

I'll delete the "P" from the MUST NOT column for DSA-TTL
in the cms draft. If that's wrong, let me know.

Stephen.

-- 
____________________________________________________________
Stephen Farrell         				   
Baltimore Technologies,   tel: (direct line) +353 1 881 6716
39 Parkgate Street,                     fax: +353 1 881 7000
Dublin 8.                mailto:[email-masked]
Ireland                             http://www.baltimore.com