Subject: RE: [AAA-WG]: ISSUE: redirect based on user names

From: <[email-masked]>
Date: Fri, 15 Feb 2002 14:58:49 +0200

I think that this change is useful.

Best Regards, Jaakko

> -----Original Message-----
> From: ext Kevin Purser [mailto:[email-masked]]
> Sent: 14 February, 2002 22:58
> To: IETF AAA List
> Subject: [AAA-WG]: ISSUE: redirect based on user names
> 
> 
> Submitter name: Kevin Purser
> Submitter email address: [email-masked]
> Date first submitted: February 14th, 2002
> Reference: none
> Document: base-08alpha02
> Comment type: Technical
> Priority: 1
> Sections: 2.9.3, 6.12
> Rationale/Explanation of issue:
> 
> Diameter redirect agents currently provide realm to server address
> resolution.  Within a single administrative domain, it could 
> be useful to
> allow redirect agents to have the option of providing user to 
> server address
> resolution.
> 
> Requested change:
> 
> * change the first paragraph of section 2.9.3 to read:
> 
> Redirect agents provide Realm to Server address resolution 
> and MAY also
> provide User to Server address resolution.  These redirect 
> agents would make
> use of the Diameter routing table or optionally, a user table 
> to determine
> where a given request should be forwarded. When a request is 
> received by a
> redirect agent, a special answer is created, which includes 
> the identity of
> the Diameter server(s) the originator of the request should contact
> directly.
> 
> * add the following enumerated value in section 6.12:
> 
>       ALL_USER                   6
>          All messages for the user requested MAY be sent to the
>          host specified in the Redirect-Host AVP.
> 
> 
>

---

From: <[email-masked]>
Date: Thu, 21 Feb 2002 13:01:05 +0200

Hi Jari,

> As I understand this, this would make the client store a 
> record for that
> particular user name until max-cache-time, even beyond the user's
> session. Kevin, can you explain why ALL_SESSION is not sufficient
> for this, as it would have a more bounded cache memory requirements?

That is good point.  Kevin, could you provide extra justification for 
this?

John

---

From: "Carolina Canales Valenzuela (ECE)" <[email-masked]>
Date: Thu, 21 Feb 2002 12:53:46 +0100

Hi Jari,
as far as I understand the issue, the client would store a record with the name of the server sent in the Redirect-Host AVP.
Like this, the client will know that the rest of the messages related with that user, independently on whether the session is maintained or not, should be sent to the server stored.

I think that ALL_SESSION  is not valid because sometimes the session might not be maintained, but even in that case, as the messages belong to the same user, they must go to the same server (this is the new added functionality that is required).
The rest of the defined values in section 6.12 are not valid either.

I don't know if this is an answer to your question, or I misunderstood it....

BR,
Carolina

>From: Jari Arkko [mailto:[email-masked]]
>Sent: Thursday, February 21, 2002 9:11 AM
>To: Berry, Nigel Howard (Nigel); [email-masked];
>[email-masked]
>Subject: Re: [AAA-WG]: ISSUE: redirect based on user names
>
>
>Jari
>----- Original Message ----- 
>From: "Berry, Nigel Howard (Nigel)" <[email-masked]>
>To: <[email-masked]>
>Sent: 20. helmikuuta 2002 19:20
>> Hi Kevin,
>> This extra optionality could be very useful.  There may a bit more
>> complexity required in the redirect agent but not 
>withstanding this I would
>> like to support the addition of this extra functionality, 
>> 
>> Regards,
>> Nigel
>> 
>> 
>> ** included from original e-mail ***
>> allow redirect agents to have the option of providing user 
>to server address
>> resolution.
>> 
>> Requested change:
>> 
>> use of the Diameter routing table or optionally, a user 
>table to determine