Subject: RE: [AAA-WG]: Issue 271: comments needed

From: <[email-masked]>
Date: Thu, 28 Feb 2002 22:37:55 +0200

Jari,

So the text to be added is adding to:

6.12  Redirect-Host-Usage AVP

The following:

  UPDATE_PREPAID		7
	An Accounting Update Prepaid record is used to indicate
  that a prepaid service will need more credit to continue. It is
  also used when service (client) need to update itself tariff of
  the ongoing accounting session. This record contains all
  information that is relevant to determine cost of the service and
  granted threshold.

and

modifying start of 9.8.x by adding " or in the Accounting-Answer from
the accounting server" just before the first ".".

Is that it?

John

> -----Original Message-----
> From: ext Jari Arkko [mailto:[email-masked]]
> Sent: 28 February, 2002 22:21
> To: Koskinen Juha-Pekka (NET/Tampere)
> Cc: Loughney John (NRC/Helsinki); [email-masked]
> Subject: Re: [AAA-WG]: Issue 271: comments needed
> 
> 
> Ok so for the most part 271 solves 272 issues as well.
> (271 also does some additional things, such as handle the
> buffering of acct messages.)
> 
> As for the spontanous updating, I think the intent at least
> of the spec has been that the base provides you exactly one
> mandatory situation to update: the interim production per
> the interval. When - not if - there is a need to have updates
> at other situations, the design allows for a new AVP to be
> designed in a specific application document. This AVP could
> be sent by the accounting server in the start answer to
> instruct the client to produce accounting interim records
> in some application specific way, e.g. every time the QoS
> of a link is modified. This would enable you to provide
> spontaneous records, for instance, by having the accounting
> server indicate in the start answer that by Accounting-Spontaneous
> AVP. The part about the semantics of your specific proposal e.g.
> more credit is needed -- I think that too can be handled by
> an application specific AVPs in the accounting requests. (Note
> that when the first application is designed that does this,
> it is perfectly OK for other apps to refer to these AVPs and
> require their use, so work doesn't have to be duplicated.)
> 
> In conclusion I think 271 solution is sufficient for base, and
> the approach outlined above can be provided in a new apps document.
> However, we discussed modifying 271 proposed text to allow the
> acct server control the realtime flag. I propose modifying
> start of 9.8.x by adding " or in the Accounting-Answer from
> the accounting server" just before the first ".".
> 
> Jari
> 
> [email-masked] wrote:
> 
> > Hi,
> > 
> > The 272 includes also one item which has not been discussed yet.
> > Among the new Accounting-Record-Type(s) introduced in 272 
> > there is also value for record which could be used when spontaneous
> > updating (from client to server) of ongoing acc session is needed. 
> > I think this is also needed even in basic acc sessions. 
> > 
> > How/should this be included in base?
> > 
> > Anyway, I think that basic idea of 271 and this 
> > updating_possibility_from _client_to_server
> > are both needed.
> > 
> > br,
> > JPK
> >  
> > 
> > -------- inc. --------------------
> > 
> >>UPDATE_PREPAID		7
> >>	An Accounting Update Prepaid record is used to indicate
> >>that a prepaid service will need more credit to continue. It is
> >>also used when service (client) need to update itself tariff of
> >>the ongoing accounting session. This record contains all
> >>information that is relevant to determine cost of the service and
> >>granted threshold.
> 
> 
> 
> 
> 
>

---

From: "Jari Arkko" <[email-masked]>
Date: Thu, 28 Feb 2002 22:45:47 +0200

> 6.12  Redirect-Host-Usage AVP

Uh... I think not. Wrong AVP first of all, I think the
folks meant Accounting-Record-Type. Secondly, I
was trying to argue that we don't need UPDATE_PREPAID
in the base...

> the accounting server" just before the first ".".

Do that, and incorporate changes from 271 as they are listed
in the issues file. Except for the state machine, which I sent
in separately.

I will take one more look at another e-mail around the prepaid
issues and verify what I said above about the need for UPDATE_
PREPAID.

Jari