Subject: RE: [AAA-WG]: [issue] AAA URI is Overloaded

From: <[email-masked]>
Date: Thu, 28 Feb 2002 21:26:31 +0200

Hi Jacques & David,

I agree with Jacques. David, if you can carefully craft 
text that fits your exact meaning, please do so.  Otherwise
lets leave the text as fqdn & if needed, provide additional
details in a BCP doc or something, as we are getting into
operation details.

John

> -----Original Message-----
> From: ext Jacques Caron [mailto:[email-masked]]
> Sent: 28 February, 2002 02:56
> To: David Spence
> Cc: Loughney John (NRC/Helsinki); [email-masked];
> [email-masked]
> Subject: Re: [AAA-WG]: [issue] AAA URI is Overloaded
> 
> 
> Then you're really adding something to the "real" FQDN that 
> is functionally 
> equivalent to a port number :-)
> 
> If you manage to write some text that explains that clearly and 
> unambiguously, why not. But I think it's easier to stick to 
> "real" FQDNs. 
> It's never hurt anyone to register a couple of addresses in the DNS.
> 
> As an alternative, if the Identity is considered fully 
> opaque, nothing 
> prevents us to change it to FQDN;<anything-unique to the host>. Where 
> <anything unique to the host> may be a PID, a port number, a 
> configuration 
> file path name, or any other arbitrary string.
> 
> Jacques.
> 
> At 01:12 28/02/2002, David Spence wrote:
> >Actually, my idea was that the portion of the identity 
> string following the
> >first dot would be a real host name registered to the host 
> on which the
> >server was running.  In my example below, both servers were 
> running on
> >srv.interlinknetworks.com, which is the real name of the 
> host.  diam1 and
> >diam2 would be unregistered prefixes to a registered host name.
> >
> >Jacques Caron wrote:
> > >
> > > Even though the full name need not necessarily be in the 
> DNS (though this
> > > might have other consequences?), it is necessary that it 
> is based on a
> > > domain name that is registered and owned by the 
> administrator of the
> > > server. Otherwise we'll end up with a bunch of 
> "diameter.example.com" all
> > > over which are definitely not unique :-(
> > >
> > > I think it's easier if the fqdn is really registered, 
> just for the purposes
> > > of ensuring uniqueness.
> > >
> > > Jacques.
> > >
> > > At 22:59 27/02/2002, David Spence wrote:
> > > >One question: Does it make any difference whether there 
> is an A record for
> > > >the fqdn in the DNS, i.e., does the fqdn actually need to be 
> > registered?  I
> > > >think not.  And if it doesn't, that makes it easier for 
> administrators.
> > > >Suppose I run two Diameter servers on 
> srv.interlinknetworks.com.  Then I
> > > >could configure one to call itself 
> diam1.srv.interlinknetworks.com, and I
> > > >could configue the other to call itself 
> diam2.srv.interlinknetworks.com.
> > > >Voila!  I have guaranteed uniqueness without having to 
> register a domain
> > > >name.  If this is agreeable, it might be worth stating 
> in the draft 
> > that the
> > > >term fqdn does not imply that the name be registered, 
> only that it be
> > > >unique.
> > >
> > > _________________________________________________________
> > > Do You Yahoo!?
> > > Get your free @yahoo.com address at http://mail.yahoo.com
> 
> 
> 
> _________________________________________________________
> 
> Do You Yahoo!?
> 
> Get your free @yahoo.com address at http://mail.yahoo.com
> 
> 
> 
>

---

From: David Spence <[email-masked]>
Date: Thu, 28 Feb 2002 16:15:29 -0500

I certainly do not want to add text specifying what operators can do.  I am
only interested in the protocol.  In this case, my concern is that you don't
over-specify the protocol in such a way as to unnecessarily limit an
operator's options.  What I do request is that if there is no protocol
requirement to resolve the fqdn, then you should relax the requirement and
specify that it "contains the fqdn of the Diameter node" rather than that it
"is the fqdn of the Diameter node".  Then operators can do what they want.