Subject: [AAA-WG]: [issue] Host-IP-Address AVP in CER and CEA is redundant

From: <[email-masked]>
Date: Thu, 28 Mar 2002 10:04:35 +0200

Subject: [issue] Host-IP-Address AVP in CER and CEA is redundant

Submitter name: Ghadiyaram Venkata Kishore
Submitter email address: [email-masked],
Date first submitted: March 28, 2002
Reference: 
Document: Base
Comment type: T
Priority: 1
Section:
Rationale/Explanation of issue

When a peer receives a CER, the IPAddress(IPAddresses in case of SCTP) of the host sending the message can be obtained from the transport layer as this information is maintained by the transport layer as part of TCP connection or SCTP association. So sending this information as part of Diameter payload is redundant.

If alternate peers have to be provided through CER/CEA then we need a list of DiameterURIs, just the IPAddress of the peers is of no use.

Requested change:

Remove Host-IP-Address AVP from the specification of CER and CEA (both in the text and te ABNF).

---

From: David Frascone <[email-masked]>
Date: Thu, 28 Mar 2002 08:07:46 -0600

I don't think I agree with this.  If a host has multiple IP addresses, or,
if a firewall is involved, the IP address reported in the transport layer
might not be the IP address that the host wants to advertise.

So, I vote, "reject".

-Dave

-- 
David Frascone

   I'm moving to Mars next week, so if you have any boxes...

---

From: Bernard Aboba <[email-masked]>
Date: Fri, 29 Mar 2002 05:33:36 -0800 (PST)

Assigned #318.