Subject: RE: [AAA-WG]: Issue 244: ELECTION_LOST result code

From: <[email-masked]>
Date: Wed, 6 Mar 2002 17:59:23 +0200

Johan,

So 3) Put ELECTION_LOST into the Result_Code AVP, probably 
      under Transient Failures

is the corrent answer, correct?

John

> -----Original Message-----
> From: ext Johan Johansson [mailto:[email-masked]]
> Sent: 06 March, 2002 18:55
> To: Loughney John (NRC/Helsinki)
> Cc: [email-masked]; [email-masked]
> Subject: Re: [AAA-WG]: Issue 244: ELECTION_LOST result code
> 
> 
> It was decided at the diameter bakeoff that when a connection 
> lost the 
> election a CEA with ELECTION_LOST as result code should be 
> sent instead 
> of a DPR which would imply that all connections with the peer was 
> severed. Unless this has for some reason been changed afterwards 
> ELECTION_LOST is used and must therefore remain.
> 
> j
> 
> [email-masked] wrote:
> 
> >Hi Fredrik,
> >
> >>I agree that this issue should be rejected. And I guess it 
> >>has. The strange
> >>thing is that I can't find the Result Code ELECTION_LOST anywhere in
> >>base-10? Has it been deleted anyway?
> >>
> >
> >There was continued discussion on this, that it is not used anymore.
> >So, I have removed it.  However, I just noticed one mail I did not
> >see - I've included the relevant mails.
> >
> >So, we are left with 3 possibilities:
> >1) ELECTION_LOST code removed from the spec
> >2) Restore ELECTION_LOST code to where it was in Base 
> (Disconnect-Cause AVP)
> >3) Put ELECTION_LOST into the Result_Code AVP, probably 
> under Transient Failures
> >
> >Your thoughts?
> >John
> >
> 
> 
> 
>

---

From: Johan Johansson <[email-masked]>
Date: Wed, 06 Mar 2002 18:14:05 +0100

Probably. I guess someone will pop up soon and claim that the socket is 
just torn down, which is what is in section 5.6 in the peer state 
machine. I'm not sure if this is just because Pat never got around to 
documenting the decision or if it was later overturned.

The thinking around sending a CEA instead of just tearing down the 
socket was that it seemed more civilized and can't be misinterpreted as 
a proper network failure, not even momentarily.

If this is no longer the consensus then it should be removed. Or rather 
not unremoved I guess.

j