Subject: RE: [AAA-WG]: [issue] Host-IP-Address AVP in CER and CEA is redundant

From: <[email-masked]>
Date: Thu, 28 Mar 2002 17:03:08 +0200

Hi David,

By "firewall involvemet" do you mean the firewall translates the address. The address/addresses retrieved from the transport layer are the addresses where the host can be reached. If there are addresses using which a host cannot be reached, why does one want to advertise them and why will be the receiver interested in them. 

In case of a multihomed host running SCTP, still all the IPAddresses can be obtained from the SCTP association.

In any case I do not see any reason for the IPAddress information to be carried in the Diameter payload.

-Kishore

-----Original Message-----
From: ext David Frascone [mailto:[email-masked]]
Sent: 28. March 2002 16:08
To: Ghadiyaram Venkata (EXT-TataConsultancy/Helsinki)
Cc: [email-masked]
Subject: Re: [AAA-WG]: [issue] Host-IP-Address AVP in CER and CEA is
redundant

I don't think I agree with this.  If a host has multiple IP addresses, or,
if a firewall is involved, the IP address reported in the transport layer
might not be the IP address that the host wants to advertise.

So, I vote, "reject".

-Dave

On Thursday, 28 Mar 2002, [email-masked] wrote:
> Subject: [issue] Host-IP-Address AVP in CER and CEA is redundant
> 
> Submitter name: Ghadiyaram Venkata Kishore
> Submitter email address: [email-masked],
> Date first submitted: March 28, 2002
> Reference: 
> Document: Base
> Comment type: T
> Priority: 1
> Section:
> Rationale/Explanation of issue
> 
> When a peer receives a CER, the IPAddress(IPAddresses in case of SCTP) of the host sending the message can be obtained from the transport layer as this information is maintained by the transport layer as part of TCP connection or SCTP association. So sending this information as part of Diameter payload is redundant.
> 
> If alternate peers have to be provided through CER/CEA then we need a list of DiameterURIs, just the IPAddress of the peers is of no use.
> 
> Requested change:
> 
> Remove Host-IP-Address AVP from the specification of CER and CEA (both in the text and te ABNF).
> 

-- 
David Frascone

   I'm moving to Mars next week, so if you have any boxes...

---

From: David Frascone <[email-masked]>
Date: Thu, 28 Mar 2002 09:09:14 -0600

> By "firewall involvemet" do you mean the firewall translates the address. The address/addresses retrieved from the transport layer are the addresses where the host can be reached. If there are addr…

By firewall involvement, I mean that I have five load balancing Diameter
servers behind a firewall.  But, only one of the servers has an IP address
that is reachable from the net for inbound connections.  The firewall 
blocks the rest.  Since SYN's will be discarded by the firewall, shouldn't
all five servers advertise the only routable address as their Host-IP-Address?

> In case of a multihomed host running SCTP, still all the IPAddresses can be obtained from the SCTP association.

Ok.  What about TCP?  Since TCP is a mandatory MUST, Host-IP-Address seems
to have value.

Since it has *some* value, why remove it.  

> In any case I do not see any reason for the IPAddress information to be carried in the Diameter payload.

I see reasons (mentioned above), so I am *against* this change.

-- 
David Frascone

                     IBM: I Buy Macinstosh