Subject: [AAA-WG]: [issue] Support for Originating-Line-Info AVP missing from NASREQ

From: Bernard Aboba <[email-masked]>
Date: Thu, 14 Mar 2002 11:00:59 -0800 (PST)

Submitter name: Bernard Aboba
Submitter email address: [email-masked]
Date first submitted: 2001-3-18 
Reference: 
Document: nasreq-09
Comment type: T 
Priority: 1 
Section: 
Rationale/Explanation of issue: 
The Diameter NASREQ application currently does not support the 
RADIUS Originating-Line-Info AVP, attribute #94. Below is information
provided by Nenad Trifunovic relating to the definition of that AVP. 

---------- Forwarded message ----------
Date: Thu, 14 Mar 2002 09:25 -0800 (PST)
From: Nenad Trifunovic <[email-masked]>
To: Bernard Aboba <[email-masked]>
Subject: Re: Spec for the Originating-Line-Info AVP

Hello, 

After some inquiry I got this pointer:

http://www.nanpa.com/number_resource_info/ani_ii_assignments.html.

so, people can synchronize to these secret numbers (although winning
lotto numbers seem to be much more in demand :-) ).

regards,
nenad

Forwarded message:
_________________________________________________________________
Date: Wed, 06 Mar 2002 15:09 -0800 (PST)
From: Nenad Trifunovic <[email-masked]>
To: Bernard Aboba <[email-masked]>
Subject: Re: Spec for the Originating-Line-Info AVP

Hello,

It appears that the only additional information I can provide
is:

   Value
   
   The Value field is two octets (00-99). ANSI T1.113 and 
   BELLCORE 394 can be used for additional information about 
   those values and their use.

Regards,
nenad

p.s.
this is my private copy for those values (i don't know how well
it matches ANSI T1.113 or BELLCORE 394 since i only found references 
to them). 

      00     Plain Old Telephone Service (POTS) -  non-coi service
             requiring no special treatment with ANI identified.
      
      01     Multiparty Line (more than 2) or Operator Number
             Identification (ONI) 

      02     ANI Failure 
      
      03     ANI Observed
      
      04     ONI Observed
      
      05     ANI Failure Observed
      
      06     Hotel/Motel without room identification
      
      07     Coinless, Hospital, Inmate, etc. 
      
      08     InterLATA Restricted
      
      09     Unassigned
      
      10     Test Call
      
      11     Unassigned
      
      12-19  Not assignable - conflict with international outpulsing code
      
      20     Automatic Identified Outward Dialing (AIOD)
      
      21-22  Unassigned
      
      23     Coin or non-coin (identified line) Line Status Unknown
      
      24     800 Service Call
      
      25-26  Unassigned
      
      27     Coin 
      
      28     Unassigned
      
      29     Prison/Inmate Service 
      
      30-32  Intercept. 
      
      30     Intercept (blank) - for calls to unassigned DN
      
      31     Intercept (trouble) - for calls to DNs that have been
             manually placed in trouble-busy state by Telco Personnel
      
      32     Intercept (regular) - for calls to recently changed or
             disconnect numbers
      
      33     Unassigned
      
      34     Telco Operator Handled Call 
      
      35-39  Unassigned
      
      40-49  Unrestricted Use - locally determined by carrier
      
      50-51  Unassigned
      
      52     Outward Wide Area Telecommunications Service (OUTWATS)
      
      53-59  Unassigned
      
      60     Telecommunications Relay Service (TRS) 
      
      61     Cellular Service (Type 1) 
      
      62     Cellular Service (Type 2)  
      
      63     Cellular Service (Roaming)  
      
      64-65  Unassigned
      
      66     Telecommunications Relay Services (TRS) 
      
      67     Telecommunications Relay Services (TRS)  

      68     InterLATA Restricted - Hotel Line
      
      69     Unassigned
      
      70     Private Pay-stations 
      
      71-77  Unassigned
      
      78     InterLATA Restricted - Coinless Line, etc.
      
      79     Unassigned
      
      80-89  Reserved for Future Expansion
      
      90-92  Unassigned
      
      93     Access for private virtual network types of service
      
      94     Unassigned
      
      95     Test Call
      
      96-99  Unassigned

Forwarded message:
_________________________________________________________________
Date: Thu, 28 Feb 2002 12:32 -0800 (PST)
From: Nenad Trifunovic <[email-masked]>
To: Bernard Aboba <[email-masked]>
CC: [email-masked],
    [email-masked]
Subject: Re: Spec for the Originating-Line-Info AVP

Hello,

Thank you for your interest in the Originating-Line-Info attribute.
I have some notes about it, but it will take few days to sort them 
out. I'll try to send more information by the middle of the next 
week.

Regards,
nenad

p.s.
just to keep your interest:

1.0 Introduction

   Signaling System 7 (SS7) network is used in Public Switched Telephone
   Network (PSTN) for call management. SS7 messages carry a number of
   information elements related to a particular circuit switched call.
   The originating line information (OLI) information element indicates
   the nature and/or characteristics of the line from which a call
   originated (e.g. payphone, hotel, cellular).  Telephone companies are
   starting to offer OLI to their customers as an option over Primary
   Rate Interface (PRI). Internet Service Providers (ISPs) can use OLI in
   addition to Called-Station-Id and Calling-Station-Id attributes to
   differentiate customer calls and define different services.
   
2.0 Originating-Line-Info Attribute

   A summary of the Originating-Line-Info attribute format is shown
   below. The fields are transmitted from left to right.

        0                   1                   2                   3
        0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
       +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
       |     Type      |    Length     |             Value             |
       +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

   Type
   
   94 for Originating-Line-Info.
   
   Length
   
   4
   
   Value
   
   The Value field is two octets and can have one of the following
   values:
      
      00     Plain Old Telephone Service (POTS) -  non-coin service 
requiring no 
             special treatment with ANI identified.

>Date: Wed, 27 Feb 2002 08:46 -0800 (PST)
>From: Bernard Aboba <[email-masked]>
>To: [email-masked]
>CC: [email-masked],
>    [email-masked]
>Subject: Spec for the Originating-Line-Info AVP
>
>The IANA RADIUS allocation page:
>
>http://www.iana.org/assignments/radius-types
>
>discloses allocation of attribute #94 to
>Originating-Line-Info, with you as author. 
>
>Is there a spec for this? We are looking to support all the existing
>RADIUS attributes in Diameter NASREQ. 
>

---

From: David Spence <[email-masked]>
Date: Thu, 14 Mar 2002 15:09:50 -0500

The only thing missing is the "Requested change:" section.  I assume it
begins, "Add the attribute."  Here are some questions.

1. What are the AVP flag rules?  M=MUST, P=MAY, V=MUST NOT, MAY Encr= Y?

2. Do I list 

      http://www.nanpa.com/number_resource_info/ani_ii_assignments.html

   as a normative reference?

3. I assume type is enumerated.  How much detail on the AVP values do I 
   include?  Only the reference?  An abbreviated list of current values?
   ani_ii_assignments.html in its entirety?

4. Which messages may this AVP occur in?   AAR, DER, ACR, and ACA?

5. How many times may this AVP occur?  0-1?