Subject: RE: [AAA-WG]: Issue 244: ELECTION_LOST result code

From: <[email-masked]>
Date: Wed, 6 Mar 2002 17:29:19 +0200

Hi Fredrik,

> I agree that this issue should be rejected. And I guess it 
> has. The strange
> thing is that I can't find the Result Code ELECTION_LOST anywhere in
> base-10? Has it been deleted anyway?

There was continued discussion on this, that it is not used anymore.
So, I have removed it.  However, I just noticed one mail I did not
see - I've included the relevant mails.

So, we are left with 3 possibilities:
1) ELECTION_LOST code removed from the spec
2) Restore ELECTION_LOST code to where it was in Base (Disconnect-Cause AVP)
3) Put ELECTION_LOST into the Result_Code AVP, probably under Transient Failures

Your thoughts?
John

Subject: Re: [AAA-WG]: Issue 244: ELECTION_LOST result code
From: <[email-masked]>
To: <[email-masked]>, <[email-masked]>, <[email-masked]>
Date: Wed, 27 Feb 2002 00:05:43 +0200

> I don't understand why this is being rejected.  Is the ELECTION_LOST
> result code used anymore?

Agreed.  If memory serves, originally when a peer lost an election, it would
send a CEA with a result code indicating success and then immediately send a
DPR with a Disconnect-Cause indicating ELECTION_LOST.  As a result of the
last interop event, it was decided it would be better to just send a CEA
with the ELECTION_LOST result code.  Thus, the idea with this issue was to
simply move this result code from the enumerated Disconnect-Cause AVP into
the Result-Code AVP.

-Kev

>
> Don Z.
>
> [email-masked] wrote:
>
> > This issue has been marked as a poosible reject. I agree & unless
> > someone speaks up, I will mark this as a reject.
> >
> > John
> >
> > Issue 244: ELECTION_LOST result code
> > Submitter name: Michael Chen
> > Submitter email address: [email-masked]
> > Date first submitted: 19-Nov-01
> > Reference:
> > Document: base-08
> > Comment type: E
> > Priority: 1
> > Section: Base: 5.4.3
> >
> > Rationale/Explanation of issue:
> > DPR is not sent to its peer when lost the election so ELECTION_LOST
> > result code is not used.
> >
> > Requested change:
> > Remove this result code.
>

Subject: Re: [AAA-WG]: Issue 244: ELECTION_LOST result code
From: <[email-masked]>
To: <[email-masked]>
Cc: <[email-masked]>
Date: Tue, 26 Feb 2002 23:18:27 +0200

I don't understand why this is being rejected.  Is the ELECTION_LOST
result code used anymore?

Don Z.

[email-masked] wrote:

> This issue has been marked as a poosible reject. I agree & unless
> someone speaks up, I will mark this as a reject.
>
> John
>
> Issue 244: ELECTION_LOST result code
> Submitter name: Michael Chen
> Submitter email address: [email-masked]
> Date first submitted: 19-Nov-01
> Reference:
> Document: base-08
> Comment type: E
> Priority: 1
> Section: Base: 5.4.3
>
> Rationale/Explanation of issue:
> DPR is not sent to its peer when lost the election so ELECTION_LOST
> result code is not used.
>
> Requested change:
> Remove this result code.

---

From: Johan Johansson <[email-masked]>
Date: Wed, 06 Mar 2002 17:55:03 +0100

It was decided at the diameter bakeoff that when a connection lost the 
election a CEA with ELECTION_LOST as result code should be sent instead 
of a DPR which would imply that all connections with the peer was 
severed. Unless this has for some reason been changed afterwards 
ELECTION_LOST is used and must therefore remain.

j