Subject: RE: [AAA-WG]: Issue 244: ELECTION_LOST result code

From: "Fredrik Johansson" <[email-masked]>
Date: Wed, 6 Mar 2002 14:56:27 +0100

I agree that this issue should be rejected. And I guess it has. The strange
thing is that I can't find the Result Code ELECTION_LOST anywhere in
base-10? Has it been deleted anyway?

/Fredrik

>-----Original Message-----
>From: [email-masked] [mailto:[email-masked]]On Behalf Of
>[email-masked]
>Sent: den 26 februari 2002 21:46
>To: [email-masked]
>Subject: [AAA-WG]: Issue 244: ELECTION_LOST result code
>
>
>This issue has been marked as a poosible reject. I agree & unless
>someone speaks up, I will mark this as a reject.
>
>John
>
>Issue 244: ELECTION_LOST result code
>Submitter name: Michael Chen
>Submitter email address: [email-masked]
>Date first submitted: 19-Nov-01
>Reference:
>Document: base-08
>Comment type: E
>Priority: 1
>Section: Base: 5.4.3
>
>Rationale/Explanation of issue:
>DPR is not sent to its peer when lost the election so ELECTION_LOST
>result code is not used.
>
>Requested change:
>Remove this result code.

---

From: <[email-masked]>
Date: Thu, 28 Mar 2002 14:11:07 +0200

Johan,

It has been moved to 7.1.4  Transient Failures now.

John

> From: ext Johan Johansson [mailto:[email-masked]]
> Sent: 06 March, 2002 19:14
> To: Loughney John (NRC/Helsinki)
> Cc: [email-masked]; [email-masked]
> Subject: Re: [AAA-WG]: Issue 244: ELECTION_LOST result code
> 
> 
> Probably. I guess someone will pop up soon and claim that the 
> socket is 
> just torn down, which is what is in section 5.6 in the peer state 
> machine. I'm not sure if this is just because Pat never got around to 
> documenting the decision or if it was later overturned.
> 
> The thinking around sending a CEA instead of just tearing down the 
> socket was that it seemed more civilized and can't be 
> misinterpreted as 
> a proper network failure, not even momentarily.
> 
> If this is no longer the consensus then it should be removed. 
> Or rather 
> not unremoved I guess.
> 
> j
> 
> [email-masked] wrote:
> 
> >Johan,
> >
> >So 3) Put ELECTION_LOST into the Result_Code AVP, probably 
> >      under Transient Failures
> >
> >is the corrent answer, correct?
> >
> >John
> >
> >>From: ext Johan Johansson [mailto:[email-masked]]
> >>Sent: 06 March, 2002 18:55
> >>To: Loughney John (NRC/Helsinki)
> >>Cc: [email-masked]; [email-masked]
> >>Subject: Re: [AAA-WG]: Issue 244: ELECTION_LOST result code
> >>
> >>
> >>It was decided at the diameter bakeoff that when a connection 
> >>lost the 
> >>election a CEA with ELECTION_LOST as result code should be 
> >>sent instead 
> >>of a DPR which would imply that all connections with the peer was 
> >>severed. Unless this has for some reason been changed afterwards 
> >>ELECTION_LOST is used and must therefore remain.
> >>
> >>j
> >>
> >>[email-masked] wrote:
> >>
> >>>Hi Fredrik,
> >>>
> >>>There was continued discussion on this, that it is not 
> used anymore.
> >>>So, I have removed it.  However, I just noticed one mail I did not
> >>>see - I've included the relevant mails.
> >>>
> >>>So, we are left with 3 possibilities:
> >>>1) ELECTION_LOST code removed from the spec
> >>>2) Restore ELECTION_LOST code to where it was in Base 
> >>>
> >>(Disconnect-Cause AVP)
> >>
> >>>3) Put ELECTION_LOST into the Result_Code AVP, probably 
> >>>
> >>under Transient Failures
> >>
> >>>Your thoughts?
> >>>John
> >>>
> >>
> >>
> >>
> >
> 
> 
> 
>