Subject: [AAA-WG]: Updated AAA WG issues list

From: Bernard Aboba <[email-masked]>
Date: Sat, 9 Mar 2002 18:58:40 -0800 (PST)

I've gone and updated the issues list. Here is the latest version:

http://www.drizzle.com/~aboba/AAA/issues.html

If there any issues that you believe are open that are listed as closed,
let me know. Similar, if issues listed as open are resolved, send me some
mail. 

-Bernard

---

From: Stephen Farrell <[email-masked]>
Date: Mon, 11 Mar 2002 14:57:19 +0000

Bernard,

The list isn't in synch with cms-04. I think that only 278 
ought remain (what do you think Jari?).

Some details below,
Cheers,
Stephen.

Issue 278: CMS issues

  This one contains a bunch of different things: 

     "People who have read the CMS document do not clearly understand
      that PDS mechanisms are not intended to create actual security
      associations, but just to offload the computations to someone else."

     I tried to clarify the text in various places.

     "Secondly, the document does not explain what to do in case
      NO_CMS_THROUGH_PROXY is maliciously returned from somewhere
      else than in our own domain."

     I think that (some of?) the requested text was added prior
     to me taking over as editor. I think that this is also affected
     by the resolution of 221/291, but could well warrant additional
     clarification.

     "Thirdly, there's some spelling problems."

     Dun doze:-)

To be closed:

Issue 221: Why require CMS to send its expected AVPs? 
Issue 279: Base does not sufficiently explain what MAY encrypt means

  The resolution to both these was to remove the expected-* AVPs 
  from CMS, and change the defintion of "MAY Encr" in both base 
  and CMS. The agreed change in the CMS I-D is at the end
  of section 3.1:

   "Note: [BASE] includes the "MAY encr" column when describing AVPs. For
    the originator "MAY encr" as used in [BASE] means that if a message
    containing that AVP is to be sent via a proxy/agent (as opposed to
    directly) then the message MUST NOT be sent unless there is a DSA
    between the originator and the recipient OR the originator has
    locally trusted configuration that indicates that CMS need not be
    used."

Issue 276 : Remove section 1.6 from the CMS appl

  The section 1.6 that was in -03 is removed from -04. (The -03
  1.7 is now 1.6, a new 1.7 was added to clarify something that
  came up during editing.)

Issue 291: Remove references to CMS-Cert in cms-sec-03

  The string CMS-Cert doesn't occur in -04.

-- 
____________________________________________________________
Stephen Farrell         				   
Baltimore Technologies,   tel: (direct line) +353 1 881 6716
39 Parkgate Street,                     fax: +353 1 881 7000
Dublin 8.                mailto:[email-masked]
Ireland                             http://www.baltimore.com

---

From: Bernard Aboba <[email-masked]>
Date: Mon, 11 Mar 2002 09:24:53 -0800 (PST)

Thanks for the update, Stephen. I will update the issues list accordingly.

---

From: "Bob Kopacz" <[email-masked]>
Date: Mon, 11 Mar 2002 14:05:55 -0500

Hi Tony and Bernard,

If it's ok with Tony, you can remove Issue 292: "Handling of
Home-Agent-In-Foreign-Network flag" from the issues list.  This was an
issue I submitted on 02-27-2002.

After getting some feedback from Tony, and thinking it over more, I
submitted Issue 299: "Need more explanation about handling MN handoffs"
on 03-04-2002.  

To my mind, issue #299 supersedes issue#292.

Bob K.

---

From: Bernard Aboba <[email-masked]>
Date: Mon, 11 Mar 2002 11:11:12 -0800 (PST)

Done.

---

From: David Spence <[email-masked]>
Date: Tue, 12 Mar 2002 16:37:30 -0500

Bernard,

Here is the disposition of the issues listed as "NASREQ Open Issues" in 
the latest issues list.      

188   NAS-Key-Binding and Ciphersuite Negotiation

      This issue was listed as resolved in nasreq-08 on the 2/11 issues 
      list.  Is there some reason to believe it was not resolved?
      
189   NAS-Session-Key and Initialization Vectors
      
      This issue was listed as resolved in nasreq-08 on the 2/11 issues 
      list.  Is there some reason to believe it was not resolved?
      
190   NAS-Session-Key and Session Master Keys
      
      This issue was listed as resolved in nasreq-08 on the 2/11 issues 
      list.  Is there some reason to believe it was not resolved?
      
246   Accounting-*-Extended-Octets numbers are inconsistent
      
      Resolved in nasreq-09.

251   References to ADIF in NASREQ-08
      
      Resolved in nasreq-09.
      
255   Translation of RADIUS vendor-specific attributes
      
      Still pending.
      
264   User-Name in Answer messages
      
      Resolved in nasreq-09.
      
293   Relax Service-Type from REQUIRED to RECOMMENDED in nasreq
      
      New issue since the 2/11 issues list.  Resolved in nasreq-09.
      
294   NASREQ Key Distribution insecure
      
      New issue since the 2/11 issues list.  Still pending.
      
295   More NASREQ AVPs needed
      
      New issue since the 2/11 issues list.  Still pending.
      
297   NASREQ-specific values for Termination-Cause AVP
      
      New issue since the 2/11 issues list.  Still pending.
      
300   EAP corner conditions
      
      New issue since the 2/11 issues list.  Still pending.

---

From: David Spence <[email-masked]>
Date: Thu, 14 Mar 2002 16:16:08 -0500

I submitted two issues that are not included on the list:

   Ambiguities in AVP Flag rules tables
      http://www.merit.edu/mail.archives/aaa-wg/2002-02/msg00147.html
      I believe this issue was resolved in both base-09 and cms-sec-04.

   Fix conflicting AVP codes in NASREQ
      http://www.merit.edu/mail.archives/aaa-wg/2002-02/msg00187.html
      I included the requested change in nasreq-09.

      This issue is important to document because I changed the AVP codes
      of two previously defined AVPs which will affect all implementations
      based on nasreq-08.

Also, I requested on 3/1/2002 that issue 218, "ABNF/Table inconsistencies",
be moved from resolved to open.  It is listed as resolved in Base-08,
MIP-08, NASREQ-08, and CMS-03.  I discovered, however, that it was
definitely not fixed in nasreq-08.  It is fixed in nasreq-09, but I would
like the other editors to confirm whether or not it is fixed in the other
drafts before we list it as resolved.

---

From: Bernard Aboba <[email-masked]>
Date: Thu, 14 Mar 2002 15:51:44 -0800 (PST)

Thanks. I've updated the issues list accordingly.