Subject: RE: [AAA-WG]: Issue #327: Message routing and vendor specific app lications

From: "Pat R. Calhoun" <[email-masked]>
Date: Tue, 16 Apr 2002 07:49:32 -0700

"If the application is one defined by the Diameter workgroup the
vendor id is 0."

Could be replaced with

"For all IETF standards track Diameter applications, the vendor id
MUST be set to zero."

PatC

- -----Original Message-----
From: Johan Johansson [mailto:[email-masked]] 
Sent: Tuesday, April 16, 2002 7:46 AM
To: Pat R. Calhoun
Cc: [email-masked]'; [email-masked];
[email-masked]
Subject: Re: [AAA-WG]: Issue #327: Message routing and vendor
specific app lications

I agree with Pat that Diameter workgroup is suboptimal, but it was
all I 
could think of at the time. Would IETF be wildly misleading?

j

Pat R. Calhoun wrote:

>  
> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
>
> Except that Diameter workgroup is not a known entity. Perhaps 
> Standards track instead?
>
> PatC
>
> - -----Original Message-----
> From: [email-masked] [ mailto:[email-masked]]
> Sent: Tuesday, April 16, 2002 12:12 AM
> To: [email-masked]
> Cc: [email-masked]; [email-masked]
> Subject: RE: [AAA-WG]: Issue #327: Message routing and vendor
> specific  applications
>
>
> Hi Johan,
>
> > Actually on second thought we should probably even change it to 
> >
> > ----------
> >
> > - Application Identifier. An application is identified by a
> > vendor  id and an application id. If the application is one
> > defined by the  Diameter workgroup the vendor id is 0. A route
> > entry can have a  different destination based on the application
> > identification avp of the message.
> > This is one of Acct-Application-Id (for accounting
> > messages), Auth-Application-Id (for non-accounting messages) or
> > Vendor-Specific-Application-Id (for vendor specific messages).
> > This 
> >  field MUST be used as a secondary key field
> > in routing table lookups.
>
> I think this is OK.
>
> John
>
> -----BEGIN PGP SIGNATURE-----
> Version: PGPfreeware 7.0.3 for non-commercial use < 
> http://www.pgp.com>
>
> iQA/AwUBPLw37zN1fXKoxmisEQJimwCgpz2GRu7NwswM1t+n5WxKeRbBXXcAn1UC
> LIULXOcDjuyI5NMSvKRtf5Jp
> =5tUq
> -----END PGP SIGNATURE-----
>

---

From: Johan Johansson <[email-masked]>
Date: Tue, 16 Apr 2002 16:56:14 +0200

A minor detail, but I specifically avoided using the word MUST since it 
implies that it could be done any other way. There is nothing to set to 
0. The application's vendor id *is* 0.

j

Pat R. Calhoun wrote:

> From: Johan Johansson [ mailto:[email-masked]]
> > http://www.pgp.com >
> Version: PGPfreeware 7.0.3 for non-commercial use < http://www.pgp.com>
>
> iQA/AwUBPLw5/DN1fXKoxmisEQJxCgCfba2VqYWIUtO5zUNGNM1v9m1hI+AAnAm3
> yGGw5FJTWs6M+riiLPpykI1g
> =76Up