Subject: RE: [AAA-WG]: [issue] Accounting-Realtime-Required

From: <[email-masked]>
Date: Mon, 1 Apr 2002 22:58:42 +0300

Hi Bernard,

This is a good catch, the change has been made, so this issue can be marked closed.

John

> -----Original Message-----
> From: ext Bernard Aboba [mailto:[email-masked]]
> Sent: 29 March, 2002 16:23
> To: Pete McCann
> Cc: [email-masked]
> Subject: Re: [AAA-WG]: [issue] Accounting-Realtime-Required
> 
> 
> Assigned #319. 
> 
> On Thu, 28 Mar 2002, Pete McCann wrote:
> 
> > 
> > Issue:                    Accounting-Realtime-Required should appear
> >                           in Section 9.7.2, and text in 
> Section 9.8.7
> >                           should give its AVP Code
> > Submitter name:           Pete McCann
> > Submitter email address:  [email-masked]
> > Date first submitted:     03-28-2002
> > Reference:
> > Document:                 diameter-base-09
> > Comment type:             Editorial
> > Priority:                 1
> > Section:                  9.7.2, 9.8.7
> > 
> > Rationale:
> > 
> > The Accounting-Realtime-Required AVP is defined in Section 
> 9.8.7, but
> > is not mentioned in the ABNF for Accounting-Answer messages 
> in Section
> > 9.7.2.  Also, the description in Section 9.8.7 lists the AVP Code as
> > "TBD", but the table on page 50-51 lists the AVP with Code 483.
> > 
> > Requested Change:
> > 
> > Add the following line to 9.7.2,
> > after "[Accounting-Interim-Interval]":
> > 
> >                   [ Accounting-Realtime-Required ]
> > 
> > Change the first line of Section 9.8.7 to read:
> > 
> >    The Accounting-Realtime-Required AVP (AVP Code 483) is of type
> > 
> > 
> > 
> > -Pete
> > 
> 
>

---

From: Joe Lau <[email-masked]>
Date: Mon, 1 Apr 2002 14:22:40 -0800 (PST)

Hello,

Section 1 of the AAA NAI for Mobile IPv4 Extension draft says:

To solve this the home agent MUST include the AAAH NAI in the
registration reply message, which the mobile node then MUST include
in every subsequent registration request sent to a foreign agent when
change point of attachement.

It is clear that the MN must include the AAA NAI in every subsequent
registration request.  But it is not clear whether the Home Agent
must incude the AAA NAI in _every_ registration reply message.

My own interpretation would be the Home Agent must inlcude the AAAH NAI
in the _initial_ registration reply message (e.g. the one that is 
delivered via the HAA message).  The MN then will cache the AAAH NAI
and use it for every subsequent registraton request.

Is this also what the author has in mind?

Thanks for the clarification.

Regards,

Joe lau

---

From: "Kevin Purser" <[email-masked]>
Date: Mon, 1 Apr 2002 14:36:34 -0800

Joe,

Section 5, paragraph 2 states:

"The home agent MUST provide this in every registratin reply if using
   the AAA server for authentication."

So, every time the HA creates and sends a MIP reg reply and returns it to a
AAA server through a HAA message, the AAA NAI must be present.

-Kevin

----- Original Message ----- 
From: "Joe Lau" <[email-masked]>
To: <[email-masked]>
Cc: <[email-masked]>
Sent: Monday, April 01, 2002 2:22 PM
Subject: [AAA-WG]: Re: AAA NAI for Mobile IPv4 Extension draft

> This message uses a character set that is not supported by the Internet
> Service.  To view the original message content,  open the attached
> message. If the text doesn't display correctly, save the attachment to
> disk, and then open it using a viewer that can display the original
> character set. <<message.txt>> 
>

---

From: Joe Lau <[email-masked]>
Date: Mon, 1 Apr 2002 14:50:01 -0800 (PST)

Kevin,

> AAA server through a HAA message, the AAA NAI must be present.

Ahh, I wasn't clear in my stating my own interpretation. 
What I meant was that the HA does not need to include the AAA NAI in 
_every_ registration reply message it sends back to the MN (only on the
reply that is delivered via the HAA message). 

I guess I didn't read section 5 carefully.

Regards,

Joe Lau