Subject: [AAA-WG]: Minor corrections/clarifications to base-10 about Failed-AVP.

From: [email-masked]
Date: Tue, 9 Apr 2002 15:03:49 +0900

Hi, 

Minor corrections/clarifications to base-10 about Failed-AVP. 
I wonder, Is this can be Issue ?
Regards, 
Byung-Gil Lee

Issue :                 Minor corrections/clarifications to base-10 about
Failed-AVP
Submitter name:         BG Lee
Submitter email address: [email-masked] 
Date first submitted:   04-9-2002 
Reference: 
Document:               draft-base-10 
Comment type:           Technical 
Priority:               ? 
Section:  			7.5  Failed-AVP AVP

In section 7.5 Failed-AVP,

7.5  Failed-AVP AVP

...presence of two or more occurrences of an AVP which is restricted to 0,
1, or 0-1
occurrences.
..   A Diameter message MAY contain one Failed-AVP AVP, containing the
   entire AVP that could not be processed successfully. If the failure
reason is omission 
of a required AVP, an AVP with the missing AVP code, the missing vendor id,
and 
a zero filled payload of the minimum required length for the omitted AVP
will be added.

but...
Currently, there is no way to enter the two or more Reason Code in Result-
Code  AVP 
and it is difficuit to match the Result-Code AVP and Failed-AVP.
so...

Existing : 

7.5  Failed-AVP AVP

      AVP Format

      <Failed-AVP> ::= < AVP Header: 279 >
                    1* {AVP}

Requested change: 

   AVP Format

      <Failed-AVP> ::= < AVP Header: 279 >
					1* {
							{Result-Code
AVP}/*Following AVP's Error Cause Value included*/
    	                	{AVP}
						}

---

From: Bernard Aboba <[email-masked]>
Date: Wed, 10 Apr 2002 07:43:41 -0700 (PDT)

Assigned Issue #329.