Subject: RE: [AAA-WG]: What is Result Cause Value ? In Multi-Failed AVP Case.

From: <[email-masked]>
Date: Mon, 15 Apr 2002 13:00:03 +0300

Hi all,

Any comments on the suggested solution?

John

==============

Minor corrections/clarifications to base-10 about Failed-AVP. 
I wonder, Is this can be Issue ? 
Regards, 
Byung-Gil Lee 
ETRI Information Security Technology Division 

Issue :                 What is Result Cause Value ?  In multi-Failed AVP Case. 
Submitter name:         BG Lee 
Submitter email address: [email-masked] 
Date first submitted:   04-9-2002 
Reference: 
Document:               draft-base-10 
Comment type:           Technical 
Priority:               ? 
Section:                        7.5  Failed-AVP AVP 

In section 7.5 Failed-AVP, 

7.5  Failed-AVP AVP 

The Failed-AVP AVP (AVP Code 279) is of type Grouped and provides debugging 
information in cases where a request is rejected or not fully processed due to 
erroneous information in a specific AVP. The value of the Result-Code AVP will 
provide information on the reason for the Failed-AVP AVP. 
... 

but... 
Currently, there is no way to enter the two or more Reason Code in Result-Code  AVP 
and it is difficult to match the Result-Code AVP and Failed-AVP. 
so... 

Existing : 

7.5  Failed-AVP AVP 

      AVP Format 
      <Failed-AVP> ::= < AVP Header: 279 > 
                    1* {AVP} 

Requested change: 

   AVP Format 
    <Failed-AVP> ::= < AVP Header: 279 > 
            1* { 
                      1* {Result-Code AVP}/*Following AVP's Error Cause Value included*/ 
                          {AVP} 
                  }

---

From: David Frascone <[email-masked]>
Date: Mon, 15 Apr 2002 08:06:16 -0500

I think that reporting and handling multiple errors is extremely difficult
to do.  I think for debugging, this would be a great feature.  But, as far
as full implementations go, it is not anything useful.

It doesn't change the behavior of the protocol, just adds more work to handle
the multiple errors.

So, I vote "no".

-Dave

-- 
David Frascone

                      Chaste makes waste.

---

From: Jari Arkko <[email-masked]>
Date: Thu, 18 Apr 2002 13:45:40 +0300

> It doesn't change the behavior of the protocol, just adds more work to handle

Me too. Should make clear though that the Diameter nodes are to report the
first error they encounter, irrespective of potential other errors in the
message.

Jari