Subject: [AAA-WG]: What is Result Cause Value ? In Multi-Failed AVP Case.

From: [email-masked]
Date: Wed, 10 Apr 2002 10:00:41 +0900

Hi All.
 
If Failed-AVP MAY contain two or more AVPs, I think that Failed-AVP is not
sufficient.  
It should contain a list of error cause code. 
For example we can consider multiple failed AVP, 
Result-Code AVPs of error cause types should contain.

so,

I suggest the modified Failed AVP...
Please, some comments. 

----------------------------------------------------------------------

Minor corrections/clarifications to base-10 about Failed-AVP. 
I wonder, Is this can be Issue ? 
Regards, 
Byung-Gil Lee 
ETRI Information Security Technology Division

Issue :                 What is Result Cause Value ?  In multi-Failed AVP
Case. 
Submitter name:         BG Lee 
Submitter email address: [email-masked] 
Date first submitted:   04-9-2002 
Reference: 
Document:               draft-base-10 
Comment type:           Technical 
Priority:               ? 
Section:                        7.5  Failed-AVP AVP 

In section 7.5 Failed-AVP, 

7.5  Failed-AVP AVP 

The Failed-AVP AVP (AVP Code 279) is of type Grouped and provides debugging 
information in cases where a request is rejected or not fully processed due
to 
erroneous information in a specific AVP. The value of the Result-Code AVP
will 
provide information on the reason for the Failed-AVP AVP.
...

but... 
Currently, there is no way to enter the two or more Reason Code in Result-
Code  AVP 
and it is difficult to match the Result-Code AVP and Failed-AVP. 
so... 

Existing : 

7.5  Failed-AVP AVP 

      AVP Format 
      <Failed-AVP> ::= < AVP Header: 279 > 
                    1* {AVP} 

Requested change: 

   AVP Format 

    <Failed-AVP> ::= < AVP Header: 279 > 
            1* { 
                      1* {Result-Code AVP}/*Following AVP's Error Cause
Value included*/ 
                     	  {AVP} 
                  } 

----------------------------------------------------------
Byung-Gil Lee
Electronics and Telecommunications 
Research Institute, KOREA
----------------------------------------------------------

---

From: <[email-masked]>
Date: Mon, 22 Apr 2002 11:00:30 +0300

Hi Jari,

> Yes, I agree. But what I really meant was that the diameter
> nodes should report the first error THEY encounter (could
> be different by different implementations). I'm not sure we
> explicitly state this anywhere at the moment. Hmm... checking...
> how about changing the last paragraph of 7 from
> 
>     The Result-Code AVP contains additional errors conditions, and
>     defines the expected behavior of each.
> 
> to
> 
>     The Result-Code AVP describes the error that the Diameter node
>     encountered in its processing. In case there are multiple errors,
>     the Diameter node MUST report only the first error it encountered
>     (detected possibly in some implementation dependent order). The
>     specific errors that can be described by this AVP are described in
>     the following section.

That's reasonable, I've made the change.

John