Subject: RE: [AAA-WG]: Result codes in vendor specific applications

From: "Miguel-Angel Pallares-Lopez (ECE)" <[email-masked]>
Date: Mon, 29 Apr 2002 09:33:55 +0200

Hi,

One minor editorial comment:

Where it says:
"All Diameter answer messages defined in vendor-specific 
applications MUST include either one Result-Code AVP or one 
Vendor-Specific-Result-Code AVP."

It should say:
"All Diameter answer messages defined in vendor-specific 
applications MUST include either one Result-Code AVP or one 
Vendor-Specific-Result AVP."

Regards,
Miguel

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Wednesday, April 24, 2002 6:35 AM
> To: [email-masked]; [email-masked]
> Subject: RE: [AAA-WG]: Result codes in vendor specific applications
> 
> 
> Hi all,
> 
> I think that this can be accomadated - does anyone have misgivings
> about this?
> 
> John
> 
> > -----Original Message-----
> > From: ext Mark Jones [mailto:[email-masked]]
> > Sent: 22 April, 2002 23:45
> > To: [email-masked]
> > Subject: RE: [AAA-WG]: Result codes in vendor specific applications
> > 
> > 
> > As I stated earlier, my preference is for a single result 
> > code per message.
> > If this is acceptable to the WG then building on 
> > Miguel-Angel's earlier text
> > submission, the following changes are required to the Base 
> > protocol draft:
> > 
> > ---
> > 
> > Modify section 7.1, replacing: "All Diameter answer messages 
> > MUST include
> > one Result-Code AVP" with "All Diameter answer messages 
> > defined in IETF
> > applications MUST include one Result-Code AVP."
> > 
> > ---
> > 
> > Add two new sub-sections to section 7:
> > 
> > 7.x Vendor-Specific-Result AVP
> > 
> > The Vendor-Specific-Result AVP (AVP Code tbd) is of type 
> Grouped, and
> > indicates whether a particular vendor-specific request was completed
> > successfully or whether an error occurred. Its Data field has 
> > the following
> > ABNF grammar:
> > 
> >       Vendor-Specific-Result ::= < AVP Header: tbd >
> >                                  { Vendor-Id }
> >                                  { Vendor-Specific-Result-Code }
> > 
> > The Vendor-Id AVP (see Section 5.3.3) in this grouped AVP 
> > identifies the
> > vendor responsible for the assignment of the result code 
> > which follows. All
> > Diameter answer messages defined in vendor-specific 
> applications MUST
> > include either one Result-Code AVP or one 
> > Vendor-Specific-Result-Code AVP.
> > 
> > 7.y Vendor-Specific-Result-Code AVP
> > 
> > The Vendor-Specific-Result-Code AVP (AVP Code TBD) is of type 
> > Unsigned32 and
> > contains a vendor-assigned value representing the result of 
> > processing the
> > request.
> > 
> > It is recommended that vendor-specific result codes follow the same
> > conventions given for the Result-Code AVP regarding the 
> > different types of
> > result codes and the handling of errors (for non 2xxx values).
> > 
> > ---
> > 
> > In chapter 4.6:
> > 
> > After:
> > ...
> > Vendor-Specific- 260 6.10 Grouped | M | P |   | V | N |
> >    Application-Id                 |   |   |   |   |   |
> > 
> > Add:
> > 
> > Vendor-Specific- TBD 7.x Grouped    | M | P |   | V | N |
> >    Result                           |   |   |   |   |   |
> > Vendor-Specific- TBD 7.y Unsigned32 | M | P |   | V | N |
> >    Result-Code                      |   |   |   |   |   |
> > 
> > Regards,
> >        Mark
> > 
> > 
>

---

From: "Mark Jones" <[email-masked]>
Date: Tue, 30 Apr 2002 08:56:15 -0400

> Vendor-Specific-Result AVP."

Agreed. Well spotted, Miguel.

Regards,
       Mark