Subject: RE: [AAA-WG]: [issue] Bug in Acct state machine + Split State Machines into Client vs. Server

From: <[email-masked]>
Date: Thu, 4 Apr 2002 14:59:07 +0300

Hi,

But should the accounting server be able to terminate the accounting session (and client will do the rest)? 

The base chapter 8.5 refers :"...the diameter server that originally _authorized_ the session may be required to cause that session to be stopped for _credit_ or other reasons..."

The credit is mentioned as a one termination reason, so should also the accounting server be able to do that termination with ASR?? Is there something missing or too much? ;)

br,
JPK

-----Original Message-----
From: ext Johan Johansson [mailto:[email-masked]]
Sent: 04. April 2002 14:39
To: Koskinen Juha-Pekka (NET/Tampere)
Cc: [email-masked]; [email-masked];
[email-masked]; Lialiamou Elena (NET-IMN/Helsinki)
Subject: Re: [AAA-WG]: [issue] Bug in Acct state machine + Split State
Machines into Client vs. Server

An accounting server can not initiate a session termination unless it 
through some means has access to the session id of the authorization 
session.

j

[email-masked] wrote:

>Hi,
>
>The case I referred is that the connection is ok but the client just failed to start the timer. 
>
>In these cases the server (when case noticed) may send ASR and client have to disconnect the session. 
>When ASA is received, the server could also close the session. 
>If ASA is not received, server will know that something more serious is wrong and left the session open(/pending). Then, I guess, there should not be problem when records come later? 
> 
>br,
>JPK
>
>
>-----Original Message-----
>From: ext Jari Arkko [mailto:[email-masked]]
>
>
>[email-masked] wrote:
>
>>Hi,
>>
>>I may have missed some parts of the discussion so forgive me if my question is irrelevant..
>>
>
>Not at all. Your comments are very relevant.
>
>>If the server has only idle state, what will be the actions in cases where ACA has interim-interval and for some reason client ignores it (timer failure)? It crossed my mind that server might have timer of it's own and when it has expired and no ACR INTERIM_RECORD has been received, some actions will be taken. Or...?
>>
>
>I sympathize with the desire to do that but the question is,
>what *can* we do?
>
>Answer A: Nothing. (current state machine)
>
>Answer B: Close the session. But what if there was a network
>partition and the records come in tomorrow when it is fixed?
>
>Jari
>

---

From: Jari Arkko <[email-masked]>
Date: Thu, 04 Apr 2002 14:49:41 +0300

> The credit is mentioned as a one termination reason, so should also the accounting server be able to do that termination with ASR?? Is there something missing or too much? ;)

I believe the idea is that ASR can be used, on a application dependent basis, at
the server end to cause a disconnect. Accounting-Auth server communication may
be needed to accomplish this in some cases. But in all cases the reasons to do
an ASR are outside the scope of the Diameter state machines.

Jari