Subject: RE: [AAA-WG]: [issue] Bug in Acct state machine + Split State Machines into Client vs. Server

From: <[email-masked]>
Date: Thu, 4 Apr 2002 14:16:54 +0300

Hi,

The case I referred is that the connection is ok but the client just failed to start the timer. 

In these cases the server (when case noticed) may send ASR and client have to disconnect the session. 
When ASA is received, the server could also close the session. 
If ASA is not received, server will know that something more serious is wrong and left the session open(/pending). Then, I guess, there should not be problem when records come later? 
 
br,
JPK

-----Original Message-----
From: ext Jari Arkko [mailto:[email-masked]]

[email-masked] wrote:
> 
> Hi,
> 
> I may have missed some parts of the discussion so forgive me if my question is irrelevant..

Not at all. Your comments are very relevant.

> If the server has only idle state, what will be the actions in cases where ACA has interim-interval and for some reason client ignores it (timer failure)? It crossed my mind that server might have timer of it's own and when it has expired and no ACR INTERIM_RECORD has been received, some actions will be taken. Or...?

I sympathize with the desire to do that but the question is,
what *can* we do?

Answer A: Nothing. (current state machine)

Answer B: Close the session. But what if there was a network
partition and the records come in tomorrow when it is fixed?

Jari

---

From: Johan Johansson <[email-masked]>
Date: Thu, 04 Apr 2002 13:39:23 +0200

An accounting server can not initiate a session termination unless it 
through some means has access to the session id of the authorization 
session.

j

---

From: Jari Arkko <[email-masked]>
Date: Thu, 04 Apr 2002 14:47:20 +0300

> In these cases the server (when case noticed) may send ASR and client have to disconnect the session. 

That's fine but what mechanisms do we have for knowing if the client
failed to start the timer, or if this is a network problem? Note that
we already have Accounting-Realtime-Requirements AVP which, on correctly
implemented Diameter nodes, allows the server to control what to do if acct
data doesn't get through.

But I don't see any way how I could distinguish incorrect implementation
and network partition just by looking at the messages the server receives.
Do you?

Jari