Subject: RE: [AAA-WG]: Suggestion about hierarchical realms a poor one

From: <[email-masked]>
Date: Mon, 15 Apr 2002 12:52:06 +0300

Hi Johan,

Do you suggest deleting all of section 6.1 or making a simplification
of it?

John

> -----Original Message-----
> From: ext Bernard Aboba [mailto:[email-masked]]
> Sent: 10 April, 2002 17:32
> To: Johan Johansson
> Cc: aaa-wg
> Subject: Re: [AAA-WG]: Suggestion about hierarchical realms a poor one
> 
> 
> Assigned Issue #328.
> 
> On Sun, 7 Apr 2002, Johan Johansson wrote:
> 
> > Issue:          Suggestion about hierarchical realms a poor one
> > Submitter name: Johan Johansson
> > Submitter email address:[email-masked]
> > Date first submitted: 04-09-2002 
> > Reference: 
> > Document:       draft-base-10-2
> > Comment type:   Technical 
> > Priority:       1 
> > Section: 6.1   
> > 
> > Rationale:
> > 
> > The suggestion is that
> > 
> > 
> > For routing of Diameter messages to work within an administrative
> >    domain, all Diameter nodes within the realm MUST be peers. If
> >    intermediate nodes are desired (see Figure 5), the 
> destination node
> >    MUST be in a subrealm and routes to that subrealm MUST 
> exist in the
> >    routing table on the sending node and all intermediate 
> nodes. Figure
> >    5 shows an example of a hierarchical network that 
> requires the use of
> >    subrealms. In such a network, routing must be performed 
> with longest
> >    match from right.
> > 
> > Figure 5 then goes on to describe a realm abc.com with e.g. 
> a subrealm 
> > called eng.abc.com and a relay node in between. It may not 
> be obvious 
> > from the draft, but the original example discussed that 
> motivated this 
> > text and figure in the first place as within the context of 
> the mobile 
> > ip application where there was a home server in the 
> containing realm 
> > abc.com and the home agents within the respective subrealms.
> > 
> > Assume that there is a user called [email-masked] 
> whose AMR is 
> > handled by the server aaah.abc.com. This is a centralized 
> home server 
> > that serves the entire realm abc.com and therefore it has a 
> route for 
> > abc.com that on longest match from right has a LOCAL_ACTION entry. 
> > Unfortunately this will never be selected since it must 
> have a route to 
> > eng.abc.com in order to send the HAR to the home agent, 
> which means that 
> > the AMR will arrive at a very surprised home agent.
> > 
> > Requested change:
> > 
> > Given the time constraints my suggestion is to fumble the issue and 
> > remove all mention of it from the document. Route configuration and 
> > network topology, within the context of the Mobile IP Diameter 
> > application at least, is a surprisingly non-intuitive topic.
> > 
> > j
> > 
> > 
> > 
> > 
> > 
> > 
> > 
> > 
> 
>

---

From: Johan Johansson <[email-masked]>
Date: Mon, 15 Apr 2002 12:04:26 +0200

The suggestion is to delete the part of section 6.1 that relates to 
hierarchical nets, nothing else. The rest is probably correct.

j