Subject: RE: [AAA-WG]: Suggestion about hierarchical realms a poor one

From: <[email-masked]>
Date: Mon, 15 Apr 2002 13:10:20 +0300

Hi Johan,

> The suggestion is to delete the part of section 6.1 that relates to 
> hierarchical nets, nothing else. The rest is probably correct.

So, I shall delete this:

For routing of Diameter messages to work within an administrative domain, all Diameter nodes within the realm MUST be peers. If intermediate nodes are desired (see Figure 5), the destination node MUST be in a subrealm and routes to that subrealm MUST exist in the routing table on the sending node and all intermediate nodes. Figure 5 shows an example of a hierarchical network that requires the use of subrealms. In such a network, routing must be performed with longest match from right.

.KS
.nf
                          +---------+
                          | abc.com |
                          +---------+

             +-------+                 +-------+
             | agent |                 | agent |
             +-------+                 +-------+

  +-------------+ +--------------+ +-------------+ +--------------+ 
  | eng.abc.com | | acct.abc.com | | mkt.abc.com | | exec.abc.com |
  +-------------+ +--------------+ +-------------+ +--------------+

John

---

From: Johan Johansson <[email-masked]>
Date: Mon, 15 Apr 2002 12:24:18 +0200

Sorry for insisting on being unclear.

[email-masked] wrote:

>For routing of Diameter messages to work within an administrative domain, all Diameter nodes within the realm MUST be peers.
>
Keep that sentence and delete the below.

> If intermediate nodes are desired (see Figure 5), the destination node MUST be in a subrealm and routes to that subrealm MUST exist in the routing table on the sending node and all intermediate nodes. Figure 5 shows an example of a hierarchical network that requires the use of subrealms. In such a network, routing must be performed with longest match from right.
>
>.KS
>.nf
>                          +---------+
>                          | abc.com |
>                          +---------+
>
>             +-------+                 +-------+
>             | agent |                 | agent |
>             +-------+                 +-------+
>
j