Subject: RE: [AAA-WG]: [Issue 330]: Diameter should not require separate TLS port

From: <[email-masked]>
Date: Fri, 12 Apr 2002 06:51:56 +0300

Hi Stephen,

> > The only gotcha is when the TLS handshake fails.  Do the 
> peers just fall
> > back to non-secure operation?
> 
> Eh - if so, why'd they bother trying to turn on TLS? Anyone 
> with access
> to the network can tweak bits and cause the TLS handshake to fail, so
> the answer to your question has to be a resounding "no".

Agreed.

John

---

From: <[email-masked]>
Date: Wed, 17 Apr 2002 10:43:46 +0300

Hi Dave,

> Ok, then NO_INBAND_SECURITY.  I think in the future someone 
> might define
> SSLv2,3 or JOE_BOBS_UNHACKABLE_SECURITY and use it instead of TLS.

I'll go with this.

John