Subject: RE: [AAA-WG]: Issue 349: Accounting Response Bloat

From: <[email-masked]>
Date: Wed, 29 May 2002 08:28:18 +0300

Hi Bernard,

Do you propose to strike the 2nd part of the text entirely (that is OK for me) or
modifying it to be something like:

	The Accounting-Answer command contains the same Session-Id and 
	includes the the usage AVPs only if the NSA specifically 
	requests that they be included, such as by including the CMS-
	DATA AVP.

John

> -----Original Message-----
> From: ext Bernard Aboba [mailto:[email-masked]]
> Sent: 28 May, 2002 01:24
> To: [email-masked]
> Subject: [AAA-WG]: Issue 349: Accounting Response Bloat
> 
> 
> Issue 349: Accounting Response Bloat
> Submitter name: Bernard Aboba
> Submitter email address: [email-masked]
> Date first submitted: May 22, 2002
> Reference: 
> Document: Base
> Comment type: T
> Priority: S
> Section: 9.7.2
> Rationale/Explanation of issue:
> 
> Early on, Accounting Response bloating was identified as an 
> issue in Diameter. For example, this is cited in
> Section 3.5 of draft-ietf-aaa-issues-05.txt, which
> refers to "SNMP-style" response bloat within Diameter. 
> The problem is having the AVPs included in the Accounting-Request
> echo'd in the Accounting-Answer, greatly increasing the size
> of the ACA message. 
> 
> Section 9.7.2 of Base states:
> 
> "The Accounting-Answer command contains the same Session-Id and 
> MAY contains the same Accounting Description and Usage AVPs 
> that were sent in the Accounting-Request command."
> 
> This is inappropriate. The only reason that the usage AVPs should
> be included in the Accounting-Answer is if the NAS specifically
> requests this, such as by including the CMS-Data AVP.
> 
> 
> 
>

---

From: Bernard Aboba <[email-masked]>
Date: Tue, 28 May 2002 22:59:35 -0700 (PDT)

> 	requests that they be included, such as by including the CMS-

This text would work for me.

---

From: Johan Johansson <[email-masked]>
Date: Wed, 29 May 2002 11:08:22 +0200

Just out of curiousity, why would anyone want the AVPs echoed back in 
the first place? Theoretically the server could create the response by 
the mere flick of a bit and replacing the source and destination AVPs, 
but this seems like an insignificant optimization to me and there is no 
gain to the access device? It can not be used for verification of the 
transmitted AVPs and CMS would be a much better candidate for that in 
any case.

Why is this needed/allowed at all?

j

---

From: Bernard Aboba <[email-masked]>
Date: Wed, 29 May 2002 07:23:52 -0700 (PDT)

I had assumed that it was needed/wanted in order for the NAS to check that
the received AVPs were the ones that were sent. However, the text does not
require or even suggest that such a check be done. 

Another reason would be if the NAS wanted a signed receipt. However, as
you point out, CMS is a better candidate for that. 

So it looks to me like you are making an argument that there is no
situation in which Response Bloating is helpful, and that it should be
prohibited. 

Does anyone want to speak up *for* Response Bloating?