Subject: Re: [AAA-WG]: [issue] Clarify relationship between auth and accounting sessions

From: Bernard Aboba <[email-masked]>
Date: Tue, 30 Apr 2002 20:51:23 -0700 (PDT)

Assigned issue 336. 

On Tue, 30 Apr 2002, Johan Johansson wrote:

> Submitter name: Johan Johansson
> Submitter email address: [email-masked]
> Date first submitted: 2002-April-30
> Document: base (could also be that mip is the correct one)
> Comment type: T
> Priority: S
> Section: 9.6
> Rationale/Explanation of issue:

---

From: <[email-masked]>
Date: Mon, 13 May 2002 16:37:18 +0300

Hi all, 

I have made the changes, so issue 336 is closed.

John

> -----Original Message-----
> From: Loughney John (NRC/Helsinki) 
> Sent: 02 May, 2002 10:32
> To: [email-masked]; [email-masked]
> Subject: RE: [AAA-WG]: [issue] Clarify relationship between auth and
> accounting sessions
> 
> 
> Hi Johan,
> 
> > Requested change:
> > 
> >    The Diameter protocol's Session-Id AVP, which is 
> globally unique (see
> >    section 8.8), is used during the authorization phase to 
> identify a
> >    particular session. Services that do not require any 
> authorization
> >    still use the Session-Id AVP to identify sessions.
> > 
> > to
> > 
> > The Diameter protocol's Session-Id AVP, which is globally 
> unique (see
> > section 8.8), is used during the authorization phase to identify a
> > particular session. Services that do not require any authorization
> > still use the Session-Id AVP to identify sessions. 
> Accounting messages 
> > MUST use a different Session-Id from that sent in 
> > authorization messages.
> 
> Somehow, the "MUST use" part of the last sentence worries me.  I think
> that it may be more application specific.  I'd prefer to 
> state something
> more like:
> 
>   Accounting messages MAY use a different Session-Id from 
> that sent in 
>   authorization messages.  Specific applications MAY require different
>   a Session-ID for accounting messages.
> 
> Then, the application (for example MIP) could use a MUST.
> 
> Comments?
> John
>  
>