Subject: RE: [AAA-WG]: Text needed for: Applicaiton ID in the header

From: "Miguel-Angel Pallares-Lopez (ECE)" <[email-masked]>
Date: Tue, 2 Jul 2002 08:39:13 +0200

> 
> > >> an underlying assumption of vendor-specific command codes in the
> > >> 3gpp environment seems to be that the hosts using them 
> are all from
> > >> a single vendor.
> > > I'm not sure where you that that idea from.  The proposed VSCs
> > of which I'm
> > > aware are 3GPP-specific; that is to say, they would only be
> > used in a 3GPP
> > > environment.  However, the 3GPP environment will certainly
> > include equipment
> > > from many different vendors.
> >
> > sounds like a need for standards.
> 
> Agreed, but whose?  3GPP writes standards, too, and it's 
> their standard that
> the vendors would need to follow (this may imply by reference 
> IETF standards
> as well, of course).
> 

3GPP's. What 3GPP have done is to make use of a feature offered by the protocol up to base-11, namely VSEs. I would like to clarify that they have been fully respectful with the base protocol; that is, no changes/additions/deletions, only decisions on some "MAYs", e.g. they use SCTP and not TCP as transport. 

3GPP VSEs will only be used in a 3GPP environment. Interoperability between 3GPP compliant equipment (even from different manufacturers) is guaranteed by conformance with the 3GPP specifications. If a peer claims support of a determined 3GPP VSE, it will have to do so in compliance with the corresponding 3GPP specifications.

Nothing in the base protocol precludes that a piece of equipment implements a 3GPP VSE (or in general a manufacturer VSE) and at the same time one or more IETF standard extensions and connect to other peer supporting the same or different extensions. There are mechanisms already in place in the base protocol that allow interoperability:
- The capabilities exchange mechanism.
- The ability to reject commands not recognised/supported.
- The ability to reject mandatory AVPs not recognised/supported.

BR/Miguel

---

From: Randy Bush <[email-masked]>
Date: Tue, 02 Jul 2002 08:32:09 -0700

> 3GPP's. What 3GPP have done is to make use of a feature offered
> by the protocol up to base-11, namely VSEs. I would like to
> clarify that they have been fully respectful with the base
> protocol; that is, no changes/additions/deletions, only decisions
> on some "MAYs", e.g. they use SCTP and not TCP as transport.

yup.  we left a loophole (which had a bug report filed against it
18 months ago), and 3gpp had the poor design taste [0] to crawl
through it.  now that we're through assessing blame, the useful
question is how we crawl out of this mess to dry ground.  this
devolves into a few sub-questions.

  o how do we help 3gpp get 5 out the door without digging a deeper
    hole?

  o how do we clean up the hole so no one else falls into it?

  o how do we help 3gpp and others understand how to meet their
    needs for 6 when the hole is not there.

what we don't need to do is figure out how to furnish the hole
with overstuffed chairs and an espresso machine.  well, maybe we
keep the espresso machine :-)

randy

---

[0] - note that they did ask for our design help, and we could have
      avoided this by helping them.  the problem was (and is) that
      spending the resources to do so would have further delayed
      progress on our already long-delayed docs, which are our
      primary task.  if we don't get a good spec done, we will
      spend the next decade helping one user community at a time
      through the swamp we have allowed.  i.e. we will have failed
      at our primary task.

---

From: Johan Johansson <[email-masked]>
Date: Tue, 02 Jul 2002 19:29:32 +0200

Randy,

Please, for the love of God, offer one single technical argument why the 
notion of VSEs is so horrible. Your phobic behaviour and adamant refusal 
to explain yourself to the wg aren't nearly as convincing as one might 
think. Please stick with solid technical terminology, specifically, 
refrain from using colourful metaphors.

Another issue is that your calls for IETF process being demanded by 
others are not quite convincing when you yourself side-step the wg the 
first chance you get. Your demand has not exactly been met with 
enthusiasm by the wg.

Nobody seems to be able to find your "bug report" and if it was such a 
show stopper, why didn't anyone follow up on it for 18 months?

I will be happy to help getting rid of "the hole" once you explain why 
it is a hole and not a foundation upon which to build wonderful things.

j