Subject: [AAA-WG]: Diameter Base Application ID values

From: <[email-masked]>
Date: Thu, 28 Nov 2002 15:07:21 +0200

Hi all,

Currently, we have the application IDs as follows in the Diameter base spec:

NASREQ                        1 [NASREQ]
Mobile-IP                     4 [DIAMMIP]
Diameter Base Accounting      5
Relay                         0xffffffff

Would anyone complain if they were modified to:

Diameter Base Accounting      0
NASREQ                        1 [NASREQ]
Mobile-IP                     2 [DIAMMIP]
Relay                         0xffffffff

thanks,
John

---

From: Randy Bush <[email-masked]>
Date: Thu, 28 Nov 2002 09:59:53 -0800

> Diameter Base Accounting      0

should not these be an iana registry with allocations based on the
iana considerations section?

randy

---

From: Yoshihiro Ohba <[email-masked]>
Date: Fri, 29 Nov 2002 18:32:40 -0500

> Diameter Base Accounting      0

I have one question.  

Which Application ID value should be included in Diameter headers 
for messages that are common to all applications but not ACR/ACA?
For example, my implementation is using 0 for CER/CEA.

> John

Regards,
Yoshihiro Ohba