Subject: [AAA-WG]: Questions about nasreq-10 preview

From: "S. Lee" <[email-masked]>
Date: Thu, 7 Nov 2002 00:27:25 +0900

I have some questions about nasreq-10 preview...

1. In Section 6.1, 

"- If state information regarding the RADIUS request was saved in a
    Proxy-Info AVP, the RADIUS Identifier and UDP IP Address and
    port number are extracted and used in issuing the RADIUS reply."

I think this sentence must be changed to :

"If state information regarding the RADIUS request was saved in a
    Proxy-Info AVP or local state table, the RADIUS Identifier and UDP IP Address and
    port number are extracted and used in issuing the RADIUS reply."

2. Multi-Round-Time-Out AVP is refered in section 6.1 & 6.1.1, 
but in 7.1 we can't find this AVP from AAR/A AVP table. 

3. In Section 6.1.1
"- The Route-Record AVPs MUST be added to the Diameter message, in
        the same order they were present in the request."
Why the Route-Record AVP MUST be added in Diameter answer?

4. Why is the NAS-Session-Key AVP omitted in this draft?
It will be only in aaa-diameter-eap draft?

5. In Section 6.1.1, what is Acct-Session-Id AVP?
where is it defined?

+------------------------------------------------------------+
+  Lee, Sokjoon (ICQ No : 69347005)
+  Office : +82-42-860-5455    Fax : +82-42-860-5611
+  Cell : +82-17-344-1295      E-Mail : [email-masked]
 
+  Wireless Internet Security Research Team
+  Electronics and Telecommunications Research Institute
+  161 Gajeongdong, Yuseonggu, Daejeon, 305-350, Korea
+------------------------------------------------------------+

---

From: Bernard Aboba <[email-masked]>
Date: Wed, 6 Nov 2002 06:42:10 -0800 (PST)

Filed as Issue 380.

---

From: David Mitton <[email-masked]>
Date: Tue, 19 Nov 2002 16:32:20 -0500

> >     port number are extracted and used in issuing the RADIUS reply."

Accepted.

> > but in 7.1 we can't find this AVP from AAR/A AVP table.

Ummm... it's there now.

> > Why the Route-Record AVP MUST be added in Diameter answer?

Per rules of Base sections 6.1.8, 6.2  et.al.

> > It will be only in aaa-diameter-eap draft?

Yes, that is why.

> > 5. In Section 6.1.1, what is Acct-Session-Id AVP?

It is the AVP formerly named Acct-RADIUS-Session-Id in the Base.
The inclusion of -RADIUS in the AVP name is a gratuitous change from RADIUS 
attribute 44 and the Base editor agreed to change it back.

---

From: "S. Lee" <[email-masked]>
Date: Tue, 26 Nov 2002 01:40:18 +0900

Thank you for your answer.

But, Route-Record AVP will be omitted in any Diameter answer message by Base
draft.
Route-Record AVP is only for loop checking, not for answer message routing.

Moreover, by Base section 6.2, the following setence of nasreq section 6.1.1
would be deleted.
"- The request's Origin-Host information is added to the Destination-Host
AVP."

I also found editorial mistake in section 8.1.
'268' would be deleted because of the absence of DER/A in this draft.

By the way, if NAS-Session-Key AVP will be only in aaa-diameter-eap draft,
then does it mean that session key share between peer and authenticator will
not be
established on nasreq application? In wireless LAN environment supporting
802.11i
(which needs session key sharing), nasreq application will be meaningless?

    Sokjoon Lee