Subject: [AAA-WG]: Diameter Mobile-IP implementation

From: "Santosh Kawade" <[email-masked]>
Date: Sun, 15 Dec 2002 10:50:07 +0530

Hi Sir,
        We are implementing a Diameter Stack and MIPv4 application but have some doubts. Could you please give us a clarification about the following cases:

1. A diameter mobile IPv4 implementation  related :
  (a)  How is communication link between Diameter Mobile IPv4 server and
Foreign agent established.
    For e.g Does the FA send AMR  messages to the default TBD port of
diameter [AAAF] server.

  (b) Are the AMR messages send per service request. Meaning that the first
AMR deals with just getting
    authenticating and subsequent AMR's will deal with any specific service
request.

2. Diameter Session layer [ Sec 8.1 ] Authorization state machine.

 a.   Has the point 1.b anything to do with Grant Access and Provide Service
Action items in Authorization state machine  [ CLIENT STATEFUL ]

b.   What is the significance of setting timers at both the client [ AAAF ]
and server [ AAAH] ends when they are in open mode for a  specific session ?

                              CLIENT, STATEFUL
      State     Event                          Action     New State
      -------------------------------------------------------------
      Open      Session-Timeout Expires on     Send STR   Discon
                    Access Device

                             SERVER, STATEFUL
      State     Event                          Action     New State
      -------------------------------------------------------------
      Open      Session-Timeout expires on     Cleanup    Idle
                    home server

Thanks,
Santosh

*********************************************************
Disclaimer

This message (including any attachments) contains 
confidential information intended for a specific 
individual and purpose, and is protected by law. 
If you are not the intended recipient, you should 
delete this message and are hereby notified that 
any disclosure, copying, or distribution of this
message, or the taking of any action based on it, 
is strictly prohibited.

*********************************************************
Visit us at http://www.mahindrabt.com

---

From: "Santosh Kawade" <[email-masked]>
Date: Sun, 15 Dec 2002 11:14:54 +0530

Description of issue               : Diameter mobile IPv4 implementation
related
Submitter name                     : Santosh Kawade
Submitter email address        : [email-masked]
Date first submitted               : 15-Dec-2002
Reference                             : NA
Document: Document Requiring change [base, nasreq, mobileip, cms]  : Base
8.1
Comment type: ['T'echnical | 'E'ditorial]                   : T
Priority: ['S' Must fix | '1' Should fix | '2' May fix ]    : NA
Section: Insert_Section_Number_Here
Rationale/Explanation of issue:
Length description of problem

Sir your clarification is needed for our understanding for implementing
Diameter Mobile IPv4 application.

1  (a)  How is communication link between Diameter Mobile IPv4 server and
Foreign agent established.
    For e.g Does the FA send AMR  messages to the default TBD port of
    diameter [AAAF] server.

  (b) Are the AMR messages send per service request. Meaning that the first
       AMR deals with just getting authenticating and subsequent AMR's will
deal with any specific service
       request.

                              CLIENT, STATEFUL

                             SERVER, STATEFUL

Requested change:  NA
Proposal :