Subject: RE: [AAA-WG]: Diameter Base Application ID values

From: <[email-masked]>
Date: Mon, 2 Dec 2002 10:48:23 +0800

Hi,

The current application ID allocation would make the following scenario impossible, since it assumes all accounting information be handled in one accounting server:

               Access Router
                        |
     /-------  Diameter Relay  -------\ 
     |                  |                         |
   NASREQ      Authentication     Multimedia
 ACCT server        Server        ACCT server

However, such a scenario could be realistic in the future that different service vendors have their own accounting servers.

Then, shall we differentiate the accounting regards to different services? For example (assuming the last bit of Application-ID as the bit of AUTH/ACCT ):
 Base Common		 0
 Base Accounting           1  /* All accounting information */
 NASREQ                      2 [NASREQ]
 NASREQ Accounting     3 [NASREQ]
 Mobile-IP                       4 [DIAMMIP]
 Mobile-IP Accounting     5 [DIAMMIP]
 Relay                            0xffffffff

Best regards,
roger

-----Original Message-----
From: ext [mailto:[email-masked]]
Sent: Saturday, November 30, 2002 1:27 PM
To: [email-masked]
Cc: [email-masked]; [email-masked]
Subject: RE: [AAA-WG]: Diameter Base Application ID values

Hi Yoshihiro,

> On Thu, Nov 28, 2002 at 03:07:21PM +0200, 
> [email-masked] wrote:
> > Hi all,
> > 
> > Currently, we have the application IDs as follows in the 
> Diameter base spec:
> > 
> > NASREQ                        1 [NASREQ]
> > Mobile-IP                     4 [DIAMMIP]
> > Diameter Base Accounting      5
> > Relay                         0xffffffff
> > 
> > Would anyone complain if they were modified to:
> > 
> > Diameter Base Accounting      0
> > NASREQ                        1 [NASREQ]
> > Mobile-IP                     2 [DIAMMIP]
> > Relay                         0xffffffff
> 
> I have one question.  
> 
> Which Application ID value should be included in Diameter headers 
> for messages that are common to all applications but not ACR/ACA?
> For example, my implementation is using 0 for CER/CEA.

Actually, I was thinking the same thing. So we would have:

 Common		0
 NASREQ                       1 [NASREQ]
 Mobile-IP                      2 [DIAMMIP]
 Base Accounting           3
 Relay                            0xffffffff

John

---

From: <[email-masked]>
Date: Mon, 2 Dec 2002 08:25:20 +0200

Hi Roger,

Thanks for the input.  Perhaps it would be best if the authors of the MIP doc and
the NASREQ doc comment on this.  Is this potentially useful for those applications?
It may simplify the routing of the messages, but we need to see if it is useful
for the applications as well.

thanks,
John

> From: Liu Qing.Roger (Nokia-RD/Beijing) 
> Sent: 02 December, 2002 04:48
> To: Loughney John (NRC/Helsinki); [email-masked]
> The current application ID allocation would make the 
> following scenario impossible, since it assumes all 
> accounting information be handled in one accounting server:
> 
>                Access Router
>                         |
> However, such a scenario could be realistic in the future 
> that different service vendors have their own accounting servers.
> 
> Then, shall we differentiate the accounting regards to 
> different services? For example (assuming the last bit of 
> Application-ID as the bit of AUTH/ACCT ):
>  Base Common		 0

---

From: <[email-masked]>
Date: Mon, 2 Dec 2002 17:12:56 +0800

Hi Fredrik,

Application ID is used in capacity negotiation first. The current Application ID allocation would make the capacity negotiation between accounting servers and the diameter relay unclear:
 
                Access Router
                         |

Best regards,
roger

-----Original Message-----
From: ext Fredrik Johansson [mailto:[email-masked]]
Sent: Monday, December 02, 2002 4:51 PM
To: Loughney John (NRC/Helsinki); Liu Qing.Roger (Nokia-RD/Beijing); [email-masked]
Cc: [email-masked]; [email-masked]
Subject: RE: [AAA-WG]: Diameter Base Application ID values

Isn't it enough to indicate that the application is MIP or NASREQ and then
you can route based on command code, e.g. mip accounting to one server and
MIP authentication to another.

/fredrik

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
[email-masked]
Sent: den 2 december 2002 07:25
To: [email-masked]; [email-masked]
Cc: [email-masked]; [email-masked]
Subject: RE: [AAA-WG]: Diameter Base Application ID values

Hi Roger,

Thanks for the input.  Perhaps it would be best if the authors of the MIP
doc and
the NASREQ doc comment on this.  Is this potentially useful for those
applications?
It may simplify the routing of the messages, but we need to see if it is
useful
for the applications as well.

thanks,
John