Subject: [AAA-WG]: Diameter messages vs. SCTP packets

From: <[email-masked]>
Date: Mon, 16 Dec 2002 19:16:47 +0200

Hi,

The base specification and the transport profile do not mandate anything about how the Diameter messages are encapsulated in the SCTP packets. This means that a Diameter implementation must be prepared to receive all possible combinations, e.g. one Diameter message sent in multiple SCTP packets or 1.5 Diameter messages in one SCTP packets.

The receiver would be greatly simplified if one of the specifications requires that a SCTP packet contains a non-fractional number of Diameter messages.

Regards,

Adrian

---

From: Bernard Aboba <[email-masked]>
Date: Mon, 16 Dec 2002 08:15:49 -0800 (PST)

> The receiver would be greatly simplified if one of the specifications
> requires that a SCTP packet contains a non-fractional number of Diameter
> messages.

I don't see how this could be required -- Diameter is assumed to run over
a stream socket, so that the packetization of the underlying reliable
transport is not under the control of the Diameter application.