Subject: [AAA-WG]: RE: Transport-10 review

From: Bernard Aboba <[email-masked]>
Date: Sat, 28 Dec 2002 12:11:03 -0800 (PST)

> It seems that the code and the state machine are still not in sync.
>
> Code onReceive():
>    case DOWN:
>         Throwaway(received packet);
>         break;
>
> State machine :
> DOWN          Receive DWA          Pending = FALSE
>                                    Throwaway()          DOWN
> DOWN          Receive non-DWA      Throwaway()          DOWN
>
> Additionally, does it make sense to describe onReceive in DOWN state. Can one receive a message in DOWN state?
>
> - Kishore
>

Actually, this does appear consistent. The code reads:

OnReceive(pcb, msgType)
{
   if (msgType == DWA) {
        Pending = FALSE;
        }

So the state machine input for the DOWN state needs to include Pending =
FALSE as part of the actions when DWA is received, whereas this is not
true when a non-DWA is received.

---

From: Jari Arkko <[email-masked]>
Date: Sun, 29 Dec 2002 13:42:01 +0200

Yes, Bernard is right that the sm & code are consistent in this case.
It is still a good question whether it makes sense to talk about
receptions in the DOWN state. Strictly speaking, your socket is
going to be closed when you are in DOWN, so you can't receive
anything... but we might leave the entries just to avoid too many
changes at this stage. They don't hurt anyone, and given Bernard's
if statement outside the switch, he'd have to make a not-so-easy change
to the code in order to remove them.

Jari

---

From: Bernard Aboba <[email-masked]>
Date: Sun, 29 Dec 2002 07:54:34 -0800 (PST)

We'll do a -12 revision to fix 3.4.1 and remove the Connection down events
in the DOWN and INITIAL states. A strawman is available at:

http://www.drizzle.com/~aboba/AAA/draft-ietf-aaa-transport-12.txt