Subject: [AAA-WG]: Ambiguity in the description of Session-Id

From: <[email-masked]>
Date: Wed, 11 Dec 2002 20:07:23 +0200

Hi,

I see that there is some ambiguity in the description of Sesion-Id AVP in section 8.8 of base-15.

  "The Session-Id MUST begin with the sender's identity encoded in the
   DiameterIdentity type (see section 4.4). The remainder of the
   Session-Id MAY be any sequence that the client can guarantee to be
   eternally unique; however, the following format is recommended,
   (square brackets [] indicate an optional element):

   <DiameterIdentity>;<high 32 bits>;<low 32 bits>[;<optional value>]"

The description indicates that a Session-Id with format "<DiameterIdentity>[unique optional value>]". If yes what is the delimiter to separate the DiameterIdentity from the unique optional value.

Kishore

---

From: <[email-masked]>
Date: Tue, 17 Dec 2002 07:16:53 +0200

Hi all,

> On Mon, Dec 16, 2002 at 07:52:27PM +0200, 
> [email-masked] wrote:
> > DiameterIdentity is fqdn and thus does not seem to allow to include
> > ";" charactor.  So I don't see the ambiguity.  Could you show an
> > example case?
> > [Kishore] The problem occurs once domain names are 
> internationalized. If we use ';' as the delimiter then we 
> restrict ourselves using ASCII names for fqdn and Diameter 
> host identities.  Secondly present base protocol 
> specification does not mandate that a ';'(or any other 
> delimiter) MUST follow the DiameterIdentity in Session-Id.
> > 
> 
> If internationalized domain name is the issue, I think we should use a
> delimiter that is not allowed to be included in stringprep.  If ";" is
> allowed to be included in stringprep, then it might be better to
> choose other delimiter.

I've discussed this with the concerned IESG member, Internationalization
should not be an issue with Diameter.  A good compromise would
be to support ":" as the delimeter.  I will make the change.

John

---

From: <[email-masked]>
Date: Tue, 17 Dec 2002 10:35:56 +0200

Hi all,

Further clarification, section 8.8 includes this definition:

	<DiameterIdentity>;<high 32 bits>;<low 32 bits>[;<optional value>] 

and this example:

	accesspoint7.acme.com;1876543210;523

So clearly, the semicolon ";" is being used at the delimiter, and is specified
in the text already. So, I think that this is a non-issue.

Just to be precise, I have modified the 3rd paragraph, to say:

	The Session-Id MUST begin with the sender's identity encoded in the 
	DiameterIdentity type (see section 4.4). The remainder of the Session-Id 
	is delimted by a ";" charcter, and MAY be any sequence that the client can 
	guarantee to be eternally unique; however, the following format is recommended, 
	(square brackets [] indicate an optional element): 

And therefore we can close this issue.

John

---

From: <[email-masked]>
Date: Tue, 17 Dec 2002 10:51:48 +0200

Hi,

I agree with the modified text (except that the word "character" is wrongly spelt in the text). 

In the old text ";" is used as a delimiter in the examples and the recommended format of a Session-Id, but the only mandatory part is that the Sesion-Id should start with DiameterIdentity.

Kishore

-----Original Message-----
From: Loughney John (NRC/Helsinki) 
Sent: 17. December 2002 10:36
To: Ghadiyaram Venkata (EXT-TataConsultancy/Helsinki)
Cc: [email-masked]
Subject: RE: [AAA-WG]: Ambiguity in the description of Session-Id

Hi all,

and this example:

John