Subject: [AAA-WG]: Query on AAA Transport profile

From: <[email-masked]>
Date: Wed, 18 Dec 2002 18:46:57 +0200

Hi,

I have one query on AAA Transport Profile draft. In Appendix A where the algorithm is detailed, says

1. The action to be performed when the number of DWAs received in REPOEN state, is just incrementing NumDWA. Should not the  action also include SetWatchDog()?
2. The action performed when the connection is down on OK state is closing the connection and setting the watch dog timer. Should not the action also include failover()?

Present text :

REOPEN        Receive DWA &
              NumDWA < 2           NumDWA++             REOPEN

OKAY          Connection down      Close Connection
                                   SetWatchdog()        DOWN

My understanding :

REOPEN        Receive DWA &        NumDWA++
              NumDWA < 2           SetWatchdog()        REOPEN

OKAY          Connection down      Close Connection
                                   failover()
                                   SetWatchdog()        DOWN

Thanks in advance,
Kishore

---

From: Bernard Aboba <[email-masked]>
Date: Thu, 19 Dec 2002 15:23:53 -0800 (PST)

> 1. The action to be performed when the number of DWAs received in REPOEN state,
> is just incrementing NumDWA. Should not the  action also include
> SetWatchDog()?

No. The watchdog timer is set after it expires, not after receipt of the
NumDWA. Recall the other two states:

REOPEN        SendWatchdog &
              !Pending             SetWatchdog()        REOPEN
REOPEN        SendWatchdog &
              Pending              SetWatchdog()        REOPEN

> 2. The action performed when the connection is down on OK state is
>closing the connection and setting the watch dog timer. Should not the
>action also include failover()?

I don't think so. Failover() is called earlier, in the SUSPECT state. So
there's no need to call it again.