Subject: RE: [AAA-WG]: Diameter messages vs. SCTP packets

From: <[email-masked]>
Date: Mon, 16 Dec 2002 19:37:31 +0200

SCTP reassembles the packets at the destination and delivers them to the application exactly how they were sent. The streaming part of SCTP does not refer to the way the packets are constructed. From encapsulation point of view SCTP resembles more to UDP then to TCP.

Adrian

-----Original Message-----
From: ext Bernard Aboba [mailto:[email-masked]]
Sent: 16 December, 2002 18:16
To: Constantin Adrian (NET/Helsinki)
Cc: [email-masked]
Subject: Re: [AAA-WG]: Diameter messages vs. SCTP packets

> The receiver would be greatly simplified if one of the specifications
> requires that a SCTP packet contains a non-fractional number of Diameter
> messages.

I don't see how this could be required -- Diameter is assumed to run over
a stream socket, so that the packetization of the underlying reliable
transport is not under the control of the Diameter application.

---

From: David Frascone <[email-masked]>
Date: Mon, 16 Dec 2002 11:49:51 -0600

I was under the impression that a single diameter message would be sent in a
single SCTP packet.  Perhaps a single line makeing that obvious should be
added.

-Dave

-- 
David Frascone

         I like to reminisce with people I don't know.

---

From: Bernard Aboba <[email-masked]>
Date: Mon, 16 Dec 2002 08:50:27 -0800 (PST)

What if the Diameter message is too big??