Subject: RE: [AAA-WG]: A question in NASREQ section 2.1

From: David Mitton <[email-masked]>
Date: Thu, 02 Jan 2003 21:46:50 -0500

I'm asking all these questions, so you may perhaps answer yourself.

- If the relay "knows" to send accounting messages to the accounting server 
and not the authentication server, then this accounting message is no 
different.

- If the authentication server did not authenticate or authorize this 
session, (eg: returned a failure) then it need not receive anything further.

- If the NAS decided it could not support an authenticated or authorized 
session,(eg: a AAA with success) then it should also issue an 
Session-Termination-Request (STR) to the Authentication Server to abort the 
session information at that server. [Section 2.3]  As well as the 
Accounting EVENT_RECORD.

Dave.

At 1/3/2003 10:12 AM +0800, [email-masked] wrote:
>Hi,
>
>As a service vendor may have a separated ACCT server, which have the same 
>diameter identity as the AUTH server. The relay will know the accounting 
>messages should be routed to ACCT server after capability negotiation with 
>the ACCT SERVER (the NASes do not need to know where is the servers, they 
>only need to set the destination host/realm AVPs properly).
>
>In this case, my question is that should the AUTH server be informed of 
>such a failure ? (Since this notification will be routed to ACCT server.) 
>If not, how to implement the following behavior of NAS, ACCT server?
>
>Thanks,
>roger
>
>
>
>-----Original Message-----
>From: ext David Mitton [mailto:[email-masked]]
>Sent: 24. December 2002 22:24
>To: Liu Qing.Roger (Nokia-RD/Beijing); [email-masked];
>[email-masked]
>Subject: Re: [AAA-WG]: A question in NASREQ section 2.1
>
>
>At 12/24/2002 05:26 PM +0800, [email-masked] wrote:
> >In NASREQ section 2.1,
> >"The failure to start a session SHOULD cause an Accounting EVENT_RECORD
> >message."
> >
> >But regards to the following scenario, where will the Accounting
> >EVENT_RECORD message be addressed to?
> >
> >      +--------+        +-------+        +-------------+
> >      |  NAS   |--------| Relay |--------| Auth Server |
> >      +--------+        +---+---+        +-------------+
> >                            |
> >                            |
> >                     +------+------+
> >                     | Acct Server |
> >                     +-------------+
> >
> >Best regards,
> >roger
>
>Where would a successful Accounting message go?
>What criteria is the Relay using to split the streams?
>How would the source know that?
>Who configured this?
>
>Dave.

---

From: <[email-masked]>
Date: Fri, 3 Jan 2003 11:32:20 +0800

Thanks Dave,

I suppose you mentioned one choice for the NAS that it could terminate the session if it failed to start a NASREQ session context. However I wonder if the NAS will go to extreme to do so, as neither NASREQ or [BASE] have mentioned what actions shall ACCT server/NAS take after an EVENT_RECORD request/answer message is received.

And this is the reason I invite Aboba to explain possible further behavior of NAS and ACCT server handling such a failure.

Best regards,
roger

-----Original Message-----
From: ext David Mitton [mailto:[email-masked]]
Sent: 03. January 2003 10:47
To: Liu Qing.Roger (Nokia-RD/Beijing); [email-masked]
Cc: [email-masked]
Subject: RE: [AAA-WG]: A question in NASREQ section 2.1 

Dave.