Subject: RE: [AAA-WG]: comment on diameter credit control

From: <[email-masked]>
Date: Wed, 26 Mar 2003 12:41:02 +0200

Hi,
 
>Q1. What is a "home environment"? I guess it should be home network.
Yes, the home environment is the home network.

Q2. Why are we precluding the Credit Control Server hosted by a third party i.e.
neither visited nor home network provider?
The Credit Control Server is located in the same network that own the user's account, which is usually the home network. The visited network may proxy the service element requests related to a visited user to the user's home network, thus a Credit Control Proxy may be located in the visited domain.

Perhaps the Credit Control Server may be hosted by third party entity trusted by the home network, in cases where a third party provider offers credit control services on behalf of the home network (home network provider). In this case the home network would forward the request to the trusted entity providing credit control services, however, the third party provider may be considered as an extention of the home network, thus belonging to the "home environment". Would we need some sentence explicitly covering  this scenario or do you have something else in mind?

Regards
Marco

	-----Original Message----- 
	From: ext Kuntal Chowdhury [mailto:[email-masked]] 
	Sent: Wed 3/26/2003 2:11 AM 
	To: [email-masked] 
	Cc: 
	Subject: [AAA-WG]: comment on diameter credit control 

	Question/Comment on: draft-hakala-diameter-credit-control-06.txt
	
	"
	    Credit Control Server
	      It is located in the home environment and is accessed by service
	      elements in real-time for purpose of price determination and credit
	      control before the service event is delivered to the end-user. It
	      may also interact with business support systems.
	"
	
	Q1. What is a "home environment"? I guess it should be home network.
	Q2. Why are we precluding the Credit Control Server hosted by a third party i.e.
	neither visited nor home network provider?
	
	-Kuntal

---

From: Kuntal Chowdhury <[email-masked]>
Date: Wed, 26 Mar 2003 14:08:31 -0600

Hello Marco,

Please see my comments inline...

> Yes, the home environment is the home network.

OK, then why don't we say "home network" instead, if you don't mind :o)?

> The Credit Control Server is located in the same network that own the user's account, which is usually the home network. The visited network may proxy the service element requests related to a visi…

IMHO, that's how AAA system works i.e. the visited AAA routes AAA messages 
through proxy chain to the home AAA.

> Perhaps the Credit Control Server may be hosted by third party entity trusted by the home network, in cases where a third party provider offers credit control services on behalf of the home network…

I did not know that you/authors assumed "home environment" may include third 
party (e.g. a prepaid reseller). In order to clarify the scenario why don't we 
say the following:

"
Credit Control Server:  The home network interfaces with this entity and is 
accessed by the service elements for the purpose of allowed usage determination 
and credit control before the service event is delivered to the end-user.
"

Regards,
KC