Subject: [AAA-WG]: Issue 406: Context removal

From: Bernard Aboba <[email-masked]>
Date: Wed, 12 Mar 2003 12:41:49 -0800 (PST)

Issue 406: Context removal
Submitter name: Bernard Aboba
Submitter email address: [email-masked]
Date first submitted: March 11, 2003
Reference:
Document: NASREQ-11
Comment type: Technical
Priority: S
Section: 2.3
Rationale/Explanation of issue:
"   Further, a NAS that receives a Abort-Session-Request (ASR) [Base]
   MUST issue an STR if the session requested is active, and disconnect
   the PPP (or tunneling) session.

   Termination of the session context, MUST cause the sending of an
   Accounting STOP_RECORD message [Base], if accounting is active.
"
What this doesn't say is that *all* context relating to the session
MUST be removed, including key state. This is important in the case
of access points which may cache the PMK. Note that termination
of the session can occur without removing all session context.

Rewrite to:

" Further, a NAS that receives a Abort-Session-Request (ASR) [Base]
MUST issue an STR if the session requested is active, disconnect
the session and completely remove all session context.

Termination of the session MUST cause the sending of an
Accounting STOP_RECORD message [Base], if accounting is active.
"

---

From: Jari Arkko <[email-masked]>
Date: Thu, 13 Mar 2003 13:33:20 +0200

Ok, but a nit inline.

> the session and completely remove all session context.

Completely remove all? I guess you want to be really sure...

Maybe s/and completely remove all session context/and remove all
context associated with the session/

> Accounting STOP_RECORD message [Base], if accounting is active.

Ok

--Jari

---

From: Bernard Aboba <[email-masked]>
Date: Thu, 13 Mar 2003 04:16:44 -0800 (PST)

> context associated with the session/

Yes. You don't need to remove *all* the context for all sessions :)

>
> > Termination of the session MUST cause the sending of an Accounting
> > STOP_RECORD message [Base], if accounting is active. "
>
> Ok
>
> --Jari
>
>