Subject: [AAA-WG]: Diameter AVP Discrepancies

From: "Simon Bradley" <[email-masked]>
Date: Thu, 17 Apr 2003 15:21:12 +0100

Reading draft-ietf-aaa-diameter-17, there are some discrepancies between the AVP table in section 4.5 and the descriptive text that follows.

Accounting-Realtime-Required
    The table says it is of type Unsigned32.
    The text says it is of type Enumerated.

Accounting-Session-Id
    The table calls it Accounting-RADIUS-Session-Id.
    The text calls it Accounting-Session-Id.

Acct-Application-Id
    The table says it is of type Integer32.
    The text says it is of type Unsigned32.

Acct-Interim-Interval
    The table calls it Accounting-Interim-Interval.
    The text calls it Acct-interim-Interval.

Auth-Application-Id
    The table says it is of type Integer32.
    The text says it is of type Unsigned32.

Destination-Realm
    The table says it is of type UTF8String.
    The text says it is of type DiameterIdentity.

Origin-Realm
    The table says it is of type UTF8String.
    The text says it is of type DiameterIdentity.

Also:

Inband-Security-Id
    The details in the table seem to have skipped down a line.
    Has it lost its M/P/V flags?

Apologies if any/all of these have already been reported.

 -- Simon

-- 
Simon Bradley, Ubiquity Software Corporation
Ubiquity House, Langstone Park
Newport NP18 2LH, UK
Tel: +44 (0)1663 765600
e-mail: [email-masked]

---

From: Jari Arkko <[email-masked]>
Date: Sat, 19 Apr 2003 11:38:51 +0300

Thanks for observing these discrepancies! Hopefully, we can take care
of this in the author's 48 hours when the RFC editor is done...

Jari