Subject: RE: [AAA-WG]: Diameter AVP Discrepancies

From: "MEYER,JEFFREY D (HP-Cupertino,ex1)" <[email-masked]>
Date: Thu, 17 Apr 2003 11:51:00 -0400

Hi,

  This is an excellent argument for having a formal single source 
for the information model which is used.  

  IPDR provides such a model in XML, so that using stylesheets
you can repurpose the information in any format you want while
avoiding human transcription errors.

Regards,

  Jeff Meyer

> -----Original Message-----
> From: Simon Bradley [mailto:[email-masked]]
> Sent: Thursday, April 17, 2003 7:21 AM
> To: [email-masked]
> Subject: [AAA-WG]: Diameter AVP Discrepancies
> 
> 
> Reading draft-ietf-aaa-diameter-17, there are some 
> discrepancies between the AVP table in section 4.5 and the 
> descriptive text that follows.
> 
> Accounting-Realtime-Required
>     The table says it is of type Unsigned32.
>     The text says it is of type Enumerated.
> 
> Accounting-Session-Id
>     The table calls it Accounting-RADIUS-Session-Id.
>     The text calls it Accounting-Session-Id.
> 
> Acct-Application-Id
>     The table says it is of type Integer32.
>     The text says it is of type Unsigned32.
> 
> Acct-Interim-Interval
>     The table calls it Accounting-Interim-Interval.
>     The text calls it Acct-interim-Interval.
> 
> Auth-Application-Id
>     The table says it is of type Integer32.
>     The text says it is of type Unsigned32.
> 
> Destination-Realm
>     The table says it is of type UTF8String.
>     The text says it is of type DiameterIdentity.
> 
> Origin-Realm
>     The table says it is of type UTF8String.
>     The text says it is of type DiameterIdentity.
> 
> Also:
> 
> Inband-Security-Id
>     The details in the table seem to have skipped down a line.
>     Has it lost its M/P/V flags?
> 
> Apologies if any/all of these have already been reported.
> 
>  -- Simon
> 
> -- 
> Simon Bradley, Ubiquity Software Corporation
> Ubiquity House, Langstone Park
> Newport NP18 2LH, UK
> Tel: +44 (0)1663 765600
> e-mail: [email-masked]
>

---

From: <[email-masked]>
Date: Thu, 17 Apr 2003 22:52:49 +0300

Hi,

> avoiding human transcription errors.

I kind of agree.  When it comes to document editing, NROFF is not
your friend ...

John