Subject: [AAA-WG]: Issue: EAP-Payload AVP vs. EAP-Message attribute?

From: <[email-masked]>
Date: Wed, 18 Jun 2003 12:55:24 +0300

(More issues to come -- I'm sending each issue in a 
separate message so as to make follow-ups easier)

EAP-Payload AVP vs. EAP-Message attribute?
Submitter name: Pasi Eronen
Submitter email address: [email-masked]
Date first submitted: 18 Jun 2003
Reference: 
Document: EAP-01
Comment type: T
Priority: 2
Section: 4.1.1
Rationale/Explanation of issue:

Is there some particular reason the Diameter AVP "EAP-Payload"
has a different name and code than the RADIUS "EAP-Message"
attribute?  Or could we simply use the same name and code?  

(And specify that when translating RADIUS->Diameter, multiple
attributes are concatenated to one AVP, and when doing
Diameter->RADIUS, long AVP values are split to multiple
attributes).

Best regards,
Pasi

---

From: Bernard Aboba <[email-masked]>
Date: Wed, 18 Jun 2003 09:34:30 -0700 (PDT)

> attribute?  Or could we simply use the same name and code?

I think the reason that the code is different is because in RADIUS an
attribute has very limited length and this is inconvenient for EAP since
it requires the EAP packet to be broken up into multiple attributes.
Therefore it would probably be better for Diameter to be able to include
the entire EAP packet in one AVP.

In general, if the RADIUS codes are reused then the attribute is assumed
to be defined identically to RADIUS.

---

From: Jari Arkko <[email-masked]>
Date: Tue, 24 Jun 2003 13:18:09 +0300

> to be defined identically to RADIUS.

Yes. If the intention is that in Diameter you'll have just
one copy of this AVP, then I think the semantics are different
enough to warrant a new code/name. But yes, this translation
too needs to be described somewhere.

--Jari