Subject: [AAA-WG]: Issue: Accounting-EAP-Auth-Method and expanded types

From: <[email-masked]>
Date: Wed, 18 Jun 2003 12:56:19 +0300

Accounting-EAP-Auth-Method and expanded types
Submitter name: Pasi Eronen
Submitter email address: [email-masked]
Date first submitted: 18 Jun 2003
Reference: 
Document: EAP-01
Comment type: T
Priority: 1
Section: 4.1.2
Rationale/Explanation of issue:

Accounting-EAP-Auth-Method AVP is defined as Enumerated type.  
This is OK for normal EAP types (0-253,255), but it's not 
enough for Expanded types (see 2284bis, section 5.7).

Proposed change: Change AVP type to Integer64, with
Vendor-Type stored in least significant 32 bits, and
Vendor-Id in the next 24 bits.

Another possibility would be to simply ignore the
existence of Expanded types, and just use "254" for them.

Best regards,
Pasi

---

From: Bernard Aboba <[email-masked]>
Date: Wed, 18 Jun 2003 09:35:35 -0700 (PDT)

> Vendor-Id in the next 24 bits.

This makes the most sense to me.