Subject: [AAA-WG]: Issue: Maximum size of EAP messages

From: <[email-masked]>
Date: Wed, 18 Jun 2003 12:57:57 +0300

Maximum size of EAP messages
Submitter name: Pasi Eronen
Submitter email address: [email-masked]
Date first submitted: 18 Jun 2003
Reference: 
Document: EAP-01
Comment type: T
Priority: S
Section: -
Rationale/Explanation of issue:

The EAP server may need to know the maximum size of EAP payload
it can send, in order to produce fragments of correct size.

Proposed change: Add new EAP-MTU AVP, sent in
Diameter-EAP-Requests (I think we shouldn't re-use Framed-MTU
AVP for this; the "framed MTU" of the link isn't necessarily 
the same as the maximum size of EAP message).

Best regards,
Pasi

---

From: Jari Arkko <[email-masked]>
Date: Tue, 24 Jun 2003 13:16:13 +0300

> the same as the maximum size of EAP message).

Ok.

We should have a section that describes how RADIUS EAP
and DIAMETER EAP map to each other, and explain there
that RADIUS Framed-MTU maps into both Framed-MTU and
EAP-MTU AVPs...

--Jari