Subject: [AAA-WG]: Authentication method AVP?

From: <[email-masked]>
Date: Tue, 12 Aug 2003 11:52:47 +0300

Authentication method AVP?
Submitter name: Pasi Eronen
Submitter email address: [email-masked]
Date first submitted: August 12, 2003
Reference: 
Document: NASREQ-12/EAP
Comment type: T
Priority: 2
Section: -
Rationale/Explanation of issue:

Diameter EAP application has Accounting-EAP-Auth-Method AVP 
that corresponds to the MS-Acct-EAP-Type RADIUS attribute 
from RFC 2548.  In RADIUS, this attribute is used together 
with MS-Acct-Auth-Type attribute (which has values for PAP, 
CHAP, EAP, MS-CHAP-1, etc.).

Should NASREQ have a corresponding AVP, named perhaps
Accounting-Auth-Method? (Note that this is different from
Acct-Authentic AVP, which has values for local, RADIUS and 
Diameter)

I guess we could define this AVP in Diameter EAP document 
if adding this to NASREQ this late would be a problem.

Best regards,
Pasi

---

From: Jari Arkko <[email-masked]>
Date: Tue, 12 Aug 2003 13:07:10 +0300

> Accounting-Auth-Method? (Note that this is different from

Yes.

> if adding this to NASREQ this late would be a problem.

I think we should put it in NASREQ.

--Jari