Subject: [AAA-WG]: Route-Record AVP in responses

From: <[email-masked]>
Date: Mon, 1 Sep 2003 12:00:13 +0300

Route-Record AVP in responses
Submitter name: Pasi Eronen
Submitter email address: [email-masked]
Date first submitted: September 1, 2003
Reference: 
Document: base and nasreq
Comment type: T/E
Priority: 1
Section: various
Rationale/Explanation of issue:

Oops, I know it's kinda late to notice this... but there 
seems to be some inconsistencies about the Route-Record AVP
in some of the following: Base, NASREQ, my head.

Route-Record AVP use in requests seems to be ok, but
it is not clear if responses should have Route-Record AVPs.

- The AVP occurrence tables (in both Base and NASREQ) show 
  that Accounting-Answers MAY have Route-Record AVPs, but 
  all other responses MUST NOT have them.
- There's no text saying when or if agents or servers 
  should add Route-Record AVP(s) to responses.
- Base (Section 2.10) says that "...the local Diameter agent, 
  on receiving a Diameter response authorizing a session, 
  MUST check the Route-Record AVPs...". 
- NASREQ (Section 9.2) says that RADIUS translation should
  add Route-Record AVPs to AA-Answers. (Route-Record is 
  mentioned several times in Section 9, but all the other 
  cases apply only to requests, so they're probably ok).

Proposed change:

I'm not totally sure what the correct change would be
(that is, should answers have Route-Record AVPs or not).
They were removed in issue 228, but the text about path
authorization (added in issue 390) clearly assumes we 
have them.

Best regards,
Pasi

---

From: Jari Arkko <[email-masked]>
Date: Tue, 02 Sep 2003 17:34:59 +0300

Auth48 is on for the base spec, so in theory we can still
fix things. Assuming the fixes are simple, and don't get
us into additional trouble...

--Jari