Subject: RE: [AAA-WG]: Route-Record AVP in responses

From: <[email-masked]>
Date: Tue, 2 Sep 2003 19:45:35 +0300

Yes, and I am waiting on the simple fixes that don't get 
us into trouble ;)

> -----Original Message-----
> From: ext Jari Arkko [mailto:[email-masked]]
> Sent: 02 September, 2003 17:35
> To: Eronen Pasi (NRC/Helsinki)
> Cc: [email-masked]
> Subject: Re: [AAA-WG]: Route-Record AVP in responses
> 
> 
> Auth48 is on for the base spec, so in theory we can still
> fix things. Assuming the fixes are simple, and don't get
> us into additional trouble...
> 
> --Jari
> 
> 
> 
>

---

From: <[email-masked]>
Date: Tue, 2 Sep 2003 21:50:06 +0300

> Yes, and I am waiting on the simple fixes that don't get 

Let's see what changes would be needed... if we stick
with the decision in issue 228 (no Route-Record AVPs
in responses), Base needs these changes:

- In section 2.10, delete the paragraph that starts 
  "Similarly, the local Diameter agent..."
- In 10.2 (AVP occurrence table), change "0+" to "0"
  in cell (Route-Record,ACA).

From editing point of view, the changes are small--but might get 
us into trouble since it removes some functionality... (especially
since the deleted paragraph also discusses some security issues).

If we decide that responses DO have Route-Records, we
need to change the following:

- First we have to decide whether the Route-Record AVPs are 
  added to the response one-by-one (as it gets forwarded 
  back to the client), or if the server does it (by copying
  all the Route-Record AVPs from the request). While the latter
  was used in e.g. Base-05, IMHO the former seems much less
  problematic.
- The former approach would mean adding a new paragraph to 
  Section 6.2.2  (after the first one): "A proxy or relay agent 
  MUST append a Route-Record AVP to all responses forwarded. 
  The AVP contains the identity of the peer the response was 
  received from."
- In 10.1 (AVP occurrence table), change "0" to "0+" in 
  cells Route-Record X (RAA,ASA,STA)
- Add "* [ Route-Record ]" to ABNFs (after Proxy-Info) 
  in 8.3.2 (RAA), 8.4.2 (STA), 8.5.2 (ASA) and 9.7.2 (ACA)

(Either way, NASREQ needs changes as well. I can try to figure 
out what they are when we decide which way to go.)

Best regards,
Pasi

---

From: <[email-masked]>
Date: Wed, 3 Sep 2003 10:05:56 +0300

Hi Pasi,

These changes sound too big to make within the authors' 48 hour
period, so I think we need to file these as a bug for the future.

I think the list should discuss what is the best way to solve this.

John

> From: ext [mailto:[email-masked]]
> Sent: 02 September, 2003 21:50
> To: Loughney John (NRC/Helsinki); [email-masked]
> Cc: [email-masked]
> Subject: RE: [AAA-WG]: Route-Record AVP in responses
> 
> 
> 
> John Loughney wrote:

---

From: David Mitton <[email-masked]>
Date: Fri, 05 Sep 2003 11:12:59 -0400

On 9/3/2003 10:05 AM +0300, [email-masked] wrote:
>...

> > out what they are when we decide which way to go.)

So, should I ignore this for now too?
Are there any minor fixups to make?

Dave.