Subject: RE: [AAA-WG]: CCA: Separation of sent and received bytes in CCA

From: "Leena Mattila (TU/LMF)" <[email-masked]>
Date: Tue, 7 Oct 2003 08:04:26 +0200

> 
> Ok, I see that the different AVPs would not be good.

As a mixture of general and specific AVPs, no. But after thinking this over and taking into account your discussion in the other thread about keeping CCA in line with RADIUS/DIAMETER NASREQ, maybe the general definition should be abandoned and the units should be defined as follows instead:
<XXX-Service-Unit>::=< AVP Header: TBD > 
                         [ CC-Time ] 
                         [ CC-Money ] (grouped, consists of monetary amount and currency code)
                         [ CC-Total-Octets ]
                         [ CC-Input-Octets ]
                         [ CC-Output-Octets ]
                         [ CC-Service-Specific-Units ]
                         *AVP
where XXX stands for Used, Requested or Granted.
The existing Unit-Type and Unit-Value AVPs become thus obsolete.
In practise this would contain exactly the same unit types that we have defined this far. The advantage of the above definition is that if one uses two (or more) unit types at the same time, e.g. CC-Input-Octets and CC-Output-Octets and CC-Time, one does not need to repeat the XXX-Service-Unit AVPs several times, giving less overhead in the message. Also the processing in the receiving end will be simpler.
 
> [Still, having the "direction"
> AVP always present might make things simpler, no need for 
> default values, no
> default handling code in decoders etc.]
> 
Ok, agreed. If we keep the general approach I can add an explicit direction value for TOTAL if that makes things simpler.

/Leena

---

From: Jari Arkko <[email-masked]>
Date: Tue, 07 Oct 2003 18:51:00 +0300

> where XXX stands for Used, Requested or Granted.

This would work for me.

--Jari