Subject: [AAA-WG]: CCA: Abnormal-Termination-Reason AVP replaced by Termination-Caus e AVP

From: "Harri Hakala (TU/LMF)" <[email-masked]>
Date: Wed, 1 Oct 2003 12:12:57 +0200

Submitter name: Harri Hakala
Submitter email address: [email-masked]
Date first submitted: October 1, 2003
Reference: 
Document: CCA-00
Comment type: T
Priority: 2
Section: 3.1, 5.1, 7.1, 9.5
Rationale/Explanation of issue:

The Diameter Base protocol contains a Termination-Cause AVP that can be used to 
indicate the reason why the session was terminated. The Abnormal-Termination-Reason
AVP was introduced in the Credit Control Application for the same purpose and can 
be removed as redundant AVP. The Abnormal-Termination-Reason AVP should be replaced
by the Termination-Cause AVP in Credit-Control-Request message.

Proposed change:

Section 3.1
Replace Abnormal-Termination-Reason with Termination-Cause.

Section 5.1
Remove.

Section 7.1
Replace Abnormal-Termination-Reason with Termination-Cause.

Section 9.5
Remove.

Best Regards.............Harri

---

From: Jari Arkko <[email-masked]>
Date: Mon, 06 Oct 2003 14:56:28 +0300

> by the Termination-Cause AVP in Credit-Control-Request message.

Agree.

--Jari