Subject: RE: [AAA-WG]: CCA: Rating Input

From: "Harri Hakala (TU/LMF)" <[email-masked]>
Date: Mon, 6 Oct 2003 11:04:38 +0200

> Can you clarify why it would not be appropriate to just 
> require new AVPs
> to be defined whenever they are needed?

I thought that there may be existing application servers, which already support 
some other data format for accounting data, e.g. ASN.1. If these servers 
do not use any other Diameter application, it may be simpler to re-use 
existing data format (embedded in the Service Parameter Info AVP) for 
credit control as well. By using SPI one can also avoid CCA protocol 
updates, when new services and rating input will be introduced.

On the other hand the Service-Parameter-Info is also an AVP and by using 
*AVP we can also avoid CCA updates, so after all do we really need SPI AVP?

Regards.........Harri

> -----Original Message-----
> From: Jari Arkko [mailto:[email-masked]]
> Sent: 3. lokakuuta 2003 17:42
> To: Harri Hakala (TU/LMF)
> Cc: [email-masked]'
> Subject: Re: [AAA-WG]: CCA: Rating Input
> 
> 
> Harri Hakala (TU/LMF) wrote:
> > Submitter name: Harri Hakala
> > Submitter email address: [email-masked]
> > Date first submitted: October 3, 2003
> > Reference: 
> > Document: CCA-00
> > Comment type: T/E
> > Priority: 2
> > Section: 4
> > Rationale/Explanation of issue:
> > 
> > There have two ways to provide rating input to the CC server,
> > either by including them in the Service-Parameter-Info AVP 
> or by re-using AVPs from other 
> > standard/vendor specific Diameter applications (NASREQ, Mobile IP).
> > The CCA only describes the first option but not the other. 
> Some rating
> > functionality is discussed here and there in the draft but a general
> > principles are not addressed in the draft.
> 
> Yes, this needs to be addressed.
> 
> > 4.x Rating Input
> > 
> > There SHOULD be an agreement between the service providers 
> of the credit control
> > client and the credit control server in order to know who 
> shall handle the billing 
> > of which services, which chargeable services are available 
> when roaming etc. Part of 
> > this process has to cover also the agreed rating input.
> > 
> > There are two ways for providing rating input to the credit 
> control server, either by
> > including them in the Service-Parameter-Info AVP or by 
> re-using AVPs from other Diameter
> > applications. The general principle for sending rating 
> parameters is that the service
> > SHOULD re-use existing AVPs, if the service can use AVPs 
> defined by some Diameter application.
> > The Service-Parameter-Info AVP SHOULD be used when the 
> service is not using any other Diameter
> > application or can't re-use any AVPs.
> 
> Can you clarify why it would not be appropriate to just 
> require new AVPs
> to be defined whenever they are needed?
> 
> --Jari
>

---

From: Jari Arkko <[email-masked]>
Date: Mon, 06 Oct 2003 14:39:40 +0300

> credit control as well. By using SPI one can also avoid CCA protocol 

Such an AVP might be useful, yes, maybe even more generally
than in CCA.

> *AVP we can also avoid CCA updates, so after all do we really need SPI AVP?

Well, you need *some* AVP to carry the information. I think you had
SHOULD for using existing AVPs, which I think is fine. *AVP is right
too. In addition, you may need the other info carrier AVP. But I'd
be happier if we could say something about its contents, e.g. at least
that it is always in ASN.1 BER form or something like that.

--Jari