Subject: [AAA-WG]: CCA: Separation of sent and received bytes in CCA

From: "Leena Mattila (TU/LMF)" <[email-masked]>
Date: Thu, 2 Oct 2003 14:50:38 +0200

Separation of sent and received bytes in CCA
Submitter name: Leena Mattila
Submitter email address: [email-masked]
Date first submitted: October 2, 2003
Reference: 
Document: CCA-00
Comment type: T
Priority: 2
Section: 5.x, 5.15, 5.17, 5.26, 9.x
Rationale/Explanation of issue:

In the current Credit Control Application it is not possible 
to measure the sent and received bytes separately. However, 
for some services the direction of the measured data volume 
can play an important role in billing, and thus there should 
be a possiblity to make a distinction between the sent and 
received bytes.

Proposed change:

ADD Section:
5.x Volume-Direction AVP  
     
   The Volume-Direction AVP (AVP Code TBD) is of type Enumerated and
   indicates in which direction the units of type volume are counted. 

       INPUT                                                   0  
       When the Volume-Direction AVP is set to INPUT the Unit-Value AVP
       contains the bytes received from the user.

       OUTPUT                                                  1 
       When the Volume-Direction AVP is set to OUTPUT the Unit-Value AVP
       contains the bytes sent to the user. 

Section 5.15
FROM:
   If the Unit-Type AVP is set to volume in the 
Credit-Control-Answer or
   AA Answer command, the Unit-Value AVP specifies the 
granted volume in
   bytes.

TO:
   If the Unit-Type AVP is set to volume in the 
Credit-Control-Answer or
   AA Answer command, the Unit-Value AVP specifies the 
granted volume in
   bytes, optionally detailed with direction information (sent or
   received bytes). If no direction information is included, the
   Unit-Value AVP contains the total volume.

FROM:
   It has the following ABNF grammar:  
         
             <Granted-Service-Unit>::=< AVP Header: TBD >  
                                          { Unit-Type }  
                                          { Unit-Value }  
                                          [ Currency-Code ]

TO:
   It has the following ABNF grammar: 
     
             <Granted-Service-Unit>::=< AVP Header: TBD > 
                                          { Unit-Type } 
                                          { Unit-Value } 
                                          [ Currency-Code ]
                                          [ Volume-Direction ]

Section 5.17
FROM:
   If the Unit-type AVP is set to volume in the Credit-Control-Request
   command, the Unit-Value AVP specifies the requested volume 
in bytes.

TO:
   If the Unit-type AVP is set to volume in the Credit-Control-Request
   command, the Unit-Value AVP specifies the requested volume 
in bytes,
   optionally detailed with direction information (sent or received
   bytes). If no direction information is included, the Unit-Value AVP
   contains the total volume.

FROM:
   It has the following ABNF grammar:  
        
             <Requested-Service-Unit>::=< AVP Header: TBD >  
                                      { Unit-Type }  
                                      { Unit-Value }  
                                      [ Currency-Code ]
TO:
   It has the following ABNF grammar:  
        
             <Requested-Service-Unit>::=< AVP Header: TBD >  
                                      { Unit-Type }  
                                      { Unit-Value }  
                                      [ Currency-Code ]
                                      [ Volume-Direction ]

Section 5.26
FROM:
   If the Unit-Type AVP is set to volume in the Credit-Control-Request
   command, the Unit-Value AVP specifies the used volume in bytes.

TO:
   If the Unit-type AVP is set to volume in the Credit-Control-Request
   command, the Unit-Value AVP specifies the used volume in bytes,
   optionally detailed with direction information (sent or received
   bytes). If no direction information is included, the Unit-Value AVP
   contains the total volume.

FROM:
   It has the following ABNF grammar:  
                 <Used-Service-Unit>::=< AVP Header: TBD >  
                                       { Unit-Type }  
                                       { Unit-Value }  
                                       [ Currency-Code ]

TO:
   It has the following ABNF grammar:  
                 <Used-Service-Unit>::=< AVP Header: TBD >  
                                       { Unit-Type }  
                                       { Unit-Value }  
                                       [ Currency-Code ]
                                       [ Volume-Direction ]

ADD Section:
9.x Volume-Direction AVP  
        
   As defined in Section 5.x, the Volume-Direction AVP (AVP Code 
   TBD) defines the values 0-1. All remaining values are available for 
   assignment via Designated Expert [IANA].  

Best Regards,
Leena Mattila

---

From: Jari Arkko <[email-masked]>
Date: Fri, 03 Oct 2003 17:37:11 +0300

> be a possiblity to make a distinction between the sent and 

I agree that this is a requirement.

>    Unit-Value AVP contains the total volume.

Hmm... would the protocol be simpler if you always included the
direction (you can set the limits to be the same, of course).
Question: do you also want to measure TOTAL bytes sent? This
gets complicated fast, but

     Sent-Bytes-Limit
     Rcvd-Bytes-Limit
     Total-Bytes-Limit

might do the job in a simpler fashion.

>    assignment via Designated Expert [IANA].  

Or 2=total?

--Jari