Subject: RE: [AAA-WG]: CCA: Separation of sent and received bytes in CCA

From: "Leena Mattila (TU/LMF)" <[email-masked]>
Date: Mon, 6 Oct 2003 08:07:49 +0200

Hi Jari,

thanks for feedback. Answers inline.

/Leena

> > TO:
> >    If the Unit-Type AVP is set to volume in the 
> > Credit-Control-Answer or
> >    AA Answer command, the Unit-Value AVP specifies the 
> > granted volume in
> >    bytes, optionally detailed with direction information (sent or
> >    received bytes). If no direction information is included, the
> >    Unit-Value AVP contains the total volume.
> 
> Hmm... would the protocol be simpler if you always included the
> direction (you can set the limits to be the same, of course).

I don't have a strong opinion about this but can't one use default values when some AVP is missing? When direction is missing it means direction-independent, i.e. total. The reason why I did not specify "total" separately was that "total" is not a direction in a similar manner as in or out. Also MIP and NASREQ only include Accounting-Input-Octets and Accounting-Output-Octets, not Accounting-Total-Octets.

> Question: do you also want to measure TOTAL bytes sent?

Answer: Yes. The absence of direction means total.

> This gets complicated fast, but
> 
>      Sent-Bytes-Limit
>      Rcvd-Bytes-Limit
>      Total-Bytes-Limit
> 
> might do the job in a simpler fashion.
> 
I don't immediately see how this would make it simpler. We have now a quite general way of requesting, granting and reporting different unit types using a grouped structure, e.g.
              <Granted-Service-Unit>::=< AVP Header: TBD > 
                                           { Unit-Type } 
                                           { Unit-Value } 
                                           [ Currency-Code ]
                                           [ Volume-Direction ]
If one wants to request, grant or report both the sent, received and total units in the same message then the grouped AVP can be repeated in the message. Having own AVPs for Sent-Bytes-Limits etc would mean that there would be a special handling, and special AVPs, just for the unit type Volume, leading to more complicated solution, in my opinion.
Besides, does one really need to report sent, received and total at the same time? I think transfer of redundant (total-bytes) information should be avoided since one can derive total bytes from the sent and received bytes. Omission of direction information would be valid for cases where direction makes no difference, i.e. in that case there would only be total (i.e. volume with no direction), but no sent or received bytes separately.

---

From: Jari Arkko <[email-masked]>
Date: Mon, 06 Oct 2003 13:52:48 +0300

Leena Mattila (TU/LMF) wrote:
,
> If one wants to request, grant or report both the sent, received and total units in the same message then the grouped AVP can be repeated in the message. Having own AVPs for Sent-Bytes-Limits etc w…

Ok, I see that the different AVPs would not be good. [Still, having the "direction"
AVP always present might make things simpler, no need for default values, no
default handling code in decoders etc.]

> Besides, does one really need to report sent, received and total at the same time? I think transfer of redundant (total-bytes) information should be avoided since one can derive total bytes from th…

In reporting usage, this would be duplicate information. But when you grant the
user some amount of service, this might not be. You could grant 100 Kb in OR
100 Kb out OR 100 Kb total, first limit to exceed being the signifant one.

--Jari