Subject: [AAA-WG]: DCC: redirection information per G-S-U

From: "Christopher Richards" <[email-masked]>
Date: Wed, 17 Dec 2003 15:54:09 -0600

Hi All,

Not sure if this has been covered previously. Here goes:

Given that a session may hold multiple G-S-U quotas, and these quotas are
used for very different services, it seems to make sense that each G-S-U can
optionally contain a Redirect-Server AVP.

If a user has a quota for traffic to a game server and another for general
web access, it seems reasonable that when the game server quota expires,
that flow is redirected, while still allowing the general web access flows
to continue until their quota is exhausted. This also implies that when one
quota is exhausted, not all user service should be blocked or redirected (I
think this point has been mentioned before).

This could either be accomplished by adding the Final-Unit-Indication AVP or
Redirect-Server AVP to the G-S-U AVP as an optional AVP. Since the
redirection may be temporary, the Final-Unit-Indication AVP does not seem to
fit best.

I propose changing the G-S-U AVP from:

         Granted-Service-Unit ::= < AVP Header: 431 > 
                                  [ Tariff-Time-Change ]   
                                  [ CC-Time ] 
                                  [ CC-Money ]   
                                  [ CC-Total-Octets ] 
                                  [ CC-Input-Octets ] 
                                  [ CC-Output-Octets ] 
                                  [ CC-Service-Specific-Units ] 
                                 *[ Service-Identifier ] 
                                  [ Rating-Group ] 

To:

         Granted-Service-Unit ::= < AVP Header: 431 > 
                                  [ Tariff-Time-Change ]   
                                  [ CC-Time ] 
                                  [ CC-Money ]   
                                  [ CC-Total-Octets ] 
                                  [ CC-Input-Octets ] 
                                  [ CC-Output-Octets ] 
                                  [ CC-Service-Specific-Units ] 
                                 *[ Service-Identifier ] 
                                  [ Rating-Group ] 
                                  [ Redirect-Server ] 

Best Regards,
Chris.

---

From: <[email-masked]>
Date: Thu, 18 Dec 2003 11:38:03 +0200

Hi Chris,
 
>Given that a session may hold multiple G-S-U quotas, and these quotas are used for very different services, it seems to make sense >that each G-S-U can optionally contain a Redirect-Server AVP.
 
Yes, in certain circumstances it may make sense. 
 
>If a user has a quota for traffic to a game server and another for general web access, it seems reasonable that when the game server >quota expires, that flow is redirected, while still allowing the general web access flows to continue until their quota is exhausted. This >also implies that when one quota is exhausted, not all user service should be blocked or redirected (I think this point has been >mentioned before).
 
Perhaps we are back to the quota allocation strategy discussion, if look carefully to the Flow X you can see that there is one credit reservation for all the services in the user's session and and the client trigger the interim interrogation only when the whole credit reservation has been consumed. This is an extremely simple and efficient approach to achieve differentiated credit control for each of the services in a user's session. I think we need to clarify this point in section 5.
 
However, it is true that we may have some case where the server determines that some service shall be denied and conveys
a value of zero granted unit associated to that service. In such a case it may be good to offer the option of redirecting the
traffic to some place that e.g. inform the user why the service has been denied (e.g. low credit or what so ever). So, I think your proposal make sense in this scenario.
 
Since we published the draf  02 and we just wait that it is announced to issue a WGLC on the document, I would suggest
we wait this event and then work out the official issue/solution in the context of the WGLC. Are you fine with this approach?
 
Cheers
Marco

---

From: "Christopher Richards" <[email-masked]>
Date: Thu, 18 Dec 2003 11:53:48 -0600

Thanks for the positive response. I can assume then that these changes will
be accepted.
 
I am a little concerned that the draft is going to WGLC so soon. It seems a
bit premature. There are still a few outstanding issues that I think should
be addressed before it goes to WGLC status - some of these issues will
probably need some discussion.

Best Regards,
Chris. 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Thursday, December 18, 2003 3:38 AM
To: Richards, Christopher [RICH2:2Q40:EXCH]
Cc: [email-masked]
Subject: RE: [AAA-WG]: DCC: redirection information per G-S-U

Hi Chris,
 
>Given that a session may hold multiple G-S-U quotas, and these quotas are
used for very different services, it seems to make sense >that each G-S-U
can optionally contain a Redirect-Server AVP.

>If a user has a quota for traffic to a game server and another for general
web access, it seems reasonable that when the game server >quota expires,
that flow is redirected, while still allowing the general web access flows
to continue until their quota is exhausted. This >also implies that when one
quota is exhausted, not all user service should be blocked or redirected (I
think this point has been >mentioned before).
 
Perhaps we are back to the quota allocation strategy discussion, if look
carefully to the Flow X you can see that there is one credit reservation for
all the services in the user's session and and the client trigger the
interim interrogation only when the whole credit reservation has been
consumed. This is an extremely simple and efficient approach to achieve
differentiated credit control for each of the services in a user's session.
I think we need to clarify this point in section 5.
 
However, it is true that we may have some case where the server determines
that some service shall be denied and conveys
a value of zero granted unit associated to that service. In such a case it
may be good to offer the option of redirecting the
traffic to some place that e.g. inform the user why the service has been
denied (e.g. low credit or what so ever). So, I think your proposal make
sense in this scenario.
 
Since we published the draf  02 and we just wait that it is announced to
issue a WGLC on the document, I would suggest
we wait this event and then work out the official issue/solution in the
context of the WGLC. Are you fine with this approach?
 
Cheers
Marco

---

From: <[email-masked]>
Date: Thu, 18 Dec 2003 20:13:04 +0200

Hi Chris,

> I am a little concerned that the draft is going to WGLC so soon. It seems a bit premature. 
> There are still a few outstanding issues that I think should be addressed before it goes 
> to WGLC status - some of these issues will probably need some discussion.

At the moment, I am unaware of any outstanding issues. WG LC is a good place to bring 
them up for discussion.  The draft started already several years ago, so we should complete 
it at some point. As I understand, other SDOs have been waiting for this protocol
to complete since 2002.

br,
John

---

From: "Harri Hakala (TU/LMF)" <[email-masked]>
Date: Fri, 19 Dec 2003 08:51:41 +0100

Hi Chris,
 
>Thanks for the positive response. I can assume then that these changes will be accepted.
Yes, we need to solve this issue then and decide the way how to solve this. I don't think that lifting
the Redirect-Server AVP to the G-S-U is the best possible solution. Perhaps it's better to 
enhance the Final-Unit-Indication AVP instead. It's not good to mix the same functionality in 
several places in several ways.
 
>I am a little concerned that the draft is going to WGLC so soon. It seems a bit premature. There are
>still a few outstanding issues that I think should be addressed before it goes to WGLC status - 
>some of these issues will probably need some discussion.
Could you mention which are those outstanding issues, so that we can discuss those issues and 
try to solve issues during WG LC. 
 
Regards...............Harri

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of Christopher Richards
Sent: 18. joulukuuta 2003 19:54
To: [email-masked]'
Cc: [email-masked]
Subject: RE: [AAA-WG]: DCC: redirection information per G-S-U

Thanks for the positive response. I can assume then that these changes will be accepted.
 
I am a little concerned that the draft is going to WGLC so soon. It seems a bit premature. There are still a few outstanding issues that I think should be addressed before it goes to WGLC status - some of these issues will probably need some discussion.

Best Regards,
Chris. 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Thursday, December 18, 2003 3:38 AM
To: Richards, Christopher [RICH2:2Q40:EXCH]
Cc: [email-masked]
Subject: RE: [AAA-WG]: DCC: redirection information per G-S-U

Hi Chris,

 

 
 
Cheers
Marco

---

From: "Christopher Richards" <[email-masked]>
Date: Fri, 19 Dec 2003 10:30:28 -0600

Hi Harri,
 
I agree - the Final-Unit-Indication actually makes more sense than the
Redirect-Server AVP. Apart from the slightly misleading name of the AVP, the
fields fit very well. So I propose the following change:-
 
         Granted-Service-Unit ::= < AVP Header: 431 > 
                                  [ Tariff-Time-Change ]   
                                  [ CC-Time ] 
                                  [ CC-Money ]   
                                  [ CC-Total-Octets ] 
                                  [ CC-Input-Octets ] 
                                  [ CC-Output-Octets ] 
                                  [ CC-Service-Specific-Units ] 
                                 *[ Service-Identifier ] 
                                  [ Rating-Group ] 
 to:-
         Granted-Service-Unit ::= < AVP Header: 431 > 
                                  [ Tariff-Time-Change ]   
                                  [ CC-Time ] 
                                  [ CC-Money ]   
                                  [ CC-Total-Octets ] 
                                  [ CC-Input-Octets ] 
                                  [ CC-Output-Octets ] 
                                  [ CC-Service-Specific-Units ] 
                                 *[ Service-Identifier ] 
                                  [ Rating-Group ] 
                                  [ Final-Unit-Indication ]

A small addition to clause 5.5 should cover the functionality, since the
existing description is equally applicable if the scope of the
Final-Unit_indication is the entire session or just a G-S-U. Adding the
following text to clause 5.5:
 
If a Granted-Service-Unit AVP is received containing a Final-Unit-Indication
AVP, the actions and values in the Final-Unit-Indication AVP are applicable
to the scope of the Granted-Service-Unit AVP in which it was received. I.e.
other services using different Granted-Service-Unit resources are not
affected.

 -----Original Message-----
From: Harri Hakala (TU/LMF) [mailto:[email-masked]] 
Sent: Friday, December 19, 2003 1:52 AM
To: Richards, Christopher [RICH2:2Q40:EXCH]; [email-masked]'
Cc: [email-masked]
Subject: RE: [AAA-WG]: DCC: redirection information per G-S-U

Hi Chris,
 
>Thanks for the positive response. I can assume then that these changes will
be accepted.
Yes, we need to solve this issue then and decide the way how to solve this.
I don't think that lifting
the Redirect-Server AVP to the G-S-U is the best possible solution. Perhaps
it's better to 
enhance the Final-Unit-Indication AVP instead. It's not good to mix the same
functionality in 
several places in several ways.

>I am a little concerned that the draft is going to WGLC so soon. It seems a
bit premature. There are
>some of these issues will probably need some discussion.
Could you mention which are those outstanding issues, so that we can discuss
those issues and 
try to solve issues during WG LC. 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
Christopher Richards
Sent: 18. joulukuuta 2003 19:54
To: [email-masked]'
Cc: [email-masked]
Subject: RE: [AAA-WG]: DCC: redirection information per G-S-U

Best Regards,
Chris. 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Thursday, December 18, 2003 3:38 AM
To: Richards, Christopher [RICH2:2Q40:EXCH]
Cc: [email-masked]
Subject: RE: [AAA-WG]: DCC: redirection information per G-S-U

Hi Chris,

 

 
 
Cheers
Marco