Subject: [AAA-WG]: Update to DCC Issue 25: addition of *[AVP] notation in some grouped AVPs structure

From: <[email-masked]>
Date: Wed, 3 Mar 2004 17:11:36 +0200

Hi,

according to recent discussion here is the updated issue 25 to add the *[ AVP ] notation
also to the G-S-U, R-S-U and U-S-U AVPs.

Regards
Marco

-------------------------------------------------------------
Description of issue: addition of *[AVP] notation in the M-S-C-C AVP structure
Submitter name:  Marco Stura
Date first submitted: 1.03.2004 
Reference: 
Document: draft-ietf-aaa-diameter-cc-03.txt 
Comment type: T
Priority: 1 
Section: 8.16

Rationale/Explanation of issues: 

In order to define a more future proof structure I propose to add the *[AVP] notation
to the M-S-C-C, G-S-U, U-S-U and R-S-U AVPs structure. According to the Base (section 4.4.1) 
the Grouped AVP can contain *[AVP].

Requested change:

-Section 8.16

ADD the *[ AVP ] notation to the AVP structure

       Multiple-Services-Credit-Control ::= < AVP Header: 456 >  
                                            [ Granted-Service-Unit ] 
                                            [ Requested-Service-Units ]  
                                           *[ Used-Service-Units ] 
                                            [ Tariff-Change-Usage ]  
                                           *[ Service-Identifier ]  
                                            [ Rating-Group ]  
                                           *[ G-S-U-Pool-Reference ]  
                                            [ Validity-Time ]  
                                            [ Result-Code ]  
                                            [ Final-Unit-Indication ] 
                                           *[ AVP ]

- Section 8.17

ADD the *[ AVP ] notation to the AVP structure

             Granted-Service-Unit ::= < AVP Header: 431 >  
                                      [ Tariff-Time-Change ]    
                                      [ CC-Time ]  
                                      [ CC-Money ]    
                                      [ CC-Total-Octets ]  
                                      [ CC-Input-Octets ]  
                                      [ CC-Output-Octets ]  
                                      [ CC-Service-Specific-Units ]
                                     *[ AVP ]

- Section 8.18

ADD the *[ AVP ] notation to the AVP structure

              Requested-Service-Unit ::= < AVP Header: 437 >  
                                         [ CC-Time ]  
                                         [ CC-Money ]     
                                         [ CC-Total-Octets ]  
                                         [ CC-Input-Octets ]  
                                         [ CC-Output-Octets ]  
                                         [ CC-Service-Specific-Units ]
                                        *[ AVP ]

- Section 8.19

ADD the *[ AVP ] notation to the AVP structure

               Used-Service-Unit ::= < AVP Header: 446 >  
                                     [ Tariff-Change-Usage ]    
                                     [ CC-Time ]  
                                     [ CC-Money ]    
                                     [ CC-Total-Octets ]   
                                     [ CC-Input-Octets ]  
                                     [ CC-Output-Octets ]  
                                     [ CC-Service-Specific-Units ]
                                    *[ AVP ]

---

From: <[email-masked]>
Date: Thu, 4 Mar 2004 09:57:18 +0200

Issue 25 updated with info below.

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]]On Behalf Of
> ext 
> Sent: 03 March, 2004 17:12
> To: [email-masked]
> Cc: [email-masked]
> Subject: [AAA-WG]: Update to DCC Issue 25: addition of *[AVP] notation
> in some grouped AVPs structure
> 
> 
> 
> Hi,
>