Subject: RE: [AAA-WG]: DCC: Issue: Client Support of Tariff Change Mechani sm

From: "Harri Hakala (TU/LMF)" <[email-masked]>
Date: Tue, 2 Mar 2004 08:27:06 +0100

Assigned issue 27.

/ Harri

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of [email-masked]
Sent: 1. maaliskuuta 2004 17:53
To: [email-masked]
Subject: [AAA-WG]: DCC: Issue: Client Support of Tariff Change Mechanism

Description of issue:  Client Support of Tariff Change Mechanism
Submitter name:  John Prudhoe
Date first submitted: 1.03.2004 
Reference: 
Document: draft-ietf-aaa-diameter-cc-03.txt 
Comment type: E
Priority: 
Section: 8.27

Rationale/Explanation of issues: 

In section 5.1 it is only specified that the client SHOULD support the tariff change mechanism and the itemising of usage using the Tariff-Change-Usage AVP. 

I believe the last sentence of section 8.27 (Tariff-Change-Usage AVP) is meant to support this, but it is not clear. 

My suggested change is in section 8.27: 

FROM 

Omission of this AVP means that no tariff change has been occurred. 

TO 

If the client does not support the itemisation of tariff change usage, when the Tariff-Time-Change AVP was present in the previous answer, this AVP MUST be omitted. 

Regards, 

John. 

In the last paragraph of 5.1 (p16 of cc-03) 

change SHOULD to MUST

******************************************************************************

The content of this e-mail may be privileged and/or confidential.
If you are not the addressee indicated in this message 
(or responsible for delivery of the message to such person), 
you may not copy or deliver this message to anyone. In such 
case, you should destroy this message and kindly notify the 
sender and [email-masked] by reply email. Please
note that in such circumstances any review, dissemination, 
disclosure, alteration, printing, copying or further transmission
of this e-mail and/or any file transmitted with it is prohibited 
and may be unlawful. Please advise us immediately if you or
your employer do not consent to Internet email for messages 
of this kind. The opinions, conclusions and other information 
in this message are of the author and shall be understood as 
neither given nor endorsed by Vodafone Ireland Limited 
unless it is otherwise indicated by an authorised representative 
independent of this message. Internet e-mail is
transmitted over the public internet over which Vodafone 
Ireland Limited has no control. As such, there is no guarantee that 
(i) this e-mail will be delivered within a reasonable time or at all
(ii) this e-mail comes from the purported sender 
(iii) this e-mail has not been intercepted by a third party 
(iv) the contents of this e-mail are unaltered from the time of
transmission. The presence of this footnote indicates that this 
message (including its attachments) has been processed by an 
automated anti-virus system; however it is the responsibility of 
the recipient to ensure that the message (and attachments) 
are safe and authorised for use in their environment.
Vodafone Ireland Ltd Directors: Peter Bamford Chairman (UK), 
Pauline Best (UK), Paul Donovan Chief Executive (UK), 
Gerry Fahy, Dermot Griffin, David Boorman, David Smithwhite(UK).
Registered in Ireland at MountainView, Leopardstown, Dublin 18. 
Number 326967 VAT Reg No. IE6346967G

******************************************************************************

This communication is confidential and intended solely for the addressee(s). Any unauthorized review, use, disclosure or distribution is prohibited. If you believe this message has been sent to you in error, please notify the sender by replying to this transmission and delete the message without disclosing it. Thank you.

E-mail including attachments is susceptible to data corruption, interruption, unauthorized amendment, tampering and viruses, and we only send and receive e-mails on the basis that we are not liable for any such corruption, interception, amendment, tampering or viruses or any consequences thereof.

---

From: "Harri Hakala (TU/LMF)" <[email-masked]>
Date: Tue, 2 Mar 2004 08:28:17 +0100

Hi,

It seems that the tariff switch mechanism is not defined very clearly
in section 5.1, perhaps we can add one sentence to clarify its usage,
in case when client does not support tariff switch mechanism. 

For instance we can add sentence (or something similar):
If a client does not support the tariff change mechanism, and it receives a
CCA message carrying Tariff-Time-Change AVP, it MUST terminate
the credit control session with proper Termination-Cause AVP reason included.

Regards.........Harri

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of [email-masked]
Sent: 1. maaliskuuta 2004 18:41
To: [email-masked]
Cc: [email-masked]; [email-masked]
Subject: RE: [AAA-WG]: DCC: Issue: Client Support of Tariff Change Mechanism

Hi Marco, 

OK, I was concentrating on 5.1 & missed 8.20.  This is a better solution than I thought the mechanism was.  I agree that some rewording of 5.1 is necessary as you suggest. 

Regards, 

John. 

<[email-masked]> 
01/03/2004 16:25 
        
        To:        <[email-masked]> 
        cc:        <[email-masked]> 
        Subject:        RE: [AAA-WG]: DCC: Issue: Client Support of Tariff Change Mechanism

Hi John,

the tariff-time-change mechanism consists of a server instructing the client when the tariff change will occurs and
of a client reporting units used before and after tariff change.

in section 8.20 it is specified that 

  If a client does not support the tariff time change mechanism it MUST 
  treat Tariff-Time-Change AVP in the answer message as an incorrect 
  CCA answer. In that case the client terminates the credit control 
  session and indicate in the Termination-Cause AVP reason 
  DIAMETER_BAD_ANSWER. 

Then, if the client accept the Tariff-Time-Change AVP it is because it supports the itemising of
usage using the Tariff-Change-Usage AVP.

You wrote:

>If the client does not support the itemisation of tariff change usage, when the Tariff-Time-Change AVP was present in the >
>previous answer, this AVP MUST be omitted. 

According to section 8.20, this case shouldn't happen.
The SHOULD keyword was used because it is not sure whether the tariff change will occur during the reporting
period. Perhaps the sentence in 5.1 should be rephrased so that "when a tariff change occurs during the
reporting period the client MUST itemize..."?

Regards
Marco

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of ext [email-masked]
Sent: 01 March, 2004 17:53
To: [email-masked]
Subject: [AAA-WG]: DCC: Issue: Client Support of Tariff Change Mechanism

FROM 

TO 

Regards, 

John. 

change SHOULD to MUST