Subject: [AAA-WG]: DCC Issue: some AVP occurence inconsistency between commands and table

From: <[email-masked]>
Date: Fri, 5 Mar 2004 16:08:59 +0200

Description of issue:  some AVP occurence  inconsistency between commands and table
Submitter name:  Marco Stura
Date first submitted: 5.03.2004 
Reference: 
Document: draft-ietf-aaa-diameter-cc-03.txt 
Comment type: E
Priority: 1 
Section: 3.1 and 3.2

Rationale/Explanation of issue

There is an inconsistence between the occurence of the CC-Correlation-Id AVP in section 3.1
and the occurence of the same AVP in the table of section 10.1. In the command multiple
instances of this AVP are possible while in the table only 0-1.
The other way round concerning the Subscription-Id and the Redirect-Host AVPs.

I think what is indicated in the table is the right one. 

Requested change:

- Section 3.1

FROM

<Credit-Control-Request> ::= < Diameter Header: 272, REQ, PXY > 
                             < Session-Id >
                                   :
                                   :
                                   :
                                   :
                            *[ CC-Correlation-Id ] 
                                   :
                                   :
                                   :
                                   :
TO

<Credit-Control-Request> ::= < Diameter Header: 272, REQ, PXY > 
                             < Session-Id >
                                   :
                                   :
                                   :
                                   :
                             [ CC-Correlation-Id ] 
                                   :
                                   :
                                   :
                                   :

- Section 3.2

FROM

<Credit-Control-Answer> ::= < Diameter Header: 272, PXY > 
                            < Session-Id >
                                   :
                                   :
                                   :
                                   :
                            [ Subscription-Id ]  
                                   :
                                   :
                            [ Redirect-Host AVP ] 
                                   :
                                   :

TO

<Credit-Control-Answer> ::= < Diameter Header: 272, PXY > 
                            < Session-Id >
                                   :
                                   :
                                   :
                                   :
                           *[ Subscription-Id ]  
                                   :
                                   :
                           *[ Redirect-Host AVP ] 
                                   :
                                   :

---

From: <[email-masked]>
Date: Mon, 8 Mar 2004 07:18:34 +0200

Assigned Issue 29.

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]]On Behalf Of
> ext 
> Sent: 05 March, 2004 16:09
> To: [email-masked]
> Subject: [AAA-WG]: DCC Issue: some AVP occurence inconsistency between
> commands and table
> 
> 
>