Subject: [AAA-WG]: Proposed resolution of EAP issue 455: User-name handling

From: <[email-masked]>
Date: Thu, 25 Mar 2004 15:32:49 +0200

Hi,

Does this look ok?

Replace in Section 2.8.1

   "Therefore, the Diameter Server SHOULD return the user's
   identity by inserting it in the User-Name AVP of subsequent
   Diameter-EAP-Answer packets.  Without the user's identity,
   the Session-Id AVP MAY be used for accounting and billing,
   however operationally this could be very difficult to manage."

by

   "Therefore, the Diameter Server SHOULD return the user's
   identity by inserting a User-Name AVP to Diameter-EAP-Answer
   messages that have a Result-Code of DIAMETER_SUCCESS.  A
   separate billing identifier or pseudonym MAY be used for
   privacy reasons (see Section 8.5). If the user's identity is
   not available to the NAS, the Session-Id AVP MAY be used for
   accounting and billing; however operationally this could be
   very difficult to manage."

BR,
Pasi

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]]On Behalf Of
> ext Joseph Salowey
> Sent: Thursday, March 04, 2004 12:00 AM
> To: [email-masked]
> Subject: [AAA-WG]: Issue EAP : User-name Handling
> 
> 
> 
> Submitter name: Joe Salowey 
> Submitter email address: [email-masked] 
> Date first submitted: 3/3/2004 
> Reference: 
> Document: eap 
> Comment type: 'E'ditorial
> Priority: '1' Should fix 
> Section: 2.8.1
> Rationale/Explanation of issue: 
> 
> The draft says "...the Diameter server SHOULD return the 
> user's identity
> by inserting it in the User-Name AVP of susequent Diameter-EAP-Answer
> packets."  It is not clear which user identity this is 
> referring to.  If
> it is referring to the user's real identity this is only 
> available once
> the EAP method completes.  It probably should state:
> 
> "...the Diameter Server SHOULD return the real user's identity by
> inserting it in the User-Name AVP of Diameter-EAP-Answer packets that
> contain a Result-Code of DIAMETER-SUCCESS."
>  
> It might also be good to discuss that the real user-name MAY 
> be omitted
> or replaced with a different billing identifier if identity privacy is
> required in the DIAMETER channel.
> 
> 
>

---

From: "Joseph Salowey" <[email-masked]>
Date: Mon, 29 Mar 2004 13:50:09 -0800

Looks good.

[email-masked] wrote:
>> it is referring to the user's real identity this is only available
>> once the EAP method completes.  It probably should state:
>> 
>> or replaced with a different billing identifier if identity privacy
>> is required in the DIAMETER channel.