Subject: [AAA-WG]: DCC Issue: Change END_USER_MSISDN to END_USER_E164

From: "Leena Mattila (TU/LMF)" <[email-masked]>
Date: Mon, 8 Mar 2004 12:57:06 +0100

Description of issue: Change END_USER_MSISDN to END_USER_E164
Submitter name:  Leena Mattila
Date first submitted: 8.03.2004 
Reference: 
Document: draft-ietf-aaa-diameter-cc-03.txt 
Comment type: T
Priority: 1 
Section: 8.46

Rationale/Explanation of issue

The Subscription-Id-Type AVP contains value END_USER_MSISDN allowing the possibility to use numbers in E.164 format as subscription identities. The current definition restricts the usage to mobile (3GPP) environment by specifying that the number should be in international MSISDN format according to the ITU-T E.164. However, E.164 numbering plan is not restricted to MSISDN and should be allowed to be used for other subscription ids as well.

Requested change:

- Section 8.46

FROM

      END_USER_MSISDN                                              0  
    
           The identifier is in international MSISDN format, according  
           to the ITU-T E.164 numbering plan as defined in [E164] and  
           [CE164].  

TO

      END_USER_E164                                                0  
    
           The identifier is in international E.164 format (e.g. MSISDN),
           according to the ITU-T E.164 numbering plan as defined in
           [E164] and [CE164].  

Regards,
Leena

This communication is confidential and intended solely for the addressee(s). Any unauthorized review, use, disclosure or distribution is prohibited. If you believe this message has been sent to you in error, please notify the sender by replying to this transmission and delete the message without disclosing it. Thank you.

E-mail including attachments is susceptible to data corruption, interruption, unauthorized amendment, tampering and viruses, and we only send and receive e-mails on the basis that we are not liable for any such corruption, interception, amendment, tampering or viruses or any consequences thereof.

---

From: "Christopher Richards" <[email-masked]>
Date: Mon, 8 Mar 2004 07:59:04 -0600

Hi Leena,

Is it still possible for the DCC server determine exactly what is contained
in the AVP if it is not restricted to the MSISDN? 

I think it makes more sense to leave it specified as the MSISDN - otherwise
it will become more difficult to determine what the E.164 AVP actually
contains. Alternatively, the text could be changed to state that "for 3GPP
networks, the MSISDN MUST be used in this field". 

Br,
Chris.

-----Original Message-----
From: Leena Mattila (TU/LMF) [mailto:[email-masked]]
Sent: Monday, March 08, 2004 5:57 AM
To: [email-masked]
Subject: [AAA-WG]: DCC Issue: Change END_USER_MSISDN to END_USER_E164

The Subscription-Id-Type AVP contains value END_USER_MSISDN allowing the
possibility to use numbers in E.164 format as subscription identities. The
current definition restricts the usage to mobile (3GPP) environment by
specifying that the number should be in international MSISDN format
according to the ITU-T E.164. However, E.164 numbering plan is not
restricted to MSISDN and should be allowed to be used for other subscription
ids as well.

Requested change:

- Section 8.46

FROM

      END_USER_MSISDN                                              0  

TO

      END_USER_E164                                                0  

Regards,
Leena

This communication is confidential and intended solely for the addressee(s).
Any unauthorized review, use, disclosure or distribution is prohibited. If
you believe this message has been sent to you in error, please notify the
sender by replying to this transmission and delete the message without
disclosing it. Thank you.

E-mail including attachments is susceptible to data corruption,
interruption, unauthorized amendment, tampering and viruses, and we only
send and receive e-mails on the basis that we are not liable for any such
corruption, interception, amendment, tampering or viruses or any
consequences thereof.

---

From: "Leena Mattila (TU/LMF)" <[email-masked]>
Date: Mon, 8 Mar 2004 15:13:56 +0100

Hi Chris,

yes, I think it is possible to separate MSISDN from other numbers since mobile networks have their own national destination codes. If I receive an E.164 number +35840123456 I know it's a number belonging to a specific gsm operator in Finland, and thus the number is MSISDN because in gsm one uses MSISDN to identify subscribers. I'd leave the clarification sentences like "...in 3GPP one does this and that..." up to 3GPP specs to define.

BR,
Leena

-----Original Message-----
From: Christopher Richards [mailto:[email-masked]]
Sent: 8. maaliskuuta 2004 15:59
To: Leena Mattila (TU/LMF); [email-masked]
Subject: RE: [AAA-WG]: DCC Issue: Change END_USER_MSISDN to END_USER_E164

Hi Leena, 
Is it still possible for the DCC server determine exactly what is contained in the AVP if it is not restricted to the MSISDN? 
I think it makes more sense to leave it specified as the MSISDN - otherwise it will become more difficult to determine what the E.164 AVP actually contains. Alternatively, the text could be changed to state that "for 3GPP networks, the MSISDN MUST be used in this field". 
Br, 
Chris.

---

From: <[email-masked]>
Date: Tue, 9 Mar 2004 11:44:30 +0200

Hi Leena,

in SIP a user can be identified also with Tel URI, which is actually E.164 number.
Example:  tel:+1-555-2222-3333
How do you see the support of this type of identity in the Subscription-Id AVP?

Cheers
Marco

> From: [email-masked] 
> [mailto:[email-masked]]On Behalf Of
> ext Leena Mattila (TU/LMF)
> Sent: 08 March, 2004 16:14
> To: 'Christopher Richards'; [email-masked]
> yes, I think it is possible to separate MSISDN from other 
> numbers since mobile networks have their own national 
> destination codes. If I receive an E.164 number +35840123456 
> I know it's a number belonging to a specific gsm operator in 
> Finland, and thus the number is MSISDN because in gsm one 
> uses MSISDN to identify subscribers. I'd leave the 
> clarification sentences like "...in 3GPP one does this and 
> that..." up to 3GPP specs to define.
> 
> BR,
> Leena
> 
> Is it still possible for the DCC server determine exactly 
> what is contained in the AVP if it is not restricted to the MSISDN? 
> I think it makes more sense to leave it specified as the 
> MSISDN - otherwise it will become more difficult to determine 
> what the E.164 AVP actually contains. Alternatively, the text 
> could be changed to state that "for 3GPP networks, the MSISDN 
> MUST be used in this field". 
> Br, 
> Chris. 
> 
> This communication is confidential and intended solely for 
> the addressee(s). Any unauthorized review, use, disclosure or 
> distribution is prohibited. If you believe this message has 
> been sent to you in error, please notify the sender by 
> replying to this transmission and delete the message without 
> E-mail including attachments is susceptible to data 
> corruption, interruption, unauthorized amendment, tampering 
> and viruses, and we only send and receive e-mails on the 
> basis that we are not liable for any such corruption, 
> interception, amendment, tampering or viruses or any 
> consequences thereof.
> 
>

---

From: "Leena Mattila (TU/LMF)" <[email-masked]>
Date: Tue, 9 Mar 2004 11:12:44 +0100

Hi Marco,

firstly, I don't see how the question is related to separation of MSISDN from other E164 numbers as discussed below???
With the existing (draft-03) structure it is less possible to indicate tel URLs, as far as I can judge.

I think it is possible to support your tel:+1-555-2222-3333 tel URL as follows:
Subscription-id-Type = END_USER_E164
Subscription-id-Data = "155522223333" 
or one can convert it to SIP URL (or is the correct name SIP URI, btw?).
I wouldn't go so far as to introduce a new id type since, as you say, tel URL is an E.164 number.

BR,
Leena

> From: [email-masked] [mailto:[email-masked]]
> Sent: 9. maaliskuuta 2004 11:45
> To: Leena Mattila (TU/LMF)
> Cc: [email-masked]; [email-masked]

---

From: <[email-masked]>
Date: Tue, 9 Mar 2004 12:24:36 +0200

> firstly, I don't see how the question is related to 
> separation of MSISDN from other E164 numbers as discussed below???

It was just unclear to me if that END_USER_E164 could be used for
tel URI type of identity.

> Subscription-id-Data = "155522223333"

I guess so, thank you for the clarification.

> you say, tel URL is an E.164 number.

I was not proposing anything, just asking a question.
Again, thank you for your answer.

Regards
Marco