Subject: RE: [AAA-WG]: Diameter EAP -05

From: <[email-masked]>
Date: Mon, 5 Apr 2004 17:12:02 +0300

Jari Arkko wrote:
>
> How about this to the end of 2.8.5:
> 
> "A disadvantage of this approach is that it becomes harder
> to support so called EAP channel bindings described in
> Section 7.15 of [RFC2284bis]. The reason for this is that
> entity performing the EAP authentication needs to be aware
> of all authorization data related to the session. It is
> therefore RECOMMENDED that the backend authentication
> server both accepts incoming authorization AVPs as well as
> returns authorization AVPs. (How the backend server finds
> out which authorization AVPs to return is outside the
> scope of this specification.)"
> 
> Another approach would be to delete the whole section.

Hmm... with this addition, the situation is not that 
different from having a Diameter proxy agent that
does some authorization parts. And that case is
already covered elsewhere.

I'd suggest that we delete the whole section 2.8.5;
any other opinions about this?

Best regards,
Pasi

---

From: Jari Arkko <[email-masked]>
Date: Tue, 20 Apr 2004 16:26:41 +0300

> any other opinions about this?

I'm fine with that. Comments from anyone else?

--Jari