Subject: [AAA-WG]: Result code vrs Error Code

From: "Glass, Cameron, Global IT" <[email-masked]>
Date: Thu, 29 Apr 2004 08:58:28 +0100

Hello

Regarding section 9.1 of CC-04

"9.1 Transient Failures  
     
   Errors that fall within the transient failures category are used to 
   inform a peer that the request could not be satisfied at the time it 
   was received, but MAY be able to satisfy the request in the future.  

...

   DIAMETER_CREDIT_CONTROL_NOT_APPLICABLE     4011 
     The credit-control server determines that the service can be 
     granted to the end user but no further credit-control is needed for 
     the service (e.g. service is free of charge).  "

The use of a 4xxx series code seems odd in this case as this does not seem to be an error but may infact be a desirable result. Was the use of a 2xxx code considered and discarded for a particular reason?

regards

Cameron Glass

Cameron Glass
Global IT Designer
Global IT 
Vodafone Group Technology & Business Integration
e-mail:[email-masked]

Vodafone Group Services Limited
Registered Office: Vodafone House, The Connection, Newbury, Berkshire, RG14 2FN 
Registered in England No  3802001

---

From: "Harri Hakala (JO/LMF)" <[email-masked]>
Date: Thu, 29 Apr 2004 12:02:24 +0200

Hi Cameron,

> The use of a 4xxx series code seems odd in this case as this 
> does not seem to be an error but may infact be a desirable 
> result. Was the use of a 2xxx code considered and discarded 
> for a particular reason?

I agree with you that it is a bit odd to use 4xxx series code, 
since it is not an error, as you said. But by using 4xxx series code
the CC server can indicate that the credit control session is over and
no further signalling is needed for the session. Otherwise (2xxx code),
the CC server should maintain the session, until it receives the 
CCR[TERMINATION] from the client.

regards...........Harri