Subject: [AAA-WG]: Multiple Quotas in Granted-Service-Unit etc. in D-CCA

From: "Glass, Cameron, Global IT" <[email-masked]>
Date: Thu, 29 Apr 2004 12:14:48 +0100

Hi,

Is it possible to include multiple quotas in Granted-Service-Unit or Used-Service-Unit?  This would mean, for example, both CC-Time and CC-Total-Octets being included in the same instance of Granted-Service-Unit.  Is that acceptable?

Regards,

Cameron.

Cameron Glass
Global IT Designer
Global IT 
Vodafone Group Technology & Business Integration

---

From: <[email-masked]>
Date: Thu, 29 Apr 2004 15:43:31 +0300

Hi Cameron,

> Is it possible to include multiple quotas in 
> Granted-Service-Unit or Used-Service-Unit?  This would mean, 
> for example, both CC-Time and CC-Total-Octets being included 
> in the same instance of Granted-Service-Unit.  Is that acceptable?

Yes it is possible. This is contemplated in the draft at sect. 5.2

"The credit-control server returns the Granted-Service-Unit AVP in the Answer message to the Diameter credit-control client. The Granted-Service-Unit AVP contains the amount of service units that the Diameter credit-control client can provide to the end user until a new Credit-Control-Request MUST be sent to the credit-control server. If several unit types are sent in the Answer message the credit-control client MUST handle each unit type separately. The type of the Granted-Service-Unit AVP can be time, volume, service specific or money depending on the type of service event. The unit type(s) SHOULD NOT be changed within an ongoing credit-control session.  
    
There MUST be maximum one instance of the same unit type in one Answer message. However, in case multiple quotas are conveyed to the credit control client in the Multiple-Services-Credit-Control AVPs, it is possible to carry two instances of the same unit type associated to a service-identifier/rating-group for instance when a tariff time change is expected."

and sect. 5.3

"When all of the granted service units for one unit type are spent by the end user or the Validity-Time is expired, the Diameter credit-control client MUST send a new Credit-Control-Request to the credit-control server."

The server can return e.g. time and volume in one instance of the G-S-U AVP. 
When all granted units for one unit type (e.g. time) have been used, the 
client re-authorizes the credit (i.e. sends CCR[Update]) and reports the
used units for all unit types (in this example time and volume) within
one instance of the U-S-U AVP.

Regards
Marco