Subject: [AAA-WG]: DCC Issue: Radius-Diameter CC Interworking model

From: "Harri Hakala (JO/LMF)" <[email-masked]>
Date: Wed, 21 Apr 2004 12:32:12 +0200

Submitter name: Harri Hakala
Submitter email address: [email-masked]
Date first submitted: 21.04.2004
Reference:
Document: DCC-04
Comment type: T
Priority: 1
Section: 11
Rationale/Explanation of issue:
In the DDC-04 the RADIUS/Diameter credit control Interworking section is
incomplete. It leaves out a lot of important standardization details, but
on the other hands it is far too detail to be a just guideline.

A writing a true guideline section is problematic without having stable 
target document for translation. It would be better to describe RADIUS-
Diameter credit control interworking model in the DCC and the detailed
translation somewhere else, either in a separate I-D or in the RADIUS 
prepaid specification as discussed on the aaa-mailing list.
http://www.merit.edu/mail.archives/aaa-wg/msg00408.html
http://www.merit.edu/mail.archives/aaa-wg/msg00417.html

To describe this interworking model, the architecture model of section 2
(figure 2) and related text as well as the flow II of the appendix can be
moved to a new section 11, RADIUS/Diameter Credit-control Interworking Model.

Requested Change:

REMOVE:

1) Section 2

	Other entities, such as RADIUS AAA servers, may act as a Diameter credit-control 
	clients for service elements that use credit control mechanisms other than Diameter
	credit-control. In this case the AAA server contact the Diameter credit-control server
	as part of the authorization process. The interworking architecture is illustrated in 
	Figure 2, the interaction between the Diameter credit-control client and the service 
	element is outside the scope of this specification. Interworking with RADIUS is addressed 
	in section 11 and Annex A.

	                                  AAA
	+--------+       +---------+    protocol  +------------+   +--------+ 
	|  End   |<----->| Service |<------------>|    AAA     |   |Business|
	|  User  |       | Element |              |  Server    |   |Support |
	+--------+   +-->|         |              |+----------+|-->|System  |
	             |   +---------+              ||CC client ||   |        |
	             |                            |+----------+|   |        |
	+--------+   |                            +------^-----+   +--------+
	|  End   |<--+                  credit-control   |               ^
	|  User  |                            protocol   |               |
	+--------+                               +-------V------+        |
	                                         |Credit-control|--------+
	                                         |   Server     |
	                                         +--------------+

	  Figure 2: Credit-control architecture with Service Element not 
	               supporting the credit-control protocol

2) Flow II from appendix A

3) the section 11

ADD:
	   
    Section 11 RADIUS/Diameter Credit-control Interworking Model
 
    This section defines the basic principles for the Diameter Credit-control/RADIUS prepaid inter-working model, 
    that is a message translation between RADIUS based prepaid solution and Diameter Credit-control application. 
    A complete description of the protocol translations between RADIUS and Diameter Credit-control application is
    beyond the scope of this specification and SHOULD be addressed in another appropriate document such as the
    RADIUS prepaid specification. 

    The Diameter credit-control architecture may have a Translation Agent, which is capable of translation between
    RADIUS prepaid and Diameter Credit-control protocol. An AAA server, usually the Home AAA server, may act as a 
    Translation Agent while acting also as Diameter credit-control client for service elements that use credit 
    control mechanisms other than Diameter credit-control, for instance RADIUS prepaid. In this case the AAA server
    contacts the Diameter credit-control server as part of the authorization process. The interworking architecture
    is illustrated in figure X and interworking flow in figure Y. In roaming situation the service element (e.g. the NAS)
    may be located in the visited network and a Visited AAA server is usually contacted. The Visited AAA server 
    connects then to the Home AAA server.
	 
	                               Radius prepaid
	+--------+       +---------+    protocol  +------------+   +--------+ 
	|  End   |<----->| Service |<------------>| Home AAA   |   |Business|
	|  User  |       | Element |              |  Server    |   |Support |
	+--------+   +-->|         |              |+----------+|-->|System  |
	             |   +---------+              ||CC client ||   |        |
	             |                            |+----------+|   |        |
	+--------+   |                            +------^-----+   +--------+
	|  End   |<--+                  credit-control   |               ^
	|  User  |                            protocol   |               |
	+--------+                               +-------V------+        |
	                                         |Credit-control|--------+
	                                         |   Server     |
	                                         +--------------+

	  Figure X: Credit-control architecture with Service Element 
	            containing translation agent, translating RADIUS 
	            prepaid to Diameter credit control protocol

	When the AAA server acting as a Translation Agent receives an initial RADIUS Access-Request message from service
	Element (e.g. NAS access), it performs regular Authentication and Authorization. If the RADIUS Access-Request message
	indicates that the service element is capable of credit-control, and if the AAA server finds that the subscriber is a
	prepaid subscriber then a Diameter Credit control request SHOULD be sent towards the credit-control server to perform 
	credit authorization and to establish a credit control session. After the Diameter credit-control server checks the end
	user's account balance, rates the service and reserves credit from the end user's account, the reserved quota is returned
	to the Home AAA server in the Diameter Credit-Control-Answer. Then the Home AAA server sends the reserved quota to the 
	service element in the RADIUS Access-Accept.
 
At the expiry of the allocated quota, the service element sends a new RADIUS Access-Request to the Home AAA server 
containing the units used this far. The AAA server shall map RADIUS Access-Request containing the reported units to the
Diameter credit-control server in a Diameter Credit-Control-Request (UPDATE_REQUEST). The Diameter credit-control server
debits the used units from the end user's account and allocates a new quota that is returned to the Home AAA server in the
Diameter Credit-Control-Answer. The quota is transferred to the service element in the RADIUS Access-Accept. When the end
user terminates the service or when all the quota has been used, the service element sends a RADIUS Access-Request. To debit
the used units from the end user's account and to stop the credit control session, the Home AAA server sends a Diameter 
Credit-Control-Request (TERMINATION_REQUEST) to the credit-control server. The Diameter credit-control server acknowledges
the session termination by sending a Diameter Credit-Control-Answer to the Home AAA server. The RADIUS Access-Accept is sent
to the NAS.
	 
	A following diagram illustrates a RADIUS prepaid - Diameter credit control interworking sequence.

	    Service Element         Translation agent
	      (e.g.NAS)                  (CC Client)             CC Server
	          |     Access-Request     |                        |
	          |----------------------->|                        |
	          |                        |    CCR (initial)       |
	          |                        |----------------------->|
	          |                        |    CCA (granted_Units) |
	          |                        |<-----------------------|
	          |     Access-Accept      |                        |
	          |     (granted Units)    |                        |
	          |<-----------------------|                        |
	          :                        :                        :
	          |     Access-Request     |                        |
	          |     (used Units)       |                        |
	          |----------------------->|                        |
	          |                        |    CCR (update,        |
	          |                        |         used Units,    |
	          |                        |----------------------->|
	          |                        |    CCA (granted_Units) |
	          |                        |<-----------------------|
	          |     Access-Accept      |                        |
	          |     (granted Units)    |                        |
	          |<-----------------------|                        |
	          :                        :                        :
	          |     Access-Request     |                        |
	          |----------------------->|                        |
	          |                        |     CCR (termin.,      |
	          |                        |          used Units)   |
	          |                        |----------------------->|
	          |                        |     CCA                |
	          |                        |<-----------------------|
	          |     Access-Accept      |                        |
	          |<-----------------------|                        |
	          |                        |                        |
	      Figure Y: Message flow example with RADIUS prepaid - Diameter 
	                          credit control interworking

---

From: <[email-masked]>
Date: Tue, 27 Apr 2004 13:41:43 +0300

assigned issue 33.

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]]On Behalf Of
> ext Harri Hakala (JO/LMF)
> Sent: 21 April, 2004 13:32
> To: [email-masked]
> Subject: [AAA-WG]: DCC Issue: Radius-Diameter CC Interworking model
> 
> 
> 
> 	             |                            
> |+----------+|   |        |
> 	|  User  |                            protocol   |      
>          |
>     This section defines the basic principles for the 
> Diameter Credit-control/RADIUS prepaid inter-working model, 
>     that is a message translation between RADIUS based 
> prepaid solution and Diameter Credit-control application. 
>     A complete description of the protocol translations 
> between RADIUS and Diameter Credit-control application is
>     beyond the scope of this specification and SHOULD be 
> addressed in another appropriate document such as the
>     The Diameter credit-control architecture may have a 
> Translation Agent, which is capable of translation between
>     RADIUS prepaid and Diameter Credit-control protocol. An 
> AAA server, usually the Home AAA server, may act as a 
>     Translation Agent while acting also as Diameter 
> credit-control client for service elements that use credit 
>     control mechanisms other than Diameter credit-control, 
> for instance RADIUS prepaid. In this case the AAA server
>     contacts the Diameter credit-control server as part of 
> the authorization process. The interworking architecture
>     is illustrated in figure X and interworking flow in 
> figure Y. In roaming situation the service element (e.g. the NAS)
>     may be located in the visited network and a Visited AAA 
> server is usually contacted. The Visited AAA server 
> 	             |                            
> |+----------+|   |        |
> 	|  User  |                            protocol   |      
>          |
> 	When the AAA server acting as a Translation Agent 
> receives an initial RADIUS Access-Request message from service
> 	Element (e.g. NAS access), it performs regular 
> Authentication and Authorization. If the RADIUS Access-Request message
> 	indicates that the service element is capable of 
> credit-control, and if the AAA server finds that the subscriber is a
> 	prepaid subscriber then a Diameter Credit control 
> request SHOULD be sent towards the credit-control server to perform 
> 	credit authorization and to establish a credit control 
> session. After the Diameter credit-control server checks the end
> 	user's account balance, rates the service and reserves 
> credit from the end user's account, the reserved quota is returned
> 	to the Home AAA server in the Diameter 
> Credit-Control-Answer. Then the Home AAA server sends the 
> reserved quota to the 
> At the expiry of the allocated quota, the service element 
> sends a new RADIUS Access-Request to the Home AAA server 
> containing the units used this far. The AAA server shall map 
> RADIUS Access-Request containing the reported units to the
> Diameter credit-control server in a Diameter 
> Credit-Control-Request (UPDATE_REQUEST). The Diameter 
> credit-control server
> debits the used units from the end user's account and 
> allocates a new quota that is returned to the Home AAA server in the
> Diameter Credit-Control-Answer. The quota is transferred to 
> the service element in the RADIUS Access-Accept. When the end
> user terminates the service or when all the quota has been 
> used, the service element sends a RADIUS Access-Request. To debit
> the used units from the end user's account and to stop the 
> credit control session, the Home AAA server sends a Diameter 
> Credit-Control-Request (TERMINATION_REQUEST) to the 
> credit-control server. The Diameter credit-control server acknowledges
> the session termination by sending a Diameter 
> Credit-Control-Answer to the Home AAA server. The RADIUS 
> Access-Accept is sent
> to the NAS.
> 	 
> 	A following diagram illustrates a RADIUS prepaid - 
> Diameter credit control interworking sequence.
>  
>