Subject: [AAA-WG]: DCCA Server State Machine

From: Schendel Jens ICM Berlin <[email-masked]>
Date: Tue, 11 May 2004 21:26:34 +0200

Hi,

I'd like to propose the following minor corrections to the CC server state machine defined in DCCA draft 04.

Page 52, 3. transition

The action "debit units" certainly applies if requested-action AVP was set to DIRECT_DEBITING. It certainly won't for any other value (BALANCE_CHECK, PRICE_ENQUIRY, REFUND_ACCOUNT). At least this would not be the primary intention.
"Debit units" should be either indicated as conditional action (does not seem to be very good style) or the transitions (from Idle to Idle) should be specified specific to requested-action AVP, such as 

Event    
	CC event received and successfully processed,
 	requested action DIRECT_DEBITING.
Action
      Send CC event answer,  
      debit units  

Event    
	CC event received and successfully processed,
 	requested action BALANCE_CHECK or PRICE_ENQUIRY.
Action
      Send CC event answer

Event    
	CC event received and successfully processed,
 	requested action REFUND_ACCOUNT.
Action
      Send CC event answer,  
      refund account

Page 52, 5. transition

Modify action "Send CC answer" to "Send CC update Answer" just to align with other transition descriptions.

Page 52, 6. transition
Page 53, 1. transition

The action "stop Tcc" might be added. However, taking a look at client state machines, it seems that in uncuccessful cases the stop of timers (i.e. Tx) is generally not considered. 

Page 53, 2. transition
  
The action "Stop Tcc" should be removed since the timer is already expired (=event).

Regards Jens

---

From: <[email-masked]>
Date: Wed, 12 May 2004 09:21:29 +0300

Hi Jens,

> I'd like to propose the following minor corrections to the CC 
> server state machine defined in DCCA draft 04.

The draft is currently being evaluated by the Area Director - Working
Group Last Call ended already.  Right now, I think we are only accepting
issues that address bugs in the specification. Could you be a bit more specific
about the problems your suggestion is addressing?

thanks,
John

> Page 52, 3. transition
> 
> The action "debit units" certainly applies if 
> requested-action AVP was set to DIRECT_DEBITING. It certainly 
> won't for any other value (BALANCE_CHECK, PRICE_ENQUIRY, 
> REFUND_ACCOUNT). At least this would not be the primary intention.
> "Debit units" should be either indicated as conditional 
> action (does not seem to be very good style) or the 
> transitions (from Idle to Idle) should be specified specific 
> to requested-action AVP, such as 
> 
> Event    
> Modify action "Send CC answer" to "Send CC update Answer" 
> just to align with other transition descriptions.
> 
> Page 52, 6. transition
> Page 53, 1. transition
> 
> The action "stop Tcc" might be added. However, taking a look 
> at client state machines, it seems that in uncuccessful cases 
> the stop of timers (i.e. Tx) is generally not considered. 
> 
> Page 53, 2. transition
>

---

From: Schendel Jens ICM Berlin <[email-masked]>
Date: Wed, 12 May 2004 15:07:51 +0200

Hi John,

sorry, that I missed the end of WG last call. It is not my intention to annoy anyone. My point is that the server state machine is not correct and I would like to see it modified. A real implementation will usually take the following into account, anyway.

My major points - in other words - are:

Page 52, 3. transition

     Idle      CC event request               Send          Idle  
               received and successfully      CC event  
               processed.                     answer,  
                                              debit units  

This says that any event request sent to the server will lead to the debit of units.
However, if the event request was made for either balance check, price enquiry or refund account, the credit control server will *not* decrease subscriber's account balance.

Page 53, 2. transition

     Open      Session supervision timer Tcc  Stop Tcc,      Idle  
               expired                        release  
                                              reserved   
                                              units    

The event says that Tcc is expired. Hence Tcc does not have be stopped anymore. The action "Stop Tcc" is not applicable.

Regards Jens

> -----Ursprüngliche Nachricht-----
> Von: [email-masked] [mailto:[email-masked]] 
> Gesendet: Mittwoch, 12. Mai 2004 08:21
> An: [email-masked]; [email-masked]
> Betreff: RE: [AAA-WG]: DCCA Server State Machine 
> 
> 
> Hi Jens,
>

---

From: "Harri Hakala (JO/LMF)" <[email-masked]>
Date: Thu, 13 May 2004 09:15:16 +0200

Hi Jens,

>                received and successfully      CC event  
TO:
             processed.                     answer  

Do you think that it covers your concerns, since the action "successfully processed"
covers all different events and processing of them accordingly?

>      Open      Session supervision timer Tcc  Stop Tcc,      Idle  
TO:
  Open      Session supervision timer Tcc  release      Idle 
            expired                        reserved  
                                           units  
Is this ok?

regards.............Harri 

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]]On Behalf Of
> Schendel Jens ICM Berlin
> Sent: 12. toukokuuta 2004 16:08
> To: [email-masked]'; [email-masked]
> Subject: AW: [AAA-WG]: DCCA Server State Machine 
> 
> 
> Hi John,
> 
> sorry, that I missed the end of WG last call. It is not my 
> intention to annoy anyone. My point is that the server state 
> machine is not correct and I would like to see it modified. A 
> real implementation will usually take the following into 
> account, anyway.
> 
> However, if the event request was made for either balance 
> check, price enquiry or refund account, the credit control 
> server will *not* decrease subscriber's account balance.
> 
> Page 53, 2. transition
> 
> The event says that Tcc is expired. Hence Tcc does not have 
> be stopped anymore. The action "Stop Tcc" is not applicable.
> 
> Regards Jens
> 
>

---

From: Schendel Jens ICM Berlin <[email-masked]>
Date: Thu, 13 May 2004 15:16:30 +0200

Hi Harri,

thanks for your suggestions I fully agree with.

> covers all different events and processing of them accordingly?

Letting the event specific action open is the plain approach that works.

>   Open      Session supervision timer Tcc  release      Idle 

Yes, just the deletion.

Regards Jens