Subject: RE: [AAA-WG]: DCCA Draft 05: Session ID

From: "Mark Grayson (mgrayson)" <[email-masked]>
Date: Wed, 26 May 2004 22:01:05 +0200

ok - apologies if it is now too late to bring these issues.... 
 
section 4.1 says that "The service SHOULD be identified using the
Service-Identifier AVP." 
 
Is this always true, even for Multi-Service?
 
Section 5.2 says that " in the case of multiple services the
Service-Identifier AVP or the Rating-Group AVP within the
Multiples-Service-Credit-Control AVP, always indicates the concerned
service." 
 
Can Rating-Group AVP be used to identify a service?
 
Note, this section defines "or" and other define "and/or". Which is
correct?

Then section 8.20 says "tariff change is not used for time based quota"
and section 5.1 indicates that "For time-based services where the quota
is NOT continuously consumed at a regular rate, the tariff change
mechanism described for volume and event units MAY be used." I presume
the latter is correct and section 8.20 needs correcting.
 
Cheers,
Mark

---

From: "Christopher Richards" <[email-masked]>
Date: Wed, 26 May 2004 16:47:13 -0400

Hi Mark,

I've put in some comments below.

Cheers,
Chris.

-----Original Message-----
From: Mark Grayson (mgrayson) [mailto:[email-masked]] 
Sent: Wednesday, May 26, 2004 3:01 PM
To: Harri Hakala (JO/LMF); [email-masked]
Cc: [email-masked]
Subject: RE: [AAA-WG]: DCCA Draft 05: Session ID

[Chris Richards ] No.

[Chris Richards ] Yes. And I would argue that it is the simpler and
preferred method to identify a service.

Note, this section defines "or" and other define "and/or". Which is correct?

[Chris Richards ] The "or". I'm not sure how the "and/or" could work.

Then section 8.20 says "tariff change is not used for time based quota" and
section 5.1 indicates that "For time-based services where the quota is NOT
continuously consumed at a regular rate, the tariff change mechanism
described for volume and event units MAY be used." I presume the latter is
correct and section 8.20 needs correcting.

[Chris Richards ] Yes. The latter is correct. Time quotas are not
necessarily decemented at a constant rate (of 1 second per second) -
therefore the tariff change mechanism is useful for these scenarios. 

Cheers,
Mark

---

From: <[email-masked]>
Date: Thu, 27 May 2004 11:57:45 +0300

Hi,
 
more comments in line.
 
Marco

-----Original Message-----
From: ext Christopher Richards [mailto:[email-masked]]
Sent: 26 May, 2004 23:47
To: Mark Grayson (mgrayson); Harri Hakala (JO/LMF); Stura Marco (Nokia-NET/Helsinki)
Cc: [email-masked]
Subject: RE: [AAA-WG]: DCCA Draft 05: Session ID

Hi Mark, 

Cheers, 
Chris. 

-----Original Message----- 
From: Mark Grayson (mgrayson) [ mailto:[email-masked]] 
Sent: Wednesday, May 26, 2004 3:01 PM 
To: Harri Hakala (JO/LMF); [email-masked] 
Cc: [email-masked] 
Subject: RE: [AAA-WG]: DCCA Draft 05: Session ID 

section 4.1 says that "The service SHOULD be identified using the Service-Identifier AVP." 

[Chris Richards ] No.  

[MSt] Chris is right. 

The DCC is basically a framework for credit control, Section 4.1 describes how to define service-specific rating inputs AVPs and ensure interoperability for those services. This sentence refers to the Service-Id at command level, that identifies the set of mandatory AVPs defined in a service specific document that may be present in the CCR command and need to be supported. The principle is that the server checks first the Service-Identifier AVP at command level to determine if the request can be satisfied.

For instance, a service "network access flow based cc" is defined in a service specific document. This document need to define the content of the Service-Identifier AVP (e.g. [email-masked]) and all the mandatory rating input AVPs that must be supported by DCC implementations that support "network access flow based cc". 

Section 5.2 says that " in the case of multiple services the Service-Identifier AVP or the Rating-Group AVP within the Multiples-Service-Credit-Control AVP, always indicates the concerned service." 

[Chris Richards ] Yes. And I would argue that it is the simpler and preferred method to identify a service. 

[MSt]  The definition and relationship of Rating-Groups and Service-id in the context of the MSCC, can be found in section 5.1.1. From there it should be clear that Rating-Groups identifies an aggregate of services subject to the same cost and rating type (e.g. $0.5/MB), not a single service. If the server grants quota to a Rating-Group, all the services belonging to that RG can consume the quota.

[MSt] and/or simply means that both RG and SI could be present at MSCC AVP level. If both AVPs are present in CCA within a MSCC AVP, only the service identified by SI can consume the granted quota. If both AVPs are present in CCR, the SI details the amount of consumed quota per each service. This is defined in section 8.16:

  The Service-Identifier and the Rating-Group AVPs are used to 
   associate the granted units to a given service or rating group.  
  In case both the Service-Identifier and the Rating-Group AVPs are 
  included, the target of the service units is always the service(s) 
  indicated by the value of the Service-Identifier AVP(s). If only the 
  Rating-Group-Id AVP is present, the Multiple-Services-Credit-Control 
  AVP relates to all the services that belong to the specified rating 
  group.

For instance, the service specific document that define "network access flow based cc" should also states whether RG only or both RG and SI levels is required. If you are happy with the RG level, then the parameters that identify the services (e.g. IP 5-tuple) could be provided to the service element associated to the same RG but with no use of SI.

Then section 8.20 says "tariff change is not used for time based quota" and section 5.1 indicates that "For time-based services where the quota is NOT continuously consumed at a regular rate, the tariff change mechanism described for volume and event units MAY be used." I presume the latter is correct and section 8.20 needs correcting.

[Chris Richards ] Yes. The latter is correct. Time quotas are not necessarily decemented at a constant rate (of 1 second per second) - therefore the tariff change mechanism is useful for these scenarios.  

[MSt] I think section 8.20 says 

  The tariff change mechanism is optional for client and server and it 
   is not used for time-based services as defined in the section 5.

Where section 5 defines what Chris pointed out.

Cheers, 
Mark