Subject: RE: [AAA-WG]: Application ID collision for MIPv4 and DCC

From: "Christopher Richards" <[email-masked]>
Date: Mon, 28 Jun 2004 13:24:29 -0400

I think DCCA is also with the IESG. So I'll leave it to the author's or WG
chairs to follow up on this issue.

Cheers,
Chris

Tel:	+1 613 763 8031
ESN:	393 8031

-----Original Message-----
From: Bernard Aboba [mailto:[email-masked]] 
Sent: June 28, 2004 1:07 PM
To: Richards, Christopher [RICH2:2Q40:EXCH]
Cc: [email-masked]
Subject: Re: [AAA-WG]: Application ID collision for MIPv4 and DCC

> The MIPv4 draft has expired so I presume that it is no longer valid 
> and it's application-id can be re-assigned to DCCA without issue. Is 
> that right?

No. Diameter MIPv4 is now under consideration by the IESG.  Please assign
another application-id.

---

From: "Harri Hakala (JO/LMF)" <[email-masked]>
Date: Tue, 29 Jun 2004 08:10:36 +0200

Hi,

RFC 3588 defines (sections 2.4 & 11.3) following Application Identifier Values:
      Diameter Common Messages      0
      NASREQ                        1 [NASREQ]
      Mobile-IP                     2 [DIAMMIP]
      Diameter Base Accounting      3
      Relay                         0xffffffff

I assume that the MIPv4 should use the Application Identifier defined by the RFC 3588, that
is the MIPv4 should use the already allocated value 2 in their application. 
We have suggested Application Id value 4 to the IANA, so I think that we don't have any 
collision between Application Ids. But in the end it will be up to the IANA to allocate 
Application Identifier values for Diameter applications. 

Regards..........Harri

-----Original Message-----
From: Christopher Richards [mailto:[email-masked]]
Sent: 28. kesäkuuta 2004 20:24
To: 'Bernard Aboba'
Cc: [email-masked]; [email-masked]'; Harri Hakala (JO/LMF); Leena Mattila (TU/LMF); [email-masked]; [email-masked]
Subject: RE: [AAA-WG]: Application ID collision for MIPv4 and DCC

I think DCCA is also with the IESG. So I'll leave it to the author's or WG chairs to follow up on this issue. 
Cheers, 
Chris 
Tel:    +1 613 763 8031 
ESN:    393 8031 

-----Original Message----- 
From: Bernard Aboba [mailto:[email-masked]] 
Sent: June 28, 2004 1:07 PM 
To: Richards, Christopher [RICH2:2Q40:EXCH] 
Cc: [email-masked] 
Subject: Re: [AAA-WG]: Application ID collision for MIPv4 and DCC 

> and it's application-id can be re-assigned to DCCA without issue. Is 
No. Diameter MIPv4 is now under consideration by the IESG.  Please assign another application-id.