Subject: Re: [AAA-WG]: QoS-Filter-Rule AVP missing in NASREQ?

From: [email-masked]
Date: Wed, 07 Jul 2004 14:38:23 -0700 (PDT)

I'll find some place to put this.

Let's see Draft 17 will have:
- this AVP
- App ID clarification(dust settled yet?)
- Error AVPs in ABNF

Dave.

On Wed, 7 Jul 2004 09:14:56 -0700 (PDT), Bernard Aboba
wrote:

> 
> > > This might also allow us to address the issue of
> the missing text.
> >
> > Do we remember why the missing text was taken away?
> 
> I've done a bit more archeology, and here is what I've
> found.
> 
> Apparently, QoS-Filter-Rule AVP was never included in
> NASREQ.  However,
...

---

From: Bernard Aboba <[email-masked]>
Date: Wed, 7 Jul 2004 15:36:10 -0700 (PDT)

Thanks.

I think dust has settled on App ID clarification in that Diameter Common
messges app-ID should be used whenever there are no new mandatory AVPs.

I think this means that AAR/AAA uses NASREQ ap-id, but that ACR/ACA,
ASR/ASA use an app-ids from Diameter Base.

I'm not sure about RAR/RAA, but think this might require a NASREQ app-id
due to RADIUS/Diameter translation issues.  Can you check?

I think that Section 9 does not imply that RAR/RAA messages in NASREQ
include any new mandatory AVPs, though I suppose this could be tricky if
NASREQ AVPs were included in RADIUS CoA messages (e.g. only
NAS-IPv6-Address and User-Name used to identify the session), and
translation were required.  In this case I think that a NAS-IP-Address,
NAS-Identifier or NAS-IPv6-Address AVP might have to be marked mandatory.

This issue could be clarified if a RAR/RAA table were to be included in
the draft...