Subject: RE: [AAA-WG]: Issue 464: Application-Id Usage

From: <[email-masked]>
Date: Wed, 7 Jul 2004 14:39:14 +0300

Pasi Eronen writes

> 
> This brings us back to the topic what an "application"
> actually is. It could mean e.g. a software module in
> a Diameter implementation, or a (set of) specifications 
> that document how Diameter is extended for some particular 
> purpose (such as SIP or Mobile IPv4).
> 
> My reading of RFC3588 supports the latter interpretation
> (but I guess there is some room for disagreement and 
> other interpretations as well...).
> 
I have the same understanding.

> With this interpretation, it does not make sense to say 
> that you send a message _to_ an application; you send 
> a message that is defined in some application. So an 
> Abort-Session-Request referring to a DCC session
> would use application identifier 0. 
> 
I think it makes sense.

Marco

---

From: <[email-masked]>
Date: Thu, 8 Jul 2004 11:02:30 +0300

> This is where we disagree.  C1 cannot use app-id Y unless 
> application Y changes the nature of the command by adding a requirement
> for a new mandatory AVP.  Otherwise it needs to use application X, as
> described in RFC 3588.

Well, I think a mandatory AVP could well be added to fulfill this requirement,
but I think avoiding the implementation of Application X is a good enough reason
to change the app-id for C1 if the command is re-used in the context of
Application Y.

If app-id X must be used with C1 it means that the peer must also advertise
support for Application X, and that means that it must also implement C2
and everything else for that application. That's way too much trouble
if you only really want to implement a peer that supports Application Y.

BTW, I agree Base Protocol commands can always be sent with app-id 0.
I forgot to mention that in my previous post.

BR,
Mikko

> -----Original Message-----
> From: ext Bernard Aboba [mailto:[email-masked]]
> Sent: 07 July, 2004 16:50
> To: Aittola Mikko (Nokia-NET/Tampere)
> Cc: [email-masked]
> Subject: RE: [AAA-WG]: Issue 464: Application-Id Usage
> 
> 
> > Application X defines commands: C1 and C2
> > Application Y defines command:  C3 and also re-uses C1
> >
> > First of all, if application Y re-uses C1 it must be stated
> > in the specification of application Y.
> 
> Agreed.
> 
> > If a DiameterIdentity advertises support for application X,
> > it must support C1 and C2. C1 is used with app-id X.
> 
> Yes.
> 
> > If a DiameterIdentity advertises support for application Y,
> > it must support C1 and C3. C1 is used with app-id Y.
> 
> This is where we disagree.  C1 cannot use app-id Y unless 
> application Y
> changes the nature of the command by adding a requirement for a new
> mandatory AVP.  Otherwise it needs to use application X, as 
> described in
> RFC 3588.
> 
> > If a DiameterIdentity advertises support for application X and Y, it
> > must support C1, C2, and C3. C1 can be used with app-id X and Y.
> 
> I disagree.  C1 can only be used with app-id Y if another 
> mandatory AVP is
> defined.  Otherwise, C1 can only be used with app-id X.
>

---

From: <[email-masked]>
Date: Mon, 12 Jul 2004 12:34:18 +0300

Hi,

John Prudhoe asked to forward the message below.

BR,
Mikko

-----Original Message-----
From: ext [email-masked] [mailto:[email-masked]]
Sent: 08 July, 2004 14:38
To: Aittola Mikko (Nokia-NET/Tampere)
Subject: RE: [AAA-WG]: Issue 464: Application-Id Usage

Hi Mikko, 

I attempted to post the following reply to your e-mail, but was unable to send it via the AAA-WG.  Please feel free to forward it or comment on it in the discussion. 

Regards, 

John. 

PS It seems that there's a reverse DNS lookup on incoming e-mails to the AAA-WG, whereas my e-mail will have gone out from a local mail server in Ireland rather than the corporate one that shows up in a DNS lookup.  I've already sent an e-mail to the postmaster @merit.edu about it. 

----- Forwarded by John Prudhoe/Vodafone on 08/07/2004 12:31 ----- 
John Prudhoe 
08/07/2004 12:11 

        To:        [email-masked], [email-masked] 
        cc:         
        Subject:        RE: [AAA-WG]: Issue 464: Application-Id UsageLink

Hi Mikko, 

It seems to me quite reasonable that someone would really want to do what you describe in your e-mail. 

Imagine if application X supports a number of commands and someone determines that one of these commands is unsuitable for their purposes, let's call it C2 to fit in with your example. 

In my scenario, the reason for defining application Y is to deliberately replace C2 with a new command, C3.  The other commands of application X would still be wanted.  So it is not just a case of wanting to use all the commands of application X with application Y except C2 which is superfluous, but a case of specifically wanting to exclude C2 because the new command C3 replaces it. 

It seems to me that this is a reasonable scenario and it would be better to have a simple and elegant means of supporting it.  Failing that, there would still be a need to support it somehow.  At the moment there doesn't seem to be any means of making use of the suitable commands defined by App-X without also allowing the unwanted command C2. 

Regards, 

John. 

<[email-masked]> 
Sent by: [email-masked] 
08/07/2004 09:02 
        
        To:        <[email-masked]> 
        cc:         

BR,
Mikko