Subject: [AAA-WG]: Use of thresholds in DCCA

From: "Mark Grayson (mgrayson)" <[email-masked]>
Date: Fri, 16 Jul 2004 21:52:58 +0200

Guys

I have a question about expected DCCA operation. There may be service
specific documentation that defines the use of thresholds which can
trigger a CCR(update) prior to full expiry of the granted service units.
Then according to DCCA, when new quota is allocated these units will be
used from the last measurement time - i.e., effectively meaning the used
threshold is subtracted from the granted service units - and the unused
threshold units are thrown away.

Then what happens if the "used threshold" exceeds the granted service
units. Doesn't this mean the CLCI-Client should report negative used
service units in its next CCR(update)?

Do we need a health warning on the use of thresholds with service
specific usage of the credit control model in DCCA?

Best regards,
Mark

_____________________________
Mark Grayson, 
Mobile Wireless Group
Cisco Systems

IP Phone : +1 919-392-1809
Mobile   : +1 919-413-1314
www.cisco.com/go/mobile

---

From: "STURA Marco Consultant" <[email-masked]>
Date: Mon, 19 Jul 2004 10:23:42 +0200

>service units in its next CCR(update)?

I think the "threshold" should be dimensioned in a way that this
case is avoided (i.e. what is not consumed by the client could be
re-allocated back and could guarantee that "used threshold" doesn't
exceed the
granted service units).

Also, I think it's up to the server to avoid this case, if so wanted.
For instance, by using the Final-Unit-Indication AVP the server can
indicate to the client that "this is the last quota I'm granting".
Therefore, shouldn't
the credit in the user's account guarantee no losses in the next report,
the
server could send the final-unit in the current CCA.

Marco   

-----Original Message-----
From: Mark Grayson (mgrayson) [mailto:[email-masked]] 
Sent: Friday, July 16, 2004 9:53 PM
To: [email-masked]; [email-masked];
[email-masked]; [email-masked]
Cc: [email-masked]
Subject: [AAA-WG]: Use of thresholds in DCCA

Guys

Best regards,
Mark

____________________________
Mark Grayson, 
Mobile Wireless Group
Cisco Systems

---

From: "Mark Grayson (mgrayson)" <[email-masked]>
Date: Mon, 19 Jul 2004 15:46:38 +0200

Marco

So I agree that this case SHOULD be avoided (hence my suggestion of a
health warning) - but what happens if this is not the case - due to
congestion or whatever (unplanned) reason. What should the DCCA-client
report? Consumed units which are now greater than the amount granted? 

Cheers,
Mark

-----Original Message-----
From: STURA Marco Consultant
[mailto:[email-masked]] 
Sent: 19 July 2004 04:24
To: Mark Grayson (mgrayson); [email-masked];
[email-masked]; [email-masked]
Cc: [email-masked]
Subject: RE: [AAA-WG]: Use of thresholds in DCCA

Marco   

-----Original Message-----
From: Mark Grayson (mgrayson) [mailto:[email-masked]] 
Sent: Friday, July 16, 2004 9:53 PM
To: [email-masked]; [email-masked];

Guys

Best regards,
Mark

---

From: "STURA Marco Consultant" <[email-masked]>
Date: Mon, 19 Jul 2004 15:57:03 +0200

>congestion or whatever (unplanned) reason.

I think the warning should be given eventually in the service specific
document defining the threshold(s).

>Consumed units which are now greater than the amount granted?

Yes, I think this is the case.

Marco

-----Original Message-----
From: Mark Grayson (mgrayson) [mailto:[email-masked]] 
Sent: Monday, July 19, 2004 3:47 PM
To: STURA Marco Consultant; [email-masked];

Marco

Cheers,
Mark

-----Original Message-----

Marco   

-----Original Message-----
From: Mark Grayson (mgrayson) [mailto:[email-masked]] 
Sent: Friday, July 16, 2004 9:53 PM
To: [email-masked]; [email-masked];

Guys

Best regards,
Mark