Subject: RE : [AAA-WG]: RFC 3588 Errata: Adding 'M' bit AVPs requires new Application-ID

From: <[email-masked]>
Date: Fri, 20 Aug 2004 15:35:21 +0300

Lionel,

> It is exactly my concern. Three kind of AVPs are used in the ABNF
> specification: fixed, required and optional AVPs. And different rules
> will be apllied based on the AVP type in the ABNF. There is no problem
> to add/remove any optional AVP without modifying the command definition.
> Rules concerning fixed and required AVPs are more ambiguous.

Fixed AVPs need to be there.  Mandatory AVPs need to be there as well,
or an error will be generated.  Optional AVPs are exactly as advertised,
they do not need to be present.

John

---

From: Bernard Aboba <[email-masked]>
Date: Fri, 20 Aug 2004 05:33:52 -0700 (PDT)

> they do not need to be present.

Yes, that was my understanding.