Subject: Re: [AAA-WG]: Diameter SIP app: issue 4

From: Miguel Garcia <[email-masked]>
Date: Fri, 10 Dec 2004 13:19:07 +0200

Inline...

[email-masked] wrote:

> Hhhmmmm, why do the Diameter entities need to know what type of profile is being transported? 

The Diameter entities need not know about the actual profile, but the 
application that is making usage of the profile must know the format of 
this profile.

> 
> Also, so far, in case of 3GPP, there is a different Application-Id, so the profile is implicitely identified.

That is not the case in Diameter SIP application. There is a single 
Application ID that is able to transport any kind of user profile form 
the server to the client.

A good protocol design rule is to add negotiation capabilities, so that 
you don't assume thet there is only one type of "thing" (profile in our 
case), but you assume that there are several types, and the client and 
the server have to agree on one type.

I would like to adhere to this kind of design rule.

- Miguel

> 
> br,
> MCarmen
> 
> -----Original Message-----
> From: Miguel Garcia [mailto:[email-masked]]
> Sent: viernes, 10 de diciembre de 2004 10:50
> To: MCarmen
> Cc: AAA mailing list; Maria Carmen Belinchon (ML/EEM); Miguel-Angel
> Pallares (ML/EEM); Carolina Canales (ML/EEM); Pete McCann; Rajaniemi
> Jaakko (Nokia-NET/Espoo); Tammi Kalle (Nokia-NET/Tampere)
> Subject: Re: [AAA-WG]: Diameter SIP app: issue 4
> 
> 
> 3GPP has defined a profile, so that would be the first one.
> 
> Others will come in the future, when people start using the Diameter SIP 
> application.
> 
> So far the assumption is that there is "THE" profile, and the contents 
> are not discussed anywhere. But there is more than "THE" profile.
> 
> - Miguel
> 
> MCarmen wrote:
> 
> 
>>Hi Miguel,
>>
>>    What type of porfiles do you have in mind?
>>br,
>>MCarmen
>>
>>Miguel Garcia wrote:
>>
>>
>>
>>>Hi:
>>>
>>>I am trying to close open issues in the Diameter SIP application. As 
>>>part of the process, I would like to initiate a discussion on the list 
>>>of those issues for which I would like to get a sense of the 
>>>consensus. Therefore, you will see a few of these posts in the next 
>>>few days.
>>>
>>>Reminder:
>>>
>>>The list of open issues is stored at:
>>>
>>>http://danforsberg.info:8080/draft-ietf-aaa-diameter-sip/
>>>
>>>Now, I would like to discuss open issue #4m which is fully described at:
>>>http://danforsberg.info:8080/draft-ietf-aaa-diameter-sip/issue4
>>>
>>>So please read it, try to understand it, and comment. My opinion is 
>>>also listed in the open issues tracker, which is, we should provide a 
>>>mechanism to indicate the type of user profile that the client or 
>>>server understand, otherwise there might be incompatibilities. But 
>>>certainly I don't like the IANA registration of this solution.
>>>
>>>Comments?
>>>
>>>/Miguel
>>>
>>
>>
> 

-- 
Miguel A. Garcia           tel:+358-50-4804586
Nokia Research Center      Helsinki, Finland

---

From: Miguel Garcia <[email-masked]>
Date: Sun, 12 Dec 2004 15:19:51 +0200

I have now included the "type of user profile selector" in the draft, 
and I have cloed issue 4.

The summary of the changes are:

This version of the draft provides support to identify the type of
user data included in the SIP-User-Data AVP (this can contain a
user profile).  The following changes has been made:

       *  Added a new SIP-Supported-User-Data-Type AVP.
       *  The old SIP-User-Data AVP is now a grouped AVP that contains
          two AVPs: SIP-User-Data-Type and SIP-User-Data-Contents.
       *  Added a new SIP-User-Data-Type AVP.
       *  Added a new SIP-User-Data-Contents (that contains the profile).
          This is equivalent to the old SIP-User-Data AVP.
       *  All the above AVPs are visible in SAR, SAA, and PPR commands.
       *  The new SIP-User-Data and SIP-Supported-User-Data-Type allows
          repetition (a server could potential send more than one
          profile; a client can express support for more than one type of
          profile).

A preliminary working copy version of the draft is available at:

http://people.nokia.net/~miguel/drafts/pre/draft-ietf-aaa-diameter-sip-app-05.txt
or in HTML:
http://people.nokia.net/~miguel/drafts/pre/draft-ietf-aaa-diameter-sip-app-05.html

A diff version with respect version -04 is also available:

http://people.nokia.net/~miguel/drafts/pre/draft-ietf-aaa-diameter-sip-app-04-to-05.html

I will submit version -05 sometime before December 18, and at that time 
I will consider the draft ready for IESG submission.

It would be good if you folks can take a look at the working version I 
pointed above... If there are comments, I can easily introduce them 
before I submit the official version -05.

Regards,

            Miguel

Miguel Garcia wrote:
>> Others will come in the future, when people start using the Diameter 
>> SIP application.
>>
>>>> part of the process, I would like to initiate a discussion on the 
>>>> list of those issues for which I would like to get a sense of the 
>>>> also listed in the open issues tracker, which is, we should provide 
>>>> a mechanism to indicate the type of user profile that the client or

---

From: Jari Arkko <[email-masked]>
Date: Mon, 13 Dec 2004 10:18:56 +0200

Hi Miguel,

>          profile; a client can express support for more than one type of

I read the changed parts, and the above resolution looks
good.

--Jari