Subject: RE: [AAA-WG]: digest issue 11 closure (fwd)

From: Avi Lior <[email-masked]>
Date: Thu, 7 Apr 2005 12:07:30 -0400

Hi David,

> -----Original Message-----
> From: Nelson, David [mailto:[email-masked]] 
> Sent: Thursday, April 07, 2005 11:30 AM
> To: [email-masked]
> Subject: RE: [AAA-WG]: digest issue 11 closure (fwd)
> 
> 
> John Loughney writes...
> 
> > What you are suggesting is
> > that we should dumb-down Diameter SIP so that it can live 
> with RADIUS.  
> > However, I don't think we have a requirement for this.
> 
> Well, the RADEXT WG *does* have a requirement that RADIUS 
> extensions be interoperable with Diameter.  I guess what 
> you're saying is that the AAA WG does *not* have a 
> requirement that Diameter be interoperable with RADIUS extensions.
> 
> There are two SIP Digest Authentication protocols, one in 
> Diameter and one in RADIUS.  My understanding is that one 
> originated in 3GPP and the other originated in 3GPP2.  Are 
> you suggesting that these are disjoint solution sets that 
> need not interoperate?

Not exactly accurate.  Diameter SIP was originally based on the 3GPP
requirements (Cx interface) but my understanding is that they divereged.
3GPP2 currently is using the Digest authentication for HTTP Digest
authentication and not for SIP at all. So 3GPP2 is using not concerned about
the SIP part and just the HTTP Digest authentication part which is what the
sterman document was originally about.

Note that Diameter SIP application does a lot more then RADIUS Digest
authentication. So they don't interoperate.  RADIUS Digest authentication is
just that, Digest authentication and not a SIP application.  I raised this
concern before.  If you want compelete SIP interoperability between RADIUS
and Diameter then you need to handle those other messages that Diameter SIP
has introduced.  In essence you need RADIUS SIP application.

So the answer to your last question: "...are these disjoint solutions sets
that need not interoperate?" They answer is yes.  The intent was to just get
the auth part to interoperate that would be nice but if its not achievable
so be it.

I have my doubts about Diameter SIP.  Why did 3GPP not adopt it? Is the
model that Diameter SIP supports originates from 3GPP, but does it have
general applicablity?  Can I take the Diameter SIP and use it for other SIP
architectures?

---

From: Jari Arkko <[email-masked]>
Date: Thu, 07 Apr 2005 21:16:22 +0300

Avi Lior wrote:

>that need not interoperate?" They answer is yes.
>
Yes... but its not really a yes/no question. It is true that the
function set in Diameter SIP is significantly bigger. But
both can do Digest (and exactly at the same manner, if
we can harmonize the nonce handling in Diameter SIP).
You could hope for interoperability in this part*.

And the translation gateway issue isn't black and white
issue either. We are debating whether it should take
X amount of effort to do the gateway, or X - epsilon.

And to answer John's question on whether there's a current
requirement for interoperability... probably not in terms
of a specific customer case. But as Dave noted there's an
IETF requirement on making these techniques compatible.
And experience has shown that where people think their
systems are entirely self sufficient, in the next customer
case/specification release/business reorg they find out
that they do, in fact, need to interoperate with something
else.

--Jari

*) I'll buy you a beer if within a year, we are not discussing the
RADIUS version of what exists in Diameter SIP beyond
RADIUS Digest.

---

From: Jari Arkko <[email-masked]>
Date: Thu, 07 Apr 2005 21:03:21 +0300

>general applicablity?  Can I take the Diameter SIP and use it for other SIP
3GPP is using something which can be considered to be
the pre-release version of Diameter SIP; they needed the
protocol before work on Diameter SIP could be done,
particularly when the AAA WG was at the time still
strugling with the base protocol definitions.

I believe there is some intent on updating once IETF
versions are available, but it remains to be seen when
(and if) this really happens.

--Jari

---

From: Miguel Garcia <[email-masked]>
Date: Fri, 08 Apr 2005 09:26:40 +0300

> general applicablity?  Can I take the Diameter SIP and use it for other SIP

Yes, that is the idea. The Diameter SIP application is largely based on 
the 3GPP Diameter application for the Cx interface. However, we have 
generalized the 3GPP stuff to make it applicable to the public Internet. 
As such, I have always been trying to remove a bunch of assumptions that 
were only valid in 3GPP (e.g., Digest AKA, first SIP request contains 
username, avoid assuming there is a single profile type, etc.)

So if you want to put Diameter SIP app to work in 3GPP, it will work 
correctly. If you want to make it work in an ISP that is not related to 
3GPP, it will work as well.

/Miguel

-- 
Miguel A. Garcia           tel:+358-50-4804586
sip:[email-masked]
Nokia Research Center      Helsinki, Finland