Subject: RE: [AAA-WG]: digest issue 11 closure (fwd)

From: Avi Lior <[email-masked]>
Date: Thu, 7 Apr 2005 14:25:36 -0400

Jari,

It's a pretty safe bet that you will *not* have to buy me a beer.  That is
why I said we need RADIUS SIP document.  Lets get the harmonizing there.  

And I agree since we came this far lets harmonize the authentication part.
But we need 3GPP2  Digest Auth quickly now.  We are delaying publication.
And by Digest Auth I mean just Digest Auth nothing to do with SIP.

> -----Original Message-----
> From: Jari Arkko [mailto:[email-masked]] 
> Sent: Thursday, April 07, 2005 2:16 PM
> To: Avi Lior
> Cc: 'Nelson, David'; [email-masked]
> Subject: Re: [AAA-WG]: digest issue 11 closure (fwd)
> 
> 
> Avi Lior wrote:
> 
> >So the answer to your last question: "...are these disjoint 
> solutions 
> >sets that need not interoperate?" They answer is yes.
> >
> Yes... but its not really a yes/no question. It is true that 
> the function set in Diameter SIP is significantly bigger. But 
> both can do Digest (and exactly at the same manner, if we can 
> harmonize the nonce handling in Diameter SIP). You could hope 
> for interoperability in this part*.
> 
> And the translation gateway issue isn't black and white
> issue either. We are debating whether it should take
> X amount of effort to do the gateway, or X - epsilon.
> 
> And to answer John's question on whether there's a current 
> requirement for interoperability... probably not in terms of 
> a specific customer case. But as Dave noted there's an IETF 
> requirement on making these techniques compatible. And 
> experience has shown that where people think their systems 
> are entirely self sufficient, in the next customer 
> case/specification release/business reorg they find out that 
> they do, in fact, need to interoperate with something else.
> 
> --Jari
> 
> *) I'll buy you a beer if within a year, we are not 
> discussing the RADIUS version of what exists in Diameter SIP 
> beyond RADIUS Digest.
>

---

From: Jari Arkko <[email-masked]>
Date: Thu, 07 Apr 2005 21:33:35 +0300

>why I said we need RADIUS SIP document.  Lets get the harmonizing there.  
Ok. Either you are right or you get beer. Sounds good, no?

>And by Digest Auth I mean just Digest Auth nothing to do with SIP.
It looks like the issues that we are discussing right now are
in the Diameter SIP part, like adding the nonce thing or
keeping/removing the grouped AVP. In that sense its not
delaying RADIUS SIP, although obviously it would be good
to ensure that the two can be in sync before we commit one
of them to an RFC...

--Jari