Subject: Re: [abfab] draft-lear-abfab-arch-01 posted

From: Rhys Smith <[email-masked]>
Date: Thu, 10 Feb 2011 17:14:38 +0000

On 21 Dec 2010, at 18:31, Eliot Lear wrote:

> Hi everyone,
> 
> We give to you the holiday present of reading ;-)  The authors have updated The ABFAB Architecture Draft.  It contains a number of changes since -00:
> 	• A high level step by step description of the process.
> 	• A "swimming lane" diagram visually demonstrating that process.
> 	• A discussion about channel binding and appropriate EAP methods.
> 	• A discussion about discovery.

Think it's looking pretty good in general, and agree with general comments made so far.

One specific comment that I don't think anybody else has made yet - the document variously refers to:
* End Host
* Client App
* Application
* Subject
* Principal
* Entity

- sometimes meaning the same thing, sometimes different things.

Where the document is using the very specific meaning of one term (e.g. subject vs principal) that should probably be clarified somewhere (terminology section?) and where it isn't using the term with that specific meaning attached then the document should pick one and stick with it for consistency.

Best Regards,
R.
--
----------------------------------------------------------------------
Dr Rhys Smith                                   e: [email-masked]
Engineering Consultant: Identity & Access Management  (GPG:0xDE2F024C)
Information Services,
Cardiff University,                            t: +44 (0) 29 2087 0126
39-41 Park Place, Cardiff,                     f: +44 (0) 29 2087 4285
CF10 3BB, United Kingdom.                      m: +44 (0) 7968 087 821
----------------------------------------------------------------------

---

From: Eliot Lear <[email-masked]>
Date: Fri, 11 Feb 2011 11:55:41 +0100

Dear Rhys,

Well spotted.  For the next round we hope to do a general terminology
cleanup (much of that is already done).

Thanks for your contribution,

Eliot

On 2/10/11 6:14 PM, Rhys Smith wrote:
> _______________________________________________
> abfab mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/abfab
>