Subject: Re: [abfab] First draft of Usability I-D submitted

From: "[email-masked]" <[email-masked]>
Date: Tue, 05 Jul 2011 17:26:15 +0200

Ok. 

But you should not store the passphrase. It should be in your head :)

Enviado desde mi HTC

----- Reply message -----
De: "Rhys Smith" <[email-masked]>
Fecha: mar., jul. 5, 2011 17:17
Asunto: [abfab] First draft of Usability I-D submitted
Para: <[email-masked]>
CC: <[email-masked]>

I guess protecting the identity selector/container with a passphrase is definitely a possibility someone implementing such a beast would consider, and therefore usability aspects should be discussed, so should probably be in the next draft.

How such a passphrase would be stored securely would be, of course, implementation specific and out of scope for this doc I think...

R.

On 5 Jul 2011, at 15:43, [email-masked] wrote:

> Hi. 
> 
> Is the password or the identity container protected by some passphrase? I suppose it is not stored in clear text.
> 
> Regards, Gabi 
> 
> Enviado desde mi HTC
> 
> ----- Reply message -----
> De: "Rhys Smith" <[email-masked]>
> Fecha: lun., jul. 4, 2011 20:07
> Asunto: [abfab] First draft of Usability I-D submitted
> Para: <[email-masked]>
> 
> Hi all,
> 
> I volunteered to pull together the document in the abfab charter around usability of abfab technologies. I've just posted a -00 draft of the doc, which can be found here:
> 
> http://www.ietf.org/id/draft-smith-abfab-usability-ui-considerations-00.txt
> 
> At the moment, it's pretty rough and ready and is more of a straw man around structure and type of content than anything else. You can consider every single paragraph as "todo".
> 
> I've split the document up into what I see as the three main areas of usability of a client that helps users perform abfab magic - managing identities, managing service to identity mappings, and handling errors. Each area definitely needs a lot more work.
> 
> So please, all reviews and comments most welcome. Usability is one of those particularly thorny areas that is hard to tie down, but will quite likely make or break this technology when it comes to user acceptance, so I think it's pretty important.
> 
> I will definitely be harassing those of you who have expressed an interest (or got shanghaied into being interested) over the coming month or so for feedback and suggestions :-).
> 
> Kind Regards,
> Rhys.
> --
> ----------------------------------------------------------------------
> Dr Rhys Smith                                   e: [email-masked]
> Engineering Consultant: Identity & Access Management  (GPG:0xDE2F024C)
> Information Services,
> Cardiff University,                            t: +44 (0) 29 2087 0126
> 39-41 Park Place, Cardiff,                     f: +44 (0) 29 2087 4285
> CF10 3BB, United Kingdom.                      m: +44 (0) 7968 087 821
> ----------------------------------------------------------------------
> 
> _______________________________________________
> abfab mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/abfab
> 
> 

--
----------------------------------------------------------------------
Dr Rhys Smith                                   e: [email-masked]
Engineering Consultant: Identity & Access Management  (GPG:0xDE2F024C)
Information Services,
Cardiff University,                            t: +44 (0) 29 2087 0126
39-41 Park Place, Cardiff,                     f: +44 (0) 29 2087 4285
CF10 3BB, United Kingdom.                      m: +44 (0) 7968 087 821
----------------------------------------------------------------------

---

From: Rhys Smith <[email-masked]>
Date: Tue, 5 Jul 2011 16:38:35 +0100

Personally I store all passphrases in my head encrypted with ECC. Makes typing it in a very long process as I mentally decrypt with the help of post-it notes each time I need to use them...

;-)

R.