Subject: [abfab] Fwd: New Version Notification for draft-wierenga-ietf-eduroam-00.txt

From: Klaas Wierenga <[email-masked]>
Date: Mon, 15 Oct 2012 13:11:41 +0200

FYI

Begin forwarded message:

> From: <[email-masked]>
> Subject: New Version Notification for draft-wierenga-ietf-eduroam-00.txt
> Date: October 15, 2012 12:24:23 PM GMT+02:00
> To: <[email-masked]>
> Cc: <[email-masked]>, <[email-masked]>
> 
> 
> A new version of I-D, draft-wierenga-ietf-eduroam-00.txt
> has been successfully submitted by Klaas Wierenga and posted to the
> IETF repository.
> 
> Filename:	 draft-wierenga-ietf-eduroam
> Revision:	 00
> Title:		 The eduroam architecture for network roaming
> Creation date:	 2012-10-15
> WG ID:		 Individual Submission
> Number of pages: 31
> URL:             http://www.ietf.org/internet-drafts/draft-wierenga-ietf-eduroam-00.txt
> Status:          http://datatracker.ietf.org/doc/draft-wierenga-ietf-eduroam
> Htmlized:        http://tools.ietf.org/html/draft-wierenga-ietf-eduroam-00
> 
> 
> Abstract:
>   This document describes the architecture of the eduroam service for
>   federated (wireless) network access in academia.  The combination of
>   802.1X, EAP and RADIUS that is used in eduroam provides a secure,
>   scalable and deployable service for roaming network access.  The
>   successful deployment of eduroam over the last decade in the
>   educational sector may serve as an example for other sectors, hence
>   this document.  In particular the initial architectural and standards
>   choices and the changes that were prompted by operational experience
>   are highlighted.
> 
> 
> 
> 
> The IETF Secretariat
>

---

From: Josh Howlett <[email-masked]>
Date: Mon, 15 Oct 2012 12:56:35 +0000

Hi Klaas,

I probably shouldn't be writing this email until I have finished the
update to aaa-saml :-). However I thought it was worth pointing out that
section 3.3. ('Routing table complexity') is a nice description of the
kind of problem that Trust Router (draft-howlett-abfab-trust-router-ps) is
trying to fix.

But now let us imagine that one was also interested in operating "govroam"
in parallel to eduroam, where they may be some overlap between these
communities. Now, in addition to the naming/connectivity incongruence
described in section 3.3, you can also add incongruence of trust
communities.

My contention is that, for the use cases that Abfab is addressing, the
number and overlap of trust communities wanting to consume identity is in
fact rather large. Therefore it will be significantly cheaper to operate a
single infrastructure that can manage these incongruences, rather than
instantiate N distinct infrastructures for N different trust communities.

It should be as cheap and easy to create and manage a trust community of
arbitrary actors as it is to connect a house full of consumer electronics
to a domestic WiFi router.

Josh.

On 15/10/2012 12:11, "Klaas Wierenga" <[email-masked]> wrote:

>> URL:            
>>http://www.ietf.org/internet-drafts/draft-wierenga-ietf-eduroam-00.txt
>> Status:         
>>http://datatracker.ietf.org/doc/draft-wierenga-ietf-eduroam
>> Htmlized:       
>>http://tools.ietf.org/html/draft-wierenga-ietf-eduroam-00
>> 
>> 
>> Abstract:
>_______________________________________________
>abfab mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/abfab

Janet is a trading name of The JNT Association, a company limited
by guarantee which is registered in England under No. 2881024 
and whose Registered Office is at Lumen House, Library Avenue,
Harwell Oxford, Didcot, Oxfordshire. OX11 0SG

---

From: Klaas Wierenga <[email-masked]>
Date: Mon, 15 Oct 2012 15:33:59 +0200

On Oct 15, 2012, at 2:56 PM, Josh Howlett <[email-masked]> wrote:

Hi Josh, all,

> update to aaa-saml :-). However I thought it was worth pointing out that

see, I knew our severity would pay of at some point…. ;-)

> to a domestic WiFi router.

Yes, I was meaning to bring this topic up. Given that we are making good progress with the abfab core documents the question arises what to do next. Fold abfab or recharter and pick up new work. I think we should have that discussion.

Klaas