Subject: Fwd: CMU Library documents

From: Randy Presuhn <[email-masked]>
Date: Fri, 1 Dec 2000 09:14:22 -0800 (PST)

Hi -

I'm forwarding a non-subscriber post to the agentx working
group mailing list.  Subscription instructions are at
http://www.ietf.org/html.charters/agentx-charter.html

 -------------------------------------------------------
 Randy Presuhn           [email-masked]
 Voice: +1 408 546-1006  BMC Software, Inc.  1-3141
 Fax:   +1 408 965-0359  2141 North First Street
 http://www.bmc.com/     San José, California 95131  USA
 -------------------------------------------------------
 My opinions and BMC's are independent variables.
 -------------------------------------------------------

> Received: from tattler.bmc.com (tattler.bmc.com [172.17.0.117])
> 	by dorothy.bmc.com (8.8.6 (PHNE_12836)/8.8.6) with ESMTP id BAA18023
> 	for <[email-masked]>; Fri, 1 Dec 2000 01:18:11 -0800 (PST)
> Received: from fw-us-hou1.bmc.com (localhost [127.0.0.1])
> 	by tattler.bmc.com (8.10.2/8.10.2) with SMTP id eB19HMh21767
> 	for <[email-masked]>; Fri, 1 Dec 2000 03:17:22 -0600 (CST)
> Received: from cisco.com ([192.135.239.144])
> 	by samrat.cisco.com (8.8.8/2.6/Cisco List Logging/8.8.8) with ESMTP id OAA17882
> 	for <[email-masked]>; Fri, 1 Dec 2000 14:49:00 +0530 (IST)
> Message-ID: <[email-masked]>
> Date: Fri, 01 Dec 2000 14:50:56 +0530
> From: Suprabha Mysore <[email-masked]>
> Reply-To: [email-masked]
> Organization: Cisco Systems
> X-Mailer: Mozilla 4.5 [en] (WinNT; I)
> X-Accept-Language: en
> MIME-Version: 1.0
> To: [email-masked]
> Subject: CMU Library documents
> Content-Type: text/plain; charset=us-ascii
> Content-Transfer-Encoding: 7bit
> 
> Hi,
> 
> I am using the CMU library for SNMP agent 
> development.
> 
> I do not sufficient documents that help me in the 
> development process.
> 
> Could somebody please suggest where I can get the
> appropriate documents.
> 
> Thanks
> Suprabha
>

---

From: "Holstein, Bert" <[email-masked]>
Date: Mon, 4 Dec 2000 10:22:20 +0100

Hi,
I presume that you're talking about the cmu agentx-library. Or 
do you refer to cmu's snmp library which is used by the snmpd.
Both come with some doc. when downloading the packages.
The snmp library with (mostly) man3 man-pages. The agentx-
library with html-pages about use of both snmpd and agentx-
library API. (After unzipping/untarring, have a look in directory 
.../doc).
If that's still insufficient, then you'd better ask some specific 
question you're struggling with (either via this mailing-list or
directory - we've done quite some programming with the 
CMU agentx-library in order to create subagents).
Hope this helps,

Kind regards,

Bert Holstein
HITT Holland Institute of Traffic Technology
[email-masked]

> -----Original Message-----
> From:	Randy Presuhn [SMTP:[email-masked]]
> Sent:	Friday, December 01, 2000 6:14 PM
> Cc:	[email-masked]
> Subject:	Fwd: CMU Library documents
> 
> 
> Hi -
>