Subject: [Anima-bootstrap] new issue in voucher github

From: "Max Pritikin (pritikin)" <[email-masked]>
Date: Thu, 20 Apr 2017 00:13:34 +0000

FYI - added the below to capture it but not distract myself from current ‘concise’ branch work. As per the recommendations I’m informing the list as well. I’ll circle back to this

- max

https://github.com/anima-wg/voucher/issues/3

There is some inconsistencies in the existing text that need to be resolved (see below). Additionally if a "voucher" can also be a "voucher request" then the requester can't necessarily populate all the fields. These related issues need to be dealt with.

leaf nonce {
type binary {
length "8..32";
}
must "not(../expires-on)";
description
"A value that can be used by a pledge in some bootstrapping
protocols to enable anti-replay protection. This node is
optional because it is not used by all bootstrapping
protocols.

---

From: Kent Watsen <[email-masked]>
Date: Thu, 20 Apr 2017 16:29:47 +0000

I don't think that the voucher should also be a voucher request.  There should be another
artifact defined for a voucher request, if needed.  YANG 'grouping' statements can be used
to ensure syntactic alignment between the two artifacts.

K.

On 4/19/17, 8:13 PM, "Max Pritikin (pritikin)" <[email-masked]<mailto:[email-masked]>> wrote:

- max

leaf nonce {
type binary {
length "8..32";
}

---

From: "Max Pritikin (pritikin)" <[email-masked]>
Date: Thu, 20 Apr 2017 17:53:28 +0000

So long as there is close alignment I’m not stuck on a particular approach.
I do want them both defined in the voucher doc so that BRSKI can reference them similarly.
There are some fields of the current voucher that apply to one aspect or the other (or both). I don’t know how ‘grouping’ addresses that but am happy to learn.

- max

On Apr 20, 2017, at 10:29 AM, Kent Watsen <[email-masked]<mailto:[email-masked]>> wrote:

K.

- max

leaf nonce {
type binary {
length "8..32";
}