Subject: [apps-discuss] For consideration as an appsawg document: draft-nottingham-http-portal

From: Barry Leiba <[email-masked]>
Date: Tue, 25 Jan 2011 21:32:18 -0500

http://tools.ietf.org/html/draft-nottingham-http-portal

This document has been discussed briefly on the httpbis mailing list,
but it's not a product of that working group.  The discussions were
some time ago, and there wasn't a lot; see the following two threads:

-00 version:
http://lists.w3.org/Archives/Public/ietf-http-wg/2010JulSep/0156.html
http://lists.w3.org/Archives/Public/ietf-http-wg/2010JulSep/0157.html
http://lists.w3.org/Archives/Public/ietf-http-wg/2010JulSep/0193.html
http://lists.w3.org/Archives/Public/ietf-http-wg/2010JulSep/0196.html

-01 version:
http://lists.w3.org/Archives/Public/ietf-http-wg/2010JulSep/0197.html
http://lists.w3.org/Archives/Public/ietf-http-wg/2010OctDec/0004.html

The document has sat with no discussion since then, and the appsawg
chairs and ADs recommend that the working group adopt, review, and
discuss it.  Please copy discussion to both lists -- this one, and
also the httpbis list, <[email-masked]>.

The appsawg chairs will be looking for objections to accepting this as
a working group document; please make such objections by 4 Feb.  In
any case, please review the document and comment on it.  This document
needs broad review and consensus across the applications area.

Barry, appsawg chair

---

From: Mark Nottingham <[email-masked]>
Date: Wed, 26 Jan 2011 13:51:27 +1100

I wouldn't be averse to this. 

However, some implementation experience is necessary. In particular, I'd like to run an experiment where the status code is deployed on a captive portal in a large network, to see if it affects current implementations.

The IETF meeting network seems like an ideal place to do so, and I've pinged [email-masked] (last August) about doing so, but haven't had any response.

It also needs adoption by people who use captive portals. To that end, I've had some positive interactions with the Wireless Broadband Alliance <http://wballiance.net/> about the draft, but that discussion tailed off without any conclusive action. I've also had some (brief) discussions with a few Squid developers (Squid is often used to interpose captive portals), and there was interest in supporting the draft, but this also needs following up.

Cheers,

On 26/01/2011, at 1:32 PM, Barry Leiba wrote:

> _______________________________________________
> apps-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/apps-discuss

--
Mark Nottingham   http://www.mnot.net/

---

From: Barry Leiba <[email-masked]>
Date: Tue, 25 Jan 2011 21:55:15 -0500

> However, some implementation experience is necessary. In particular, I'd like to
> run an experiment where the status code is deployed on a captive portal in a large
> network, to see if it affects current implementations.

That might mean that the target status of the document should, for
now, be "experimental".  The best way to get some experiments going,
and to drive some experimental implementations, is to have an
experimental spec.

> The IETF meeting network seems like an ideal place to do so, and I've pinged
> [email-masked] (last August) about doing so, but haven't had any
> response.

Try sending Joel a note (he responded to your other query on the wgchairs list).

Barry