Subject: Re: [apps-discuss] For consideration as an appsawg document:draft-hoffman-server-has-tls-03.txt

From: "Jiankang YAO" <[email-masked]>
Date: Mon, 17 Jan 2011 14:46:49 +0800

----- Original Message ----- 
From: "Paul Hoffman" <[email-masked]>
To: <[email-masked]>
Sent: Monday, January 17, 2011 10:41 AM
Subject: [apps-discuss] For consideration as an appsawg document:draft-hoffman-server-has-tls-03.txt

> Greetings again. I would like this WG to consider adopting the following 
> draft as a WG item. It is definitely apps-related, and there is no other 
> appropriate WG in the Applications or Security areas for it. It has been 
> discussed in the websec WG, but that WG is limited to HTTP only (and 
> this document covers TLS for all application protocols).
> 

This document also discusses The HASTLS Resource Record and
requests that IANA allocate a new DNS resource record
   type called HASTLS from the data types range.

I think that DNSEXT WG's comments are also important to the ADs and WG to consider whether this document happens to be fall in the scope of  APPSAWG.

Jiankang Yao

> FWIW, some of the topics in this draft are quite open for active 
> discussion. The discussion in websec brought up some interesting issues, 
> but they got discussed in the HTTP context only, and this WG would be a 
> better place to discuss them for all server protocols.
> 
> --Paul Hoffman
> 
> A New Internet-Draft is available from the on-line Internet-Drafts 
> directories.
> 
> Title           : Specifying That a Server Supports TLS
> Author(s)       : P. Hoffman
> Filename        : draft-hoffman-server-has-tls-03.txt
> Pages           : 8
> Date            : 2011-01-16
> 
> A server that hosts applications that can be run with or without TLS
> may want to communicate with clients whether the server is hosting an
> application only using TLS or also hosting the application without
> TLS.  Many clients have a policy to try to set up a TLS session but
> fall back to insecure if the TLS session cannot be set up.  If the
> server can securely communicate whether or not it can fall back to
> insecure tells such a client whether or not they should even try to
> set up an insecure session with the server.  This document describes
> the use cases for this type of communication and a secure method for
> communicating that information.
> 
> A URL for this Internet-Draft is:
> http://www.ietf.org/internet-drafts/draft-hoffman-server-has-tls-03.txt
> _______________________________________________
> apps-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/apps-discuss

---

From: Paul Hoffman <[email-masked]>
Date: Mon, 17 Jan 2011 07:22:08 -0800

On 1/16/11 10:46 PM, Jiankang YAO wrote:
> This document also discusses The HASTLS Resource Record and requests
> that IANA allocate a new DNS resource record type called HASTLS from
> the data types range.
>
> I think that DNSEXT WG's comments are also important to the ADs and
> WG to consider whether this document happens to be fall in the scope
> of  APPSAWG.

Of course, getting input from the wide community is important. Note that 
for Resource Records, however, the DNSEXT WG is not the decider: the 
expert reviewer for the registry is. This is why the APPSAWG is a more 
appropriate place to discuss the semantics and desirability of the protocol.

(Also, given that I have not yet done a first attempt at a wire format 
for the new RRtype, it is certainly premature to even ask DNSEXT...)

---

From: Andrew Sullivan <[email-masked]>
Date: Mon, 17 Jan 2011 10:25:20 -0500

> appropriate place to discuss the semantics and desirability of the 

Speaking as one of the co-chairs of DNSEXT, but without having
discussed this with my co-chair, I agree with Paul.  The RRTYPE itself
is way less interesting than the overall protocol.

A

-- 
Andrew Sullivan
[email-masked]
Shinkuro, Inc.