Subject: [apps-discuss] draft IETF 80 minutes

From: Peter Saint-Andre <[email-masked]>
Date: Wed, 13 Apr 2011 20:50:42 -0600

These are draft minutes:

http://www.ietf.org/proceedings/80/minutes/apparea.txt

Corrections are welcome.

Many thanks to Bert Greevenbosch for scribing!

/psa

========================================================================
AppsArea / APPSAWG Meeting Minutes
IETF 80
Monday, March 28, 2010, 0900-1130
Prague, Czech Republic
Hilton Prague, Congress Hall II

Area Directors: Alexey Melnikov, Peter Saint-Andre, Pete Resnick

APPSAWG WG Chairs: Barry Leiba, Jiankang Yao

Scribe: Bert Greevenbosch

Agenda:

<http://www.ietf.org/proceedings/80/agenda/apparea.txt>

Slides:

<https://datatracker.ietf.org/meeting/80/materials.html#wg-apparea>

Audio:

<http://ietf80streaming.dnsalias.net/ietf80/ietf80-ch3-mon-am.mp3>

Chat Log:

<http://www.ietf.org/jabber/logs/apparea/2011-03-28.txt>

========================================================================

MINUTES

Chairs:
Note well reviewed
Logistics reviewed
Agenda bashed

Paul Hoffman:
Draft-hoffman-server-has-tls-04
Question: Should it be a service discovery protocol? Group is requested
  to consider.
Question: Is there a way to securely negotiate usage of this secure
  protocol?
Remark: We should do this in a separate working group
Question: Conflict with W3C security policy? Need to coordinate making
  sure there are not many different formats.
Remark: Requirements in APPAREA is OK, but we need experts. New working
  group or current DNS based working group?
Maybe it can be built on top of DNSsec.
Question: Does it require something we already have? Maybe UNAPTR. Don't
  focus on new protocol, but see if needed, and if so, which technology
  can be re-used.
Show of hands on the following:
* Who thinks we should not do it?
  (small support)
* Who thinks we should do it in a separate working group?
  (medium support)
* Who thinks we should do it in apparea?
  (small support)
* Who thinks we don't know enough yet?
  (highest support)

Patrik Faltstrom:
Unicode and IDNA
Remark: Seems network issue, should be in lower layer.

Mark Nottingham:
draft-nottingham-http-portal
Question: HTTPS could also allow this?
More discussion needed.

Murray S. Kucherawy:
Draft-kucherawy-mta-malformed
Several problems could arise when browsers/mail readers give some leeway
  to malformed messages. There are security issues involved. IETF should
  consider these and give some guidance.
Question: Separate WG or in APPSAWG? Individual draft?

Draft-kucherawy-rfc3462bis
Question: Connection to SpamRep in OMA?
YAM WG is going to recharter. Right place could become YAM.
Wait until YAM recharters. If doesn't, then APPSAWG makes sense.

Draft-lear-iana-timezone-database
More discussion is needed, and a side meeting on Wednesday morning
  8:00 â€“ 9:00 is planned.

Eliot Lear:
draft-lear-iana-timezone-database-02
IANA Procedures for Maintaining the Timezone Database
Volunteers are needed to provide feedback on the document.

Eric Rescorla:
Draft-rescolra-jsms-00
Bar BoF about cryptography 20:00 in Karlin I.
Question: Is there a need for a http-URI or is https-URI enough?

Bernie HÃ¶neisen:
IANA Registration of Enumservices for Internet Calendaring
Session chair: Look for experts on calendaring (small group) first.
Question: Why shut down ENUM and not work on that there?
Answer: Leadership wants wg to be shut down.

Alexey Melnikov:
Draft-melnikov-smtp-altrecip-on-error-00
Remark: Threat analysis is needed.
Draft-melnikov-smtp-priority-01
Discussion on mailing list.

Florian Echtler:
Draft-echtler-gispl-specification-01
Question: Is this related to W3C web-actions?
Answer: Yes, it is.
Remark: Transmitting the format could be work for another
  organization.
Close relationship to eventing and API. Chris and Mark should look
  for a suitable WG.

Dave Crocker
Draft-crocker-doseta-base
Remark: Semantics need thorough considerations, as they cannot be
  changed after implementation.
Question: Where is the work to be done?
Answer: Not looking for a working group, but for people that are
  interested. If the interest is there, we can have a look at the
  mechanics.

Chris Lilley
http://trac.tools.ietf.org/wg/httpbis/trac/ticket/20
More discussion needed.

Bhumip Khasnabish
Virtual Desktop Infrastructure
List of possible work items
Remark: Proposal in OMA also to set-up virtual experience work item.
Next discussions from AD? Work of IETF? Is it a protocol or an API?
Need to discuss with ADs.

END

========================================================================

---

From: Barry Leiba <[email-masked]>
Date: Wed, 13 Apr 2011 23:14:35 -0400

> Answer: Leadership wants wg to be shut down.

More complete answer was that the WG is ending its useful life and is
ready to be shut down, and that at this point this document is more a
calendar issue than an enum issue, so there's little reason to do it
in enum anyway.

Add:
"Action: Ask Cyrus and Bernard to review and address open calendar questions."

Barry

---

From: Peter Saint-Andre <[email-masked]>
Date: Wed, 13 Apr 2011 21:21:38 -0600

> "Action: Ask Cyrus and Bernard to review and address open calendar questions."

Fixed.

Peter

-- 
Peter Saint-Andre
https://stpeter.im/

---

From: Bernie Hoeneisen <[email-masked]>
Date: Thu, 14 Apr 2011 14:29:42 +0200 (CEST)

Hi Peter et al.

On Wed, 13 Apr 2011, Barry Leiba wrote:

>> Bernie Hoeneisen:

Correct.

My I ask to adjust the minutes to emphasize the fact that the 
Caldenaring issues are the tricky ones (as the ENUM issues are trivial, 
once the Calendaring issues are resolved).

Proposal:

OLD:
   Question: Why shut down ENUM and not work on that there?
   Answer: Leadership wants WG to be shut down (outlived its useful
   life).

NEW:
   Question: Why shut down ENUM and not work on that there?
   Answer: IETF Leadership wants ENUM WG to be shut down (outlived its
   useful life). Furthermore, the issues with this document are in
   the Calendaring space (as opposed to ENUM).

cheers,
  Bernie

--

http://ucom.ch/
Tech Consulting for Internet Standardization

---

From: Cyrus Daboo <[email-masked]>
Date: Thu, 14 Apr 2011 09:37:15 -0400

Hi Barry,

> "Action: Ask Cyrus and Bernard to review and address open calendar

And Barry did carry out that action and I am in the process of reviewing.

-- 
Cyrus Daboo

---

From: Peter Saint-Andre <[email-masked]>
Date: Thu, 14 Apr 2011 07:39:53 -0600

Fixed.

-- 
Peter Saint-Andre
https://stpeter.im/