Subject: [apps-discuss] FW: I-D Action: draft-kucherawy-authres-spf-erratum-00.txt

From: "Murray S. Kucherawy" <[email-masked]>
Date: Tue, 3 Jan 2012 14:46:20 -0800

I've started this individual submission to correct the SPF entry in the Authentication-Results result name table from "hardfail" to "fail", to match what RFC4408 (and presumably RFC4408bis) says.  This corrects an approved erratum against RFC5451.

I suggested this as a first-tier work item for spfbis but there was resistance to doing so for the sake of keeping its charter lean; since it's really a lightweight effort, I decided to move ahead with it on my own.

Please give it a once over and a thumbs-up if I haven't missed anything.

Thanks,
-MSK

Subject: I-D Action: draft-kucherawy-authres-spf-erratum-00.txt
From: "[email-masked]" <[email-masked]>
To: "[email-masked]" <[email-masked]>
Date: Tue, 3 Jan 2012 14:43:51 -0800
List-Id: Internet Draft Announcements only <i-d-announce.ietf.org>

A New Internet-Draft is available from the on-line Internet-Drafts directories.

	Title           : Authentication-Results Registration Update for SPF Results
	Author(s)       : Murray S. Kucherawy
	Filename        : draft-kucherawy-authres-spf-erratum-00.txt
	Pages           : 5
	Date            : 2012-01-03

   This memo updates the registry of authentication method results in
   Authentication-Results: message header fields, correcting a
   discontinuity between the original registry creation and the SPF
   specification.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-kucherawy-authres-spf-erratum-00.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

This Internet-Draft can be retrieved at:
ftp://ftp.ietf.org/internet-drafts/draft-kucherawy-authres-spf-erratum-00.txt

_______________________________________________
I-D-Announce mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/i-d-announce
Internet-Draft directories: http://www.ietf.org/shadow.html
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

---

From: SM <[email-masked]>
Date: Tue, 03 Jan 2012 15:11:34 -0800

Hi Murray,
At 14:46 03-01-2012, Murray S. Kucherawy wrote:
>I've started this individual submission to correct the SPF entry in 
>the Authentication-Results result name table from "hardfail" to 
>"fail", to match what RFC4408 (and presumably RFC4408bis) 
>says.  This corrects an approved erratum against RFC5451.
>
>I suggested this as a first-tier work item for spfbis but there was 
>resistance to doing so for the sake of keeping its charter lean; 
>since it's really a lightweight effort, I decided to move ahead with 
>it on my own.

May I suggest that you consider a few points:

  1. If this work is dependent upon 4408bis, the author has an incentive to see
     4408bis published. :-)

  2. There is an assumption about what 4408bis will conclude.

  3. 5451bis will likely be published this year.  The erratum could be folded
     into it.

Regards,
-sm

---

From: "Murray S. Kucherawy" <[email-masked]>
Date: Tue, 3 Jan 2012 15:58:59 -0800

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of SM
> Sent: Tuesday, January 03, 2012 3:12 PM
> To: [email-masked]
> Subject: Re: [apps-discuss] FW: I-D Action: draft-kucherawy-authres-
> spf-erratum-00.txt
> 

It is not dependent on 4408bis.  The update is correct whether or not that ever publishes.

>   2. There is an assumption about what 4408bis will conclude.

Where?

>   3. 5451bis will likely be published this year.  The erratum could be folded

There's no 5451bis effort afoot that I know of.

-MSK

---

From: SM <[email-masked]>
Date: Tue, 03 Jan 2012 16:23:02 -0800

Hi Murray,
>It is not dependent on 4408bis.  The update is correct whether or 

Could the update wait until 4408bis is done?

>Where?

There is an existing effort to revise RFC 4408.

>There's no 5451bis effort afoot that I know of.

Don't tempt me. :-)

Regards,
-sm

---

From: Scott Kitterman <[email-masked]>
Date: Tue, 03 Jan 2012 22:28:30 -0500

On Tuesday, January 03, 2012 03:11:34 PM SM wrote:
>   1. If this work is dependent upon 4408bis, the author has an incentive to
> see 4408bis published. :-)

This work is not dependent on 4408bis.  This is a defect in 5451 that exists 
relative to 4408.  IIRC I even brought it up in the working group, but didn't 
prevail at the time.

I have some opinions about other issues that might be addressed, but I think 
this is just a plain bug in 5451 that ought to be fixed.

Scott K

---

From: "Murray S. Kucherawy" <[email-masked]>
Date: Tue, 3 Jan 2012 19:33:42 -0800

> Sent: Tuesday, January 03, 2012 4:23 PM
> Subject: Re: [apps-discuss] FW: I-D Action: draft-kucherawy-authres-spf-erratum-00.txt
> 

Yes, that's one option.  But why wait?  4408bis is not likely to change the name of "fail" as it would seriously impact backward compatibility, something its charter says they will be avoiding.

-MSK

---

From: SM <[email-masked]>
Date: Wed, 04 Jan 2012 02:28:56 -0800

Hi Murray,
At 19:33 03-01-2012, Murray S. Kucherawy wrote:
>Yes, that's one option.  But why wait?  4408bis is not likely to 
>change the name of "fail" as it would seriously impact backward 
>compatibility, something its charter says they will be avoiding.

It's a question of prioritizing work.  If I were to object on the 
Last Call (and you know that I won't), I would adapt some arguments 
from draft-arkko-iesg-crossarea-00.  For example:

  "The essence of most work is getting the right expertise to the room
   and to the list.  This does not happen through mere organizational
   forms, people have to be interested about the problem."

  "expertise is brought through the right people actually reading the
   specifications."

  "The best examples of successful work involve combining pieces of
   expertise, with the parties having an incentive to complete the work."

Obviously, none of the above is an adequate basis to prevent 
publication.  It would be easier for me to say that this draft should 
be published quickly as it is a minor fix that doesn't require too 
much effort.  The decision rests with the Sponsoring AD anyway and 
whatever I say won't have any effect on it.  And by demonstrating 
support, I end up looking good.

Regards,
-sm

---

From: Peter Saint-Andre <[email-masked]>
Date: Wed, 04 Jan 2012 11:25:02 -0700

On 1/4/12 3:28 AM, SM wrote:
> It's a question of prioritizing work.  If I were to object on the Last
> Call (and you know that I won't), I would adapt some arguments from
> draft-arkko-iesg-crossarea-00.  For example:
> 
> publication.  It would be easier for me to say that this draft should be
> published quickly as it is a minor fix that doesn't require too much
> effort.  The decision rests with the Sponsoring AD anyway and whatever I
> say won't have any effect on it.  And by demonstrating support, I end up
> looking good.

I've agreed to sponsor this document. It's a simple bug fix, and bug
fixes are good. Yes, it will require cycles from various people (IESG,
IANA, RFC Editor), but I hope not too many.

Peter

-- 
Peter Saint-Andre
http://stpeter.im/