Subject: Re: [apps-discuss] WGLC on draft-ietf-appsawg-xdash-02.txt

From: "t.petch" <[email-masked]>
Date: Wed, 1 Feb 2012 10:01:44 +0100

----- Original Message -----
From: "Dave CROCKER" <[email-masked]>
To: "Peter Saint-Andre" <[email-masked]>
Cc: "Paul Hoffman" <[email-masked]>; <[email-masked]>
Sent: Friday, January 27, 2012 8:48 PM
> On 1/27/2012 10:44 AM, Peter Saint-Andre wrote:
> >>       The specification only cover parameter names, not numbers.
> >>  Brevity is good.
> Usually.

As long as it is right.  My number parameters have text names; my textual
parameters have text names.  I think that 'the specification only cover textual
parameter, not numeric one'.

Aliter,
'Note that this document only discusses parameters expressed in text; it does
not discuss parameters that are expressed with numbers.'
modifying Paul's original proposal slightly.

Arguably, the first sentence of the Introduction has the same problem with its
reference to 'named parameters' as opposed to 'parameters expressed in text'.

But like Paul, I think that that is worth explicitly stating in this I-D,
because when I get to Appendix B, it says
' [BCP82] is entitled "Assigning Experimental and Testing Numbers
       Considered Useful" and therefore implies that the "X-" prefix is
       also useful for experimental parameters.  '
Well, if this is about textual parameters, then BCP82 is irrelevant, its
title clearly states its scope and reading and re-reading it, I see nothing in
it
about text or characters, every reference is to number(s) and so I see
nothing that has implications for X-.  Reading Appendix B might well muddy the
waters as to the scope of this I-D which is why I would like that sentence
above added.

Tom Petch
> d/

---

From: Peter Saint-Andre <[email-masked]>
Date: Mon, 13 Feb 2012 15:45:35 -0700

> waters as to the scope of this I-D which is why I would like that sentence

In our working copy I have:

"Note that this document covers only parameters with textual names, not
parameters that are expressed as numbers."

I've also clarified the matter a bit in the abstract and the introduction:

"[T]his document deprecates the "X-" convention for textual parameters
in application protocols."

"Many application protocols use parameters with textual names to
identify data..."

Etc.

Shall I submit -03 so that the text is easier to track?

Peter

-- 
Peter Saint-Andre
https://stpeter.im/

---

From: Dave CROCKER <[email-masked]>
Date: Mon, 13 Feb 2012 15:19:40 -0800

> Shall I submit -03 so that the text is easier to track?

+1

d/
-- 

   Dave Crocker
   Brandenburg InternetWorking
   bbiw.net

---

From: Peter Saint-Andre <[email-masked]>
Date: Mon, 13 Feb 2012 16:39:39 -0700

>> Shall I submit -03 so that the text is easier to track?

Ask and ye shall receive:

http://tools.ietf.org/rfcdiff?url2=draft-ietf-appsawg-xdash-03

Peter

-- 
Peter Saint-Andre
https://stpeter.im/