Subject: Re: [apps-discuss] I-D Action: draft-ietf-appsawg-greylisting-05.txt

From: "Murray S. Kucherawy" <[email-masked]>
Date: Wed, 14 Mar 2012 19:50:47 +0000

Some offlist feedback suggests adding this to the end of the list in Section 5:

   7.  An ADMD's own submission service (see [SUBMISSION]) SHOULD NOT
       apply greylisting checks.  Alternately, an ADMD could simply
       exempt internal IP addresses from being greylisted, as described
       in the previous point.

Seems reasonable to me.  Others?

-MSK

---

From: Dave Crocker <[email-masked]>
Date: Wed, 14 Mar 2012 13:10:25 -0700

> Seems reasonable to me.  Others?

I think the general form of this is:

    7.  Greylisting SHOULD NOT be applied by an ADMD's submission service (see 
[SUBMISSION]) for authenticated client hosts.  Authentication can include 
whatever mechanisms are deemed appropriate for the ADMD, such as known internal 
IP addresses, SASL or the like.

The "alternately" is confusing to me.  Is it meant to apply to non-submission 
services?  If so, then this rule needs something broader, such as:

    7.  Greylisting SHOULD NOT be applied to client hosts internal to the ADMD 
or otherwise part of the ADMD's operation, such as having membership on a list 
of exempt IP Addresses.

d/
-- 

   Dave Crocker
   Brandenburg InternetWorking
   bbiw.net

---

From: "Murray S. Kucherawy" <[email-masked]>
Date: Wed, 14 Mar 2012 20:12:47 +0000

> -----Original Message-----
> From: Dave Crocker [mailto:[email-masked]]
> Sent: Wednesday, March 14, 2012 1:10 PM
> To: Murray S. Kucherawy
> Cc: [email-masked]
> Subject: Re: [apps-discuss] I-D Action: draft-ietf-appsawg-greylisting-05.txt
> 
> [SUBMISSION]) for authenticated client hosts.  Authentication can
> include whatever mechanisms are deemed appropriate for the ADMD, such
> as known internal IP addresses, SASL or the like.
> 
> The "alternately" is confusing to me.  Is it meant to apply to non-
> submission services?  If so, then this rule needs something broader,
> such as:
> 
>     7.  Greylisting SHOULD NOT be applied to client hosts internal to
> the ADMD or otherwise part of the ADMD's operation, such as having
> membership on a list of exempt IP Addresses.

I think your first restatement is more what I had in mind.

-MSK

---

From: Barry Leiba <[email-masked]>
Date: Wed, 14 Mar 2012 16:13:41 -0400

> The "alternately" is confusing to me.

Maybe because it should be "alternatively"; they're not the same thing.

I have this image of applying greylisting to odd-numbered submissions,
but not to even-numbered ones.

Barry, as pedant

---

From: Dave Crocker <[email-masked]>
Date: Wed, 14 Mar 2012 13:18:11 -0700

> but not to even-numbered ones.

doesn't help.  I don't really understand what is being alternated or sequenced 
or whatever.  That is, I'm not clear what the overriding scope/principal of the 
rule is.  There seem to be multiple possibilities, as I indicated.

d/

-- 

   Dave Crocker

---

From: Dave Crocker <[email-masked]>
Date: Wed, 14 Mar 2012 13:23:16 -0700

> I think your first restatement is more what I had in mind.

goodie.

d/
-- 

   Dave Crocker