Subject: Re: [apps-discuss] Feedback about "Update to MIME regarding Charset Parameter Handling in Textual Media Types"

From: Alexey Melnikov <[email-masked]>
Date: Sun, 25 Mar 2012 22:10:04 +0200

Hi Martin,
Catching up with this thread.
On Thu, Feb 23, 2012 at 6:53 AM, "Martin J. Dürst"
<[email-masked]>wrote:

>
> On 2012/02/22 22:25, Henri Sivonen wrote:
>
>>
>>
>
>  In order to improve interoperability with deployed agents, "text/*" media
>>> type definitions SHOULD either a) specify that the "charset" parameter is
>>> not used for the defined subtype, because the charset information is
>>> transported inside the payload (as in "text/xml")
>>>
>>
>> This seems wrong. If the charset parameter is present, it has an
>> effect for text/xml.
>>
> Yes indeed.
>
>
>
Please describe this behavior. (As Julian pointed out, this might be just a
bad example here. This document is not changing defaults for any existing
text/* media type.)

---

From: Julian Reschke <[email-masked]>
Date: Fri, 30 Mar 2012 14:24:00 +0200

On 2012-02-23 04:59, Ned Freed wrote:
 > ...
>> For backwards compatibility, pretty much every existing text/* type
>> >  will have to violate this "SHOULD NOT".
> Yep. That's the main reason why it needs to be a SHOULD.
 > ...

Alexey and myself just discussed this, and we do agree that the SHOULD 
will need to be violated for updates of text/xml and text/html, but we 
believe this is ok (the authors of the new registrations will understand 
what the SHOULD is about and how to deal with it).

Best regards, Julian

---

From: Ned Freed <[email-masked]>
Date: Fri, 30 Mar 2012 11:15:22 -0700 (PDT)

> what the SHOULD is about and how to deal with it).

Sounds like we're all in agreement then.

				Ned