Subject: [apps-discuss] Free Universal Construction Kit

From: Mark Nottingham <[email-masked]>
Date: Thu, 22 Mar 2012 11:37:47 +1100

<http://fffff.at/free-universal-construction-kit/>

I think there's a lesson for us in this; not sure what it is, though. Maybe something about the relationship between Open Source and standards? Anyway.

See especially:

<http://media.fffff.at/free-universal-construction-kit/images/free-universal-construction-kit-poster.pdf>

--
Mark Nottingham   http://www.mnot.net/

---

From: "Tschofenig, Hannes (NSN - FI/Espoo)" <[email-masked]>
Date: Thu, 22 Mar 2012 08:03:39 +0200

Hi Mark,

Nice stuff in two ways:
1) as a toy useful, and
2) interesting when compared with IETF technologies.

I believe we are, however, already deeply into this 'adaptor/gatewaying' business. As an example think about the asynchronous real-time protocol work (lacking a better word). Folks are looking into the interaction between XMPP and SIP, between SIP and RTCWEB and various sub-components within these areas, such as emergency services.

Another example is all the work on IPv4/IPv6 transition.

btw, while the comparison between Lego blocks and IETF protocols had been used  before I believe it is not a perfect match since we often have one or multiple architectures in mind when we design the building blocks. Consequently, the building blocks work fine in a range of architectures but not everywhere. They are not as nicely interchangeable as Lego blocks.

Just a few thoughts early in the morning in response to your mail.

Ciao
Hannes

Sent from my Windows Phone

-----Original Message-----
From: ext Mark Nottingham
Sent: 3/22/2012 2:38 AM
To: Apps Discuss
Subject: [apps-discuss] Free Universal Construction Kit

See especially:

_______________________________________________
apps-discuss mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/apps-discuss