Subject: [apps-discuss] FW: New Version Notification for draft-jones-appsawg-webfinger-01.txt

From: "Paul E. Jones" <[email-masked]>
Date: Mon, 12 Mar 2012 03:25:53 -0400

Folks,

I just wanted to let everyone know that we have published a revised version of the Webfinger draft.  Your comments are encouraged.

Paul

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Monday, March 12, 2012 3:23 AM
> To: [email-masked]
> Cc: [email-masked]; [email-masked]
> Subject: New Version Notification for draft-jones-appsawg-webfinger-01.txt
> 
> A new version of I-D, draft-jones-appsawg-webfinger-01.txt has been
> successfully submitted by Paul E. Jones and posted to the IETF repository.
> 
> Filename:	 draft-jones-appsawg-webfinger
> Revision:	 01
> Title:		 Webfinger
> Creation date:	 2012-03-12
> WG ID:		 Individual Submission
> Number of pages: 17
> 
> Abstract:
>    This specification defines the Webfinger protocol.  Webfinger may be
>    used to discover information about people on the Internet, such as a
>    person&#39;s personal profile address, identity service, telephone
>    number, or preferred avatar.  Webfinger may also be used to learn
>    information about objects on the network, such as the amount of toner
>    in a printer or the physical location of a server.
> 
> 
> 
> 
> The IETF Secretariat

---

From: Bob Wyman <[email-masked]>
Date: Tue, 13 Mar 2012 11:12:33 -0400

Examples teach as much or more than the actual text of
specifications... Thus, I'd like to suggest a small modification to
the examples provided:
Many webfinger clients will inevitably seek to cache the host metadata
returned as an XRD or JRD. However, we can anticipate that many
developers will skip a detailed analysis of the actual XRD draft and
will, instead, have designs driven largely by what they see in the
examples. Because of the complex interaction between XRD Expire
elements and HTTP Cache control I suggest that the examples in 3.1 and
3.2 be modified slightly to include an Expires element as defined in
the XRD specification. Doing so in the examples might, in fact,
motivate developers to seek out the documentation that explains the
element. Thus, a modified example in 3.1 would be something like:

     HTTP/1.1 200 OK
     Access-Control-Allow-Origin: *
     Content-Type: application/xrd+xml; charset=UTF-8

     <?xml version="1.0" encoding="UTF-8"?>
     <XRD xmlns="http://docs.oasis-open.org/ns/xri/xrd-1.0">
       <Expires>2011-11-11T23:11:11Z</Expires>
       <Subject>acct:[email-masked]</Subject>
       <Link rel="http://webfinger.net/rel/avatar"
             href="http://www.example.com/~bob/bob.jpg"/>
       <Link rel="http://webfinger.net/rel/profile-page"
             href="http://www.example.com/~bob/"/>
       <Link rel="blog"
             href="http://blogs.example.com/bob/"/>
     </XRD>

bob wyman

On Mon, Mar 12, 2012 at 3:25 AM, Paul E. Jones <[email-masked]> wrote:
> _______________________________________________
> apps-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/apps-discuss

---

From: "Paul E. Jones" <[email-masked]>
Date: Tue, 13 Mar 2012 17:02:46 -0400

Bob,

That's a good suggestion.  I've updated several examples (both host-meta and
LRDD) with Expires (both XRD and JRD).

Paul

> From: [email-masked] [mailto:[email-masked]] On Behalf Of Bob
> Wyman
> Sent: Tuesday, March 13, 2012 11:13 AM
> To: Paul E. Jones
> Cc: [email-masked]; WebFinger List
> Subject: Re: [apps-discuss] FW: New Version Notification for draft-jones-
> appsawg-webfinger-01.txt
> 
> Examples teach as much or more than the actual text of specifications...
> Thus, I'd like to suggest a small modification to the examples provided:
> returned as an XRD or JRD. However, we can anticipate that many developers
> will skip a detailed analysis of the actual XRD draft and will, instead,
> have designs driven largely by what they see in the examples. Because of
> the complex interaction between XRD Expire elements and HTTP Cache control
> I suggest that the examples in 3.1 and
> 3.2 be modified slightly to include an Expires element as defined in the
> XRD specification. Doing so in the examples might, in fact, motivate
> developers to seek out the documentation that explains the element. Thus,
> a modified example in 3.1 would be something like:
> 
>      HTTP/1.1 200 OK
> > I just wanted to let everyone know that we have published a revised
> version of the Webfinger draft.  Your comments are encouraged.
> >
> > Paul
> >
> > > WG ID:                 Individual Submission Number of pages: 17
> > >
> > > Abstract: