Subject: [apps-discuss] Looking to begin discussion about email and IPv6

From: Terry Zink <[email-masked]>
Date: Thu, 5 Apr 2012 22:16:53 +0000

Hi, everyone,

I am new to the IETF process but have wanted to get involved for some time.  

I browsed through the various working groups and I didn't any that were related to the topic I need to discuss, so I am bringing it up here.  If need be, perhaps we can create a separate WG.

The topic I want to discuss is IPv6 and email.  At the Paris IETF, one of my colleagues presented some slides I drew up regarding the problem of email and IPv6.  Because of widespread abuse of SMTP today in IPv4, the email industry is hesitant to move to IPv6 for sending anonymous email as the current techniques in use will not scale.

Has anyone else addressed this?  There are workarounds floating around but most of what we see today is that most people don't send mail over IPv6 and those that do know who they want to receive it from.  The problem is that once IPv6 becomes mainstream, eventually we will "build a better spammer" and the problem of abuse would swamp email servers.

I have some ideas on how to address this, at least in the short term.  I'd also like go gauge interest for discussing this at the Vancouver IETF at the end of July.

Thanks.

-- Terry

---

From: Marc Blanchet <[email-masked]>
Date: Thu, 5 Apr 2012 18:30:41 -0400

to me, the issue is real and relevant to IETF and apps area is a good place to start discussing. I would suggest you to write an internet-draft describing first the problem and maybe/optional the solution space you are thinking.  

if you don't know how to start writing an Internet-draft, either take a look at another one or see: http://www.ietf.org/tao.html#anchor38

marc.

Le 2012-04-05 à 18:16, Terry Zink a écrit :

> _______________________________________________
> apps-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/apps-discuss

---

From: "Murray S. Kucherawy" <[email-masked]>
Date: Thu, 5 Apr 2012 22:38:22 +0000

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of Terry Zink
> Sent: Thursday, April 05, 2012 3:17 PM
> To: [email-masked]
> Subject: [apps-discuss] Looking to begin discussion about email and IPv6
> 
> [...]
> I have some ideas on how to address this, at least in the short term.
> I'd also like go gauge interest for discussing this at the Vancouver
> IETF at the end of July.

Hi Terry,

This is a frequent topic in industry, especially at the Messaging Anti-Abuse Working Group (MAAWG, http://www.maawg.org) which is not part of IETF.  You'd probably get a lot of interested people if you put together a BoF there.  You can probably get some people together at IETF in Vancouver too for a bar BoF.

Off the top of my head, I can only think of this document (now expired) on the topic:

https://datatracker.ietf.org/doc/draft-oreirdan-rosenwald-ipv6mail-transition/

I think this is of interest to people in the Applications area.  I suggest writing up a draft and circulating it for discussion with what you have in mind.

-MSK

---

From: Peter Saint-Andre <[email-masked]>
Date: Thu, 05 Apr 2012 16:41:03 -0600

On 4/5/12 4:38 PM, Murray S. Kucherawy wrote:
>> -----Original Message----- From: [email-masked]
>> [mailto:[email-masked]] On Behalf Of Terry Zink 
>> Sent: Thursday, April 05, 2012 3:17 PM To: [email-masked] 
>> [...] I have some ideas on how to address this, at least in the
>> short term. I'd also like go gauge interest for discussing this at
>> the Vancouver IETF at the end of July.
> 
> Hi Terry,
> 
> This is a frequent topic in industry, especially at the Messaging
> Anti-Abuse Working Group (MAAWG, http://www.maawg.org) which is not
> part of IETF.  You'd probably get a lot of interested people if you
> put together a BoF there.  You can probably get some people together
> at IETF in Vancouver too for a bar BoF.

Which reminds me that there's been talk about holding IETF interim
meetings for relevant WGs at conferences like MAAWG and RIPE. Our new
AppsArea overlords might want to consider something like that at a
future MAAWG meeting. :)

Peter

-- 
Peter Saint-Andre
https://stpeter.im/

---

From: Nico Williams <[email-masked]>
Date: Thu, 5 Apr 2012 17:42:06 -0500

How does IP6 have any kind of an effect on spam?  Just curious,

Nico
--

---

From: "Murray S. Kucherawy" <[email-masked]>
Date: Thu, 5 Apr 2012 22:43:36 +0000

> From: [email-masked] [mailto:[email-masked]] On Behalf Of Nico Williams
> Sent: Thursday, April 05, 2012 3:42 PM
> To: Terry Zink
> Cc: [email-masked]
> Subject: Re: [apps-discuss] Looking to begin discussion about email and IPv6
> 

The portion of an anti-spam framework that evaluates based on client IP address (DNSBLs, for instance) has a far larger problem to deal with in IPv6.

-MSK

---

From: "John Levine" <[email-masked]>
Date: 6 Apr 2012 00:43:01 -0000

>https://datatracker.ietf.org/doc/draft-oreirdan-rosenwald-ipv6mail-transition/

There's also my draft of an alternate way to publish DNSBLs as B-trees that
can directly express address ranges:

http://tools.ietf.org/html/draft-levine-iprangepub-02

Something that would make our lives a lot easier is a way for networks
to publish their customer allocation size, be it /64 or whatever.
Sure, some naughty networks will like, but the largest ones won't, and
when you get spam from a 'bot, it'd be a useful hint to know how large
a range the bot has infected.

R's,
John

---

From: "Murray S. Kucherawy" <[email-masked]>
Date: Fri, 6 Apr 2012 05:51:24 +0000

> From: John Levine [mailto:[email-masked]]
> Sent: Thursday, April 05, 2012 5:43 PM
> Cc: Murray S. Kucherawy

I've been keeping an eye on various work in sidr, dnsop, and weirds to see where this capability is more likely to emerge.  It's definitely desirable specifically for the email-over-IPv6 space, but possibly for other security-related things as well.  I'll be putting work into it wherever it appears, and/or will submit a draft of my own if I come up with an idea that seems workable.  I just haven't found that yet.

-MSK

---

From: "John Levine" <[email-masked]>
Date: 6 Apr 2012 06:20:32 -0000

>I've been keeping an eye on various work in sidr, dnsop, and weirds to see where this capability
>is more likely to emerge.  It's definitely desirable specifically for the email-over-IPv6 space,
>but possibly for other security-related things as well.  I'll be putting work into it wherever
>it appears, and/or will submit a draft of my own if I come up with an idea that seems workable. 
>I just haven't found that yet.

In Paris I had dinner with the guys who were running the conference
network, and explained to them why we wanted the allocation size.
They had a bunch of plausible ideas, none of which I remember in
detail (darn that cheap but tasty wine from southern France) other
than that if WEIRDS succeeds, it could either be a field in the
response for the allocation, or they could SWIP all of the
suballocations.  I suggested that for both scale and privacy reasons
ARIN would probably not welcome 50,000,000 SWIPs from Comcast, but
they noted that large networks can run their own subservers, and it's
quite possible to have entries for individuals that don't include the
PII.

R's,
John