Subject: [apps-discuss] SenML, sensor tasking, etc. From the Open Geospatial Consortium

From: "Carl Reed" <[email-masked]>
Date: Fri, 27 Apr 2012 15:30:35 -0600

All -

I have just become aware of the SenML and related sensor standard activities in the IETF. I would like to consider how the sensor work in the IETF community and the work on sensor standards in the OGC can be possibly coordinated. By way of background.

I am the CTO and Executive Director Standards for the Open Geospatial Consortium (OGC). The OGC focus is on standards that enable the integration and interoperable integration of geospatial services and content into any application.

Since 2000, a number of OGC Member organizations have been working an activity we call Sensor Web Enablement (SWE). This activity has resulted in a baseline of standards for describing, tasking, accessing, and managing network accessible sensors. These standards work with both in-situ and dynamic sensors. The SWE standards have been widely implemented in a variety of domains, such as for ocean sensing, early warning systems, hydrology, satellite ground stations, and mobile location services. Due to the OGC focus on location enabled, network accessible sensors, we have been collaborating with JTC1 Working Group 7, the W3C, ISO TC 211, KRONOS, IEEE, and other organizations to insure that the standards stack for integrating sensor observations into applications is as consistent as possible.
There is a high level OGC White Paper that describes the SWE standards and architecture. This WP just underwent a major revision and has not been publicly released yet. There is also a much more detailed technical SWE document here: http://portal.opengeospatial.org/files/?artifact_id=29405 

Looking forward to this groups thoughts.

Regards

Carl Reed, PhD
CTO and Executive Director Standards Program
Open Geospatial Consortium
www.opengeospatial.org

The OGC: Making Location Count!

---------------------

This communication, including attachments, is for the exclusive use of addressee and may contain proprietary, confidential or privileged information. If you are not the intended recipient, any use, copying, disclosure, dissemination or distribution is strictly prohibited. If you are not the intended recipient, please notify the sender immediately by return email and delete this communication and destroy all copies.

"The important thing is not to stop questioning." -- Albert Einstein 
"Security is mostly a superstition. It does not exist in nature. Life is either a daring adventure or nothing." -- Helen Keller

---

From: Barry Leiba <[email-masked]>
Date: Fri, 27 Apr 2012 18:33:53 -0400

Hi, Carl.
There is no work on SenML going on in the IETF at this time, so
there's nothing for us to coordinate.

The IAB, however, has held a workshop on "smart objects"; see here:
http://www.iab.org/activities/workshops/smartobjects/

You can contact the IAB, of which Jari Arkko and Hannes Tschofenig are
active in this space, and see what their plans are and what they
suggest.  You can reach the IAB at <[email-masked]>.

Barry Leiba, Applications Area Director

On Fri, Apr 27, 2012 at 5:30 PM, Carl Reed <[email-masked]> wrote:
> All -
>
> I have just become aware of the SenML and related sensor standard activities
> in the IETF. I would like to consider how the sensor work in the IETF
> community and the work on sensor standards in the OGC can be possibly
> coordinated. By way of background.
>
> I am the CTO and Executive Director Standards for the Open Geospatial
> Consortium (OGC). The OGC focus is on standards that enable the integration
> and interoperable integration of geospatial services and content into any
> application.
>
> Since 2000, a number of OGC Member organizations have been working an
> activity we call Sensor Web Enablement (SWE). This activity has resulted in
> a baseline of standards for describing, tasking, accessing, and managing
> network accessible sensors. These standards work with both in-situ and
> dynamic sensors. The SWE standards have been widely implemented in a variety
> of domains, such as for ocean sensing, early warning systems, hydrology,
> satellite ground stations, and mobile location services. Due to the OGC
> focus on location enabled, network accessible sensors, we have been
> collaborating with JTC1 Working Group 7, the W3C, ISO TC 211, KRONOS, IEEE,
> and other organizations to insure that the standards stack for integrating
> sensor observations into applications is as consistent as possible.
> There is a high level OGC White Paper that describes the SWE standards and
> architecture. This WP just underwent a major revision and has not been
> publicly released yet. There is also a much more detailed technical SWE
> document here: http://portal.opengeospatial.org/files/?artifact_id=29405
>

---

From: "Adrian Farrel" <[email-masked]>
Date: Sat, 28 Apr 2012 12:57:25 +0100

Hi all,

I think Carl will want to be aware of
http://www.ietf.org/internet-drafts/draft-jennings-senml-08.txt and maybe
contact the authors listed on the document.

There was some discussion of the document on the Apps Discuss mailing list
starting with
http://www.ietf.org/mail-archive/web/apps-discuss/current/msg04361.html on 23rd
Feb this year.

Cheers,
Adrian (Not an Apps person, but understands how to use grep)

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> On Behalf Of Barry Leiba
> Sent: 27 April 2012 23:34
> To: Carl Reed
> Cc: apps-discuss IETF
> Subject: Re: [apps-discuss] SenML, sensor tasking, etc. From the Open
Geospatial
> Consortium
> _______________________________________________
> apps-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/apps-discuss

---

From: Barry Leiba <[email-masked]>
Date: Sat, 28 Apr 2012 09:42:38 -0400

> contact the authors listed on the document.

Yes, that's what prompted Carl to send his message in the first place
(so he is aware of it), and Jari, whom I suggested in my response, is
one of the authors.  The document is an individual contribution, and
not official IETF work at this point.  I think the IAB workshop is the
best fit, and also the IAB is the right place to go for
inter-organizational coordination.

Apart from that, it turns out that Carl knows Hannes.  So he intends
to contact him.

Barry

---

From: Ned Freed <[email-masked]>
Date: Sun, 29 Apr 2012 11:16:52 -0700 (PDT)

> contact the authors listed on the document.

One interesting thing about this draft is that the cites clearly imply that the
intent is to publish the actual SENML specification as an RFC. (I note in
passing that publication by some standards body is necessary for the types to
be in the standards tree.)

				Ned