Subject: Re: [apps-discuss] feedback on draft-ietf-appsawg-json-patch-01.txt

From: Julian Reschke <[email-masked]>
Date: Thu, 12 Apr 2012 16:10:32 +0200

On 2012-03-21 10:11, Julian Reschke wrote:
> On 2012-03-21 07:55, "Martin J. Dürst" wrote:
>> On 2012/03/21 6:40, Murray S. Kucherawy wrote:
>>
>>> Does there need to be one-and-only-one?
>>
>> In theory, not necessarily. In practice, not having a lot of variation
>> usually helps.
>>
>>> Or I guess more accurately, do we need to say this is the one and only
>>> way to do this? Seems like that closes the door to someone coming up
>>> with a better idea.
>>
>> Fragment pointers into datastructures such as JSON isn't exactly a brand
>> new field with lots of new possibilities. And XPointer has shown that
>> making it too complicated cuts out most implementations. My proposal
>> would be to somehow include an extensibility hatch, but then say this is
>> the one and only one.
>
> In XML, as far as I understand, the escape hatch is that identifiers do
> not allow brackets, and thus these are free for defining new addressing
> schemes. So in JSON Pointer, we'd need to escape a few more characters
> when using in fragment identifiers.
>
> Also, it seems this needs to be coordinated with a potential spec
> defining a "+json" media type suffix...
> ...

It would be good if we made up our minds whether we are defining a 
fragment identifier syntax for application/json or not.

My proposal is to keep things simple for now and thus not to do it; that 
implies removing or clarifying the examples in the spec.

Best regards, Julian

---

From: Mark Nottingham <[email-masked]>
Date: Thu, 12 Apr 2012 09:12:19 -0500

On 12/04/2012, at 9:10 AM, Julian Reschke wrote:
> It would be good if we made up our minds whether we are defining a fragment identifier syntax for application/json or not.
> 
> My proposal is to keep things simple for now and thus not to do it; that implies removing or clarifying the examples in the spec.

+1

--
Mark Nottingham
http://www.mnot.net/