Subject: [apps-discuss] APPSDIR review of draft-ietf-eai-rfc5721bis-04

From: Glenn Parsons <[email-masked]>
Date: Sun, 6 May 2012 13:58:48 -0400

I have been selected as the Applications Area Directorate reviewer for this draft (for background on appsdir, please see http://trac.tools.ietf.org/area/app/trac/wiki/ApplicationsAreaDirectorate ).
Please resolve these comments along with any other Last Call comments you may receive. Please wait for direction from your document shepherd or AD before posting a new version of the draft.
Document: draft-ietf-eai-rfc5721bis-04
Title: POP3 Support for UTF-8
Reviewer: Glenn Parsons
Review Date: May 5, 2012
Summary:   This draft is almost ready for publication as Proposed Standard RFC but has a few issues that should be fixed before publication
Major Issues:  None that I found
Minor Issues:
1.1 "silly" seems like the wrong word.  How about "will appear incorrectly as a result"
   but why not consider posting a companion PDF version with the correct accents?
   Then you could reword this note here (and the one in section 2) to indicate the limitation is only in the txt version...
2.  section 2 seems somewhat long without any subsections.  Consider adding one or more...perhaps for the examples?
3.1 After the nice example in section 2, the reader feels that they are missing from the end of section 3.  A full example would be onerous, but a shortened one would be helpful
3.2 the 5th and 7th paragraphs are related and it would likely read better if the 7th paragraph was made the second sentence of the 5th paragraph.
5. I am curious as to what would casue the "better mood" of the server :-)  I suspect it is implementation choice and if the CPU is running at max it would be in a "bad mood" and decline a downconvert request?  Whatever the case, I suggest you explain this a bit more...
6.  The section -> Section
     ...in both paragraphs
Nits:
-- The draft header indicates that this document obsoletes RFC5721, but the abstract doesn't seem to mention this, which it should
 -- The document has a disclaimer for pre-RFC5378 work, but was first submitted on or after 10 November 2008. Does it really need the disclaimer?
 == Outdated reference: A later version (-04) exists of draft-ietf-eai-simpledowngrade-03

---

From: "Jiankang YAO" <[email-masked]>
Date: Mon, 7 May 2012 10:14:32 +0800

I think that AD has clarified that IESG did not ask to mention the obsoleted rfc in the abstract.

Jiankang Yao
  ----- Original Message ----- 
  From: Glenn Parsons 
  To: [email-masked] ; [email-masked] 
  Sent: Monday, May 07, 2012 1:58 AM
  Subject: [apps-discuss] APPSDIR review of draft-ietf-eai-rfc5721bis-04

  Nits: 

------------------------------------------------------------------------------

  _______________________________________________
  apps-discuss mailing list
  [email-masked]
  https://www.ietf.org/mailman/listinfo/apps-discuss

---

From: Glenn Parsons <[email-masked]>
Date: Mon, 7 May 2012 21:16:39 -0400

On this point, I would think that consistency between draft-ietf-eai-rfc5721bis<http://tools.ietf.org/wg/eai/draft-ietf-eai-rfc5721bis/> and draft-ietf-eai-5738bis<http://tools.ietf.org/wg/eai/draft-ietf-eai-5738bis/> would be appropriate.

That is they should either both mention it in the abstract or not.  My suggestion, based on the Nit tool, was that they should mention it.

Cheers,
Glenn.

________________________________
From: Jiankang YAO [mailto:[email-masked]]
Sent: May-06-12 10:15 PM
To: Glenn Parsons; [email-masked]; [email-masked]
Subject: Re: [apps-discuss] APPSDIR review of draft-ietf-eai-rfc5721bis-04

Jiankang Yao
----- Original Message -----
From: Glenn Parsons<mailto:[email-masked]>
To: [email-masked]<mailto:[email-masked]> ; [email-masked]<mailto:[email-masked]>
Sent: Monday, May 07, 2012 1:58 AM
Subject: [apps-discuss] APPSDIR review of draft-ietf-eai-rfc5721bis-04

Nits:

________________________________

---

From: Ned Freed <[email-masked]>
Date: Mon, 07 May 2012 19:30:53 -0700 (PDT)

> On this point, I would think that consistency between
> draft-ietf-eai-rfc5721bis<http://tools.ietf.org/wg/eai/draft-ietf-eai-rfc5721bis/>
> and
> draft-ietf-eai-5738bis<http://tools.ietf.org/wg/eai/draft-ietf-eai-5738bis/>
> would be appropriate.

By that standard, they should not mention it, because RFCs 6530-6533 do not.
 
> That is they should either both mention it in the abstract or not.  My
> suggestion, based on the Nit tool, was that they should mention it.

Rather than following the advice from a piece of software, I suggest thinking
about the two purposes abstracts serve and whether or not such a sentence
actually makes sense for either one. My conclusion was that it doesn't.

				Ned