Subject: [apps-discuss] I-D Action: draft-jones-appsawg-webfinger-04.txt

From: [email-masked]
Date: Fri, 04 May 2012 05:40:25 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories. This draft is a work item of the Applications Area Working Group Working Group of the IETF.

	Title           : WebFinger
	Author(s)       : Paul E. Jones
                          Gonzalo Salgueiro
                          Joseph Smarr
	Filename        : draft-jones-appsawg-webfinger-04.txt
	Pages           : 21
	Date            : 2012-05-04

   This specification defines the WebFinger protocol.  WebFinger may be
   used to discover information about people on the Internet, such as a
   person's personal profile address, identity service, telephone
   number, or preferred avatar.  WebFinger may also be used to learn
   information about objects on the network, such as the amount of toner
   in a printer or the physical location of a server.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-jones-appsawg-webfinger-04.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

This Internet-Draft can be retrieved at:
ftp://ftp.ietf.org/internet-drafts/draft-jones-appsawg-webfinger-04.txt

The IETF datatracker page for this Internet-Draft is:
https://datatracker.ietf.org/doc/draft-jones-appsawg-webfinger/

---

From: Mike Jones <[email-masked]>
Date: Fri, 4 May 2012 14:08:39 +0000

Thanks for the new draft, Paul.

				-- Mike

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Friday, May 04, 2012 5:40 AM
To: [email-masked]
Cc: [email-masked]
Subject: [apps-discuss] I-D Action: draft-jones-appsawg-webfinger-04.txt

	Title           : WebFinger

_______________________________________________
apps-discuss mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/apps-discuss

---

From: Mike Jones <[email-masked]>
Date: Wed, 9 May 2012 17:15:50 +0000

I'd been asked in private threads whether I supported using draft-jones-appsawg-webfinger-04.txt as a starting point for discovery standardization.  Per my note below thanking Paul, yes, I do.

Here's a few of additional thoughts on next steps at this point...

Making the "resource" parameter required in webfinger -04 was a step in the right direction, as it enables single-GET queries for per-user values.  I appreciated Paul making that change.  I think the language could be clearer, especially the language about what is returned when "resource" is recognized but can't be processed (I assume the host-meta document), but that can be cleaned up.

It's not clear to me whether the acct: scheme definition belongs in the discovery document or a separate specification.  I'm OK having the working group decide that, but personally, I'd move it to a separate specification, as it is actually independent of discovery.

Paul had privately asked me whether I would be OK calling the result "Simple Web Discovery", since that's a better name than WebFinger.  I think I would be OK with that if all that's in the discovery draft is discovery - not also the orthogonal acct: scheme definition.

Anyway, I agree with Blaine and Paul and many others who've been part of this discussion on how important it is to have a ubiquitously agreed upon and adopted discovery mechanism for the open Web.  I believe that should be all of our goal in this work.  Hopefully that's exactly what we'll achieve.

				-- Mike

P.S.  As a historical note, for those of you who never experienced the original "finger" service, try "finger [email-masked]".  The CMU CS department is still running their finger service, sending people the contents of my .plan file to this day!

-----Original Message-----
From: Mike Jones 
Sent: Friday, May 04, 2012 7:09 AM
To: Paul E. Jones
Cc: [email-masked]
Subject: RE: [apps-discuss] I-D Action: draft-jones-appsawg-webfinger-04.txt

				-- Mike

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Friday, May 04, 2012 5:40 AM
To: [email-masked]
Cc: [email-masked]
Subject: [apps-discuss] I-D Action: draft-jones-appsawg-webfinger-04.txt

	Title           : WebFinger