Subject: Re: [apps-discuss] FYI: LCI -02

From: Julian Reschke <[email-masked]>
Date: Sat, 02 Jun 2012 12:59:27 +0200

On 2012-06-01 03:08, Mark Nottingham wrote:
> We've published an -02 draft of LCI:
>    <http://tools.ietf.org/html/draft-nottingham-linked-cache-inv-02>
>
> and intend to request publication as an Individual Submission Informational RFC soon (the link relations have just been submitted for review). Feedback still welcome (http list is best, I think).
> ...

HTTPbis introduces a registry for cache directives (see 
<http://greenbytes.de/tech/webdav/draft-ietf-httpbis-p6-cache-19.html#rfc.section.3.2.3>).

Would it make sense to change the dependency from RFC 2616 to HTTPbis, 
and to register as defined in Part 6?

Best regards, Julian

---

From: Mark Nottingham <[email-masked]>
Date: Mon, 4 Jun 2012 11:38:20 +1000

On 02/06/2012, at 8:59 PM, Julian Reschke wrote:

> HTTPbis introduces a registry for cache directives (see <http://greenbytes.de/tech/webdav/draft-ietf-httpbis-p6-cache-19.html#rfc.section.3.2.3>).
> 
> Would it make sense to change the dependency from RFC 2616 to HTTPbis, and to register as defined in Part 6?

I'm not against it, although it'd require reworking the BNF. I'll look into it.

Cheers,

--
Mark Nottingham   http://www.mnot.net/

---

From: Julian Reschke <[email-masked]>
Date: Mon, 04 Jun 2012 10:08:51 +0200

> and intend to request publication as an Individual Submission Informational RFC soon (the link relations have just been submitted for review). Feedback still welcome (http list is best, I think).

Here's another question: the proposal defines both a cache directive and 
link relations. Have you considered putting all the link-related 
information into a cache directive as well? (Not saying it should be the 
case but wondering whether that would keep things together that belong 
together).

Best regards, Julian

---

From: Mark Nottingham <[email-masked]>
Date: Mon, 4 Jun 2012 20:33:47 +1000

On 04/06/2012, at 6:08 PM, Julian Reschke wrote:

> Here's another question: the proposal defines both a cache directive and link relations. Have you considered putting all the link-related information into a cache directive as well? (Not saying it should be the case but wondering whether that would keep things together that belong together).

Yes. However, some use cases are to strip the link on the way out, and it's easier to strip all Link headers than to parse and selectively change Cache-Control headers. I know that theoretically other Link headers could be emitted, but with current software, this is the easier path.

Additionally, I didn't want to rely on the quality of Cache-Control parsers already out there.

Also, we didn't want to re-invent the Link header and all of its associated machinery (e.g., relative vs. absolute, scoping, etc.).

Finally, it's conceivable that some folks might want to use the relations for other purposes.

After all, they may be separate headers, but they'll be in the same message. 

Cheers,

---

From: "Poul-Henning Kamp" <[email-masked]>
Date: Mon, 04 Jun 2012 08:11:34 +0000

>case but wondering whether that would keep things together that belong 

I think that will wastly increase the chances that people understand
how to use it.

-- 
Poul-Henning Kamp       | UNIX since Zilog Zeus 3.20
[email-masked]         | TCP/IP since RFC 956
FreeBSD committer       | BSD since 4.3-tahoe    
Never attribute to malice what can adequately be explained by incompetence.