Subject: [apps-discuss] I-D Action: draft-jones-appsawg-webfinger-06.txt

From: [email-masked]
Date: Sun, 17 Jun 2012 22:09:25 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the Applications Area Working Group Working Group of the IETF.

	Title           : WebFinger
	Author(s)       : Paul E. Jones
                          Gonzalo Salgueiro
                          Joseph Smarr
	Filename        : draft-jones-appsawg-webfinger-06.txt
	Pages           : 24
	Date            : 2012-06-17

Abstract:
   This specification defines the WebFinger protocol.  WebFinger may be
   used to discover information about people on the Internet, such as a
   person's personal profile address, identity service, telephone
   number, or preferred avatar.  WebFinger may also be used to learn
   information about objects on the network, such as the amount of toner
   in a printer or the physical location of a server.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-jones-appsawg-webfinger

There's also a htmlized version available at:
http://tools.ietf.org/html/draft-jones-appsawg-webfinger-06

A diff from previous version is available at:
http://tools.ietf.org/rfcdiff?url2=draft-jones-appsawg-webfinger-06

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "Paul E. Jones" <[email-masked]>
Date: Mon, 18 Jun 2012 01:28:44 -0400

Folks,

I posted a new version of the WebFinger draft, taking into consideration
some of the feedback received, some of the off-line exchanges I've had with
Mike and few others, contributed text from Peter, etc.  I tried to capture
the significant changes in the change log at the end of the document.

Please have a look at this revised draft and we'll try to move it forward.

I have also sent a request to the email address specified for URI scheme
review to try to move registration of "acct" along.  I hope that will not
take long, and I would hope it would not considering the specific and narrow
scope of "acct".

Paul

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> On Behalf Of [email-masked]
> Sent: Monday, June 18, 2012 1:09 AM
> To: [email-masked]
> Cc: [email-masked]
> Subject: [apps-discuss] I-D Action: draft-jones-appsawg-webfinger-06.txt
> 
> 
> _______________________________________________
> apps-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/apps-discuss

---

From: Bjoern Hoehrmann <[email-masked]>
Date: Mon, 18 Jun 2012 07:51:54 +0200

>take long, and I would hope it would not considering the specific and narrow

http://www.ietf.org/mail-archive/web/uri-review/current/msg01605.html if
anyone wants to follow along.
-- 
Björn Höhrmann · mailto:[email-masked] · http://bjoern.hoehrmann.de
Am Badedeich 7 · Telefon: +49(0)160/4415681 · http://www.bjoernsworld.de
25899 Dagebüll · PGP Pub. KeyID: 0xA4357E78 · http://www.websitedev.de/

---

From: elf Pavlik <[email-masked]>
Date: Mon, 18 Jun 2012 07:57:13 +0000

Hi Paul,

> take long, and I would hope it would not considering the specific and narrow

We have discussed at some point strategy for marking in my XRD/JRD profile that I've *moved to* another webfinger address. Do I understand correctly that section: '7. The "acct" Link Relation' explains how we can do it?

I see it quite important that people can 'lightheaded' create accounts somewhere just to 'give it a try' than take more time to choose providers for their accounts, including using domain names they have control over, and than migrate leaving old webfinger just pointing to new one :)

Cheers!
~ elf Pavlik ~

---

From: "Paul E. Jones" <[email-masked]>
Date: Mon, 18 Jun 2012 11:13:53 -0400

Elf,

The intent is that the "acct" link relation would be a means of allowing one account to incorporate link relations from a different account URI.  So, let's suppose I have an account acct:[email-masked] and I also have an account that holds pictures on flickr.com.  Within my packetizer.com account, I could include a reference to my flickr.com account, like this:
  <Link rel="acct" href="acct:[email-masked]"/>

I could include the particular link relations that Flickr might advertise from within my packetizer.com account.  However, that requires me to ensure I keep those references up-to-date.  A reference like the above helps simplify my life.

I added two new paragraphs following the first paragraph in that section to make it clearer in the -07 draft:

===
7.1. Purpose for the “acct” Link Relation

Users of some services might have an “acct” URI that looks significantly different from his or her email address, perhaps using an entirely different domain name.  It is also possible for a user have multiple accounts that a user wants to advertise and that a WebFinger client may want to query.  To address both of these needs, this specification defines the “acct” link relation.

The "acct" link relation allows a WebFinger server to reference one or more other user account URIs from within a user account.  The "acct" link relation is intended to allow a client to incorporate additional link relations by reference to produce a complete set of link relations for a user.  Any newly discovered link relations found by querying the referenced account should be merged into the resource descriptor document at the point where the "acct" link relation was inserted.

Note that the "acct" link relation does not replace the use of standard HTTP 3xx response codes to indicate the new temporary or permanent location of a user account.  If a user account is moved to a different location, then a 3xx response code SHOULD be used.

...
===

Do those additional paragraphs help?

As for creating accounts here and there just to give WebFinger a try, I would hope users don't try to hold on to those.  That would be messy for a computer or human to deal with. :-)

Paul

> From: elf Pavlik [mailto:[email-masked]]
> Sent: Monday, June 18, 2012 3:57 AM
> To: Paul E. Jones
> Cc: apps-discuss
> Subject: Re: [apps-discuss] FW: I-D Action: draft-jones-appsawg-webfinger-
> 06.txt
> 
> Hi Paul,
> 
> > I posted a new version of the WebFinger draft, taking into
> > consideration some of the feedback received, some of the off-line
> > exchanges I've had with Mike and few others, contributed text from
> > Peter, etc.  I tried to capture the significant changes in the change
> log at the end of the document.
> >
> > I have also sent a request to the email address specified for URI
> > scheme review to try to move registration of "acct" along.  I hope
> > that will not take long, and I would hope it would not considering the
> > specific and narrow scope of "acct".
> >
> > Paul
> 
> We have discussed at some point strategy for marking in my XRD/JRD profile
> that I've *moved to* another webfinger address. Do I understand correctly
> that section: '7. The "acct" Link Relation' explains how we can do it?
> 
> I see it quite important that people can 'lightheaded' create accounts
> somewhere just to 'give it a try' than take more time to choose providers
> for their accounts, including using domain names they have control over,
> and than migrate leaving old webfinger just pointing to new one :)
> 
> Cheers!
> ~ elf Pavlik ~

---

From: elf Pavlik <[email-masked]>
Date: Mon, 18 Jun 2012 16:04:48 +0000

Hi Paul,

> Do those additional paragraphs help?

That helped me with clarifying it, thank you!
:)
~ elf Pavlik ~