Subject: Re: [apps-discuss] The acct: scheme question

From: Melvin Carvalho <[email-masked]>
Date: Tue, 26 Jun 2012 14:06:20 +0200

On 22 May 2012 09:22, Murray S. Kucherawy <[email-masked]> wrote:

>  As we prepare to bring webfinger into appsawg, it looks a lot like
> there’s substantial discussion just on the point of the proposed “acct:”
> scheme.****
>
> ** **
>
> So, a question for those tracking the discussion:  Is this a big enough
> topic that it should be split into its own document?  This would be a
> useful thing to decide as we figure out how to handle the work once it
> enters working group mode.****
>
> ** **
>
> (This by itself has me wondering if we should revisit the conversation
> about whether webfinger needs its own working group, but I’ll leave it to
> Barry and Pete to make that call.)
>

There has been some discussion of this here and on other lists, and the
consensus I think is for people to follow the process at :

<[email-masked]>.

I think the current state of play is that webfinger can be used with any
URI type e.g. mailto: http: acct: etc. acct: is recommended in the RFC.

****
>
> ** **
>
> -MSK****
>
> _______________________________________________
> apps-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/apps-discuss
>
>

---

From: Mike Jones <[email-masked]>
Date: Tue, 26 Jun 2012 13:20:16 +0000

Yes, I believe that the acct: scheme should be considered separately from discovery, in its own document.

                                                            -- Mike

From: [email-masked] [mailto:[email-masked]] On Behalf Of Melvin Carvalho
Sent: Tuesday, June 26, 2012 5:06 AM
To: Murray S. Kucherawy
Cc: [email-masked]
Subject: Re: [apps-discuss] The acct: scheme question

On 22 May 2012 09:22, Murray S. Kucherawy <[email-masked]<mailto:[email-masked]>> wrote:
As we prepare to bring webfinger into appsawg, it looks a lot like there's substantial discussion just on the point of the proposed "acct:" scheme.

So, a question for those tracking the discussion:  Is this a big enough topic that it should be split into its own document?  This would be a useful thing to decide as we figure out how to handle the work once it enters working group mode.

(This by itself has me wondering if we should revisit the conversation about whether webfinger needs its own working group, but I'll leave it to Barry and Pete to make that call.)

There has been some discussion of this here and on other lists, and the consensus I think is for people to follow the process at :

<[email-masked]<mailto:[email-masked]>>.

I think the current state of play is that webfinger can be used with any URI type e.g. mailto: http: acct: etc. acct: is recommended in the RFC.

-MSK

_______________________________________________
apps-discuss mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/apps-discuss

---

From: Peter Saint-Andre <[email-masked]>
Date: Tue, 26 Jun 2012 07:58:17 -0600

> from discovery, in its own document.

Personally I have no strong preference, although given that the relevant
sections of draft-jones-appsawg-webfinger-06 take up about a page, it
will be quite a brief specification. :)

http://tools.ietf.org/html/draft-jones-appsawg-webfinger-06#section-6
http://tools.ietf.org/html/draft-jones-appsawg-webfinger-06#section-12.1

Do folks think that the 'acct' link relation would belong in the
webfinger spec, in the 'acct' URI spec, or in a separate spec?

Peter

-- 
Peter Saint-Andre
https://stpeter.im/

---

From: Bob Wyman <[email-masked]>
Date: Tue, 26 Jun 2012 10:36:35 -0400

I would leave acct: link relation in the WebFinger spec.

I can see no utility in breaking it out. Nothing but additional process
overhead and more fragmentation of the specs will result from breaking it
out.

bob wyman

---

From: John Bradley <[email-masked]>
Date: Tue, 26 Jun 2012 10:37:59 -0400

I think it is better to have it in a separate spec.

The current spec requires normalization of bare identifiers i.e. [email-masked] to acct:[email-masked].
That would also need to change if we separate the specs.

John B.

---

From: Peter Saint-Andre <[email-masked]>
Date: Tue, 26 Jun 2012 08:40:20 -0600

> That would also need to change if we separate the specs.

In what way would it need to change?

Peter

-- 
Peter Saint-Andre
https://stpeter.im/

---

From: John Bradley <[email-masked]>
Date: Tue, 26 Jun 2012 10:43:05 -0400

I would change the account link relation to use the http: scheme.  acct: is unnecessary for the link relation, other link relations don't require a new scheme.

That is one of the biggest things people will object to about acct:

Yes if acct: is registered it looks nicer I will give you that.

John B.

On 2012-06-26, at 10:36 AM, Bob Wyman wrote:

> I can see no utility in breaking it out. Nothing but additional process overhead and more fragmentation of the specs will result from breaking it out.
> 
> bob wyman
> 
> On Tue, Jun 26, 2012 at 9:58 AM, Peter Saint-Andre <[email-masked]> wrote:

---

From: William Mills <[email-masked]>
Date: Tue, 26 Jun 2012 08:07:07 -0700 (PDT)

Is there any advantage to breaking it out?  The WF draft depends on it and so can't finalize until acct: does, right?

Will one get done more quickly than the other?

>________________________________
> From: Mike Jones <[email-masked]>
>To: Melvin Carvalho <[email-masked]>; Murray S. Kucherawy <[email-masked]> 
>Cc: "[email-masked]" <[email-masked]> 
>Sent: Tuesday, June 26, 2012 6:20 AM
>From:[email-masked] [mailto:[email-masked]] On Behalf Of Melvin Carvalho
>As we prepare to bring webfinger into appsawg, it looks a lot like there’s substantial discussion just on the point of the proposed “acct:” scheme.
> 
>(This by itself has me wondering if we should revisit the conversation about whether webfinger needs its own working group, but I’ll leave it to Barry and Pete to make that call.)
>

---

From: John Bradley <[email-masked]>
Date: Tue, 26 Jun 2012 11:11:48 -0400

The "resource" parameter is currently a fully qualified URI, and that is normalized to acct:

The template paramater {uri} also precludes relative URI as near as I can tell.

Perhaps Paul can correct me,  but I think that the request.

GET /.well-known/host-meta.json?resource=[email-masked] HTTP/1.1
Host: bar.com

Is not allowed by the spec, or be interoperable.    The goal of SWD was to make the above (slightly different syntax same idea) work.

There are a lot of places in the spec where the acct: uri and normalizing things to it are baked in.

There are likely also issues with host-meta as that is where the template is defined.

Paul's likely reaction will be that separating them is not trivial, and he may be correct in that.

On the other hand it is probably the right thing to do, even if it touches a bunch of things.

John B.

---

From: Mike Jones <[email-masked]>
Date: Tue, 26 Jun 2012 15:17:34 +0000

Yes, there’s a significant advantage.  It allows the acct: scheme to be approved (or rejected) quickly so that we will know whether it is safe for WebFinger and other specifications to use it.  That approval/rejection can then happen in parallel with refining the discovery specification.

Otherwise, we could be in a position where we think we have a final discovery specification, only to learn that it can’t go forward because of objections to the acct: scheme from the W3C and possibly others.  It would be much better for us to know whether that is the case up front.

                                                            -- Mike

From: William Mills [mailto:[email-masked]]
Sent: Tuesday, June 26, 2012 8:07 AM
To: Mike Jones; Melvin Carvalho; Murray S. Kucherawy
Cc: [email-masked]
Subject: Re: [apps-discuss] The acct: scheme question

________________________________
From: Mike Jones <[email-masked]<mailto:[email-masked]>>
To: Melvin Carvalho <[email-masked]<mailto:[email-masked]>>; Murray S. Kucherawy <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Sent: Tuesday, June 26, 2012 6:20 AM
Subject: Re: [apps-discuss] The acct: scheme question

                                                            -- Mike

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]]<mailto:[mailto:[email-masked]]> On Behalf Of Melvin Carvalho
Sent: Tuesday, June 26, 2012 5:06 AM
To: Murray S. Kucherawy
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [apps-discuss] The acct: scheme question

-MSK

---

From: [email-masked] (Henry S. Thompson)
Date: Tue, 26 Jun 2012 16:51:36 +0100

> from discovery, in its own document.

Yes, please.  Discussion on [email-masked] will be much more
focussed and appropriate given a specific self-contained uri-scheme
proposal to consider.  I for one have been standing back from this
discussion lately because I can no longer tell exactly what is part of
the acct: scheme and what isn't -- a separate document will, I hope,
clarify that.

ht
-- 
       Henry S. Thompson, School of Informatics, University of Edinburgh
      10 Crichton Street, Edinburgh EH8 9AB, SCOTLAND -- (44) 131 650-4440
                Fax: (44) 131 650-4587, e-mail: [email-masked]
                       URL: http://www.ltg.ed.ac.uk/~ht/
 [mail from me _always_ has a .sig like this -- mail without it is forged spam]

---

From: William Mills <[email-masked]>
Date: Tue, 26 Jun 2012 13:06:41 -0700 (PDT)

I note that Paul's message there dated June 15th has generated no traffic in reply yet.

> From: Henry S. Thompson <[email-masked]>
>To: Mike Jones <[email-masked]> 
>Cc: "[email-masked]" <[email-masked]>; Murray S. Kucherawy <[email-masked]> 
>Sent: Tuesday, June 26, 2012 8:51 AM

---

From: "Martin J. Dürst" <[email-masked]>
Date: Wed, 27 Jun 2012 10:48:39 +0900

On 2012/06/26 21:06, Melvin Carvalho wrote:
> On 22 May 2012 09:22, Murray S. Kucherawy<[email-masked]>  wrote:
>

Others have pointed out that it's only a page or two. In my opinion, 
that would strongly suggest a single document.

> consensus I think is for people to follow the process at :

Warning: procedural nitpicking ahead!

I think we should be careful about this. [email-masked] is for 
review of URI/IRI schemes in general. This has a rather low barrier. The 
fact that it gets approved there doesn't mean that it will pass through 
the IETF standardization process. On the other hand, if the IETF 
standardizes it, it has the possibility of overriding the decision on 
[email-masked] if that should be necessary.
I'm just mentioning this here because we have been through this for 
another URI scheme.

So I think the correct use of mailing lists would be:

[email-masked]: (or a dedicated WG if that gets created) General 
discussion of scheme, working towards IETF standardization.

[email-masked]: Comments from URI/IRI experts, check of basic 
criteria for registrability, ...

[email-masked] (the mailing list of the IETF IRI WG): General 
discussion about registration criteria for new IRI schemes, for RFC 4395bis.

[email-masked] (I'm just mentioning this list because that's where the most 
discussion so far has taken place): General discussion as it relates to 
Web architecture.

Regards,    Martin.

---

From: SM <[email-masked]>
Date: Tue, 26 Jun 2012 23:06:54 -0700

Hi Martin,
At 18:48 26-06-2012, Martin J. Dürst wrote:
>I think we should be careful about this. 
>[email-masked] is for review of URI/IRI 
>schemes in general. This has a rather low 
>barrier. The fact that it gets approved there 
>doesn't mean that it will pass through the IETF 
>standardization process. On the other hand, if 
>the IETF standardizes it, it has the possibility 
>of overriding the decision on [email-masked] if that should be necessary.
>I'm just mentioning this here because we have 
>been through this for another URI scheme.

I don't like the idea of mixing registration 
criteria and the standardization process.  The 
authors of the other URI scheme were nice not to 
turn such a matter into an issue.  This is the 
sort of issue which generate controversies.  It 
will be detrimental to the IETF as people will walk away.

Regards,
-sm

---

From: "Martin J. Dürst" <[email-masked]>
Date: Wed, 27 Jun 2012 16:43:10 +0900

Hello SM,

On 2012/06/27 15:06, SM wrote:
>> review of URI/IRI schemes in general. This has a rather low barrier.
>> The fact that it gets approved there doesn't mean that it will pass
>> through the IETF standardization process. On the other hand, if the
>> IETF standardizes it, it has the possibility of overriding the
>> decision on [email-masked] if that should be necessary.
> I don't like the idea of mixing registration criteria and the
> standardization process. The authors of the other URI scheme were nice
> not to turn such a matter into an issue. This is the sort of issue which
> generate controversies. It will be detrimental to the IETF as people
> will walk away.

I can't disagree with what you say, but I'm not sure whether you agree 
or disagree with what I said. Can you clarify?

Regards,    Martin.

---

From: SM <[email-masked]>
Date: Wed, 27 Jun 2012 01:56:27 -0700

Hi Martin,
At 00:43 27-06-2012, Martin J. Dürst wrote:
>I can't disagree with what you say, but I'm not 
>sure whether you agree or disagree with what I said. Can you clarify?

I think that what you said makes sense.  I don't 
like the override as it is difficult to explain 
that to someone who views Expert review as a 
barrier he or she should not jump over twice.

Regards,
-sm

---

From: Melvin Carvalho <[email-masked]>
Date: Wed, 27 Jun 2012 12:18:14 +0200

On 27 June 2012 03:48, "Martin J. Dürst" <[email-masked]> wrote:

> Others have pointed out that it's only a page or two. In my opinion, that
> would strongly suggest a single document.

I agree with others that it would be good for acct: to have its own
document.

Webfinger describes itself as scheme "agnostic" which I think is the right
way to be.

This also means that both acct: and webfinger can be evaluated, and further
developed, on their own merits.

> fact that it gets approved there doesn't mean that it will pass through the
> IETF standardization process. On the other hand, if the IETF standardizes
> it, it has the possibility of overriding the decision on
> discussion so far has taken place): General discussion as it relates to Web
> architecture.
>
> Regards,    Martin.
>

---

From: Graham Klyne <[email-masked]>
Date: Wed, 27 Jun 2012 17:10:08 +0100

On 27/06/2012 07:06, SM wrote:
>> I think we should be careful about this. [email-masked] is for review of
>> URI/IRI schemes in general. This has a rather low barrier. The fact that it
>> gets approved there doesn't mean that it will pass through the IETF
>> standardization process. On the other hand, if the IETF standardizes it, it
>> has the possibility of overriding the decision on [email-masked] if that
>> should be necessary.
>> I'm just mentioning this here because we have been through this for another
>> URI scheme.
>
> I don't like the idea of mixing registration criteria and the standardization
> process. The authors of the other URI scheme were nice not to turn such a matter
> into an issue. This is the sort of issue which generate controversies. It will
> be detrimental to the IETF as people will walk away.

FWIW, as URI scheme reviewer, I would generally regard achieving standards-track 
status as demonstrating satisfaction of criteria for permanent registration. 
It's one of the strongest expressions of community consensus that I know of.

As far as I'm aware, the URI-review list doesn't make decisions, but it does 
provide a pool of comments that can help to indicate the level of consensus for 
a proposal, and highlight if there are any potential problems that need to be 
addressed.  Considering the role of the reviewer as more concierge than 
gatekeeper, this helps me to make hopefully constructive comments to a submitter.

#g
--

---

From: William Mills <[email-masked]>
Date: Wed, 27 Jun 2012 10:27:10 -0700 (PDT)

Based on the comments to date is there consensus for a path forward?  Will we leave acct: in the WF draft or split it out?  

If we're splitting it do we have someone stepping up to author the new draft?

Thanks,

-bill

---

From: "Paul E. Jones" <[email-masked]>
Date: Wed, 27 Jun 2012 16:32:04 -0400

No, no. I think overloading http is a bad idea.

http has a very well-defined purpose in life.  Yes, we could do this:

http://packetizer.com/acct/ <http://packetizer.com/acct/%3cuser_id>
<user_id>

But, that steps on the namespace of domain owners.  I do not think it would
be good practice for RFCs to dictate to domain owners how to use their
namespace.

We need something predictable and simple. acct:[email-masked] is
precisely that.

Paul

From: [email-masked] [mailto:[email-masked]]
On Behalf Of John Bradley
Sent: Tuesday, June 26, 2012 10:43 AM
To: Bob Wyman
Cc: [email-masked]; Murray S. Kucherawy
Subject: Re: [apps-discuss] The acct: scheme question

I would change the account link relation to use the http: scheme.  acct: is
unnecessary for the link relation, other link relations don't require a new
scheme.

 

John B.

bob wyman

On Tue, Jun 26, 2012 at 9:58 AM, Peter Saint-Andre <[email-masked]>
wrote:

Peter

--
Peter Saint-Andre
https://stpeter.im/

---

From: "Paul E. Jones" <[email-masked]>
Date: Wed, 27 Jun 2012 16:39:24 -0400

John,

That's correct, but not a function of the WebFinger draft, but one of RFC
6415.  The URI template accepts URIs, not bits and pieces of URIs.

We had discussed long ago to use only "[email-masked]", for example,
but the group decided to use URIs and "acct" was the preferred URI scheme to
refer to user accounts.

What I've been doing was trying to document the agreements various folks had
reached on WebFinger.  Don't shoot the messenger.  That said, I don't see a
good reason to backtrack at this point.  The "acct" URI scheme is out in the
wild, its use has a limited scope and specific purpose, etc.

If we were to separate them, we would have the question thrust upon us of
"what URI scheme do I use to refer to paulej's Twitter account?"  It's not
mailto.  It should not be http.  I do agree with the group who reached the
consensus before that "acct" is a reasonable way forward.  Nobody was in
love with "acct", but nothing else worked better.

Paul

Sent: Tuesday, June 26, 2012 11:12 AM
To: Peter Saint-Andre

The "resource" parameter is currently a fully qualified URI, and that is
normalized to acct:

The template paramater {uri} also precludes relative URI as near as I can
tell.

Is not allowed by the spec, or be interoperable.    The goal of SWD was to
make the above (slightly different syntax same idea) work.

There are a lot of places in the spec where the acct: uri and normalizing
things to it are baked in.

There are likely also issues with host-meta as that is where the template is
defined.

Paul's likely reaction will be that separating them is not trivial, and he
may be correct in that.

On the other hand it is probably the right thing to do, even if it touches a
bunch of things.

John B.

The current spec requires normalization of bare identifiers i.e. [email-masked]
to acct:[email-masked].

Peter

-- 
Peter Saint-Andre
https://stpeter.im/

---

From: "Paul E. Jones" <[email-masked]>
Date: Wed, 27 Jun 2012 16:43:14 -0400

I submitted a query to the uri-review list on June 18. So far, there have been no comments on the list.

I do not see a reason why the URI review could not be concluded fairly quickly regardless of where it is documented.

Now, should the URI review process result in rejecting “acct” then we have to scramble to come up with an alternative.  It cannot simply be left to speculation.  We need a concrete and predictable way of constructing URIs that refer to user accounts.  How do I query a Twitter user’s account?  Flickr? Google+?  (Don’t get me started about the Facebook deciding their email address was my preferred email address...)

Paul

From: [email-masked] [mailto:[email-masked]] On Behalf Of Mike Jones
Sent: Tuesday, June 26, 2012 11:18 AM
To: William Mills; Melvin Carvalho; Murray S. Kucherawy
Cc: [email-masked]
Subject: Re: [apps-discuss] The acct: scheme question

                                                            -- Mike

  _____  

                                                            -- Mike

 

<[email-masked]>.

-MSK

---

From: Mike Jones <[email-masked]>
Date: Wed, 27 Jun 2012 20:44:28 +0000

If we separate them, the WebFinger draft would continue to have a normative dependency on the Acct draft.  But practically then the Acct draft could go up for working group last call and then IETF last call essentially immediately after the draft is produced and we'd get a clear up/down standards decision sooner, rather than later.

If you don't have the time to be editor for that draft, I'm willing to do so.  It won't take more than a few hours to tease apart.

                                                                -- Mike

From: [email-masked] [mailto:[email-masked]] On Behalf Of Paul E. Jones
Sent: Wednesday, June 27, 2012 1:39 PM
To: 'John Bradley'; 'Peter Saint-Andre'
Cc: [email-masked]; 'Murray S. Kucherawy'
Subject: Re: [apps-discuss] The acct: scheme question

John,

That's correct, but not a function of the WebFinger draft, but one of RFC 6415.  The URI template accepts URIs, not bits and pieces of URIs.

We had discussed long ago to use only "[email-masked]<mailto:[email-masked]>", for example, but the group decided to use URIs and "acct" was the preferred URI scheme to refer to user accounts.

What I've been doing was trying to document the agreements various folks had reached on WebFinger.  Don't shoot the messenger.  That said, I don't see a good reason to backtrack at this point.  The "acct" URI scheme is out in the wild, its use has a limited scope and specific purpose, etc.

If we were to separate them, we would have the question thrust upon us of "what URI scheme do I use to refer to paulej's Twitter account?"  It's not mailto.  It should not be http.  I do agree with the group who reached the consensus before that "acct" is a reasonable way forward.  Nobody was in love with "acct", but nothing else worked better.

Paul

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]]<mailto:[mailto:[email-masked]]> On Behalf Of John Bradley
Sent: Tuesday, June 26, 2012 11:12 AM
To: Peter Saint-Andre
Cc: [email-masked]<mailto:[email-masked]>; Murray S. Kucherawy
Subject: Re: [apps-discuss] The acct: scheme question

GET /.well-known/host-meta.json?resource=[email-masked]<mailto:resource=[email-masked]> HTTP/1.1

Host: bar.com<http://bar.com>

John B.

The current spec requires normalization of bare identifiers i.e. [email-masked]<mailto:[email-masked]> to acct:[email-masked].
That would also need to change if we separate the specs.

Peter

--
Peter Saint-Andre
https://stpeter.im/

---

From: "Paul E. Jones" <[email-masked]>
Date: Wed, 27 Jun 2012 17:49:48 -0400

Bill,

I'd say there is a division right down the middle.  It's not clear if there
are more in favor of keeping it there or moving it to a separate document.
However, there is not an overwhelming number on one side.

Moving it to a separate document should not be necessary.  We can publish
the WF RFC with the "acct" URI scheme and work to get URI reviewer approval
in parallel.  Is URI reviewer approval required first?  I don't think so.
Graham suggested that having it agreed in a standards-track RFC carries a
lot of weight.

It seems that those who want to separate it are mostly concerned that it
will delay the RFC publication.  That does not appear to be an issue at all.

Paul

From: [email-masked] [mailto:[email-masked]]
On Behalf Of William Mills
Sent: Wednesday, June 27, 2012 1:27 PM
To: Graham Klyne; SM
Cc: [email-masked]
Subject: Re: [apps-discuss] The acct: scheme question

Based on the comments to date is there consensus for a path forward?  Will
we leave acct: in the WF draft or split it out?  

If we're splitting it do we have someone stepping up to author the new
draft?

Thanks,

-bill

---

From: Mike Jones <[email-masked]>
Date: Wed, 27 Jun 2012 21:53:58 +0000

At least based upon my experience with the OAuth Core and OAuth Bearer specs, until IESG/IETF last call, a lot of the IESG members don't raise issues, and then they're often raised as DISCUSS issues, which block publication until resolved.  Sometimes these DISCUSS issues also call for cross-organizational review with the W3C.

Until the acct: URI is actually in a spec in IESG/IETF last call, my experience says that we really won't know where we stand.  Hence me wanting to get us there as soon after Vancouver as possible.

                                                                -- Mike

From: [email-masked] [mailto:[email-masked]] On Behalf Of Paul E. Jones
Sent: Wednesday, June 27, 2012 2:50 PM
To: 'William Mills'; 'Graham Klyne'; 'SM'
Cc: [email-masked]
Subject: Re: [apps-discuss] The acct: scheme question

Bill,

I'd say there is a division right down the middle.  It's not clear if there are more in favor of keeping it there or moving it to a separate document.  However, there is not an overwhelming number on one side.

Moving it to a separate document should not be necessary.  We can publish the WF RFC with the "acct" URI scheme and work to get URI reviewer approval in parallel.  Is URI reviewer approval required first?  I don't think so.  Graham suggested that having it agreed in a standards-track RFC carries a lot of weight.

It seems that those who want to separate it are mostly concerned that it will delay the RFC publication.  That does not appear to be an issue at all.

Paul

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]]<mailto:[mailto:[email-masked]]> On Behalf Of William Mills
Sent: Wednesday, June 27, 2012 1:27 PM
To: Graham Klyne; SM
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [apps-discuss] The acct: scheme question

Thanks,

-bill

---

From: "Paul E. Jones" <[email-masked]>
Date: Wed, 27 Jun 2012 17:56:06 -0400

Mike,

I would still like to at least try to keep these together.  The "acct" URI
is a WebFinger URI, so I think it's best to keep them together.  It does not
seem that approval of the RFC is contingent on the approval of the URI
scheme.  It could be registered provisionally at first.  But, I think it
would be approved given that it is already in use and the fact that folks
agree to go forward with the document.

If folks are absolutely opposed to the URI scheme and wish to hold up
WebFinger over it, then we could consider splitting it.  I don't hear that,
though.  I think folks see the value.  The only concern is whether approval
of the URI scheme might hold up approval of the RFC.  That does not seem to
be a problem, but perhaps I'm wrong.

In any case, I'd prefer to split it out only if we absolutely had to.

Paul

From: Mike Jones [mailto:[email-masked]] 
Sent: Wednesday, June 27, 2012 4:44 PM
To: Paul E. Jones; 'John Bradley'; 'Peter Saint-Andre'
Cc: [email-masked]; 'Murray S. Kucherawy'
Subject: RE: [apps-discuss] The acct: scheme question

If we separate them, the WebFinger draft would continue to have a normative
dependency on the Acct draft.  But practically then the Acct draft could go
up for working group last call and then IETF last call essentially
immediately after the draft is produced and we'd get a clear up/down
standards decision sooner, rather than later.

If you don't have the time to be editor for that draft, I'm willing to do
so.  It won't take more than a few hours to tease apart.

                                                                -- Mike

On Behalf Of Paul E. Jones

John,

Paul

John B.

Peter

-- 
Peter Saint-Andre
https://stpeter.im/

---

From: "Paul E. Jones" <[email-masked]>
Date: Wed, 27 Jun 2012 18:02:25 -0400

Who in the IESG might raise a concern?  We should talk.

So far, it seems like folks are happy in broad terms, but only concerned
about the unknown.  Worrying does not help us.  Let's get whomever we need
involved right now.

Paul

From: Mike Jones [mailto:[email-masked]] 
Sent: Wednesday, June 27, 2012 5:54 PM
To: Paul E. Jones; 'William Mills'; 'Graham Klyne'; 'SM'
Cc: [email-masked]
Subject: RE: [apps-discuss] The acct: scheme question

At least based upon my experience with the OAuth Core and OAuth Bearer
specs, until IESG/IETF last call, a lot of the IESG members don't raise
issues, and then they're often raised as DISCUSS issues, which block
publication until resolved.  Sometimes these DISCUSS issues also call for
cross-organizational review with the W3C.

Until the acct: URI is actually in a spec in IESG/IETF last call, my
experience says that we really won't know where we stand.  Hence me wanting
to get us there as soon after Vancouver as possible.

                                                                -- Mike

Bill,

Paul

Thanks,

-bill

---

From: John Bradley <[email-masked]>
Date: Wed, 27 Jun 2012 18:13:27 -0400

It is the W3C TAG that is the most likely to raise a blocking objection.   

John B. 

Sent from my iPhone

On 2012-06-27, at 6:02 PM, "Paul E. Jones" <[email-masked]> wrote:

> So far, it seems like folks are happy in broad terms, but only concerned about the unknown.  Worrying does not help us.  Let’s get whomever we need involved right now.
>  
> Paul
>  
> At least based upon my experience with the OAuth Core and OAuth Bearer specs, until IESG/IETF last call, a lot of the IESG members don’t raise issues, and then they’re often raised as DISCUSS issues, which block publication until resolved.  Sometimes these DISCUSS issues also call for cross-organizational review with the W3C.
>  
> Until the acct: URI is actually in a spec in IESG/IETF last call, my experience says that we really won’t know where we stand.  Hence me wanting to get us there as soon after Vancouver as possible.
>  
>                                                                 -- Mike
>  
> I’d say there is a division right down the middle.  It’s not clear if there are more in favor of keeping it there or moving it to a separate document.  However, there is not an overwhelming number on one side.
>  
> Moving it to a separate document should not be necessary.  We can publish the WF RFC with the “acct” URI scheme and work to get URI reviewer approval in parallel.  Is URI reviewer approval required first?  I don’t think so.  Graham suggested that having it agreed in a standards-track RFC carries a lot of weight.
>  
> From: [email-masked] [mailto:[email-masked]] On Behalf Of William Mills

---

From: Peter Saint-Andre <[email-masked]>
Date: Wed, 27 Jun 2012 16:16:17 -0600

> It is the W3C TAG that is the most likely to raise a blocking objection.   

Folks, we're into pure speculation here.

In any case, the W3C TAG has no role in the IETF Standards Process. If
individuals who currently serve on the W3C TAG wish to raise concerns
during IETF Last Call, they are free to do so.

Peter

-- 
Peter Saint-Andre
https://stpeter.im/

---

From: SM <[email-masked]>
Date: Wed, 27 Jun 2012 16:50:44 -0700

Hi Paul,
At 14:49 27-06-2012, Paul E. Jones wrote:
>Moving it to a separate document should not be necessary.  We can 
>publish the WF RFC with the "acct" URI scheme and work to get URI 
>reviewer approval in parallel.  Is URI reviewer approval required 
>first?  I don't think so.  Graham suggested that having it agreed in 
>a standards-track RFC carries a lot of weight.

If the draft is on-track as an IETF RFC, the URI review should not be 
a problem.  Graham already suggested the easy path.  If you completed 
the steps to request a URI review, it's not worth worrying about that 
if the draft is making progress.

A DISCUSS from the an IESG member is not the end of the world.  It's 
merely a question which can be answered with a little effort.  The 
ADs actually ask questions which we all know should be answered.  We 
prefer to hand-wave them though. :-)

If an author get a few good reviews for a draft, the last stages are 
easier.  If an author only wants reviews from people who will agree 
with him/her, the last stages can seem like an unsurmountable effort.

Regards,
-sm

---

From: Bjoern Hoehrmann <[email-masked]>
Date: Thu, 28 Jun 2012 02:37:45 +0200

>if the draft is making progress.

I believe for proposals in Standards Track documents, as is the case
here, the process consists of asking for review on the uri-review list
and addressing any feedback there. Anything else, like asking the ex-
pert reviewer whether they approve or coordinating IANA registration,
would be done by the IESG or otherwise happen automatically after the
IESG is asked to consider the document for publication. A request for
review has been posted to the uri-review list, so if there is anything
else Paul has to initiate, could you spell that out?
-- 
Björn Höhrmann · mailto:[email-masked] · http://bjoern.hoehrmann.de
Am Badedeich 7 · Telefon: +49(0)160/4415681 · http://www.bjoernsworld.de
25899 Dagebüll · PGP Pub. KeyID: 0xA4357E78 · http://www.websitedev.de/

---

From: SM <[email-masked]>
Date: Wed, 27 Jun 2012 18:22:13 -0700

Hi Bjoern,
>and addressing any feedback there. Anything else, like asking the ex-

Graham commented on that in a message at 
http://www.ietf.org/mail-archive/web/apps-discuss/current/msg06377.html

>IESG is asked to consider the document for publication. A request for

IANA asks some administrative questions about the registration 
request.  The document shepherd responds.  Sometimes the author or 
the WG Chair takes up the task.  This is usually during the IESG 
Evaluation stage.

>else Paul has to initiate, could you spell that out?

He has done what BCP 35 requests the registrant to do.  As there 
weren't any comments, there's no problem to be solved.  BTW, you know 
about URI reviews better than me. :-)

Regards,
-sm

---

From: Melvin Carvalho <[email-masked]>
Date: Thu, 28 Jun 2012 09:28:34 +0200

On 27 June 2012 22:43, Paul E. Jones <[email-masked]> wrote:

> I submitted a query to the uri-review list on June 18. So far, there have
> been no comments on the list.****
>
> ** **
>
> I do not see a reason why the URI review could not be concluded fairly
> quickly regardless of where it is documented.****
>
> ** **
>
> Now, should the URI review process result in rejecting “acct” then we have
> to scramble to come up with an alternative.  It cannot simply be left to
> speculation.  We need a concrete and predictable way of constructing URIs
> that refer to user accounts.  How do I query a Twitter user’s account?
> Flickr? Google+?  (Don’t get me started about the Facebook deciding their
> email address was my preferred email address...)
>

Should acct: be rejected, we can simply use mailto: as per SWD.  Similarly
you could simply use ?acct=user@host as has been suggested.  This would
possibly be an improvement in any case.  acct: is a 'nice to have' but not
necessary for a discovery protocol, imho.  It's a slight weakness of XRD
that it doesnt have a query language (like SPARQL) that makes things more
challenging.  Perhaps one day it will have.  Nevertheless, SWD has proven
that the problem CAN be solved without a new uri scheme.

Twitter, Facebook, Flikr and Google Plus all use HTTP URIs to describe
their user accounts.  This is best practice on the web, and recommended in
Linked Data Principles [1] which is the dominant discovery mechanism on the
Web today.  The gap in linked data, which I hope Webfinger can address, is
a common discovery pattern (using well-known locations) for email
addresses.  If Twitter or Facebook and others have not asked for yet
another way to identify users, I am unsure why this use case is in scope.
Do note that Facebook already have a first class discovery system in the
Open Graph Protocol.

I believe they say in the IETF, "A spec is not finished when there's
nothing left to put in, a spec is finished when there's nothing left to
take out."  If acct: was rejected or removed, I think we have a ways to
fallback, in fact, I think WebFinger would be a stronger specification for
it.

[1] http://www.w3.org/DesignIssues/LinkedData.html

> ****
>
> ** **
>
> Paul****
>
> ** **
>
> *From:* [email-masked] [mailto:
> [email-masked]] *On Behalf Of *Mike Jones
> *Sent:* Tuesday, June 26, 2012 11:18 AM
> *To:* William Mills; Melvin Carvalho; Murray S. Kucherawy
>
> *Cc:* [email-masked]
> *Subject:* Re: [apps-discuss] The acct: scheme question****
>
> ** **
>
> Yes, there’s a significant advantage.  It allows the acct: scheme to be
> approved (or rejected) quickly so that we will know whether it is safe for
> WebFinger and other specifications to use it.  That approval/rejection can
> then happen in parallel with refining the discovery specification.****
>
> ** **
>
> Otherwise, we could be in a position where we think we have a final
> discovery specification, only to learn that it can’t go forward because of
> objections to the acct: scheme from the W3C and possibly others.  It would
> be much better for us to know whether that is the case up front.****
>
> ** **
>
>                                                             -- Mike****
>
> ** **
>
> *From:* William Mills [mailto:[email-masked]]
> *Sent:* Tuesday, June 26, 2012 8:07 AM
> *To:* Mike Jones; Melvin Carvalho; Murray S. Kucherawy
> *Cc:* [email-masked]
> *Subject:* Re: [apps-discuss] The acct: scheme question****
>
> ** **
>
> Is there any advantage to breaking it out?  The WF draft depends on it and
> so can't finalize until acct: does, right?****
>
> ** **
>
> Will one get done more quickly than the other?****
>
> ** **
> ------------------------------
>
> *From:* Mike Jones <[email-masked]>
> *To:* Melvin Carvalho <[email-masked]>; Murray S. Kucherawy <
> [email-masked]>
> *Cc:* "[email-masked]" <[email-masked]>
> *Sent:* Tuesday, June 26, 2012 6:20 AM
> *Subject:* Re: [apps-discuss] The acct: scheme question****
>
> ** **
>
> Yes, I believe that the acct: scheme should be considered separately from
> discovery, in its own document.****
>
>  ****
>
>                                                             -- Mike****
>
>  ****
>
> *From:* [email-masked]
> [mailto:[email-masked]] *On Behalf Of *Melvin Carvalho
> *Sent:* Tuesday, June 26, 2012 5:06 AM
> *To:* Murray S. Kucherawy
> *Cc:* [email-masked]
> *Subject:* Re: [apps-discuss] The acct: scheme question****
>
>  ****
>
>  ****
>
> On 22 May 2012 09:22, Murray S. Kucherawy <[email-masked]> wrote:****
>
> As we prepare to bring webfinger into appsawg, it looks a lot like there’s
> substantial discussion just on the point of the proposed “acct:” scheme.**
> **
>
>  ****
>
> Barry and Pete to make that call.)****
>
>
> URI type e.g. mailto: http: acct: etc. acct: is recommended in the RFC.  *
> ***
>
>  ****
>
> -MSK****
>
>
> https://www.ietf.org/mailman/listinfo/apps-discuss****
>
>  ****
>
>
> https://www.ietf.org/mailman/listinfo/apps-discuss****
>
>

---

From: Melvin Carvalho <[email-masked]>
Date: Thu, 28 Jun 2012 01:21:48 +0200

On 27 June 2012 23:56, Paul E. Jones <[email-masked]> wrote:

> Mike,****
>
> ** **
>
> I would still like to at least *try* to keep these together.  The “acct”
> URI is a WebFinger URI, so I think it’s best to keep them together.  It
> does not seem that approval of the RFC is contingent on the approval of the
> URI scheme.  It could be registered provisionally at first.  But, I think
> it would be approved given that it is already in use and the fact that
> folks agree to go forward with the document.****
>
> ** **
>
> WebFinger over it, then we could consider splitting it.  I don’t hear that,
> be a problem, but perhaps I’m wrong.****
>
> ** **
>
> In any case, I’d prefer to split it out only if we absolutely had to.
>

I could be mistaken, but my impression was that more were in favor of the
acct: URI scheme having it's own document, than not.  Is there a way in
which consensus can be established, on this issue?

> ****
>
> ** **
>
> Paul****
>
> ** **
>
> *From:* Mike Jones [mailto:[email-masked]]
> *Sent:* Wednesday, June 27, 2012 4:44 PM
> *To:* Paul E. Jones; 'John Bradley'; 'Peter Saint-Andre'
>
> *Cc:* [email-masked]; 'Murray S. Kucherawy'
> *Subject:* RE: [apps-discuss] The acct: scheme question****
>
> ** **
>
> If we separate them, the WebFinger draft would continue to have a
> normative dependency on the Acct draft.  But practically then the Acct
> draft could go up for working group last call and then IETF last call
> essentially immediately after the draft is produced and we’d get a clear
> up/down standards decision sooner, rather than later.****
>
> ** **
>
> If you don’t have the time to be editor for that draft, I’m willing to do
> so.  It won’t take more than a few hours to tease apart.****
>
> ** **
>
>                                                                 -- Mike***
> *
>
> ** **
>
> [mailto:[email-masked]] *On Behalf Of *Paul E. Jones
> *Sent:* Wednesday, June 27, 2012 1:39 PM
> *To:* 'John Bradley'; 'Peter Saint-Andre'
> *Cc:* [email-masked]; 'Murray S. Kucherawy'
> John,****
> That’s correct, but not a function of the WebFinger draft, but one of RFC
> 6415.  The URI template accepts URIs, not bits and pieces of URIs.****
>
> ** **
>
> We had discussed long ago to use only “[email-masked]”, for
> example, but the group decided to use URIs and “acct” was the preferred URI
> scheme to refer to user accounts.****
>
> ** **
>
> What I’ve been doing was trying to document the agreements various folks
> had reached on WebFinger.  Don’t shoot the messenger.  That said, I don’t
> see a good reason to backtrack at this point.  The “acct” URI scheme is out
> in the wild, its use has a limited scope and specific purpose, etc.****
>
> ** **
>
> “what URI scheme do I use to refer to paulej’s Twitter account?”  It’s not
> consensus before that “acct” is a reasonable way forward.  Nobody was in
> love with “acct”, but nothing else worked better.****
>
> ** **
>
> Paul****
>
> ** **
>
> [mailto:[email-masked]] *On Behalf Of *John Bradley
> *Sent:* Tuesday, June 26, 2012 11:12 AM
> *To:* Peter Saint-Andre
> *Cc:* [email-masked]; Murray S. Kucherawy
> normalized to acct:****
> tell.****
> Perhaps Paul can correct me,  but I think that the request.****
>
> ** **
>
> GET /.well-known/host-meta.json?resource=[email-masked] HTTP/1.1****
>
> Host: bar.com****
>
> ** **
>
> make the above (slightly different syntax same idea) work.****
>
> ** **
>
> things to it are baked in.****
>
> ** **
>
> There are likely also issues with host-meta as that is where the template
> is defined.****
>
> ** **
>
> may be correct in that.****
>
> ** **
>
> On the other hand it is probably the right thing to do, even if it touches
> a bunch of things.****
>
> ** **
>
> John B.****
>
> ** **
>
> On 2012-06-26, at 10:40 AM, Peter Saint-Andre wrote:****
>
> ** **
>
> On 6/26/12 8:37 AM, John Bradley wrote:****
>
> The current spec requires normalization of bare identifiers i.e.
> [email-masked] to acct:[email-masked].****
>
> That would also need to change if we separate the specs.****
>
>

---

From: Graham Klyne <[email-masked]>
Date: Thu, 28 Jun 2012 12:09:03 +0100

On 28/06/2012 08:28, Melvin Carvalho wrote:
> you could simply use ?acct=user@host as has been suggested.

Since my comments with reviewer hat on have been cited, I feel I should 
summarize my personal feelings about the specification of the acct: scheme.

*Reviewer hat OFF*

Roughly, I think the acct: scheme does provide a useful, possibly minor, purpose 
that is not served by other URI schemes, and as such it has reasonable claim to 
meet the bar for registering a new scheme.  But I think the description of the 
acct: scheme in the WebFinger document does a poor job of explaining this; i.e. 
I think there is a document quality issue here around the acct: scheme 
registration/specification.

I've had private exchanges with one of the document editors, but I don't think 
my suggestions have been reflected in the current draft.  In summary, what I 
think is not as clear as it should be in the scheme registration includes:
* what does an acct URI identify
* how are acct URIs allocated; what's the assignment delegation structure?
* how should an acct: URI be dereferenced?  (e.g. if one were used as a link in 
a web page, how should it be handled?).

I suspect that most of this information can be inferred if one has a detailed 
knowledge of WebFinger protocol, but for an average Joe web developer I don't 
think that's really helpful.

I don't think this is a sufficiently important issue for me to engage more 
actively with the discussion.

#g
--

---

From: "Paul E. Jones" <[email-masked]>
Date: Thu, 28 Jun 2012 10:37:29 -0400

Melvin,

Just to the below point, it is the common discovery pattern that acct
addresses.  A service provider might identify users  in any number of ways,
but people need a well-defined and predictable way of using WebFinger.
Plus, they need an ID that has been proven to be understood by the average
user.  If I see a twitter ID like "paulej", I should be able to safely
assume that I can discover information via WF using acct:[email-masked].
Users will likely not enter the "acct:" part, but that's fine.  They often
do not enter "http://", either.

The reason I say that identifying Twitter, Facebook, Flickr, or other users
is in scope is that, regardless if those services publish via WebFinger or
not, the approach taken to discovery given a username and a domain name
should be consistent across the web.

Things like Open Graph are fine, but we need something consistent across the
web for simple, consistent discovery of information related to a URI.

Paul

Twitter, Facebook, Flikr and Google Plus all use HTTP URIs to describe their
user accounts.  This is best practice on the web, and recommended in Linked
Data Principles [1] which is the dominant discovery mechanism on the Web
today.  The gap in linked data, which I hope Webfinger can address, is a
common discovery pattern (using well-known locations) for email addresses.
If Twitter or Facebook and others have not asked for yet another way to
identify users, I am unsure why this use case is in scope.  Do note that
Facebook already have a first class discovery system in the Open Graph
Protocol.

---

From: [email-masked] (Henry S. Thompson)
Date: Thu, 28 Jun 2012 15:57:46 +0100

> It is the W3C TAG that is the most likely to raise a blocking objection.   

As the informal TAG liaison here, I should make clear that the TAG has
no _official_ standing from which to "raise a blocking objection".

_In extremis_ the TAG chair might make an appeal on some IETF list wrt
some issue of architectural concern, or might contact his/her opposite
number on the IAB, or might feed something in to the official W3C/IETF
liaison call.

There has been no formal TAG discussion of the acct: matter to date.

ht

---

From: [email-masked] (Henry S. Thompson)
Date: Thu, 28 Jun 2012 16:03:43 +0100

Graham Klyne writes:

> I've had private exchanges with one of the document editors, but I
> don't think my suggestions have been reflected in the current draft.
> In summary, what I think is not as clear as it should be in the scheme
> registration includes:
> * how should an acct: URI be dereferenced?  (e.g. if one were used as
> a link in a web page, how should it be handled?).

Hear, hear.  My primary reason for preferring a separate draft is/was
precisely that this would make the gaps in the current proposal more
obvious -- that is, make it clearer what was needed to assess the
acct: proposal _as a proposal in its own right_.

ht

---

From: Peter Saint-Andre <[email-masked]>
Date: Thu, 28 Jun 2012 10:53:04 -0600

On 6/28/12 5:09 AM, Graham Klyne wrote:
> Roughly, I think the acct: scheme does provide a useful, possibly minor,
> purpose that is not served by other URI schemes, and as such it has
> reasonable claim to meet the bar for registering a new scheme.  But I
> think the description of the acct: scheme in the WebFinger document does
> a poor job of explaining this; i.e. I think there is a document quality
> issue here around the acct: scheme registration/specification.
> 
> I've had private exchanges with one of the document editors, but I don't
> think my suggestions have been reflected in the current draft.  In
> summary, what I think is not as clear as it should be in the scheme
> registration includes:
> * how should an acct: URI be dereferenced?  (e.g. if one were used as a
> link in a web page, how should it be handled?).
> 
> I suspect that most of this information can be inferred if one has a
> detailed knowledge of WebFinger protocol, but for an average Joe web
> developer I don't think that's really helpful.
> 
> I don't think this is a sufficiently important issue for me to engage
> more actively with the discussion.

Graham, I think you're right about the fact that these matters are
underspecified. I hereby offer to propose some text, and will do that in
the next few days.

Peter

-- 
Peter Saint-Andre
https://stpeter.im/

---

From: "Martin J. Dürst" <[email-masked]>
Date: Fri, 29 Jun 2012 17:43:46 +0900

> which consensus can be established, on this issue?

A few days/weeks, the WG chairs have asked us what we'd prefer to do. 
It's now up to the WG chairs to tell us which way they want the thing to 
proceed. Based on the feedback I have seen, it could go either way. I 
think the most important thing now is for the chairs to make a decision, 
so that people can go back to work on the document(s) and can stop 
discussing procedural stuff.

Regards,    Martin.

---

From: Peter Saint-Andre <[email-masked]>
Date: Sat, 30 Jun 2012 21:09:05 -0600

> underspecified. I hereby offer to propose some text, and will do that in

I went beyond proposing text and decided to write a standalone I-D:

http://datatracker.ietf.org/doc/draft-saintandre-acct-uri/

Graham, I think that text answers the questions you posed, hopefully in
an accurate way.

Feedback is welcome.

Peter

-- 
Peter Saint-Andre
https://stpeter.im/

---

From: Mike Jones <[email-masked]>
Date: Sun, 1 Jul 2012 03:35:25 +0000

Bravo!!!

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Peter Saint-Andre
Sent: Saturday, June 30, 2012 8:09 PM
To: Graham Klyne
Cc: [email-masked]; Murray S. Kucherawy
Subject: Re: [apps-discuss] The acct: scheme question

On 6/28/12 10:53 AM, Peter Saint-Andre wrote:
>> Since my comments with reviewer hat on have been cited, I feel I 
>> should summarize my personal feelings about the specification of the acct: scheme.
>>
>> *Reviewer hat OFF*
>>
>> Roughly, I think the acct: scheme does provide a useful, possibly 
>> minor, purpose that is not served by other URI schemes, and as such 
>> it has reasonable claim to meet the bar for registering a new scheme.  
>> But I think the description of the acct: scheme in the WebFinger 
>> document does a poor job of explaining this; i.e. I think there is a 
>> document quality issue here around the acct: scheme registration/specification.
>>
>> In summary, what I think is not as clear as it should be in the 
>> scheme registration includes:
> underspecified. I hereby offer to propose some text, and will do that 
> in the next few days.

Graham, I think that text answers the questions you posed, hopefully in an accurate way.

Feedback is welcome.

Peter

--
Peter Saint-Andre
https://stpeter.im/