Subject: [apps-discuss] #10: json-pointer fragment identifiers

From: "Manger, James H" <[email-masked]>
Date: Tue, 3 Jul 2012 18:56:19 +1000

>> Picking the right key from a JSON Web Key value is a possible use [draft-ietf-jose-json-web-key].

> It seems that you then would have to rely on array indices, right?

Yes, with the current JWK syntax. http://example.org/jim.json#/keys/1 to pick the 2nd key.

--
James Manger

---

From: Julian Reschke <[email-masked]>
Date: Tue, 03 Jul 2012 11:19:07 +0200

On 2012-07-03 10:56, Manger, James H wrote:
> ...

And relying on a specific order is not a problem? (Asking because this 
seems to be a nice example for a case where a more expressive pointer 
syntax could be useful).

Best regards, Julian

---

From: "Manger, James H" <[email-masked]>
Date: Wed, 4 Jul 2012 09:36:04 +1000

> seems to be a nice example for a case where a more expressive pointer

Relying on the order in an array shouldn't be a problem.

Each key can have a key id, which is probably a better way to refer to a particular key. A more sophisticated pointer/fragment syntax could address that, but a better approach is to redesign the JWK JSON syntax so the key id is used as the element name (then a JSON pointer would be a perfect fragment value).

--
James Manger