Subject: [apps-discuss] Referencing content on social networking sites

From: "Paul E. Jones" <[email-masked]>
Date: Fri, 6 Jul 2012 14:31:35 -0400

Folks,

I've often seen people post content on social networking sites like Facebook
and Google+ and wondered what logic went into selecting the graphic to use
to represent the content and the picture that appeared beside that text.
Sometimes the social networking sites do a great job at displaying a good
summary and image, but sometimes it's totally wrong.

It's common to see headers like this in HTML documents:

  <meta name="description" content="This is text related to the page">

However, social networking sites do not consistently use that metadata, even
when present.

I'm not aware of a link relation defined specifically for such referencing
purposes.  However, something like this might work:

   <link rel="page-graphic" href="picture_to_display.jpg">

Are there existing elements social networking sites follow or should follow?
Is there value in recommending how and image and descriptive text are
selected?

Paul

---

From: Behnam Esfahbod <[email-masked]>
Date: Fri, 6 Jul 2012 16:50:16 -0400

Hi Paul,

Facebook uses the Open Graph Protocol. http://ogp.me/

*"The Open Graph protocol enables any web page to become a rich object in a
social graph. For instance, this is used on Facebook to allow any web page
to have the same functionality as any other object on Facebook."*

OTOH, Google has been leading the development of OpenSocial protocol.
http://docs.opensocial.org/display/OS/Home

*"OpenSocial helps [social web]sites share their social data with the web.
Applications that use the OpenSocial APIs can be embedded within a social
network itself, or access a site's social data from anywhere on the web."*

Of course the good old FOAF project is providing some of
these functionalities as well, via the its extensions.
http://wiki.foaf-project.org/w/FoafExtensions

Best,
-Behnam

On Fri, Jul 6, 2012 at 2:31 PM, Paul E. Jones <[email-masked]> wrote:

> Folks,****
>
> ** **
>
> I’ve often seen people post content on social networking sites like
> Facebook and Google+ and wondered what logic went into selecting the
> graphic to use to represent the content and the picture that appeared
> beside that text.  Sometimes the social networking sites do a great job at
> displaying a good summary and image, but sometimes it’s totally wrong.****
>
> ** **
>
> It’s common to see headers like this in HTML documents:****
>
>   <meta name=”description” content=”This is text related to the page”>****
>
> ** **
>
> However, social networking sites do not consistently use that metadata,
> even when present.****
>
> ** **
>
> I’m not aware of a link relation defined specifically for such referencing
> purposes.  However, something like this might work:****
>
> ** **
>
>    <link rel=”page-graphic” href=”picture_to_display.jpg”>****
>
> ** **
>
> Are there existing elements social networking sites follow or should
> follow?  Is there value in recommending how and image and descriptive text
> are selected?****
>
> ** **
>
> Paul****
>
> ** **
>
> _______________________________________________
> apps-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/apps-discuss
>
>

-- 
    '     بهنام اسفهبد
    '     Behnam Esfahbod
   '      http://behnam.esfahbod.info
  *  ..   Persian Internet Society
 *  `  *  http://persian-isoc.org
  * o *   3E7F B4B6 6F4C A8AB 9BB9 7520 5701 CA40 259E 0F8B

---

From: "Paul E. Jones" <[email-masked]>
Date: Fri, 6 Jul 2012 17:14:13 -0400

Behnam,

I’m not referring to stuff like that.  What I’m referring to is not really related to social networks, per se, but that’s where I see the problem show up.

Let’s say you want to talk about a BBC article and post a link on Facebook or Google+.  The article might have a picture related to the story and the first paragraph might serve as good text to appear when including snippets of the article and text when posting such references on social networking sites or blogs or elsewhere.

The problem is that these sites do not always grab the most apropos image on the page, nor the most appropriate text.  In fact, I’ve seen some very bad “misses”.

So, what I’m thinking is that sites like the BBC, CNN, or even one’s own personal blog should include a “description” metadata element and a link to an image that is appropriate for the news article or blog entry to remove that guesswork.  Perhaps the right solution is markup in the HTML document itself that flags certain content as appropriate.  I don’t have the solution, but it seems like we’re missing some basic elements that make embedding “rich references” (for lack of a better term) in other sites.

Paul

From: [email-masked] [mailto:[email-masked]] On Behalf Of Behnam Esfahbod
Sent: Friday, July 06, 2012 4:50 PM
To: Paul E. Jones
Cc: [email-masked]
Subject: Re: [apps-discuss] Referencing content on social networking sites

Hi Paul,

"The Open Graph protocol enables any web page to become a rich object in a social graph. For instance, this is used on Facebook to allow any web page to have the same functionality as any other object on Facebook."

OTOH, Google has been leading the development of OpenSocial protocol. http://docs.opensocial.org/display/OS/Home

"OpenSocial helps [social web]sites share their social data with the web. Applications that use the OpenSocial APIs can be embedded within a social network itself, or access a site's social data from anywhere on the web."

Of course the good old FOAF project is providing some of these functionalities as well, via the its extensions. http://wiki.foaf-project.org/w/FoafExtensions

Best,

-Behnam

Folks,

I’ve often seen people post content on social networking sites like Facebook and Google+ and wondered what logic went into selecting the graphic to use to represent the content and the picture that appeared beside that text.  Sometimes the social networking sites do a great job at displaying a good summary and image, but sometimes it’s totally wrong.

It’s common to see headers like this in HTML documents:

  <meta name=”description” content=”This is text related to the page”>

However, social networking sites do not consistently use that metadata, even when present.

I’m not aware of a link relation defined specifically for such referencing purposes.  However, something like this might work:

   <link rel=”page-graphic” href=”picture_to_display.jpg”>

Are there existing elements social networking sites follow or should follow?  Is there value in recommending how and image and descriptive text are selected?

Paul

 

-- 

    '     بهنام اسفهبد
    '     Behnam Esfahbod

---

From: Bob Wyman <[email-masked]>
Date: Fri, 6 Jul 2012 17:27:33 -0400

Are you looking for something like rich snippets?
http://googlewebmastercentral.blogspot.com/2009/05/introducing-rich-snippets.html?m=1

---

From: Behnam Esfahbod <[email-masked]>
Date: Fri, 6 Jul 2012 17:28:57 -0400

Paul,

OpenGraph allows the website owner to define various data to be used by
social networks, like the title, normative URL, an image, etc.

For example, if you look at the HTML "head" section of this NYTimes page
[1] you can see that many "meta" tags are defined with their "property"
attribute starting with "og:". That mean whenever a social-network likes to
make a link to this page, they can use the hint and use "U.N. Affirms
Internet Freedom as a Basic Right" as the title of the link (as meta
og:title tag says), "http://graphics8.nytimes.com/gfx/blogs/bits/bits75.gif"
for the image (as meta og:image tag says), etc.

1:
http://bits.blogs.nytimes.com/2012/07/06/so-the-united-nations-affirms-internet-freedom-as-a-basic-right-now-what/

Now, if a social website does NOT grab the best image for a link, that's
because the website hasn't told the social website what image to pick. If
they like to do so, they can: using the protocols I mentioned.

So, is this what you are talking about? Or you are only curious about the
cases that websites do NOT provide any "social data" and you are thinking
about better methods to handle those cases?

-Behnam

On Fri, Jul 6, 2012 at 5:14 PM, Paul E. Jones <[email-masked]> wrote:

> Behnam,****
>
> ** **
>
> I’m not referring to stuff like that.  What I’m referring to is not really
> related to social networks, per se, but that’s where I see the problem show
> up.****
>
> ** **
>
> Let’s say you want to talk about a BBC article and post a link on Facebook
> or Google+.  The article might have a picture related to the story and the
> first paragraph might serve as good text to appear when including snippets
> of the article and text when posting such references on social networking
> sites or blogs or elsewhere.****
>
> ** **
>
> The problem is that these sites do not always grab the most apropos image
> on the page, nor the most appropriate text.  In fact, I’ve seen some very
> bad “misses”.****
>
> ** **
>
> So, what I’m thinking is that sites like the BBC, CNN, or even one’s own
> personal blog should include a “description” metadata element and a link to
> an image that is appropriate for the news article or blog entry to remove
> that guesswork.  Perhaps the right solution is markup in the HTML document
> itself that flags certain content as appropriate.  I don’t have the
> solution, but it seems like we’re missing some basic elements that make
> embedding “rich references” (for lack of a better term) in other sites.***
> *
>
> ** **
>
> Paul****
>
> ** **
>
> *From:* [email-masked] [mailto:[email-masked]] *On Behalf Of *Behnam
> Esfahbod
> *Sent:* Friday, July 06, 2012 4:50 PM
> *To:* Paul E. Jones
> *Cc:* [email-masked]
> *Subject:* Re: [apps-discuss] Referencing content on social networking
> sites****
>
> ** **
>
> Hi Paul,****
>
> ** **
>
> Facebook uses the Open Graph Protocol. http://ogp.me/****
>
> ** **
>
> *"The Open Graph protocol enables any web page to become a rich object in
> a social graph. For instance, this is used on Facebook to allow any web
> page to have the same functionality as any other object on Facebook."*****
>
> ** **
>
> http://docs.opensocial.org/display/OS/Home****
>
> ** **
>
> *"OpenSocial helps [social web]sites share their social data with the
> web. Applications that use the OpenSocial APIs can be embedded within a
> social network itself, or access a site's social data from anywhere on the
> web."*****
>
> ** **
>
> http://wiki.foaf-project.org/w/FoafExtensions****
>
> ** **
>
> Best,****
>
> -Behnam****
>
> ** **
>
> ** **
>
> ** **
>
> On Fri, Jul 6, 2012 at 2:31 PM, Paul E. Jones <[email-masked]>
> wrote:****
>
> Folks,****
>
>  ****
>
>  ****
>  ****
>  ****
>  ****
>  ****
>  ****
>  ****
> https://www.ietf.org/mailman/listinfo/apps-discuss****
>
>
>
> ****
>
> ** **
>
> -- ****
>
>     '     بهنام اسفهبد
>     '     Behnam Esfahbod
>   * o *   3E7F B4B6 6F4C A8AB 9BB9 7520 5701 CA40 259E 0F8B****
>
> ** **
>

---

From: "Paul E. Jones" <[email-masked]>
Date: Fri, 6 Jul 2012 18:04:55 -0400

Behnam,

Ah!  Yes, that’s exactly it.  I apologize.  I assumes OG was just to query via an API.  I didn’t realize it also defined certain markup.

Paul

From: [email-masked] [mailto:[email-masked]] On Behalf Of Behnam Esfahbod
Sent: Friday, July 06, 2012 5:29 PM
To: Paul E. Jones
Cc: [email-masked]
Subject: Re: [apps-discuss] Referencing content on social networking sites

Paul,

OpenGraph allows the website owner to define various data to be used by social networks, like the title, normative URL, an image, etc.

For example, if you look at the HTML "head" section of this NYTimes page [1] you can see that many "meta" tags are defined with their "property" attribute starting with "og:". That mean whenever a social-network likes to make a link to this page, they can use the hint and use "U.N. Affirms Internet Freedom as a Basic Right" as the title of the link (as meta og:title tag says), "http://graphics8.nytimes.com/gfx/blogs/bits/bits75.gif" for the image (as meta og:image tag says), etc.

1:  http://bits.blogs.nytimes.com/2012/07/06/so-the-united-nations-affirms-internet-freedom-as-a-basic-right-now-what/

Now, if a social website does NOT grab the best image for a link, that's because the website hasn't told the social website what image to pick. If they like to do so, they can: using the protocols I mentioned.

So, is this what you are talking about? Or you are only curious about the cases that websites do NOT provide any "social data" and you are thinking about better methods to handle those cases?

-Behnam

Behnam,

Paul

Hi Paul,

Best,

-Behnam

Folks,

Paul

 

-- 

    '     بهنام اسفهبد
    '     Behnam Esfahbod

-- 

    '     بهنام اسفهبد
    '     Behnam Esfahbod

---

From: "Paul E. Jones" <[email-masked]>
Date: Fri, 6 Jul 2012 18:08:21 -0400

No, I was looking for something like this:

<meta property="og:title" content="U.N. Affirms Internet Freedom as a Basic
Right" />

<meta property="og:type" content="article" />

<meta property="og:url"
content="http://bits.blogs.nytimes.com/2012/07/06/so-the-united-nations-affi
rms-internet-freedom-as-a-basic-right-now-what/" /><meta
property="og:site_name" content="Bits Blog" />

<meta property="og:description" content="The United Nations Human Rights
Council passed a nonbinding resolution that supports Internet freedom,
leaving Internet companies to decide how much to collaborate with government
authorities in the tracking of citizens." />

<meta property="og:image"
content="http://graphics8.nytimes.com/gfx/blogs/bits/bits75.gif"/>

That's exactly the kind of thing I was looking for, but I do wonder how
pervasive this will become.  Is this being standardized?

Paul

From: Bob Wyman [mailto:[email-masked]] 
Sent: Friday, July 06, 2012 5:22 PM
To: Paul E. Jones
Cc: [email-masked]
Subject: Re: [apps-discuss] Referencing content on social networking sites

Are you looking for something like "rich snippets?"
http://googlewebmastercentral.blogspot.com/2009/05/introducing-rich-snippets
.html?m=1

bob wyman

Folks,

Paul

---

From: Goix Laurent Walter <[email-masked]>
Date: Sat, 7 Jul 2012 12:58:16 +0200

Hello Paul,

I guess the closest specification to this is the Microformats/microdata/rdfa effort that have been evolving for years now and is now mostly supported by the schema.org [1] project.
These are understood by the major search engines or social sites to "extract" metadata from a web page, for example to display title & thumbnail when sharing or in a search result snippet.

Is it what you are looking at?
walter

[1] http://schema.org/

Da: [email-masked] [mailto:[email-masked]] Per conto di Paul E. Jones
Inviato: sabato 7 luglio 2012 0.08
A: 'Bob Wyman'
Cc: [email-masked]
Oggetto: Re: [apps-discuss] Referencing content on social networking sites

<meta property="og:title" content="U.N. Affirms Internet Freedom as a Basic Right" />

<meta property="og:url" content="http://bits.blogs.nytimes.com/2012/07/06/so-the-united-nations-affirms-internet-freedom-as-a-basic-right-now-what/" /><meta property="og:site_name" content="Bits Blog" />

<meta property="og:description" content="The United Nations Human Rights Council passed a nonbinding resolution that supports Internet freedom, leaving Internet companies to decide how much to collaborate with government authorities in the tracking of citizens." />

<meta property="og:image" content="http://graphics8.nytimes.com/gfx/blogs/bits/bits75.gif"/>

That's exactly the kind of thing I was looking for, but I do wonder how pervasive this will become.  Is this being standardized?

Paul

Are you looking for something like "rich snippets?" http://googlewebmastercentral.blogspot.com/2009/05/introducing-rich-snippets.html?m=1

bob wyman
On Jul 6, 2012 2:31 PM, "Paul E. Jones" <[email-masked]<mailto:[email-masked]>> wrote:
Folks,

I've often seen people post content on social networking sites like Facebook and Google+ and wondered what logic went into selecting the graphic to use to represent the content and the picture that appeared beside that text.  Sometimes the social networking sites do a great job at displaying a good summary and image, but sometimes it's totally wrong.

I'm not aware of a link relation defined specifically for such referencing purposes.  However, something like this might work:

Paul

_______________________________________________
apps-discuss mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/apps-discuss
Questo messaggio e i suoi allegati sono indirizzati esclusivamente alle persone indicate. La diffusione, copia o qualsiasi altra azione derivante dalla conoscenza di queste informazioni sono rigorosamente vietate. Qualora abbiate ricevuto questo documento per errore siete cortesemente pregati di darne immediata comunicazione al mittente e di provvedere alla sua distruzione, Grazie.

This e-mail and any attachments is confidential and may contain privileged information intended for the addressee(s) only. Dissemination, copying, printing or use by anybody else is unauthorised. If you are not the intended recipient, please delete this message and any attachments and advise the sender by return e-mail, Thanks.

Rispetta l'ambiente. Non stampare questa mail se non ? necessario.

---

From: Melvin Carvalho <[email-masked]>
Date: Sat, 7 Jul 2012 13:06:59 +0200

On 7 July 2012 12:58, Goix Laurent Walter <
[email-masked]> wrote:

>  Hello Paul,****
>
> ** **
>
> I guess the closest specification to this is the
> Microformats/microdata/rdfa effort that have been evolving for years now
> and is now mostly supported by the schema.org [1] project.****
>
> These are understood by the major search engines or social sites to
> “extract” metadata from a web page, for example to display title &
> thumbnail when sharing or in a search result snippet.
>

Do note that, as of last month, (after about 5 years of work), RDFa 1.1 has
become an official W3C REC.

http://www.w3.org/blog/SW/2012/06/07/rdfa-core-1-1-rdfa-lite-1-1-and-xhtmlrdfa-1-1-are-w3c-recommendation/

> ****
>
> ** **
>
> Is it what you are looking at?****
>
> walter****
>
> ** **
>
> [1] http://schema.org/ ****
>
> ** **
>
> *Da:* [email-masked] [mailto:[email-masked]]
> *Per conto di *Paul E. Jones
> *Inviato:* sabato 7 luglio 2012 0.08
> *A:* 'Bob Wyman'
> *Oggetto:* Re: [apps-discuss] Referencing content on social networking
> sites****
>
> ** **
>
> No, I was looking for something like this:****
>
> ** **
>
> <meta property="og:title" content="U.N. Affirms Internet Freedom as a
> Basic Right" />****
>
> ** **
>
> <meta property="og:type" content="article" />****
>
> ** **
>
> <meta property="og:url" content="
> http://bits.blogs.nytimes.com/2012/07/06/so-the-united-nations-affirms-internet-freedom-as-a-basic-right-now-what/"
> /><meta property="og:site_name" content="Bits Blog" />****
>
> ** **
>
> leaving Internet companies to decide how much to collaborate with
> government authorities in the tracking of citizens." />****
>
> ** **
>
> <meta property="og:image" content="
> http://graphics8.nytimes.com/gfx/blogs/bits/bits75.gif"/>****
>
> ** **
>
> That’s exactly the kind of thing I was looking for, but I do wonder how
> pervasive this will become.  Is this being standardized?****
>
> ** **
>
> Paul****
>
> ** **
>
> ** **
>
> *From:* Bob Wyman [mailto:[email-masked]]
> *Sent:* Friday, July 06, 2012 5:22 PM
> *To:* Paul E. Jones
> bob wyman****
> On Jul 6, 2012 2:31 PM, "Paul E. Jones" <[email-masked]> wrote:****
>
> Folks,****
>
>  ****
>
>     Questo messaggio e i suoi allegati sono indirizzati esclusivamente
> alle persone indicate. La diffusione, copia o qualsiasi altra azione
> derivante dalla conoscenza di queste informazioni sono rigorosamente
> vietate. Qualora abbiate ricevuto questo documento per errore siete
> cortesemente pregati di darne immediata comunicazione al mittente e di
> provvedere alla sua distruzione, Grazie.
>
> *This e-mail and any attachments** is **confidential and may contain
> privileged information intended for the addressee(s) only. Dissemination,
> copying, printing or use by anybody else is unauthorised. If you are not
> the intended recipient, please delete this message and any attachments and
> advise the sender by return e-mail, Thanks.*
> *Rispetta l'ambiente. Non stampare questa
> mail se non è necessario.*
>
>

---

From: Robins George <[email-masked]>
Date: Sat, 7 Jul 2012 17:31:58 +0530

Hi all,

FYI:
similar attempts made from vcarddav WG

http://tools.ietf.org/html/draft-ietf-vcarddav-social-networks-00

- robins
On Sat, Jul 7, 2012 at 4:36 PM, Melvin Carvalho <[email-masked]>wrote:

> Do note that, as of last month, (after about 5 years of work), RDFa 1.1
> has become an official W3C REC.
>
>
>> I’m not aware of a link relation defined specifically for such
>> referencing purposes.  However, something like this might work:****
>>
>>  ****
>>

-- 
This is from my personal email account and any materials from this account
come with personal disclaimers

---

From: Bob Wyman <[email-masked]>
Date: Fri, 6 Jul 2012 17:21:31 -0400

bob wyman