Subject: [apps-discuss] "Best Practices for Fragment Identifiers and Media Type Definitions"

From: Larry Masinter <[email-masked]>
Date: Mon, 30 Jul 2012 09:36:42 -0700

To be more explicit (and provide additional URLs):

   http://www.w3.org/TR/fragid-best-practices/ is now (as of last week) a W3C "First Public Working Draft" as the first step of the "Recommendation" track at W3C.
The W3C TAG plan for moving this to Recommendation is  http://www.w3.org/2001/tag/products/fragids.html 

(a) comments on the document itself should be sent to [email-masked]. Please note that the latest 'editor draft' is http://www.w3.org/2001/tag/doc/mimeTypesAndFragids. 

(b) it is likely too late to affect draft-ietf-appsawg-media-type-regs

(c) Perhaps a reference to it from http://tools.ietf.org/html/draft-ietf-appsawg-media-type-suffix-regs (as an informative source of considerations an expert reviewer might take into account) would be in order.

Larry
--
http://larry.masinter.net

---

From: "Murray S. Kucherawy" <[email-masked]>
Date: Mon, 30 Jul 2012 13:17:23 -0700

On Mon, Jul 30, 2012 at 9:36 AM, Larry Masinter <[email-masked]> wrote:

>    http://www.w3.org/TR/fragid-best-practices/ is now (as of last week) a
> W3C "First Public Working Draft" as the first step of the "Recommendation"
> track at W3C.
> The W3C TAG plan for moving this to Recommendation is
> http://www.w3.org/2001/tag/products/fragids.html
>
> (a) comments on the document itself should be sent to [email-masked].
> Please note that the latest 'editor draft' is
> http://www.w3.org/2001/tag/doc/mimeTypesAndFragids.
>
> (c) Perhaps a reference to it from
> http://tools.ietf.org/html/draft-ietf-appsawg-media-type-suffix-regs (as
> an informative source of considerations an expert reviewer might take into
> account) would be in order.
>
>
Is there any objection from the WG to making a reference to this in the
suffix-regs document?  (Perhaps before we go there: Is that first
w3.orgURI going to be a permanent URI to which we could make
reference?)

-MSK

---

From: [email-masked] (Henry S. Thompson)
Date: Mon, 30 Jul 2012 22:01:16 +0100

Murray S. Kucherawy writes:

>> . . .
> suffix-regs document?

I can't speak officially for the rest of the TAG, but I am pretty sure
it is our hope that you will do precisely that.

> (Perhaps before we go there: Is that first w3.org URI going to be a
> permanent URI to which we could make reference?)

Yes, the URI above will be as permanent as any w3.org document URI.
It will track the latest version, and will eventually be the URI for
the approved W3C Recommendation, assuming we get that far.

ht
-- 
       Henry S. Thompson, School of Informatics, University of Edinburgh
      10 Crichton Street, Edinburgh EH8 9AB, SCOTLAND -- (44) 131 650-4440
                Fax: (44) 131 650-4587, e-mail: [email-masked]
                       URL: http://www.ltg.ed.ac.uk/~ht/
 [mail from me _always_ has a .sig like this -- mail without it is forged spam]

---

From: Ned Freed <[email-masked]>
Date: Tue, 31 Jul 2012 09:54:46 -0700 (PDT)

> w3.orgURI going to be a permanent URI to which we could make

I certainly have no objection, but I also think this doesn't have much value.
As I've pointed out several times now, the mandate of this document is to seed
the registry. Nothing more. As such, it seems, well, unlikely that people will
look in it for guidance as to how to define fragment identifiers.

The timing here is really unfortunate because this really belongs in the media
types registry document, but IMO adding such a reference there would require
reopening the document and probably issuing a second last call. And that's too
much, especially since, if past history is any indication the place people
will look for this material is in existing registrations they find in
the registry.

So perhaps the thing to do is clean up the fragment id information in
some existing registrations. Just a thought.

				Ned