Subject: [apps-discuss] Updated Simple Web Discovery (SWD) Specification

From: Mike Jones <[email-masked]>
Date: Fri, 6 Jul 2012 23:37:34 +0000

I've updated the Simple Web Discovery (SWD)<http://tools.ietf.org/html/draft-jones-simple-web-discovery> specification to incorporate editorial improvements suggested by Julian Reschke and to apply applicable editorial improvements also recently made to the JOSE<http://datatracker.ietf.org/wg/jose/> specifications.  No normative changes were made.

The updated specification is available at:

*         http://tools.ietf.org/html/draft-jones-simple-web-discovery-03

Changes made were:

*         Changed "requests use the x-www-form-urlencoded format" to "requests use query parameters" and changed "an x-www-form-urlencoded form" to "a form encoded using the application/x-www-form-urlencoded encoding algorithm", both at the suggestion of Julian Reschke.

*         Updated examples to use "urn:example:" URNs rather than "urn:example.org:" URNs, also at Julian's suggestion.

*         Applied applicable editorial improvements from JOSE specs to SWD.

*         Updated references to related specifications.

                                                                -- Mike

---

From: "Murray S. Kucherawy" <[email-masked]>
Date: Sat, 7 Jul 2012 23:18:23 -0700

On Fri, Jul 6, 2012 at 4:37 PM, Mike Jones <[email-masked]>wrote:

>  I’ve updated the Simple Web Discovery (SWD)<http://tools.ietf.org/html/draft-jones-simple-web-discovery>specification to incorporate editorial improvements suggested by Julian
> Reschke and to apply applicable editorial improvements also recently made
> to the JOSE <http://datatracker.ietf.org/wg/jose/> specifications.  No
> normative changes were made.****
>
> ** **
>
> The updated specification is available at:****
>
> **·         **
> http://tools.ietf.org/html/draft-jones-simple-web-discovery-03****
>
> **[...]
>

Hi Mike,

Does this mean anything with respect to the convergence of Webfinger and
SWD?  I was a little surprised to see this separate update.

-MSK

---

From: John Bradley <[email-masked]>
Date: Sun, 8 Jul 2012 16:18:10 -0400

OpenID Connect still references SWD.   Until a decision to switch to a different discovery spec is taken SWD needs to be kept up to date with changes in JOSE and be kept from expiring.

The update is more a artifact of the IETF process, than a statement about convergence one way or the other.

John B.

On 2012-07-08, at 2:18 AM, Murray S. Kucherawy wrote:

> On Fri, Jul 6, 2012 at 4:37 PM, Mike Jones <[email-masked]> wrote:
> I’ve updated the Simple Web Discovery (SWD) specification to incorporate editorial improvements suggested by Julian Reschke and to apply applicable editorial improvements also recently made to the JOSE specifications.  No normative changes were made.
> 
>  
> 
> ·         http://tools.ietf.org/html/draft-jones-simple-web-discovery-03
> 
> [...]
> 
> 
> Hi Mike,
> 
> Does this mean anything with respect to the convergence of Webfinger and SWD?  I was a little surprised to see this separate update.
> 
> -MSK
> 
> _______________________________________________
> apps-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/apps-discuss

---

From: Mike Jones <[email-masked]>
Date: Mon, 9 Jul 2012 01:12:26 +0000

I agree with John's characterization.  Until such time as it's clear that an Apps Area discovery specification has stabilized, is simple and efficient enough, and is headed for approval, I believe that the consensus among the OpenID Connect working group is to stick with Simple Web Discovery.  This draft refreshed the SWD spec, since the -02 draft had expired.

                                                            -- Mike

From: John Bradley [mailto:[email-masked]]
Sent: Sunday, July 08, 2012 1:18 PM
To: Murray S. Kucherawy
Cc: Mike Jones; Julian Reschke; [email-masked]
Subject: Re: [apps-discuss] Updated Simple Web Discovery (SWD) Specification

John B.

On Fri, Jul 6, 2012 at 4:37 PM, Mike Jones <[email-masked]<mailto:[email-masked]>> wrote:
I've updated the Simple Web Discovery (SWD)<http://tools.ietf.org/html/draft-jones-simple-web-discovery> specification to incorporate editorial improvements suggested by Julian Reschke and to apply applicable editorial improvements also recently made to the JOSE<http://datatracker.ietf.org/wg/jose/> specifications.  No normative changes were made.

Hi Mike,

-MSK
_______________________________________________
apps-discuss mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/apps-discuss