Subject: [apps-discuss] Proposed changes to WebFinger regarding XML vs JSON

From: "Paul E. Jones" <[email-masked]>
Date: Mon, 27 Aug 2012 11:56:55 -0400

Folks,

Mike, Gonzalo, and I have had some off-list discussions about WebFinger and
how to resolve the one sticky point that we think has caused the most
concern.  That point is whether we should we allow both XML and JSON.

We have heard proposals to "just pick one" and, while I appreciate the
reasoning, I could not help ignoring that

  1) RFC 6415 exists and describes XML the single mandatory format
  2) Existing implementations use XML

Nonetheless, I also cannot ignore the long-term value in selecting one
format we can be sure is widely supported consistently.  I'm fairly
confident that most want only JSON at this point, even though most (if not
all) current implementations today use XML.  While I'm personally favorable
to using XML, I know my personal preferences are not representative of
everyone. :-)

So what we discussed was mentioning XML (perhaps with examples), but putting
that in an appendix and saying the usage is historic.  What this would mean
is that the text acknowledges that there are servers that might process both
XML and JSON, and even older servers that only process XML.  The main body
of the document would only require support for JSON from clients and
servers.

Before we make these changes to the text, I want to seek input from the
group.  I believe it would be acceptable, but I do not want those changes to
cause significant issues for anyone.

Thanks,
Paul

PS - Please follow-up only on the apps-discuss list.

---

From: Pelle Wessman <[email-masked]>
Date: Mon, 27 Aug 2012 18:03:11 +0200

> of the document would only require support for JSON from clients and

+1 from me. Mentioning it as historic use in an appendix so that new
implementers know about it and can take it into account sounds like a good
compromise to me - it of course depends a bit on the wording of that
appendix, but it could definitely turn out well.

/ Pelle Wessman

---

From: James M Snell <[email-masked]>
Date: Mon, 27 Aug 2012 09:06:21 -0700

+1... definitely a step in the right direction... now about the rest of
it..... ;-)

- James

On Mon, Aug 27, 2012 at 8:56 AM, Paul E. Jones <[email-masked]>wrote:

> _______________________________________________
> apps-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/apps-discuss
>

---

From: William Mills <[email-masked]>
Date: Mon, 27 Aug 2012 09:17:57 -0700 (PDT)

I think this works in general but that there should be a mention of it in the body of the spec citing the appendix.  Do we even need an appendix though, we could simply cite 6415 as still normative for the XML stuff but deprecated for new implementations.

>________________________________
> From: Paul E. Jones <[email-masked]>
>To: [email-masked] 
>Cc: [email-masked]; [email-masked] 
>Sent: Monday, August 27, 2012 8:56 AM
>Subject: [apps-discuss] Proposed changes to WebFinger regarding XML vs JSON
> 
>Folks,
>

---

From: Tim Bray <[email-masked]>
Date: Mon, 27 Aug 2012 09:26:53 -0700

What William said about not needing the appendix. If you’re going to
go through the pain of abandoning the XML version, why also go through
the pain of writing an appendix, when there’s a perfectly good RFC in
place to point to.  -T

On Mon, Aug 27, 2012 at 9:17 AM, William Mills <[email-masked]> wrote:
> I think this works in general but that there should be a mention of it in
> the body of the spec citing the appendix.  Do we even need an appendix
> though, we could simply cite 6415 as still normative for the XML stuff but
> deprecated for new implementations.
>
>

---

From: Blaine Cook <[email-masked]>
Date: Mon, 27 Aug 2012 18:29:14 +0200

+1 to this, and William and Tim's points.

---

From: "Paul E. Jones" <[email-masked]>
Date: Mon, 27 Aug 2012 17:56:21 -0400

Ok... we could also do that. 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> On Behalf Of Blaine Cook
> Sent: Monday, August 27, 2012 12:29 PM
> Subject: Re: [apps-discuss] Proposed changes to WebFinger regarding XML vs
> JSON
> 
> >> I think this works in general but that there should be a mention of
> >> it in the body of the spec citing the appendix.  Do we even need an
> >> appendix though, we could simply cite 6415 as still normative for the
> >> XML stuff but deprecated for new implementations.
> >>
> >>
> >> Mike, Gonzalo, and I have had some off-list discussions about
> >> WebFinger and how to resolve the one sticky point that we think has
> >> caused the most concern.  That point is whether we should we allow both
> XML and JSON.
> >>
> >> We have heard proposals to "just pick one" and, while I appreciate
> >> the reasoning, I could not help ignoring that
> >>
> >> Nonetheless, I also cannot ignore the long-term value in selecting
> >> one format we can be sure is widely supported consistently.  I'm
> >> fairly confident that most want only JSON at this point, even though
> >> most (if not
> >> all) current implementations today use XML.  While I'm personally
> >> favorable to using XML, I know my personal preferences are not
> >> representative of everyone. :-)
> >>
> >> So what we discussed was mentioning XML (perhaps with examples), but
> >> putting that in an appendix and saying the usage is historic.  What
> >> this would mean is that the text acknowledges that there are servers
> >> that might process both XML and JSON, and even older servers that
> >> only process XML.  The main body of the document would only require
> >> support for JSON from clients and servers.
> >>
> >> Before we make these changes to the text, I want to seek input from
> >> the group.  I believe it would be acceptable, but I do not want those
> >> changes to cause significant issues for anyone.
> >>
> >> Thanks,
> >> Paul
> >>

---

From: Will Norris <[email-masked]>
Date: Mon, 27 Aug 2012 16:13:22 -0700

as one of the editors of said XML format, I'm +1 as well.  The reasons for
pushing so heavily for the XML format back then are no longer really true.
 Instead, all the active work is on JSON-based formats, so it makes sense
to update webfinger as well.

---

From: elf Pavlik <[email-masked]>
Date: Tue, 28 Aug 2012 12:20:48 +0000

> Ok... we could also do that. 
+1

---

From: Melvin Carvalho <[email-masked]>
Date: Tue, 28 Aug 2012 14:23:06 +0200

On 27 August 2012 17:56, Paul E. Jones <[email-masked]> wrote:

> putting

+1 for the general move towards JSON.

Earlier this year I made a case that there are two areas that could
strengthen webfinger

1) A shift towards JSON

I think we've made big progress on this one.  Happy with the state of
affairs, after reading thru this thread.

2) That acct: could be removed from the spec to reduce complexity

Again there has been a lot of progress on this, but I suppose there is
still some elements of contention.

While *acct* has grown on me slightly, happy that the two RFCs are, to an
extent, decoupled.

>From the discussions, so far, I like the idea from mnot of using
.well-known/user/bob as being simple, intuitive and easy to implement

I think webfinger is becoming a stronger spec, as time goes on, in terms of
ease of deployment, interoperability and quality.

+1 Great to see this progress!

---

From: John Bradley <[email-masked]>
Date: Tue, 28 Aug 2012 14:25:37 -0400

+1 JSON must be MTI for servers.

I am not opposed to servers supporting XML or other formats via content negotiation,  however clients need to be interoperable with servers using JSON, and not forced to support XML for some servers.

John B.

On 2012-08-27, at 7:13 PM, Will Norris <[email-masked]> wrote:

> as one of the editors of said XML format, I'm +1 as well.  The reasons for pushing so heavily for the XML format back then are no longer really true.  Instead, all the active work is on JSON-based formats, so it makes sense to update webfinger as well.
> 
> On Mon, Aug 27, 2012 at 2:56 PM, Paul E. Jones <[email-masked]> wrote:

---

From: "Paul E. Jones" <[email-masked]>
Date: Tue, 28 Aug 2012 15:03:06 -0400

John,

Previously, JSON and XML were MTI on servers; clients could implement what
they want.

If we make the proposed change, XML will be dropped on the server side.  The
result will be that clients can only rely on JSON support.  XML support
might be rare.

Paul

PS - My personal preference is still to require XML and JSON on the server,
but I'm willing to give in on this one in order to reach group consensus.  I
think this was the most significant point of contention.

From: John Bradley [mailto:[email-masked]] 
Sent: Tuesday, August 28, 2012 2:26 PM
To: Will Norris
Cc: Paul E. Jones; [email-masked]
Subject: Re: [apps-discuss] Proposed changes to WebFinger regarding XML vs
JSON

I am not opposed to servers supporting XML or other formats via content
negotiation,  however clients need to be interoperable with servers using
JSON, and not forced to support XML for some servers.

John B.

as one of the editors of said XML format, I'm +1 as well.  The reasons for
pushing so heavily for the XML format back then are no longer really true.
Instead, all the active work is on JSON-based formats, so it makes sense to
update webfinger as well.

On Mon, Aug 27, 2012 at 2:56 PM, Paul E. Jones <[email-masked]>
wrote:

> > What William said about not needing the appendix. If you're going to
> > the pain of writing an appendix, when there's a perfectly good RFC in
> > place to point to.  -T
> >

---

From: John Bradley <[email-masked]>
Date: Tue, 28 Aug 2012 15:13:13 -0400

I understand, but I think forcing servers to support both will hurt adoption, though not as much as requiring it on the client.

John B.

On 2012-08-28, at 3:03 PM, "Paul E. Jones" <[email-masked]> wrote:

> John,
>  
> Previously, JSON and XML were MTI on servers; clients could implement what they want.
>  
> If we make the proposed change, XML will be dropped on the server side.  The result will be that clients can only rely on JSON support.  XML support might be rare.
>  
> Paul
>  
> PS – My personal preference is still to require XML and JSON on the server, but I’m willing to give in on this one in order to reach group consensus.  I think this was the most significant point of contention.
>  
> Subject: Re: [apps-discuss] Proposed changes to WebFinger regarding XML vs JSON
>

---

From: ☮ elf Pavlik ☮ <[email-masked]>
Date: Wed, 29 Aug 2012 20:15:31 +0000

> .well-known/user/bob as being simple, intuitive and easy to implement

I also see some advantages of using convention like:
https://example.net/.well-known/acct/nick for [email-masked]

Two of the reasons for acct instead of user:
* We have acct: scheme cooking on separate burner
* I can see place for *collective*/*shared* accounts for which user might imply an individual in a confusing way

Besides that, I see topic of advantage in having an option of using static files coming up again, having written myself my first XRD profile by hand, I can't deny it having practical use :) I don't remember details of debate on requesting all account info vs element by element, but couldn't we try to solve it with something like:

https://example.net/.well-known/acct/nick
responding with full profile, or whatever one wants to publish as it

https://example.net/.well-known/acct/nick/some_element
responding with just given part of profile

both could work with generating them on request or just with static files

Also it could handle case which I would like to have available as well for acct:example.net type accounts (without local part) by mapping it simply to:

https://example.net/.well-known/acct

but in such case for selected elements it might require introducing reserved path part like /.el/ or something:
https://example.net/.well-known/acct/.el/some_element

and for our dear [email-masked] then:

https://example.net/.well-known/acct/nick/.el/some_element

?

---

From: William Mills <[email-masked]>
Date: Wed, 29 Aug 2012 13:31:33 -0700 (PDT)

As a query syntax I think path elements are a bad way to go, it's limited in extensibility and flexibilty.  The only real advantage is cacheability.  Query string parameters are better.

> From: ☮ elf Pavlik ☮ <[email-masked]>
>To: webfinger <[email-masked]>; apps-discuss <[email-masked]> 
>Sent: Wednesday, August 29, 2012 1:15 PM
>Subject: [apps-discuss] webfinger: .well-known/acct/nick approach (was: Proposed changes to WebFinger regarding XML vs JSON)
> 
>

---

From: "Paul E. Jones" <[email-masked]>
Date: Wed, 29 Aug 2012 23:07:33 -0400

But what if one wishes to use WebFinger to query for things other than account URIs?

Personally, I don't see a lot of advantages in using this structure.  It certainly looks clean as compared to /host-meta?resource={uri}, but the latter form allows any URI to be provided, including URIs to web pages, devices, or anything else we can associate with the domain.

Paul

> On Behalf Of ? elf Pavlik ?
> Sent: Wednesday, August 29, 2012 4:16 PM
> To: webfinger; apps-discuss
> Subject: [apps-discuss] webfinger: .well-known/acct/nick approach (was:
> Proposed changes to WebFinger regarding XML vs JSON)
> 
> 
> Besides that, I see topic of advantage in having an option of using static
> files coming up again, having written myself my first XRD profile by hand,
> I can't deny it having practical use :) I don't remember details of debate
> on requesting all account info vs element by element, but couldn't we try
> to solve it with something like:
> 
> Also it could handle case which I would like to have available as well for
> acct:example.net type accounts (without local part) by mapping it simply
> to:
> 
> but in such case for selected elements it might require introducing
> reserved path part like /.el/ or something:

---

From: Goix Laurent Walter <[email-masked]>
Date: Thu, 30 Aug 2012 11:55:19 +0200

I am also fine with the json version being privileged in the future.
However we cannot ignore completely that webfinger XML-based implementations already exist (and may not upgrade all together), and we do have already some text written in the draft so instead of deleting entirely what was written we could probably find a way to rephrase it to make it optional for servers to support the xml version (no appendix).

BTW as rfc6415 currently says, jrd is returned only in response to host-meta.json endpoint. If only host-meta is queried, negotiation is required using the accept header. Given the current agreement in the group, is there any change or clarification expected in the wf draft regarding this? In other words, as per current statements both xrd and jrd can already be supported on distinct endpoints, thus simplifying their coexistence. But it seems to me that the group would like some stronger statements towards jrd with no need for ".json" in the endpioint name neither for content negotiation (but as default content). Am I right?

Regards
walter

Da: [email-masked] [mailto:[email-masked]] Per conto di John Bradley
Inviato: martedì 28 agosto 2012 21.13
A: Paul E. Jones
Cc: [email-masked]
Oggetto: Re: [apps-discuss] Proposed changes to WebFinger regarding XML vs JSON

John B.

On 2012-08-28, at 3:03 PM, "Paul E. Jones" <[email-masked]<mailto:[email-masked]>> wrote:

John,

Paul

PS - My personal preference is still to require XML and JSON on the server, but I'm willing to give in on this one in order to reach group consensus.  I think this was the most significant point of contention.

From: John Bradley [mailto:[email-masked]<http://ve7jtb.com>]
Sent: Tuesday, August 28, 2012 2:26 PM
To: Will Norris
Cc: Paul E. Jones; [email-masked]<mailto:[email-masked]>
Subject: Re: [apps-discuss] Proposed changes to WebFinger regarding XML vs JSON

John B.

On 2012-08-27, at 7:13 PM, Will Norris <[email-masked]<mailto:[email-masked]>> wrote:

as one of the editors of said XML format, I'm +1 as well.  The reasons for pushing so heavily for the XML format back then are no longer really true.  Instead, all the active work is on JSON-based formats, so it makes sense to update webfinger as well.
On Mon, Aug 27, 2012 at 2:56 PM, Paul E. Jones <[email-masked]<mailto:[email-masked]>> wrote:
Ok... we could also do that.

> From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]<mailto:[email-masked]>]
> On Behalf Of Blaine Cook
> To: [email-masked]<mailto:[email-masked]>
> On 27 August 2012 18:26, Tim Bray <[email-masked]<mailto:[email-masked]>> wrote:
> > On Mon, Aug 27, 2012 at 9:17 AM, William Mills <[email-masked]<mailto:[email-masked]>>
> wrote:
> >> From: Paul E. Jones <[email-masked]<mailto:[email-masked]>>
> >> To: [email-masked]<mailto:[email-masked]>
> >> Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
> >> [email-masked]<mailto:[email-masked]>
> >> [email-masked]<mailto:[email-masked]>
> > [email-masked]<mailto:[email-masked]>
> [email-masked]<mailto:[email-masked]>

_______________________________________________
apps-discuss mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/apps-discuss

_______________________________________________
apps-discuss mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/apps-discuss

Questo messaggio e i suoi allegati sono indirizzati esclusivamente alle persone indicate. La diffusione, copia o qualsiasi altra azione derivante dalla conoscenza di queste informazioni sono rigorosamente vietate. Qualora abbiate ricevuto questo documento per errore siete cortesemente pregati di darne immediata comunicazione al mittente e di provvedere alla sua distruzione, Grazie.

This e-mail and any attachments is confidential and may contain privileged information intended for the addressee(s) only. Dissemination, copying, printing or use by anybody else is unauthorised. If you are not the intended recipient, please delete this message and any attachments and advise the sender by return e-mail, Thanks.

Rispetta l'ambiente. Non stampare questa mail se non è necessario.

---

From: "Paul E. Jones" <[email-masked]>
Date: Fri, 31 Aug 2012 21:18:10 -0400

Walter,

I believe the group is leaning toward not having the appendix and merely
indicating that JSON is the only format that is mandatory to implement.
I’ll try to re-word it in that way.  In all examples, I will use
host-meta.json.  I do think it would be useful to discuss content
negotiation.  I’ll mention that and provide an example.  Host-meta should
support content negotiation, in my opinion.  However, since XML might not be
implemented, a client may get nothing.

Making JSON the only MTI format does still give me a feeling of uneasiness
since, as you note, every implementation right now is XML.  This will
definitely break that.  However, the push has been pretty strong to go in
this direction.  My own personal preference still remains that servers
implement both, since it’s so darn simple to do.

That said, we would still have a problem with existing servers if they do
not support JSON and a client expected all servers support JSON.  Would
people feel ok with saying that servers should support both XRD and JRD?  Or
is the preference really JRD is MUST and XRD is MAY?

Paul

From: Goix Laurent Walter [mailto:[email-masked]] 
Sent: Thursday, August 30, 2012 5:55 AM
To: John Bradley; Paul E. Jones
Cc: [email-masked]
Subject: R: [apps-discuss] Proposed changes to WebFinger regarding XML vs
JSON

However we cannot ignore completely that webfinger XML-based implementations
already exist (and may not upgrade all together), and we do have already
some text written in the draft so instead of deleting entirely what was
written we could probably find a way to rephrase it to make it optional for
servers to support the xml version (no appendix). 

BTW as rfc6415 currently says, jrd is returned only in response to
host-meta.json endpoint. If only host-meta is queried, negotiation is
required using the accept header. Given the current agreement in the group,
is there any change or clarification expected in the wf draft regarding
this? In other words, as per current statements both xrd and jrd can already
be supported on distinct endpoints, thus simplifying their coexistence. But
it seems to me that the group would like some stronger statements towards
jrd with no need for “.json” in the endpioint name neither for content
negotiation (but as default content). Am I right?

Regards

walter

Da: [email-masked] [mailto:[email-masked]] Per
conto di John Bradley
Inviato: martedì 28 agosto 2012 21.13
A: Paul E. Jones
Cc: [email-masked]
Oggetto: Re: [apps-discuss] Proposed changes to WebFinger regarding XML vs
JSON

I understand, but I think forcing servers to support both will hurt
adoption, though not as much as requiring it on the client.

John B.

John,

Paul

PS – My personal preference is still to require XML and JSON on the server,
but I’m willing to give in on this one in order to reach group consensus.  I
think this was the most significant point of contention.

John B.

On 2012-08-27, at 7:13 PM, Will Norris < <mailto:[email-masked]>
[email-masked]> wrote:

On Mon, Aug 27, 2012 at 2:56 PM, Paul E. Jones <
<mailto:[email-masked]> [email-masked]> wrote:

> From:  <mailto:[email-masked]>
[email-masked] [mailto:
<mailto:[email-masked]> [email-masked]]
> To:  <mailto:[email-masked]> [email-masked]
> On 27 August 2012 18:26, Tim Bray < <mailto:[email-masked]>
[email-masked]> wrote:
> > On Mon, Aug 27, 2012 at 9:17 AM, William Mills <
<mailto:[email-masked]> [email-masked]>
> >> From: Paul E. Jones < <mailto:[email-masked]>
[email-masked]>
> >> To:  <mailto:[email-masked]> [email-masked]
> >> Cc:  <mailto:[email-masked]> [email-masked];
<mailto:[email-masked]> [email-masked]
> >>  <mailto:[email-masked]> [email-masked]
> >>  <https://www.ietf.org/mailman/listinfo/apps-discuss>
> >>  <mailto:[email-masked]> [email-masked]
> >>  <https://www.ietf.org/mailman/listinfo/apps-discuss>
> >  <mailto:[email-masked]> [email-masked]
> >  <https://www.ietf.org/mailman/listinfo/apps-discuss>
>  <mailto:[email-masked]> [email-masked]
>  <https://www.ietf.org/mailman/listinfo/apps-discuss>

_______________________________________________
apps-discuss mailing list
 <mailto:[email-masked]> [email-masked]
 <https://www.ietf.org/mailman/listinfo/apps-discuss>
https://www.ietf.org/mailman/listinfo/apps-discuss

_______________________________________________
apps-discuss mailing list
 <mailto:[email-masked]> [email-masked]
 <https://www.ietf.org/mailman/listinfo/apps-discuss>
https://www.ietf.org/mailman/listinfo/apps-discuss

Questo messaggio e i suoi allegati sono indirizzati esclusivamente alle
persone indicate. La diffusione, copia o qualsiasi altra azione derivante
dalla conoscenza di queste informazioni sono rigorosamente vietate. Qualora
abbiate ricevuto questo documento per errore siete cortesemente pregati di
darne immediata comunicazione al mittente e di provvedere alla sua
distruzione, Grazie. 

This e-mail and any attachments is confidential and may contain privileged
information intended for the addressee(s) only. Dissemination, copying,
printing or use by anybody else is unauthorised. If you are not the intended
recipient, please delete this message and any attachments and advise the
sender by return e-mail, Thanks. 

rispetta l'ambienteRispetta l'ambiente. Non stampare questa mail se non è
necessario.

---

From: John Bradley <[email-masked]>
Date: Fri, 31 Aug 2012 21:28:24 -0400

JRD is a MUST , XRD and other serializations is a MAY. 

Sent from my iPhone

On 2012-08-31, at 9:18 PM, "Paul E. Jones" <[email-masked]> wrote:

> Walter,
>  
> I believe the group is leaning toward not having the appendix and merely indicating that JSON is the only format that is mandatory to implement.  I’ll try to re-word it in that way.  In all examples, I will use host-meta.json.  I do think it would be useful to discuss content negotiation.  I’ll mention that and provide an example.  Host-meta should support content negotiation, in my opinion.  However, since XML might not be implemented, a client may get nothing.
>  
> Making JSON the only MTI format does still give me a feeling of uneasiness since, as you note, every implementation right now is XML.  This will definitely break that.  However, the push has been pretty strong to go in this direction.  My own personal preference still remains that servers implement both, since it’s so darn simple to do.
>  
> That said, we would still have a problem with existing servers if they do not support JSON and a client expected all servers support JSON.  Would people feel ok with saying that servers should support both XRD and JRD?  Or is the preference really JRD is MUST and XRD is MAY?
>  
> Paul
>  
> Subject: R: [apps-discuss] Proposed changes to WebFinger regarding XML vs JSON
>  
> BTW as rfc6415 currently says, jrd is returned only in response to host-meta.json endpoint. If only host-meta is queried, negotiation is required using the accept header. Given the current agreement in the group, is there any change or clarification expected in the wf draft regarding this? In other words, as per current statements both xrd and jrd can already be supported on distinct endpoints, thus simplifying their coexistence. But it seems to me that the group would like some stronger statements towards jrd with no need for “.json” in the endpioint name neither for content negotiation (but as default content). Am I right?
>  
> Regards
> walter
>

---

From: John Panzer <[email-masked]>
Date: Fri, 31 Aug 2012 18:31:59 -0700

+1
On Aug 31, 2012 6:29 PM, "John Bradley" <[email-masked]> wrote:

> Walter,****
> ** **
> support content negotiation, in my opinion.  However, since XML might not
> be implemented, a client may get nothing.****
>
> ** **
>
> implement both, since it’s so darn simple to do.****
>
> ** **
>
> people feel ok with saying that servers *should* support both XRD and
> JRD?  Or is the preference really JRD is MUST and XRD is MAY?****
>
> ** **
>
> Paul****
>
> ** **
>
> *From:* Goix Laurent Walter [mailto:[email-masked]]
> *Sent:* Thursday, August 30, 2012 5:55 AM
> *To:* John Bradley; Paul E. Jones
> *Cc:* [email-masked]
> *Subject:* R: [apps-discuss] Proposed changes to WebFinger regarding XML
> vs JSON****
>
> ** **
>
> I am also fine with the json version being privileged in the future.****
>
> However we cannot ignore completely that webfinger XML-based
> implementations already exist (and may not upgrade all together), and we do
> have already some text written in the draft so instead of deleting entirely
> what was written we could probably find a way to rephrase it to make it
> optional for servers to support the xml version (no appendix). ****
>
> ** **
>
> this? In other words, as per current statements both xrd and jrd can
> already be supported on distinct endpoints, thus simplifying their
> coexistence. But it seems to me that the group would like some stronger
> statements towards jrd with no need for “.json” in the endpioint name
> neither for content negotiation (but as default content). Am I right?****
>
> ** **
>
> Regards****
>
> walter****
>
> ** **
>
> *Da:* [email-masked] [mailto:[email-masked]]
> *Per conto di *John Bradley
> *Inviato:* martedì 28 agosto 2012 21.13
> *A:* Paul E. Jones
> *Cc:* [email-masked]
> *Oggetto:* Re: [apps-discuss] Proposed changes to WebFinger regarding XML
> vs JSON****
>
> ** **
>
> adoption, though not as much as requiring it on the client.****
>
> ** **
>
> John B.****
>
> ** **
>
> ** **
>
> On 2012-08-28, at 3:03 PM, "Paul E. Jones" <[email-masked]> wrote:*
> ***
>
> ** **
>
> John,****
>
>  ****
>
> they want.****
>  ****
> If we make the proposed change, XML will be dropped on the server side.
> The result will be that clients can only rely on JSON support.  XML support
> might be rare.****
>
>  ****
>
> Paul****
>
>  ****
>
> PS – My personal preference is still to require XML and JSON on the
> server, but I’m willing to give in on this one in order to reach group
> consensus.  I think this was the most significant point of contention.****
>
>  ****
>
> *From:* John Bradley [mailto:[email-masked]]
> *Sent:* Tuesday, August 28, 2012 2:26 PM
> *To:* Will Norris
> *Cc:* Paul E. Jones; [email-masked]
> *Subject:* Re: [apps-discuss] Proposed changes to WebFinger regarding XML
> vs JSON****
>
>  ****
>
> +1 JSON must be MTI for servers.****
>
>  ****
>
> JSON, and not forced to support XML for some servers.****
>
>  ****
>
> John B.****
>
>  ****
>
> On 2012-08-27, at 7:13 PM, Will Norris <[email-masked]> wrote:****
>
>
>
> ****
>
> to update webfinger as well.****
>
> wrote:****
> Ok... we could also do that.****
>
>
> https://www.ietf.org/mailman/listinfo/apps-discuss****
>
>
> https://www.ietf.org/mailman/listinfo/apps-discuss****
>
> ** **
>
> distruzione, Grazie. ****
>
> *This e-mail and any attachments** is **confidential and may contain
> privileged information intended for the addressee(s) only. Dissemination,
> copying, printing or use by anybody else is unauthorised. If you are not
> the intended recipient, please delete this message and any attachments and
> advise the sender by return e-mail, Thanks.* ****
>
> *Rispetta l'ambiente. Non stampare questa mail se non è
> necessario.* ****
>
> ** **
>
>

---

From: "Paul E. Jones" <[email-masked]>
Date: Fri, 31 Aug 2012 21:54:42 -0400

OK … I’ll word it that way.

From: John Bradley [mailto:[email-masked]] 
Sent: Friday, August 31, 2012 9:28 PM
To: Paul E. Jones
Cc: Goix Laurent Walter; <[email-masked]>
Subject: Re: [apps-discuss] Proposed changes to WebFinger regarding XML vs JSON

Sent from my iPhone

Walter,

Paul

Regards

walter

John B.

John,

Paul

John B.

On 2012-08-27, at 7:13 PM, Will Norris < <mailto:[email-masked]> [email-masked]> wrote:

On Mon, Aug 27, 2012 at 2:56 PM, Paul E. Jones < <mailto:[email-masked]> [email-masked]> wrote:

> From:  <mailto:[email-masked]> [email-masked] [mailto: <mailto:[email-masked]> [email-masked]]
> On Behalf Of Blaine Cook
> On 27 August 2012 18:26, Tim Bray < <mailto:[email-masked]> [email-masked]> wrote:
> > On Mon, Aug 27, 2012 at 9:17 AM, William Mills < <mailto:[email-masked]> [email-masked]>
> wrote:
> >> From: Paul E. Jones < <mailto:[email-masked]> [email-masked]>
> >> Cc:  <mailto:[email-masked]> [email-masked];  <mailto:[email-masked]> [email-masked]
> >>  <https://www.ietf.org/mailman/listinfo/apps-discuss> https://www.ietf.org/mailman/listinfo/apps-discuss
> >>
> >>
> >>
> >>  <https://www.ietf.org/mailman/listinfo/apps-discuss> https://www.ietf.org/mailman/listinfo/apps-discuss
> >>
> >  <https://www.ietf.org/mailman/listinfo/apps-discuss> https://www.ietf.org/mailman/listinfo/apps-discuss
>  <https://www.ietf.org/mailman/listinfo/apps-discuss> https://www.ietf.org/mailman/listinfo/apps-discuss

_______________________________________________
apps-discuss mailing list
 <mailto:[email-masked]> [email-masked]
 <https://www.ietf.org/mailman/listinfo/apps-discuss> https://www.ietf.org/mailman/listinfo/apps-discuss

_______________________________________________
apps-discuss mailing list
 <mailto:[email-masked]> [email-masked]
 <https://www.ietf.org/mailman/listinfo/apps-discuss> https://www.ietf.org/mailman/listinfo/apps-discuss

---

From: William Mills <[email-masked]>
Date: Fri, 31 Aug 2012 19:57:22 -0700 (PDT)

I'm in favor of mentioning legacy applications using XML and referring to the original spec there, just to make it clear that there is an installed base.

>To: 'Goix Laurent Walter' <[email-masked]>; 'John Bradley' <[email-masked]> 
>Sent: Friday, August 31, 2012 6:18 PM
>From:Goix Laurent Walter [mailto:[email-masked]] 
>Da:[email-masked] [mailto:[email-masked]] Per conto di John Bradley

---

From: Nat Sakimura <[email-masked]>
Date: Sat, 1 Sep 2012 14:39:17 +0900

I vote for just referencing.

=nat via iPhone