Subject: Re: [apps-discuss] New version of I-D for ENUM service for acct URI

From: Salvatore Loreto <[email-masked]>
Date: Mon, 29 Oct 2012 15:12:59 +0200

I have read the last version of the draft, and I think that is more then
reasonable and useful register an
ENUM service for 'acct' URIs.

from Section 3, it is not completely clear to me if OMA Social Network
Enabler will be built on acct URI,
or it is just an example to highlight the need to translate MSISDN to
"information about people on the Internet".

moreover it is also not clear to what specific acct URI it will be mapped.
I mean is it limited to the one provided by the telecom service provider
or it can be any acct URIs

thanks
Salvatore

-- 
Salvatore Loreto, PhD
www.sloreto.com

On 9/13/12 3:38 AM, Likepeng wrote:
>
> Just to clarify that in the previous enum-sn-service draft, it only
> focuses on social network account.
>
> Now in the new enum-acct-uri draft, we change that to acct uri, don’t
> limit it to social network account.
>
> We received many valuable offline discussion comments for the previous
> draft, hope to get feedback to the new draft.
>
> Thanks,
>
> Kind Regards
>
> Kepeng
>
> *发件人:*Goix Laurent Walter [mailto:[email-masked]]
> *发送 时间:*2012年9月11日21:54
> *收件人:[email-masked]
> *抄送:*Likepeng
> *主题:*New version of I-D for ENUM service for acct URI
>
> Dear all,
>
> I just uploaded this draft [1] as a revision of former
> draft-goix-appsawg-enum-sn-service-02 based on the discussion held in
> Vancouver.
>
> In particular the text was generalized and a use cases section was
> added to clarify the problem to be solved as requested by Dave.
>
> We also expanded the security section to clarify potential privacy
> issues as requested by Ted and Hannes, further clarifying why
> inserting link rel endpoint directly in ENUM itself are not
> appropriate. The example was slightly revised as well.
>
> Finally, on whether RAI or APPS should handle this draft, the authors
> sponsor APPS, and in particular APPSAWG, which already handles the
> webfinger and acct uri drafts and the related experts. Enum experts
> already performed a sanity check on previous versions of this draft.
>
> We welcome your feedback on this revision.
>
> Walter
>
> [1] http://tools.ietf.org/html/draft-goix-appsawg-enum-acct-uri-00
>
> Questo messaggio e i suoi allegati sono indirizzati esclusivamente
> alle persone indicate. La diffusione, copia o qualsiasi altra azione
> derivante dalla conoscenza di queste informazioni sono rigorosamente
> vietate. Qualora abbiate ricevuto questo documento per errore siete
> cortesemente pregati di darne immediata comunicazione al mittente e di
> provvedere alla sua distruzione, Grazie.
>
> /This e-mail and any attachments//is //confidential and may contain
> privileged information intended for the addressee(s) only.
> Dissemination, copying, printing or use by anybody else is
> unauthorised. If you are not the intended recipient, please delete
> this message and any attachments and advise the sender by return
> e-mail, Thanks./
>
> *rispetta l'ambienteRispetta l'ambiente. Non stampare questa mail se
> non è necessario.*
>

---

From: Goix Laurent Walter <[email-masked]>
Date: Mon, 29 Oct 2012 16:17:54 +0100

Thank you salvatore for the review. My answers inline

Da: [email-masked] [mailto:[email-masked]] Per conto di Salvatore Loreto
Inviato: lunedì 29 ottobre 2012 14.13
A: [email-masked]
Oggetto: Re: [apps-discuss] New version of I-D for ENUM service for acct URI

I have read the last version of the draft, and I think that is more then reasonable and useful register  an
ENUM service for 'acct' URIs.

from Section 3, it is not completely clear to me if OMA Social Network Enabler will be built on acct URI,
or it is just an example to highlight the need to translate MSISDN to "information about people on the Internet".

[walter] indeed the enabler builds on acct : URIs. Support for acct: and tel: URI schemes is mandated in the spec (optionally other may be supported), also to interoperate with non-mobile social networks. Reference to this enum draft is also part of the spec of course. I may clarify this in the text if you have some suggestion.

moreover it is also not clear to what specific acct URI it will be mapped.
I mean is it limited to the one provided by the telecom service provider or it can be any acct URIs
[walter] although i expect this to be the main use case (mainly solving the authoritative telco for that number) it may not always be the case. For example if that number Is a company-provided mobile number, it may also point to the related account (just like you could find both details on a business card). I could cite this use case in the example section if you believe it is relevant.

walter

thanks
Salvatore

--

Salvatore Loreto, PhD

www.sloreto.com<http://www.sloreto.com>

On 9/13/12 3:38 AM, Likepeng wrote:
Just to clarify that in the previous enum-sn-service draft, it only focuses on social network account.

Now in the new enum-acct-uri draft, we change that to acct uri, don’t limit it to social network account.

We received many valuable offline discussion comments for the previous draft, hope to get feedback to the new draft.

Thanks,

Kind Regards
Kepeng

发件人: Goix Laurent Walter [mailto:[email-masked]]
发送 时间: 2012年9月11日 21:54
收件人: [email-masked]<mailto:[email-masked]>
抄送: Likepeng
主题: New version of I-D for ENUM service for acct URI

Dear all,

I just uploaded this draft [1] as a revision of former draft-goix-appsawg-enum-sn-service-02 based on the discussion held in Vancouver.

In particular the text was generalized and a use cases section was added to clarify the problem to be solved as requested by Dave.
We also expanded the security section to clarify potential privacy issues as requested by Ted and Hannes, further clarifying why inserting link rel endpoint directly in ENUM itself are not appropriate. The example was slightly revised as well.

Finally, on whether RAI or APPS should handle this draft, the authors sponsor APPS, and in particular APPSAWG, which already handles the webfinger and acct uri drafts and the related experts. Enum experts already performed a sanity check on previous versions of this draft.

Questo messaggio e i suoi allegati sono indirizzati esclusivamente alle persone indicate. La diffusione, copia o qualsiasi altra azione derivante dalla conoscenza di queste informazioni sono rigorosamente vietate. Qualora abbiate ricevuto questo documento per errore siete cortesemente pregati di darne immediata comunicazione al mittente e di provvedere alla sua distruzione, Grazie.

This e-mail and any attachments is confidential and may contain privileged information intended for the addressee(s) only. Dissemination, copying, printing or use by anybody else is unauthorised. If you are not the intended recipient, please delete this message and any attachments and advise the sender by return e-mail, Thanks.
Rispetta l'ambiente. Non stampare questa mail se non è necessario.

Questo messaggio e i suoi allegati sono indirizzati esclusivamente alle persone indicate. La diffusione, copia o qualsiasi altra azione derivante dalla conoscenza di queste informazioni sono rigorosamente vietate. Qualora abbiate ricevuto questo documento per errore siete cortesemente pregati di darne immediata comunicazione al mittente e di provvedere alla sua distruzione, Grazie.

This e-mail and any attachments is confidential and may contain privileged information intended for the addressee(s) only. Dissemination, copying, printing or use by anybody else is unauthorised. If you are not the intended recipient, please delete this message and any attachments and advise the sender by return e-mail, Thanks.

Rispetta l'ambiente. Non stampare questa mail se non è necessario.