Subject: [apps-discuss] Link type registry for OAuth draft

From: William Mills <[email-masked]>
Date: Mon, 1 Oct 2012 09:12:35 -0700 (PDT)

I think the link registry for OAuth 2 is pretty close to done, especially with Goix Laurent Walter's recent review.  If one or two more folks could give it a read that would be great.

http://tools.ietf.org/id/draft-wmills-oauth-lrdd-03.html

Thanks,

-bill

---

From: William Mills <[email-masked]>
Date: Sun, 7 Oct 2012 08:43:47 -0700 (PDT)

There has been one further review of this (thanks Mark) and the title has been corrected (as has the subject line of this message).  As an individual submission does this get a WGLC through this WG?  

Thanks,

-bill

>________________________________
> From: William Mills <[email-masked]>
>To: Apps Discuss <[email-masked]> 
>Sent: Monday, October 1, 2012 9:12 AM
>Subject: Link type registry for OAuth draft
> 
>

---

From: SM <[email-masked]>
Date: Sun, 07 Oct 2012 09:04:48 -0700

Hi Bill,
At 08:43 07-10-2012, William Mills wrote:
>There has been one further review of this (thanks Mark) and the 
>title has been corrected (as has the subject line of this 
>message).  As an individual submission does this get a WGLC through this WG?

No.  A working group would have to adopt the draft for it to go 
through a WGLC.  I'll send some quick nits.

The text in the Abstract Section needs to be reworded.  The title 
mentions "OAuth 2" while there is text about "OAuth 1a" in the draft.

In Section 2:

   "In examplesl ine breaks have been inserted for readability."

This is a typo.

I don't see why RFC 2119 key words are used in the IANA 
Considerations section.  The draft has examples in Section 5.  I 
don't see what that has to do with registries.  Section 3 mentions that:

   "This document is informational, defining values in existing
    registries, and as such has no security properties to discuss."

Regards,
-sm

---

From: William Mills <[email-masked]>
Date: Sun, 7 Oct 2012 11:47:04 -0700 (PDT)

So examples are not needed here?

> From: SM <[email-masked]>
>To: William Mills <[email-masked]> 
>Cc: Apps Discuss <[email-masked]> 
>Sent: Sunday, October 7, 2012 9:04 AM
>Subject: Re: [apps-discuss] Link type registration for OAuth draft
> 
>Hi Bill,
>No.  A working group would have to adopt the draft for it to go through a WGLC.  I'll send some quick nits.
>
>The text in the Abstract Section needs to be reworded.  The title mentions "OAuth 2" while there is text about "OAuth 1a" in the draft.
>
>In Section 2:
>
>I don't see why RFC 2119 key words are used in the IANA Considerations section.  The draft has examples in Section 5.  I don't see what that has to do with registries.  Section 3 mentions that:
>

---

From: William Mills <[email-masked]>
Date: Sun, 7 Oct 2012 11:52:24 -0700 (PDT)

Fixed the 2 obvious corrections, thank you.

Can an individual submission proceed without a WG?  If so how do I do that?  Or is Apps willing to take this up?

---

From: SM <[email-masked]>
Date: Sun, 07 Oct 2012 12:04:15 -0700

Hi Bill,
>So examples are not needed here?

I don't think that the examples are needed in this draft as the 
purpose of the draft is to do the registrations. The examples would 
be a better fit in the technical specification.

Regards,
-sm

---

From: SM <[email-masked]>
Date: Sun, 07 Oct 2012 12:10:07 -0700

Hi Bill,
At 11:52 07-10-2012, William Mills wrote:
>Can an individual submission proceed without a WG?  If so how do I 
>do that?  Or is Apps willing to take this up?

Yes.  You could contact the Apps ADs ([email-masked]) to 
sponsor the draft if it is an Individual Submission.  The draft only 
goes through a Last Call once it is ready for publication.

Regards,
-sm

---

From: William Mills <[email-masked]>
Date: Sun, 7 Oct 2012 19:51:46 -0700 (PDT)

Fair enough.  I can pull the examples.

>Sent: Sunday, October 7, 2012 12:04 PM
>I don't think that the examples are needed in this draft as the purpose of the draft is to do the registrations. The examples would be a better fit in the technical specification.
>
>Regards,
>-sm 
>
>
>