Subject: [apps-discuss] Media Type for HTML 'snippets'?

From: Jan Algermissen <[email-masked]>
Date: Wed, 10 Oct 2012 13:03:44 +0200

Hi,

I am looking for an appropriate media type to use when serving HTML snippets that have a <div> as their root element.

I feel that serving HTML document fragments has become such a common scenario, I think there must be some solution already. However - I cannot find anything appropriate.

The closest thing is likely Atom's type attribute: http://tools.ietf.org/html/rfc4287#section-3.1.1.3

Can anyone provide a pointer or ideas?

Or is it time probably time for application/xhtml-div+xml

Jan

---

From: Jon Moore <[email-masked]>
Date: Wed, 10 Oct 2012 07:33:17 -0400

> Or is it time probably time for application/xhtml-div+xml

Is this sufficient? Not all valid HTML snippets are valid XML. Does this need to be application/html-div+sgml? (Which begs the question: has someone documented application/sgml?)

Jon

---

From: Jan Algermissen <[email-masked]>
Date: Wed, 10 Oct 2012 13:38:29 +0200

On Oct 10, 2012, at 1:33 PM, Jon Moore wrote:

> Is this sufficient? Not all valid HTML snippets are valid XML.

I would be inclined to require just that. SGML days should be considered over, IMHO. 

(At least on the Web. I guess Boeing, DOD et al. are SGML-bound for some time to come, eh? :-)

Jan

> Does this need to be application/html-div+sgml? (Which begs the question: has someone documented application/sgml?)
> 
> Jon