Subject: [apps-discuss] Solving the file format problem

From: Paul Hoffman <[email-masked]>
Date: Sat, 27 Oct 2012 09:43:59 -0700

There are many people on this list that care a lot about Internet applications but are not active in IETF protocol work who might be wondering how they can help. If you are such a person (or you are active in the IETF *and* you care about the problem of having a zillion file formats), maybe take a look at <http://justsolve.archiveteam.org>. This is a one-month sprint to add to the catalog of formats from the past and present and document or create conversion programs that will allow someone holding an item that is in a "dead" format to retrieve the useful data from it. A recent blog post from the organizer is here: <http://ascii.textfiles.com/archives/3730>. There are lots of opportunities for people on all levels of ability.

To be clear, the effort is about formats that are in stored files, not on-the-wire protocols. Although the latter is the focus of the IETF Applications Area, the former was important to us not that many decades ago.

--Paul Hoffman

---

From: Mark Nottingham <[email-masked]>
Date: Mon, 29 Oct 2012 10:35:02 +1100

The fact that <http://justsolve.archiveteam.org/index.php/Original_Plan#List_of_Places_Keeping_Track_of_Formats> does not list <http://www.iana.org/assignments/media-types/index.html> says something; I'm not sure who about, but I doubt it's good.

On 28/10/2012, at 3:43 AM, Paul Hoffman <[email-masked]> wrote:

> _______________________________________________
> apps-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/apps-discuss

--
Mark Nottingham   http://www.mnot.net/

---

From: Paul Hoffman <[email-masked]>
Date: Sun, 28 Oct 2012 16:58:05 -0700

> The fact that <http://justsolve.archiveteam.org/index.php/Original_Plan#List_of_Places_Keeping_Track_of_Formats> does not list <http://www.iana.org/assignments/media-types/index.html> says somethin…

One could argue that the IANA registry is not meant to be a list of formats, just the small subset for which there are registered types. If there are formats in the IANA registry that aren't on that list, that would be an issue, but I don't think that's the case.

--Paul Hoffman

---

From: Ned Freed <[email-masked]>
Date: Mon, 29 Oct 2012 02:21:24 -0700 (PDT)

> > The fact that
> > <http://justsolve.archiveteam.org/index.php/Original_Plan#List_of_Places_Keeping_Track_of_Formats>
> > does not list <http://www.iana.org/assignments/media-types/index.html> says
> > something; I'm not sure who about, but I doubt it's good.

I concur.

> One could argue that the IANA registry is not meant to be a list of formats,
> just the small subset for which there are registered types.

Except that registering a type is good hygiene for any format intended for
transfer or storage on the Internet.

It used to be the case that type registration was considered to be something
reserved for a subset of formats, but that notion died an unlamented death
with the publication of RFC 4288, if not earlier.

				Ned

---

From: John C Klensin <[email-masked]>
Date: Mon, 29 Oct 2012 07:40:39 -0400

--On Monday, October 29, 2012 02:21 -0700 Ned Freed
<[email-masked]> wrote:

>> > <http://justsolve.archiveteam.org/index.php/Original_Plan#L
>> > ist_of_Places_Keeping_Track_of_Formats> does not list
>> > <http://www.iana.org/assignments/media-types/index.html>
>> > says something; I'm not sure who about, but I doubt it's
>> > good.
> 
> I concur.

Agreed.  The same comment would apply to
Content-transfer-encodings and I note that, at least as of some
hours ago, Base64 and Quoted-printable did not seem to be on the
list.

>...

The list itself has become both redundant (with many things
listed more than once) and a little strange, mixing hardware and
physical formats without distinction from actual file formats.
For example, "paper tape", "1/2 inch open reel tape", and "IBM
[punch?] cards" aren't file formats (although many file formats
were used with each, most of them not on the list either) nor
are they even sufficiently precise enough physical or logical
formats to be useful.   I'm aware of at least two, physically
incompatible, paper tape formats and would be not at all
surprised if there are more, open reel magnetic tape came in at
least 7 and 9 bit formats (again mutually incompatible wrt
reader/writer heads), and those punched cards existed in both
row formats and the more familiar column ones.   

As with media types, the observation that people didn't manage
to even recognize those differences enough to organize things
into categories before there were well over a thousand entries
on the list doesn't bode well for this project, even as a
catalog.

  john