Subject: [apps-discuss] FW: New Version Notification for draft-lilley-xml-mediatypes-00.txt

From: Chris Lilley <[email-masked]>
Date: Thu, 1 Nov 2012 12:01:00 +0100

Hello apps-discuss,

draft-lilley-xml-mediatypes-00.txt is a restart of a proposed replacement for RFC3023. The previous attempt foundered because the approach taken required deprecation of text/xml, and the implementor community was not happy with that as there is much legacy content using that type that still has to be supported.

The present draft takes advantage of recent changes in HTTP-bis which removes the default charset, and so treats text/xml the same as application/xml. This approach is also what most implementations already do, in practice. The present draft also introduces some clarifications on fragment identifiers for xml, and updates some references.

It has been suggested that this document would be a good fit for the apps area WG, and the editors would like to request review and adoption by the WG (or an alternative suggestion of where/how to handle this document).

This would be a standards-track document.

-- 
 Chris Lilley   Technical Director, Interaction Domain                 
 W3C Graphics Activity Lead, Fonts Activity Lead
 Co-Chair, W3C Hypertext CG
 Member, CSS, WebFonts, SVG Working Groups

Subject: New Version Notification for draft-lilley-xml-mediatypes-00.txt
From: [email-masked]
To: [email-masked]
Cc: [email-masked], [email-masked], [email-masked]
Date: Mon, 15 Oct 2012 04:49:36 -0700

A new version of I-D, draft-lilley-xml-mediatypes-00.txt
has been successfully submitted by Henry S. Thompson and posted to the
IETF repository.

Filename:	 draft-lilley-xml-mediatypes
Revision:	 00
Title:		 XML Media Types
Creation date:	 2012-10-15
WG ID:		 Individual Submission
Number of pages: 35
URL:             http://www.ietf.org/internet-drafts/draft-lilley-xml-mediatypes-00.txt
Status:          http://datatracker.ietf.org/doc/draft-lilley-xml-mediatypes
Htmlized:        http://tools.ietf.org/html/draft-lilley-xml-mediatypes-00

Abstract:
   This specification standardizes three media types -- application/xml,
   application/xml-external-parsed-entity, and application/xml-dtd --
   for use in exchanging network entities that are related to the
   Extensible Markup Language (XML) while defining text/xml and text/
   xml-external-parsed-entity as aliases for the respective application/
   types.  This specification also standardizes a convention (using the
   suffix '+xml') for naming media types outside of these five types
   when those media types represent XML MIME entities.  XML MIME
   entities are currently exchanged via the HyperText Transfer Protocol
   on the World Wide Web, are an integral part of the WebDAV protocol
   for remote web authoring, and are expected to have utility in many
   domains.

   Major differences from [RFC3023] are alignment of charset handling
   for text/xml and text/xml-external-parsed-entity with application/
   xml, the addition of XPointer and XML Base as fragment identifiers
   and base URIs, respectively, mention of the XPointer Registry, and
   updating of many references.

The IETF Secretariat

---

From: Julian Reschke <[email-masked]>
Date: Wed, 07 Nov 2012 13:45:13 +0100

> draft-lilley-xml-mediatypes-00.txt is a restart of a proposed replacement for RFC3023. The previous attempt foundered because the approach taken required deprecation of text/xml, and the implemento…

Useful links:

Draft: <http://tools.ietf.org/html/draft-lilley-xml-mediatypes-00>

Diff from RFC 3023: 
<http://tools.ietf.org//rfcdiff?url1=rfc3023&url2=draft-lilley-xml-mediatypes-00>

> The present draft takes advantage of recent changes in HTTP-bis which removes the default charset, and so treats text/xml the same as application/xml. This approach is also what most implementation…

Nit: you need to work on that HTTPbis reference :-).

> This would be a standards-track document.

+1 on doing this over here.

I believe it would be good to start from RFC 3023, to raise issues, and 
then to resolve them one by one (re-playing the changes that the ID 
contains).

Best regards, Julian

---

From: "Murray S. Kucherawy" <[email-masked]>
Date: Thu, 15 Nov 2012 06:36:16 -0800

So far there's been only one expression of support for processing this
through appsawg.  Are there any others?  Any objections to processing it
here?  Other suggestions?

-MSK, co-chair

On Thu, Nov 1, 2012 at 4:01 AM, Chris Lilley <[email-masked]> wrote:

> Hello apps-discuss,
>
> draft-lilley-xml-mediatypes-00.txt is a restart of a proposed replacement
> for RFC3023. The previous attempt foundered because the approach taken
> required deprecation of text/xml, and the implementor community was not
> happy with that as there is much legacy content using that type that still
> has to be supported.
>
> The present draft takes advantage of recent changes in HTTP-bis which
> removes the default charset, and so treats text/xml the same as
> application/xml. This approach is also what most implementations already
> do, in practice. The present draft also introduces some clarifications on
> fragment identifiers for xml, and updates some references.
>
> It has been suggested that this document would be a good fit for the apps
> area WG, and the editors would like to request review and adoption by the
> WG (or an alternative suggestion of where/how to handle this document).
>
> _______________________________________________
> apps-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/apps-discuss
>
>

---

From: Tim Bray <[email-masked]>
Date: Thu, 15 Nov 2012 15:41:46 +0100

I would support APPSAWG taking it up.  3023 is so horribly wrong, it would
be good to have a sane replacement. -T

---

From: SM <[email-masked]>
Date: Thu, 15 Nov 2012 11:47:45 -0800

At 06:36 15-11-2012, Murray S. Kucherawy wrote:
>So far there's been only one expression of support for processing 
>this through appsawg.  Are there any others?  Any objections to 
>processing it here?  Other suggestions?

This draft seems like RFC 3023bis.  It requires MIME, URI, XML and 
Internationalization expertise.  It is difficult to assess the extent 
of the work.  I'll commit to review as I have to give something back 
to two of the authors for having volunteered their time for other work.

Regards,
-sm

---

From: Tony Hansen <[email-masked]>
Date: Thu, 15 Nov 2012 15:25:42 -0500

I support it.

     Tony

On 11/15/2012 9:36 AM, Murray S. Kucherawy wrote:
> through appsawg.  Are there any others?  Any objections to processing 
> it here?  Other suggestions?
>
> -MSK, co-chair
>
>
> On Thu, Nov 1, 2012 at 4:01 AM, Chris Lilley <[email-masked] 
> <mailto:[email-masked]>> wrote:
>
>     Hello apps-discuss,
>
>     draft-lilley-xml-mediatypes-00.txt is a restart of a proposed
>     replacement for RFC3023. The previous attempt foundered because
>     the approach taken required deprecation of text/xml, and the
>     implementor community was not happy with that as there is much
>     legacy content using that type that still has to be supported.
>
>     The present draft takes advantage of recent changes in HTTP-bis
>     which removes the default charset, and so treats text/xml the same
>     as application/xml. This approach is also what most
>     implementations already do, in practice. The present draft also
>     introduces some clarifications on fragment identifiers for xml,
>     and updates some references.
>
>     It has been suggested that this document would be a good fit for
>     the apps area WG, and the editors would like to request review and
>     adoption by the WG (or an alternative suggestion of where/how to
>     handle this document).
>
>     [email-masked] <mailto:[email-masked]>

---

From: "Martin J. Dürst" <[email-masked]>
Date: Fri, 16 Nov 2012 14:02:24 +0900

I agree with APPSAWG taking it up. 3023 is really outdated, and needs to 
be fixed.

Regards,   Martin.

On 2012/11/15 23:41, Tim Bray wrote:
> On Thu, Nov 15, 2012 at 3:36 PM, Murray S. Kucherawy<[email-masked]>wrote:
>
>> On Thu, Nov 1, 2012 at 4:01 AM, Chris Lilley<[email-masked]>  wrote:
>>
>>> Hello apps-discuss,
>>>

---

From: "Murray S. Kucherawy" <[email-masked]>
Date: Thu, 15 Nov 2012 23:35:52 -0800

Are the people agreeing that it should be processed in appsawg (Julian,
Martin, Tony, and Tim so far; hopefully others) committing to doing reviews
if we adopt this document?  SM has already said he will.

-MSK

On Thu, Nov 15, 2012 at 9:02 PM, "Martin J. Dürst"
<[email-masked]>wrote:

>> On Thu, Nov 15, 2012 at 3:36 PM, Murray S. Kucherawy<[email-masked]>
>> **wrote:
>>
>>>> draft-lilley-xml-mediatypes-**00.txt is a restart of a proposed
>>>> replacement
>>>> ______________________________**_________________
>>>> https://www.ietf.org/mailman/**listinfo/apps-discuss<https://www.ietf.org/mailman/listinfo/apps-discuss>
>>>>
>>>>
>>>>
>>> ______________________________**_________________
>>> https://www.ietf.org/mailman/**listinfo/apps-discuss<https://www.ietf.org/mailman/listinfo/apps-discuss>
>>>
>>>
>>>
>>
>>
>> ______________________________**_________________
>> https://www.ietf.org/mailman/**listinfo/apps-discuss<https://www.ietf.org/mailman/listinfo/apps-discuss>
>>
>

---

From: "Martin J. Dürst" <[email-masked]>
Date: Fri, 16 Nov 2012 16:52:24 +0900

Yes, I volunteer to review the document.    Regards,   Martin.

---

From: Peter Saint-Andre <[email-masked]>
Date: Fri, 16 Nov 2012 08:34:36 -0700

Me, too.

On 11/16/12 12:52 AM, "Martin J. Dürst" wrote:
>>>> this
>>>>>> do, in practice. The present draft also introduces some
>>>>>> clarifications
>>>>>> on