Subject: [apps-discuss] Informal documentation on WebFinger

From: "Paul E. Jones" <[email-masked]>
Date: Fri, 30 Nov 2012 00:59:35 -0500

Folks,

Since we overhauled the WebFinger spec, I decided to update the
documentation on my web site:

http://www.packetizer.com/webfinger/

Many have seen this before, but this version is JSON-only and uses the
"webfinger" resource (rather than host-meta).

It's intended to allow people who want to know something about WF or deploy
it to do so without reading through the RFC.  Once we finalize the spec, I
do still intend to publish the simple WF server program I wrote so people
can use if they prefer something a bit more dynamic than quasi-static pages.
(It's not written to handle large sites, but it's meets my needs, so others
might find it useful.)

On these pages, I did include one JRD document that uses every facet of JRD.
Even that is pretty simple, but I hope the example illustrates the purpose
of each:

.         expires

.         subject

.         aliases

.         properties

.         links

o   rel

o   type

o   href

o   titles

o   properties

o   {"template" is not shown as it's not used in WF and would be ignored if
seen}

Paul

---

From: Jeremy Carbaugh <[email-masked]>
Date: Fri, 30 Nov 2012 10:45:46 -0500

Hello webfinger,

Longtime lurker here. Three years ago (!) I wrote and published a simple
Python webfinger client and a Django provider. I check in on the spec a few
times a year to keep everything up-to-date and plan to update both packages
to whatever the current draft is when I sit down to write the code.

https://github.com/jcarbaugh/python-webfinger (client)
https://github.com/jcarbaugh/django-webfinger (provider)

So once the spec is wrapped up, there will be some Python code ready to
help get people started.

On Fri, Nov 30, 2012 at 12:59 AM, Paul E. Jones <[email-masked]>wrote:

> Folks,****
> ** **
> documentation on my web site:****
>
> http://www.packetizer.com/webfinger/****
>
> ** **
>
> “webfinger” resource (rather than host-meta).****
>
> ** **
>
> It’s intended to allow people who want to know something about WF or
> deploy it to do so without reading through the RFC.  Once we finalize the
> spec, I do still intend to publish the simple WF server program I wrote so
> people can use if they prefer something a bit more dynamic than
> quasi-static pages.  (It’s not written to handle large sites, but it’s
> meets my needs, so others might find it useful.)****
>
> ** **
>
> On these pages, I did include one JRD document that uses every facet of
> JRD. Even that is pretty simple, but I hope the example illustrates the
> purpose of each:****
>
> **·         **expires****
>
> **·         **subject****
>
> **·         **aliases****
>
> **·         **properties****
>
> **·         **links****
>
> **o   **rel****
>
> **o   **type****
>
> **o   **href****
>
> **o   **titles****
>
> **o   **properties****
>
> **o   **{“template” is not shown as it’s not used in WF and would be
> ignored if seen}****
>
> ** **
>
> Paul****
>
> ** **
>