Subject: [apps-discuss] draft-ietf-appsawg-webfinger-06

From: "Paul E. Jones" <[email-masked]>
Date: Thu, 29 Nov 2012 16:02:14 -0500

Folks,

In this draft, I tried to correct the referenced to objects and arrays used
in the JSON name/value pairs described in JRD.  The results are published in
the latest draft:

http://tools.ietf.org/html/draft-ietf-appsawg-webfinger-06

We made substantial changes to the text in section 6 (CORS).

The first few paragraphs of Section 9 (Security Considerations) have been
revised.

Personally, I'd like to say "we're done".  What I see as current points of
contention and active discussion are:

.         HTTPS vs HTTP : HTTPS is required to be attempted by clients.
HTTP may then be used as a fallback.  However, there is nothing to prevent a
client - especially one used for sensitive information - from only using
HTTPS.

.         Document format : we've gone from using host-meta and requiring
XRD and JRD to using a "webfinger" resource and selecting only JRD.  It's a
trivial format and I see no good reason to spend time minimizing this
further. I do see value in using the "properties" field and, while one could
refer to external documents to convey information that might be made
available directly in the JRD, why do it when it can be trivially exposed
via the JRD?  (Mail server config is a good example.  I can put everything I
need right into a JRD that would be returned if I query
mailto:[email-masked]. It might be the only thing in the JRD.)  I strongly
prefer to retain JRD exactly as-is for WebFinger.

.         Document JRD in the WF spec or make external references :
presently, the text refers to RFC 6415 which then refers to XRD.  Since JRD
is so trivial, we had discussed before just providing examples, because
that's likely what a number of implementers will look at, anyway.  So, we
did.  Now there is a desire to document JRD in the WF spec, replicating and
re-writing the text from XRD.  This might be worthwhile, though I don't
personally want to spend the time to do it.  That said, I view that as a far
better use of time than re-inventing the WF document format.

I think I've said before that, while I am excited to see something like
WebFinger standardized, this has nothing to do with my real job and is
actually quite a distraction for me.  I feel like I've consumed far more
time on this than I should have already.  As such, I would really prefer
someone else take over as document editor if the group wants to make
substantial changes to the existing text.

Paul

---

From: Joseph Holsten <[email-masked]>
Date: Thu, 29 Nov 2012 13:32:22 -0800

On Nov 29, 2012, at 13:02, "Paul E. Jones" <[email-masked]> wrote:
> I think I’ve said before that, while I am excited to see something like WebFinger standardized, this has nothing to do with my real job and is actually quite a distraction for me.  I feel like I’ve consumed far more time on this than I should have already.  As such, I would really prefer someone else take over as document editor if the group wants to make substantial changes to the existing text.
> 
You will never get enough thanks to make up for the effort you've invested. But I have no end of respect for your ability to turn our bickering into meaningful work. <3!

--
http://josephholsten.com

---

From: James M Snell <[email-masked]>
Date: Thu, 29 Nov 2012 14:09:13 -0800

I'd definitely like to see this wrapped up sooner rather than later.. I'll
volunteer to help out with further editing if you need it.

- James

On Thu, Nov 29, 2012 at 1:02 PM, Paul E. Jones <[email-masked]>wrote:

> [snip]
** **
>
> I think I’ve said before that, while I am excited to see something like
> actually quite a distraction for me.  I feel like I’ve consumed far more
> substantial changes to the existing text.****
>
> ** **
>
> Paul****
>
> ** **
>
> _______________________________________________
> apps-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/apps-discuss
>
>

---

From: Joseph Holsten <[email-masked]>
Date: Thu, 29 Nov 2012 17:02:23 -0800

I an effort to make Paul's life easier: I suggest we limit conversation on this list to:
- suggested changes (must include a patch or requested spec language), including justification
- voting in support of a change
- voting against a proposed change (aka supporting current spec language), including justification

These need to occur on [email-masked] for intellectual property reasons, please be sure patches are sent to that list. 

Does everyone think we could have a patch deadline of Monday 23:59 UTC (5pm pacific)? And a voting/discussion deadline of Friday 23:59 UTC?

--
http://josephholsten.com

On Nov 29, 2012, at 13:02, "Paul E. Jones" <[email-masked]> wrote:

> Folks,
>  
> In this draft, I tried to correct the referenced to objects and arrays used in the JSON name/value pairs described in JRD.  The results are published in the latest draft:
> The first few paragraphs of Section 9 (Security Considerations) have been revised.
>  
> Personally, I’d like to say “we’re done”.  What I see as current points of contention and active discussion are:
> ·         HTTPS vs HTTP : HTTPS is required to be attempted by clients.  HTTP may then be used as a fallback.  However, there is nothing to prevent a client – especially one used for sensitive information – from only using HTTPS.
> ·         Document format : we’ve gone from using host-meta and requiring XRD and JRD to using a “webfinger” resource and selecting only JRD.  It’s a trivial format and I see no good reason to spend time minimizing this further. I do see value in using the “properties” field and, while one could refer to external documents to convey information that might be made available directly in the JRD, why do it when it can be trivially exposed via the JRD?  (Mail server config is a good example.  I can put everything I need right into a JRD that would be returned if I query mailto:[email-masked]. It might be the only thing in the JRD.)  I strongly prefer to retain JRD exactly as-is for WebFinger.
> ·         Document JRD in the WF spec or make external references : presently, the text refers to RFC 6415 which then refers to XRD.  Since JRD is so trivial, we had discussed before just providing examples, because that’s likely what a number of implementers will look at, anyway.  So, we did.  Now there is a desire to document JRD in the WF spec, replicating and re-writing the text from XRD.  This might be worthwhile, though I don’t personally want to spend the time to do it.  That said, I view that as a far better use of time than re-inventing the WF document format.
>

---

From: SM <[email-masked]>
Date: Thu, 29 Nov 2012 19:33:33 -0800

Hi Joseph,
>language), including justification

The IETF does not vote.

Regards,
-sm

---

From: Dick Hardt <[email-masked]>
Date: Thu, 29 Nov 2012 19:54:10 -0800

> - voting against a proposed change (aka supporting current spec language), including justification

I'm sure you meant to say that we do a poll to see where we have consensus. Correct?

> Does everyone think we could have a patch deadline of Monday 23:59 UTC (5pm pacific)? And a voting/discussion deadline of Friday 23:59 UTC?

I don't. But that might be because I am traveling for the next 10 days and won't have much time to patch/discuss. :)

I think there has been some great discussion on JRD and on HTTP(S) in the last week that has brought many people I respect into the conversation. 

Paul has been a champ responding to questions and turning out drafts. I'll volunteer to herd cats and find consensus so that we are handing patches to Paul to incorporate if that would help, but won't be able to do that for another 10 days.

-- Dick

---

From: Mike Jones <[email-masked]>
Date: Fri, 30 Nov 2012 05:18:51 +0000

I think we're making a lot of progress and the level of participation is encouraging.  But I'm with Dick on having an artificial deadline that soon from now - I both don't think it's realistic and I don't think it's actually in line with the IETF processes either.

I do appreciate the work that Paul is doing and I believe he's doing a great job reflecting the consensus of this oh-so-feisty working group. :)

                                                            -- Mike

From: [email-masked] [mailto:[email-masked]] On Behalf Of Dick Hardt
Sent: Thursday, November 29, 2012 7:54 PM
To: [email-masked]
Cc: [email-masked]
Subject: Re: [apps-discuss] draft-ietf-appsawg-webfinger-06

On Nov 29, 2012, at 5:02 PM, Joseph Holsten <[email-masked]<mailto:[email-masked]>> wrote:

These need to occur on [email-masked]<mailto:[email-masked]> for intellectual property reasons, please be sure patches are sent to that list.

-- Dick

---

From: Joseph Holsten <[email-masked]>
Date: Fri, 30 Nov 2012 01:42:06 -0800

> I'm sure you meant to say that we do a poll to see where we have consensus. Correct?

Oh yes, no voting at polls, right. Humming or some such. Thanks for reminding me I'm not being sufficiently pedantic. But you all missed the failed time zone conversion, no bonus points. 

--
http://josephholsten.com

---

From: Joseph Holsten <[email-masked]>
Date: Fri, 30 Nov 2012 01:54:10 -0800

The great thing about an artificial deadline for a draft: you get to the working code. Which can actually justify a basis for rough consensus. It's even a good time to come back and tighten up error handling, ambiguity, examples, security concerns, etc to be more useful.

(I think I'm getting the hang of threads that contribute in no way to the spec, this is fun!)

--
http://josephholsten.com

On Nov 29, 2012, at 21:18, Mike Jones <[email-masked]> wrote:

> I think we’re making a lot of progress and the level of participation is encouraging.  But I’m with Dick on having an artificial deadline that soon from now – I both don’t think it’s realistic and I don’t think it’s actually in line with the IETF processes either.
>  
> I do appreciate the work that Paul is doing and I believe he’s doing a great job reflecting the consensus of this oh-so-feisty working group. J
>  
>                                                             -- Mike
>

---

From: Evan Prodromou <[email-masked]>
Date: Fri, 30 Nov 2012 06:50:32 -0500

+1 to being done.

Also, much thanks for the excellent work you've done.

-Evan

On 12-11-29 04:02 PM, Paul E. Jones wrote:
>
> Folks,
>
> In this draft, I tried to correct the referenced to objects and arrays 
> used in the JSON name/value pairs described in JRD.  The results are 
> published in the latest draft:
>
> Personally, I'd like to say "we're done". What I see as current points 
> of contention and active discussion are:
>
> ·HTTPS vs HTTP : HTTPS is required to be attempted by clients.  HTTP 
> may then be used as a fallback.  However, there is nothing to prevent 
> a client -- especially one used for sensitive information -- from only 
> using HTTPS.
>
> ·Document format : we've gone from using host-meta and requiring XRD 
> and JRD to using a "webfinger" resource and selecting only JRD.  It's 
> a trivial format and I see no good reason to spend time minimizing 
> this further. I do see value in using the "properties" field and, 
> while one /could/ refer to external documents to convey information 
> that might be made available directly in the JRD, why do it when it 
> can be trivially exposed via the JRD?  (Mail server config is a good 
> example.  I can put everything I need right into a JRD that would be 
> returned if I query mailto:[email-masked]. It might be the only 
> thing in the JRD.)  I strongly prefer to retain JRD exactly as-is for 
> WebFinger.
>
> ·Document JRD in the WF spec or make external references : presently, 
> the text refers to RFC 6415 which then refers to XRD.  Since JRD is so 
> trivial, we had discussed before just providing examples, because 
> that's likely what a number of implementers will look at, anyway.  So, 
> we did.  Now there is a desire to document JRD in the WF spec, 
> replicating and re-writing the text from XRD.  This might be 
> worthwhile, though I don't personally want to spend the time to do 
> it.  That said, I view that as a far better use of time than 
> re-inventing the WF document format.
>
> I think I've said before that, while I am excited to see something 
> like WebFinger standardized, this has nothing to do with my real job 
> and is actually quite a distraction for me.  I feel like I've consumed 
> far more time on this than I should have already.  As such, I would 
> really prefer someone else take over as document editor if the group 
> wants to make substantial changes to the existing text.
>
> Paul
>
>
>