Subject: [apps-discuss] Fwd: FW: Simple Web Discovery (SWD) Enabling Hosted Deployments

From: "Paul E. Jones" <[email-masked]>
Date: Mon, 05 Nov 2012 08:44:11 -0500

FYI

-------- Original Message --------
From: Mike Jones <[email-masked]>
Sent: Mon Nov 05 07:55:14 EST 2012
To: "Paul E. Jones" <[email-masked]>
Subject: FW: Simple Web Discovery (SWD) Enabling Hosted Deployments

Paul, could you do me a favor and forward this note to the apps-discuss list so people have context on why I updated SWD?  For some reason, the list doesn't appear to be accepting my message.

                                                            Thanks,
                                                            -- Mike

From: Mike Jones
Sent: Sunday, November 04, 2012 9:21 PM
To: [email-masked]
Subject: Simple Web Discovery (SWD) Enabling Hosted Deployments

I've updated the Simple Web Discovery (SWD)<http://tools.ietf.org/html/draft-jones-simple-web-discovery> specification to incorporate a means of performing discovery on domains for which it may not be possible to create a .well-known endpoint.  This can often be the case for hosted domains, where it is common for e-mail to be provided but no web server.  This solution was developed in discussions by the OpenID Connect<http://openid.net/connect/> working group.

This draft is being published now to facilitate discussions of the need to enable discovery for hosted domains and possible solutions for doing so at the IETF Applications Area working group meeting at IETF 85 in Atlanta<http://www.ietf.org/meeting/85/>.

The updated specification is available at:

*        http://tools.ietf.org/html/draft-jones-simple-web-discovery-04

Changes made were:
*        Specified that the SWD server for a domain may be located at the simple-web-discovery subdomain of the domain and that SWD clients must first try the endpoint at the domain and then the endpoint at the subdomain.
*        Removed the SWD_service_redirect response, since redirection can be accomplished by pointing the simple-web-discovery subdomain to a different location than the domain's host.
*        Removed mailto: from examples in favor of bare e-mail address syntax.
*        Specified that SWD servers may also be run on ports other than 443, provided they use TLS on those ports.

An HTML formatted version is available at:

*        http://self-issued.info/docs/draft-jones-simple-web-discovery-04.html

(This notice was also posted to http://self-issued.info/?p=891.)

                                                            -- Mike

---

From: Blaine Cook <[email-masked]>
Date: Mon, 5 Nov 2012 19:55:45 +0000

To continue with the "simplicity is the goal" theme, if it turns out that
people are happier to use DNS records for discovering the Webfinger/SWD
endpoint, then the host-meta lookup should be dropped entirely in favour of
DNS lookups (or vice versa).

If we're going to go the DNS route (and require it as a mandatory
fallback), then it seems like following normal DNS semantics and making the
lookup behave like MX or SRV records would be sensible. Rather than having
a fallback, just have all lookups go immediately to the agreed-upon domain
prefix / SRV record (I would express a slight bias towards SRV record,
simply because the mechanism as specified is trivially vulnerable to attack
on numerous existing platforms. E.g.,
http://simple-web-discovery.tumblr.com/ )

b.

On 5 November 2012 13:44, Paul E. Jones <[email-masked]> wrote:

> FYI
>
> ------------------------------
> *From:* Mike Jones <[email-masked]>
> *Sent:* Mon Nov 05 07:55:14 EST 2012
> *To:* "Paul E. Jones" <[email-masked]>
> *Subject:* FW: Simple Web Discovery (SWD) Enabling Hosted Deployments
>
>  Paul, could you do me a favor and forward this note to the apps-discuss
> list so people have context on why I updated SWD?  For some reason, the
> list doesn’t appear to be accepting my message.****
>
> ** **
>
>                                                             Thanks,****
>
>                                                             -- Mike****
>
> ** **
>
> *From:* Mike Jones
> *Sent:* Sunday, November 04, 2012 9:21 PM
> *To:* [email-masked]
> *Subject:* Simple Web Discovery (SWD) Enabling Hosted Deployments****
>
> ** **
>
> I’ve updated the Simple Web Discovery (SWD)<http://tools.ietf.org/html/draft-jones-simple-web-discovery>specification to incorporate a means of performing discovery on domains for
> which it may not be possible to create a .well-known endpoint.  This can
> often be the case for hosted domains, where it is common for e-mail to be
> provided but no web server.  This solution was developed in discussions by
> the OpenID Connect <http://openid.net/connect/> working group.****
>
> ** **
>
> This draft is being published now to facilitate discussions of the need to
> enable discovery for hosted domains and possible solutions for doing so at
> the IETF Applications Area working group meeting at IETF 85 in Atlanta<http://www.ietf.org/meeting/85/>
> .****
>
> ** **
>
> The updated specification is available at:****
>
> **·        **
> http://tools.ietf.org/html/draft-jones-simple-web-discovery-04****
>
> ** **
>
> Changes made were:****
>
> **·        **Specified that the SWD server for a domain may be located at
> the simple-web-discovery subdomain of the domain and that SWD clients
> must first try the endpoint at the domain and then the endpoint at the
> subdomain. ****
>
> **·        **Removed the SWD_service_redirect response, since redirection
> can be accomplished by pointing the simple-web-discovery subdomain to a
> different location than the domain's host. ****
>
> **·        **Removed mailto: from examples in favor of bare e-mail
> address syntax. ****
>
> **·        **Specified that SWD servers may also be run on ports other
> than 443, provided they use TLS on those ports.****
>
> ** **
>
> An HTML formatted version is available at:****
>
> **·        **
> http://self-issued.info/docs/draft-jones-simple-web-discovery-04.html****
>
> ** **
>
> (This notice was also posted to http://self-issued.info/?p=891.)****
>
> ** **
>
>                                                             -- Mike****
>
> ** **
>
> _______________________________________________
> apps-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/apps-discuss
>
>